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LESSON NAME: OPENING THE PROJECT  

 LESSON OBJECTIVE: 

In this lesson the student will learn to access the workshop’s project data that will 
be used to explore the new Bentley Civil Geometry Tools. 

 

EXERCISE: GETTING STARTED 

This exercise will guide you through the steps to get started. 

1. Go to Start > Programs > Bentley > InRoads Group V8i (SELECTseries 2) > 

InRoads Suite.  

2. The instructor will provide the appropriate path location for this project. When 

the MicroStation Manager appears select the file: 

\DATA\Geometry Layout.dgn and click OK. 

3. Load the project’s XIN file: File>Open>\\X11-Using the New Civil Geometry 

Tools\DATA\civil.xin. 

 

 

 

 

LESSON NAME: TEST DRIVE  

 LESSON OBJECTIVE: 

In this part of the work shop you and your instructor will browse the new Civil 
Geometry Tools and examine the previously designed intersection. We will use the 
new tools to explore alternative designs for this future infrastructure improvement. 

 

EXERCISE: TEST DRIVE 

This exercise is to examine the new tools and view the project data. It is also 
a good time to ask general questions before beginning the workshop. 

1. Locate, examine & familiarize yourself with the Civil Geometry Tasks. The 

instructor will give a short tour. 
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2. Invoke the Item Browser from Files>Item Brower. 

3. Review Content Management tab within the Item Browser. Your instructor will 

guide you through the Content Management and the Details pane. Take note to 

the two sources of the content management. 

4. Content Management’s feature styles can be populated from a XIN file via 

linking the active DGN to Style’s in the XIN or via attaching a DGNLIB with the 

Content Management. 

 

 

 

 

 

 

5. If the folder path has been modified for this workshop, the DGNLIB may not 

show. Simply, <Link the Feature Styles> to the civil.xin that was previously 
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loaded by right clicking the Content Management Model (Geometry Layout.dgn). 

 

 

6. Examine the previously civil.xin file by going to Tools>Style Manager. 

 

 

***Hint- Notice the Feature Names, do they look familiar? The Content Management is the KEY to 

allow the new civil geometry tools to “talk” to the ALG. You may want to pin the dialog since 

workshop machines typically has limited screen space. 

 

 

7. Review the Geometric Layout that already exists in the DGN file. Examine the 

reference files. 
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LESSON NAME: GEOMETRIC LAYOUT OF THE INTERSECTION  

 LESSON OBJECTIVE: 

The objective of this lesson is to construct the 4th leg to the existing T-Intersection 
with the Civil Geometry tools. The centerline geometry has been imported from an 
InRoads Horizontal Alignment from an ALG file into the DGN as a Civil Geometry 
Element.  The below diagram shows an actual configuration of the intersection that 
now exists today. 

 

 

 

 

EXERCISE: USING IN-PLACE EDITING 

This exercise will exhibit the in-place editing capabilities. The MicroStation 
Selection tool will display the glyphs and the construct values on how the 
element was constructed. This allows you to edit the civil geometry element 
without looking for the appropriate tool to make edits by simply clicking on 
the value that needs to be changed. 



  7 
  © 2010 Bentley Systems, Incorporated. 

1. Select the curb return of the southwest quadrant of the intersection. The In-

Place manipulators will appear as follows: 

 

2. Click on the Radius of 50’ which is blue. The radius is now able to be edited.  

3. Enter a value of <85>. This value will allow larger vehicle to perform the right 

turning movement. 

4. Review the Geometric Layout. What else has changed? 

5. Civil Geometry in-place edits can be Undone/Redone. Examine this by going to 

MicroStation>Edit>Undo then Redo so the curb return holds the 85’ that you 

previously entered.  

 

 

 

EXERCISE: REMOVE NOSING 

This exercise will use the existing MicroStation tools to remove the pavement 
marking nosing and establish a left turn lane. 
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1. Let’s look at the element first by selecting the nosing with the Selection Tool. 

 

2. Next, use the MicroStation <Delete> to remove the 2 elements composing the 

nosing of western leg of the intersection. 

3. Removing the Fillets will restore the element to its original definition. How was 

the elements constructed?  

Hint; Use the Element Selection……  

4. We will use these elements for the left turning lane for eastern leg of the 

intersection. 

5. Review the results. 

 

EXERCISE: ESTABLISH THE CURB RETURNS  

This exercise will use the Arc Between Elements tool to establish the edges 
of pavement for curb returns for easterly leg of the intersection. 

1. Locate the Civil geometry tool <Arc Between Elements>  

2. We will do SE quadrant first. Toggle on <Use Feature> and choose <Curb> 

3. Select the south to north blue centerline. 

4. Within the heads up display enter the offset value of 27’ and <Enter> to lock.  
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5. Left click to accept. 

6. Select west to east blue centerline. 

7. Within the heads up display enter the offset value of 20’, Enter, and left click to 

accept.  

 

 

8. Enter a radius of 75’, <Enter> and then left click to accept. 



  10 
  © 2010 Bentley Systems, Incorporated. 

 

9. We will repeat this process for the NE quadrant. 

10. Locate the Civil geometry tool < Arc Between Elements>  

11. Verify that the toggle is on for <Use Feature> and <Curb> is the defined feature 

style. 

12. Select the south to north blue centerline. 

13. Within the heads up display enter the offset value of 27’, <Enter> and left click 

to accept. 

14. Select west to east blue centerline. 

15. Within the heads up display enter the offset value of 34’, <Enter> and left click 

to accept. Enter a radius of 50’ and then left click to accept. 

 



  11 
  © 2010 Bentley Systems, Incorporated. 

 

EXERCISE: ESTABLISH THE EDGES OF PAVEMENT  

This exercise will use the Single Offset Partial tool to establish the edges of 
pavement for easterly leg of the intersection. 

1. Locate the Civil geometry tool < Single Offset Partial > 

 

2. Toggle on <Use Feature> and choose <Curb> 

3. Select west to east blue centerline  

4. Keyin an offset value of 20’ and <Enter> to lock the offset value.  The tool is still 

active: Snap to the edge of the curb return in the SW quadrant to define the 

start point. 
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5. Set the end distance to the most easterly point of the alignment selected by 

simply moving the cursor beyond the most easterly point of the alignment and 

left clicking to accept. The line will terminate and not go pass the end point of 

the originating element. 

6. Repeat process for NE quadrant. 

7. Toggle on <Use Feature> and choose <Curb> 

8. Select west to east blue centerline.  

9. Key in an offset value of 34’, <Enter>, and snap to the edge of the curb return 

in the NE quadrant. 

10. Set the end distance to the most easterly point of the alignment selected by 

simply moving the cursor beyond the most easterly point of the alignment and 

left clicking to accept. 

 

 

EXERCISE: PARTIAL DELETES 

 

1. Select <Partial Delete> from MicroStation Modify Task Bar. 

2. Use the Partial Delete as you would with MicroStation. Remove the edge of 

pavement of the South to North corridor in the area of the newly created leg of 

the intersection. 

 

Hint: It is easier to Partial Delete twice, this way you do not have multiple 

elements to choose from. 

3. Turn on reference <lucprdmk.dgn> for reference and trim left turn lanes back to 

the Stop bar as shown below: 
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4. Precede to partial delete the left turn lanes back to SW quadrant’s fillets PT 

Point. 

 

5. Shut off the reference file <lucprdmk.dgn>. 
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EXERCISE: DEVELOPING THE LEFT TURN LANE 

 

1. Select <Variable Offset Taper> from Civil Geometry Task Bar.  

 

2. Toggle on feature style and select <Curb>. 

3. Select the Centerline. 

4. Enter the start offset 6’ and move cursor to the south of the baseline and click to 

<Enter>. 

5. Arrow Right to access Distance Start and enter 187+00 for a precision input. 

6. Enter the End Parameter 6’ for the offset <enter> to lock and then arrow right 

and key in 187+75 and enter. Make sure your cursor is on the northside of the 

alignment and click a left mouse click to accept. 

Hint: The cursor location is determining the sign of the offset +/-. 

 

7. Select <Ration Defined Taper> from Civil Geometry Task Bar.  

8. Toggle on feature style and select <Curb>. 

9. Select the blue west to east Centerline. 

10. Enter a start offset of 6’ and hit enter  

11. Arrow right and key in 187+75 & <Enter> 

12. Move the cursor north of the centerline and left click to accept the start 

parameters. 

13. Key in a ration of 1:25 & <enter>. 

14. Arrow right and key in 189+25 & <Enter> and left click to accept. 
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15. Examine the elements created with this exercise with Element Info & the 

Selection Tool. 

 

EXERCISE: CLEAN-UP  

 

1. Use the Partial Delete to clean-up the 4 lane lines as shown below. These lane 

line need to taper back to remove the left turn and tie back into existing typical 

section of the roadway which will be done in the next exercise. **Be sure to use 

the snaps with the partial deletes.** 
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EXERCISE: FINISHING UP  

1. Select <Single Offset Entire Element> from Civil Geometry Task Bar.  

2. Toggle on feature style and select <Curb>. 

3. Select the NE quadrants tangent edge of pavement that ties into the curb return. 

4. Keyin the offset value of 14’ and <Enter>. 

5. Left Click to accept making sure the cursor is south of the original element. 

6. Locate and Select the MicroStation <Extend Line> command and extend the 

previously created line to match up with the beginning of the left turn lane. 

 

7. Select <Line Between Points> from Civil Geometry Task Bar.  

8. Toggle on feature style and select <Curb>. 

9. Snap to the left turn lane and to the end of the ratio taper previously created as 

showed below to aid: 

 

Hint: The snaps are critical….remembers the designer’s intent is captured. 
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The last construct that needs to be done is to taper the thru lanes to. Since we 

established the critical points with the Ratio Defined Taper tool, and know the 

lane width is 14’, we can simply offset these elements by 14’ to establish the 

one eastbound lane and then repeat twice for the two westbound lanes. 

 

10. Select <Single Offset Entire Element> from Civil Geometry Task Bar.  

11. Toggle on feature style and select <Curb>. 

12. Select the element that was defined by Ratio Defined Taper. 

13. Key in the offset value of 14’ and <enter>. 

14. Left Click to accept making sure the cursor is north of the original element 

15. Repeat the process for second westbound lane. 

16. Offset the eastbound lane in the same matter as defined above, but select the 

element created with the place line tool that is south of the Ration Defined 

Taper. The below figure should reflect your results. 

 

 

17. There are small gap that need to be closed with the elements just created. Use 

the MicroStation >Trim to Intersection to fix this.  
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LESSON NAME: UPDATE THE ALG  

 LESSON OBJECTIVE: 

The only thing that is certain in this world is change, particularly in civil engineering.  
The review of your recently designed project requires a minor change to the 
centerline geometry of the roadway that you just used to complete the easterly leg 
of the intersection. You are provided the ALG file with this change. 

 

EXERCISE: UPDATE WITH THE IMPORT TOOL 

 

2. Select <Import Geometry> from Civil Geometry Task Bar. 

 

3. Navigate to the new ALG file. Located under at \Modified ALG\lucent.alg 
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4. Examine the Import list Why is there only 2 Horizontal Alignments selected? 

 

5. Click <Import>. 

6. Review your Intersection. 

7. Turn on the reference files for comparison. 

Hint: Why is storing the the engineers design inputs so important? 

8. Look in your default.alg file…. 
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Hint: Remember the Content Management Detail Pane…Auto persist was set to TRUE. 

 

 

 


