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Agenda

» Working with Integrated AutoCAD
— AutoCAD Integration Settings
— AutoCAD Ribbon Bar

— Session File Manager
— AutoCAD Datalinks

» Working with Integrated Revit

— Configure Revit application associations in ProjectWise
Administrator

— Converting Revit Central files to work in ProjectWise

— Basic worksharing operations in a ProjectWise-integrated
Revit environment

— Revit Best Practices
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AutoCAD Integration Settings

* AutoCAD iDesktop Integration
— ProjectWise V8i Network
— Setting iDesktop Auto-Login for AutoCAD

x
" General I DNS Services I Datasource Listing  iDesktop Auto-Login |

r~ User settings

Mction | <Doitlogh adonaiech Modify Auto-Login Setting for AutoCAD
X - =
Micro Station <Do not login automatically = Ho-drfv Auto-Login Setting for Aut: —I
Revit <Do not login automatically = — Actions
4| T 0 {~ Use default computer setting
" Do not login automatically
~Global settings

{* Auto-ogin to datasource selected below

These settings are common to all application classes on this computer.

Global settings can be viewed by any user, but only administrators of this computer ~ Auto-ogin setting
can change them.

Datasource: I ProjectVise j

¥ Use Single Sign-On during autodogin;

Global settings... |

IUser mame: I

Passward) I

oK | Cancel | Ay |
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AutoCAD Integration Settings

« Commands for Integrated AutoCAD
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» Complete List of Commands in ProjectWise Explorer
Help

| Command | Description
IDMSNEW same as NEW, or File > New.

|DMSOPEN same as OPEN, or File > Open.

IDMSQSAVE same as QSAVE, or File > Save.

IDMSSAVE, DMESAVEAS  [Same as SAVE and SAVEAS, respectively, or File > Save As.

IDMsQuIT same as QUIT, or File > Exit.

|DM55ESSIDNFILEMAHAGER |Same as ProjectWise > Session File Manager.

|DMSPLACEONSHEET |same as ProjectWise > Place On Sheet

IDMSINSERT same as INSERT, or Insert > Block,

|DM5WB LOCK |Same as WBLOCK (used to save a block as a ProjectWise document)
DMSEXPORT |Same as EXPORT, or File > Export, or ProjectWise > Export.
|DMSIMPORT same as IMPORT, or File > Import or ProjectWise > Import.

(This is an internal command used by the integration module and is not intended for use by
the user.)
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AutoCAD Integration Settings
» DMSSET variables

— To configure ProjectWise integration variables

o List of DMSSET variables in ProjectWise Explorer Help

Variable Value / Description

REETIME Sets how often (in minutes) integrated AutoCAD checks for updated references. See Reloading
External References for details.

Controls how references are to be reloaded into the master document, if any of the master

REFMODE document's references happen to be updated or checked in by another user. See Reloading
External References for details.

Instructs integrated AutoCAD what to do when it detects a missing external reference, and the
REFMISSINGMODE reference is from ProjectWise:

« REFMODE controls reload of updated Xref:

— REFMODE-=1: opens notification dialog to reload xref
— REFMODE=2: silent update e r——

Enter variable name or [?]: REFMODE

— REFMODE:B: no reloading | Enter new value for REFMOde <1>:2
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AutoCAD Ribbon Bar

 AutoCAD Ribbon Bar for ProjectWise integrated

commands (useful for non-integrated mode)

— Document Section

— Reference Section

— Title Block Section

— Block Section

— Sheet Set Section

— Tools Section

Haome Insert Annotate Parametric View Manage Qutput  Plug-ins Online Express Tools ProjectWise

Dﬁ Mew A k3
bt B B RN W dE B o N
Impaort Export F'erEFtIES Attach Reload Insert Update  Update Insert Write | Place on Sheet & Open Session File
a Save As Drawing ProjectWise Manager
Document | Reference | Title Blodk | Blodk | Sheet Set | Tools I
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Session File Manager

* Access files used during AutoCAD session o

* Select Session File Manager from Ribbon bar ==
or use DMSSESSIONFILEMANAGER from command line

. U S e d fo r: E:;zjeclwise Sessiovn File Manager e
Recent Documnents ~ & I
- N aV|gate Content ‘gg/ - ¥ ProjectWise Session File Manager
. . . . DWM A2 Junction.dig az-stempelhr2.dwg ‘E‘ 2 & E‘Q l
— Locate files in ProjectWise = ===
— Open, Check in and out, Free, etc. [
— e L
_.,.é:—_—ﬁ gt: eeeeeeeeeeeee

— Display Preview, Properties, Audit Trail =~~~
— Show Xref hierarchy =
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AutoCAD Datalinks

 Bidirectional link between AutoCAD DWG and Excel
sheet

« Embed a link in DWG document to Excel document in
ProjectWise

 Dynamic links

Description: DM A2 Junction

— Notification when Excel content changes | ...

1) Data Link Has Changed X i
A data link has changed. Any tables Using this data ink may need to be updated,
Update tables Lsing the data link: Attributes
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AutoCAD support in V8i SELECTseries 4

 AutoCAD support in ProjectWise V8i (SELECTseries 4)
— AutoCAD 32-bit versions 2008, 2009
— AutoCAD 32- and 64-bit versions 2010, 2011 and 2012

— Separate install supports basic AutoCAD 2013 and:

* AutoCAD Architecture 2013 (32- and 64-bit)

* AutoCAD Civil 3D 2013 (32- and 64-bit)

*  AutoCAD Map 3D 2013 (32- and 64-bit)

* AutoCAD MEP 2013 (32- and 64-bit)

* AutoCAD P&ID 2013 (32- and 64-bit)

* AutoCAD Raster Design 2013 (32- and 64-bit)

* AutoCAD Mechanical 2013 (32- and 64-bit)
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Agenda

» Working with Integrated AutoCAD
— AutoCAD Integration Settings
— AutoCAD Ribbon Bar

— Session File Manager
— AutoCAD Datalinks

» Working with Integrated Revit

— Configure Revit application associations in ProjectWise
Administrator

— Converting Revit Central files to work in ProjectWise

— Basic worksharing operations in a ProjectWise-integrated
Revit environment

— Revit Best Practices
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ProjectWise Revit Integration Components

« QOrchestration Framework — for thumbnail extraction of RVT,
RFA, RTE, and RFT files. Revit does not need to be installed on
the server for extractions.

* ProjectWise Administrator — to be able to select\change the drive
letter mapping used for the datasource (default is R: drive). Revit
does not need to be on the client or server used for
administration.

* ProjectWise Explorer — for the desktop integration components
for Revit integration.
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Revit support in V8i SELECTseries 4

* Revit support in ProjectWise V8i (SELECTseries 4)
— Autodesk Revit version 2010, 2011, 2012

— Separate install supports Autodesk Revit 2013, including:
* Revit Architecture 2013
+ Revit MEP 2013
* Revit Structure 2013

— 32- and 64-bit versions
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Configure Revit Application Associations

* Use ProjectWise Administrator

* Delivered RevitVersion.appinfo.xml for import definitions

strator VBi (SELECTseries 3)

g}‘ File Action View Window Help

=101

e | Hmld L RE C = HEE

& ProjectWise Administrator V8i (SELECTseries 3)
= @ Servers
= (@ BCMWin2kavm L.bentley.com
= UJ Datasources
Bl | PWBCM (BENTLEY\Bobby.Mullenax)
4~ Llinear Features
q—; Coordinate Systems
E Symbologies
rgl Spatial Metadata Scanners
s Attribute Mappings
Background Maps
% Messaging Services
1T Workspace Profiles
Lﬂe Project Types
™ Applications
Departments
g1 States
ﬁ& Workflows
“g Storage areas
O Views
[T Environments
=] interfaces
s Users
ﬂ Groups
€ User Lists
E’H Attribute Exchange Rules
-;j} Document Processors
@; Registered Full Text Index Servers

Name | Web viewer

| General Programs

2| Acrobat PDF Windows IE Association

m Adobe InDesign

#' AutoCAD ProjectWWise Publishing Server
5 autodesk Revit

R Autodesk Revit 2010

[ autcPIPE

= AutoPLANT Equipment

[ AutoPLANT Isometrics

[ AutoPLANT P&ID

= AutoPLANT Piping

B AutoPLANT Raceways

1 AutoPLANT Structural

| Batchplot

FBentley Architecture

FBentley Architecture | SpacePlanner

P Bentley Building Electrical Systems (DE)
P Bentley Building Electrical Systems (UK)
= Bentley Building Electrical Systems (US)
I Bentley Building Mechanical Systems
I Bentley Building Suite

FBentley Civilstorm

FBentley CulvertMaster

F=Bentley Digital Print Format(DPR)

4]

ProjectWWise Publishing Server
ProjectWWise Publishing Server
ProjectWWise Publishing Server
Projectiise Publishing Server
ProjectWise Publishing Server
ProjectWise Publishing Server

ProjectWWise Publishing Server
ProjectWWise Publishing Server
ProjectWWise Publishing Server
ProjectWise Publishing Server
Projectiise Publishing Server
ProjectWise Publishing Server
ProjectWise Publishing Server

ProjectWWise Publishing Server

IRETE

Autodesk Revit 2012 Properties

"General Actions | Web viewing I Managed Workspace I

en Aut evit

Open Mon4rtearated Autodesk R...

Action Association

Create

d

Modify
Remove

Set Default

:

 Properties of Open action (Autodesk Revit)

Program class name:

Revit. Document. PW

Enable legacy integration: MNo
Replace default anguments: Mo

Command line that will be used to startt application:

Iglam Files\Autodesk\Revit Architecture 2012%Program“Revit exe"

o]

Cancel | Apply
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Convert Revit Central files to ProjectWise

* Move Revit Central models to ProjectWise

« Resave Central models

,
ProjectWise Warning M

» Remap broken Links

— Manage Links in Revit ) |
— New dialog on Open in PW V8i SS4 S —

ProjectWise Explorer, then use the 'Resolve Links to ProjectWise' dialog

that opens automatically to point these links to the correct files in

The file 201 3rvt-Architecture Metric_rvt contains the following unresolved links.
To fix the links, click the Browse button next to each file and select the comect file in

P

e — — _ — = |

@ Bentley MEF Metric.nt [unresolved] C]
D:\Revit-2013-Dataset\Metric'2013-RVT\Bentley MEP Metric.rvt

@ Bentley Structure Metric.nt [unresolved] :]
D:\Revit-2013-Dataset\Metric'2013-RVT \Bentley Structure Metric. rvt
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Bentley Ribbon Bar in Revit

* The Bentley Ribbon bar contains the following tools:
— Open Local Project: Open projects and templates from local disk

— Reload Links: Refresh local copies of linked models which are
updated in ProjectWise

— Update Server Copy: Update document copy on ProjectWise
server

— Document Properties: Displays ProjectWise document
properties

— Disable Integration: Turns Integration off
— Options: ProjectWise Options e
— Help: Help on ProjectWise integration e

@ Architecture Stiucture Systems | Inset | Annofate Analze Massing &Site | Collaborate. | View  Manage  Madify | Bentley -

= o =) a4

i
Projectise ineeraion Cptor S

I
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Worksharing operations in integrated Revit

Create Revit Local file

Synchronize changes with Central model in ProjectWise
— Notifications (locking/updating Central file)

ProjectWise Revit Integration Options e

Worksharing Concepts -
— Optimize file sharing and element borrowing
— Worksets — break-up e.g. in disciplines, floors

Worksharing Display Settings...

M= Checkout Status
E8, Owners

= Model Updates
oDy Worksets

% Worksharing Display Off

G 4
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Revit Best Practices

1. Rule of thumb you should have 1-2 worksets per user on the project.

2. Do not treat worksets as if they are layers in a CAD program. A
workset is a collection of building elements like doors, walls, floors,

etc

3. Worksets should be planned out in advanced to optimize the size of
the Project and number of team members. Look at the project as a
whole rather than isolating individual components.

4. When dividing up worksets consider the building elements and the
number of people working on each of those elements.

5. Once you have 6-8 people working on a Revit project performance
will begin to slow down inside or outside ProjectWise.
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Revit Best Practices (Cont.)

6. If your Revit Project is large enough to have more than 6-8 people
concurrently in a model you should consider dividing the model into
multiple files.

7. Use the word Central in your file naming convention when creating
the central file.

8. Divide your model up before it reaches a size of 200 MB (64-bit).

9. Avoid Groups if possible, the more groups in a file the slower the file
becomes. If using Groups in Revit files avoid having different parts
of an object in a group being in different worksets.

10. Try to Sync to Central every hour is possible.
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Revit Best Practices (Cont.)

11. Take ownership of the entire workset if you are the only one working
on that workset, this will help the need to borrow elements on the fly.

12. If you cannot take ownership of the entire workset try to take
ownership of the group of elements you will be working on at the
same time, to avoid borrowing elements on the fly.

13. Opening a Revit file from ProjectWise Explorer by double clicking on
the Revit File is the preferred method. File is only locked when
“Open File’dialog appears. After Open: Delta File transfer runs and
any changes are downloaded then the file is unlocked and ready to
be worked on. ,-

| J o
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Agenda

» Working with Integrated AutoCAD
— AutoCAD Integration Settings
— AutoCAD Ribbon Bar

— Session File Manager
— AutoCAD Datalinks

» Working with Integrated Revit

— Configure Revit application associations in ProjectWise
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— Converting Revit Central files to work in ProjectWise

— Basic worksharing operations in a ProjectWise-integrated
Revit environment

— Revit Best Practices
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What's Next for Autodesk Users in

ProjectWise V8i (SELECTseries 4)

 Enhanced Support for Civil3D 2012 and 2013 -
delivered as an add-in for current PW Explorer V8i
(SELECTseries 4) users - expected in Q4- 2012

— Data Shortcuts\References (Create, Edit, Delete,
Import/Export)

» Links to objects / items (Surface, PipeNetwork or Alignment) stored in 2 Xy
a companion XML file.

— Working Directory Support

* Place on local system where Civil 3D stores Data Shortcut for the

Projects.
— Prospector palette Integration i
 Used in Civil3D is used to create and manage Data Shortcuts m_
~ Surface features of Civil3D (MMS and GRS)
+  MMS and GRS files are satellite references to the DWG
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