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StormCAD reads S&S files!
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e StormCAD v8i Project>Import>InRoads

InRoads Drainage Import

Optianal InRoads Files

Project Configuration: | [%f-3 Drainage

vl

|E:"-.2EIEIEI RBCHWW-3WDATAMstandardz\Bentley Training| @ -
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Workshop - X5 Using InRoads S&S

e Monday at 2:30pm...Rob Nice
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InRoads reads S&S files!

e Storm & Sanitary files are InRoads-readable

e Display and Plans Production functions
- Plan/3D Drainage Display and Notes
— Cross Section Display and Notes

— Profile Notes
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Cross Sections See Drainage
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— Similar to Features w/ bandwidth

— Cells can be used to represent structures

e Storm & Sanitary are integrated into Cross Sections

I
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InRoads Survey to Drainage

= Survey Data To Drainage

] Mame: | Drefaulk |
o Streamllned data fIOW frOm Description: | J
Survey to Storm&Sanitary Sructre: | NI v
Aftribute Mapping:
e Part of InRoads Survey e I
Irlet IM
ID D INID =
Description | Desc |IN.Desc
Clagz | Clazs |IM.Class
Tupe | Tupe [IN.Type
Length [L [IM.L
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Stule M apping
Available Styles:

M apped Styles:
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Products

e Included in InRoads (Suite)

e Included in PowerCivil for "Country”
e InRoads Site Suite

e InRoads Storm & Sanitary
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Site Modeler

e Site Modeler is being plagiarized from GEOPAK
to InRoads

e Get goodies like the Pond Wizard...

B Create a Pond - Define name and design constraints

Define Pond Mame BEample

Add to Surface:; = ﬂ
Style: Aggregate =

B Creste a Pond - Start [= [ ===
Design Constraints
Chverview Bample B i i
Thiz wizard will step through the creation of 3 e [ F il R
pond... ) Top - Down Design

Steps: @ To Bevation: 4.00

1) Defing the Pond MName:

2) Define the Pond Blements.

3) Define Pond and Berm Slope Details.
4) Finih.

1 To Volume: HOBOG0

[] Use a Fresboard: [p 0o
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SS1 Updates

o Import Excel file to IDF table.

° Generate Graphical IDF from IDF table

o Moved curbHeight, curbOpeningHeight, curbLength, orificeDepth from the Drainage Options to the structures.dat.

o Drainage > Utilities - add Edit Utilities to edit z values similar to the Edit Feature Points?

o DRAINAGE>VIEW>ANNOTATE STRUCTURES (Profile also) - Left and Right offset abbreviations from Tools>Options.

o Surface>View Surface>Annotate Feature>Crests and Sags tab. Helps locate crests and sags along a proposed flow
line feature for laying out inlets.

o Drainage > Lay Out - Pipe Tab: Added an option "Use Centerline Elevations". This option is similar to the "Use Soffit
Elevations" except the elevations are based on the centerline of the pipe.

o We added EC data to the drainage solids. So... if structures are displayed as solids, the same data that is available in
the inroads explorer will appear in the EC Browser. The browser is opened by keying in “items browse” in the
mstation keyin window. Look under “Active”.
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Translate Excel to IDF File

59 Translate Excel to IDF

Previews of E xcel Spreadshest:
Fl F2 F3 F4 5 A
1 Irten... | Table |(San  Bemarding | Ok K
2 K15 [Inter. |in | Victowile
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4 I; |Long..[117.3 |deg  Elevation |
5 4
r B M [ [50 [100
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1 |376; 147e lab) B¢
07 337 [427 [4%5 (562 v
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4 Al
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10 263 333 385 438
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12 23 23 33 3%
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M
First Row of Dater |5 Last Row of Datar [ 47 Duration Courir: [ |
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Save As

Close.

Help
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Display IDF Curves

23 Display IDF Curves Exaggeration
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Annotate Features Sag and Crest

|

Apriotate

[JPoints  [JLine Segments  [] Slope Direction Crests Sags

[__peoy | [Preferences... | [ Chose |
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Lay Out Pipe Elevations from Center
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- Drainage Lay Out
| CuvePipe | Mubipledunctions | Pips by Slope
| Fiee [ Channel | Cuben | Marhole | It
Pipe D [P ] [CEer |
Location
Upstream Downstream
D [Motset | ] [Noiser | #|
Horthing: {0,000 | | [oooo ]
% +
Essting: 0000 | _| [nooo |
[ Lateral Connection
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Inlets by Spread...NEW.

B Drainage Lay Out [ = =]
Pipe I Channel I Culvert I Manhole I Inlet | Curve Pipe |
Multiple Junctions I Fipe by Slope | Inlets by Spread
Inlet 1D: N1 Help
Crest Station: 10+00.00 ﬂ
Sag Station: 20:00.00 ﬂ
Imitial Inlet Station: 10+50.00 ﬂ
Drainage Width: .00
Madimum Spacing:  360.00
Spacing Step: 20.00
Connecting Pipes
[¥] Add Connecting Pipes
® BvSlooe | ppo% i) By Elevation
User Data Field: E
User Data Value:
Apphy Options. .. ] ’ Close
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V8i Updates

e View > Drainage As Solids display has been improved.

e Layout > Pipe. Locate buttons to pick elevations
graphically were added for Invert In and Invert Out.

e Edit/Review > Styles tab. Read only fields were added to
note the assigned style.

o Edit/Review > Inlets. Target buttons were added for
slopes and inverts for pipes and elevations for inlets.

e Edit/Review. When scrolling through a network with the
Edit Up and Edit Down buttons, the current ID, Upstream
ID, and Downstream ID displays in the message center.

e Network > Design. Clear ALL existing design tables was
added.

e Cross Section > Update Cross Section > Storm and
Sanitary leaf. The All or None buttons were replaced with
right click options in the list view.
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View Drainage as Solids

e Smart Solids!

e Visual Collision Detection
e Introduced in v8.9 SP1

e Improved in v8.11

e Application Add-in

e [tem Browser

18 | WWW.BENTLEY.COM

= Bentley

© 2009 Bentley Systems, Incorporated



_ 2009 ROADS AND BRIDGES CONFERENCE

Extend Pipe and Channel in Profile

e “Extend Culvert” now
works for pipes and
channels
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Interface and Workflow Streamlined

e Laying Out and Editing Drainage Structures have always
been a streamlined intuitive workflow, fully-integrated with
the CAD and InRoads environments

e Recent Release continue making adds and edits faster and
more intuitive
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Improvements to dialogs

e Edit/Review

- Styles tab has additional feedback

21 | WWW.BENTLEY.COM

e Layout > Pipe: Locate Buttons for Invert In and Invert Out

— Locate Buttons for Inverts, Rims and Pipe Slopes, Gutter Slopes
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Edit Utility Points

e Added the ability to edit
S&S Utility points

e Similar to Surface Edit
Feature Point command

e "Report” button launches a
report on Utility vertices’
XYZ and segments’ length
and slope
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=s Edit/Reyiew Utility

Utiity | User Data|

Ikility M ame; E-I;::-:Water :..' E st ater
2 X Repart...
Eeature Style: ET'-:-H-".l'i".TEH LIME :;, WA TER LIME
Shape: Cirzle ¥
width: 12.00 1
Height: 2o |
Stored Elevation
| () Top () Center %) Bottom
Fuint !1 j':'f 3 ﬂ [ Inzert ] [ Delete ]
] Center View
Nothing: | 202620163 |
e B 4
Easting: | 2052938,30 | |+
Elesation: {539 0 ]ﬂ
Back Ahead
Lengte (5 | | Length:  [353p #
Dhirechior: i_ """""""" —i e Diirection: IN?IE;‘E?'EI?”E_| 4
Slope:  [opi | 4| Sleee poox |+
Elereation: Elevation: 939.00

[ Apply ] [ Cloze
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Pipe ID Annotation

ID at junctions

[N

It Ine 944,90
Imnvert Out: 942.90
Irivert Oit: 942,90

Invert Out: 942.90
§ N & Invert Out: 942.90

Y

e Plan and Profile Annotation can now label attached Pipes’

11.01° Curb UOpening
Rim: 948.05

(P4

(P1e
(P8
(P11

(P9

- 5
= NEJ
o=
= P

- NW)
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Renumber Areas Using Bulk Area
Update

3 Bulk Area Update x|
® Create SeleCtiOn ID | Aea | Coefficient | Frequency | Peak Flow | { 4|}  Acoly |
Set of the Areas to Cose |
renumber. Fel
¢ Use PICk BUtton FFicie : 1\ Useelanerﬂscurrtainedinselediun@
and Click “"OK"” at T e S '
the prompt. = T =

e Check Renumber
Areas and Click

Make sure rainfall frequency is

Apply. correct.
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Report Improvements

e New data available for Reports

- Upstream and Downstream stations for ends of
e Pipes
e Culverts

e Channels

— All Pipe Names at Manholes and Inlets

Report All lreverts at Stuctures

Digplay Irwvert Direction Labels
Label Type: | ID - Direction w
Label Location: | Direction Only
D Onl
Farmatz
Pipes: Direction - 10 o o
|ID - Direckion :

Channels: Areas:
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IN41
IN43

IN45
IN46

950.49
949.96
949.69
949.69
948.86
948.58
948.56

(N - P75)
(N - P78)
(E - P76)
(W - P100)
(W - P81)
(NE - P80)
(SW - P82)
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Report Improvements

e New data available for Reports

- Upstream and Downstream stations for ends of
e Pipes
e Culverts

e Channels

— All Pipe Names at Manholes and Inlets

Report All lreverts at Stuctures

Digplay Irwvert Direction Labels
Label Type: | ID - Direction w
Label Location: | Direction Only
D Onl
Farmatz
Pipes: Direction - 10 o o
|ID - Direckion :

Channels: Areas:
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Updates in Sequence...
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V8.9 Updates

e Edit/Review > Inlet > Gutter tab - Added
locate buttons for the slope fields.

e Drainage > Network > Renumber - Areas can
be renumbered.

e Tools > Drainage > Structures File — The
Drainage Structures File and the Sizes dialog
boxes are now re-sizeable. -

e Structure > Extend Culvert in Profile - Added
the ability to extend Free Entrance and Free
Exit ends of Pipes and Channels.
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V8.9 (SP1) Updates

e View > Drainage As Solids - Added new
command to display pipes, culverts, manholes,
inlets and utilities as Smart Solids for 3D
viewing and visual collision detection.

e This is enabled through Tools > Application
Add-Ins.

e When enabled, reports can now contain all
inverts for manholes and inlets.

29 | WWW.BENTLEY.COM g Benﬂeg'

ated

por:

© 2009 Bentley Systems, Incor



2009 ROADS AND BRIDGES CONFERENCE

V8.9 (SP2) Updates

was added.
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e \VView> Annotate Structures and Evaluation>
Profile> Annotate Drainage Profile. The option
to annotate the ID of all inverts at structures
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V8i Updates

e View > Drainage As Solids display has been improved.

e Layout > Pipe. Locate buttons to pick elevations
graphically were added for Invert In and Invert Out.

e Edit/Review > Styles tab. Read only fields were added to
note the assigned style.

o Edit/Review > Inlets. Target buttons were added for
slopes and inverts for pipes and elevations for inlets.

e Edit/Review. When scrolling through a network with the
Edit Up and Edit Down buttons, the current ID, Upstream
ID, and Downstream ID displays in the message center.

e Network > Design. Clear ALL existing design tables was
added.

e Cross Section > Update Cross Section > Storm and
Sanitary leaf. The All or None buttons were replaced with
right click options in the list view.
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SS1 Fixes

. NETWORK DESIGN - for Grate Inlets in a Sag, weir flow equation and orifice flow equation should be average depth across grate instead of
depth of flow at curb. Filed for Jason Zhao, MSTHA According to HEC-22 equation 4-26, d needs to be average depth across the grate, not
depth at curb. This applies to orifice flow as well

. View Drainage as solids: made a fix for utilities that had segments shorter than 0.05 master units.

o Analysis of arch pipes. Changed the way the arch properties are computed. Now the arch pipe is constructed using the radii that are
provided and the Y coordinates for the corner radii are exact and the pipes are tangent at all radii. In the past, the bottom height was used
from the structures.dat file. Well, those were values were rounded off to the nearest 1/8 inch in most cases for constructability. Now the
bottom height is computed so that all radii are tangent. This will also fix problems with arch pipes in cross section and displayed as solids.

. HGL/EGL fixes for special cases.

o Insert in Profile. This was caused by the user trying to insert an inlet at the end of a pipe which is not allowed. Fixed the code so that
users can't inset structures within 0.1 master units of the end of a pipe.

. Reports, queries, plan annotation, drafting notes all display the coordinates for the placement point. Changed the Annotate Drainage Profile
to report the placement point instead of the vault location.

° Import Drainage From ASCII fixes/enhancements.

. SURVEY DATA TO DRAINAGE - Styles for new structures in database should come from structures.dat file instead of what is currently active
in Tools>Drainage>Options.

. Layout - The target buttons displayed the last elevation picked on the surface, and does not update when new points are selected that are
off of the surface.

. FIX: Now an error message will be output to the status bar and the elevation will set to 0.0. Check to make sure the message appears
when clicking off the surface but still inside the DTM range rectangle and also when the data point is outside the range rectangle. Also
check the behavior is correct when the coordinates are keyed in.
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