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Storm Drainage Layout with 
InRoads Storm & Sanitary 

Module Overview 

This workshop demonstrates the tools available in InRoads Storm and Sanitary for precision 
placement of drainage structures in a design model, and the tools available for automating the 
design and analysis of storm drainage networks. 

Module Prerequisites 

 Knowledge of basic InRoads functionality 

 Basic knowledge of InRoads alignments 

 Basic knowledge of InRoads surfaces 

Modules Objectives 

After completing this module, you will be able to: 

 Define standard structures 

 Lay out storm structures 

 Create drainage profiles 

 Design networks 

 Annotate drainage networks 

 Edit and update drainage networks 

 Annotate and report design data 
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 Introductory Knowledge 

Introductory Knowledge 

Before you being this module, let’s define what you already know. 

Questions 

1. What is the purpose of Project Defaults? 

2. How are Feature Styles used? 
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 Introductory Knowledge 

Answers 

1. What is the purpose of Project Defaults? 

Answer:  Use this command to set the default directory locations for opening/saving files. 
You can also set up preference files to be opened when InRoads is started. 

2. How are Feature Styles used? 

Answer:  Feature Styles are used to determine in which view (plan, profile, cross section) 
features may be displayed.  They are also used to specify which Named Symbology will 
be used to set the feature’s symbology, such as Level, Color, Line Style and Weight. 
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 Starting InRoads Storm & Sanitary 

Starting InRoads Storm & Sanitary 

Demonstrates how to open InRoads Storm & Sanitary, set project defaults, and open data 
files. 

 Exercise: In this exercise you will open InRoads Storm & Sanitary, set project 
defaults, and identify and open project data files. 

1. Select Start > All Programs > Bentley > InRoads Group > InRoads Storm & Sanitary. 

2. On the MicroStation Manager dialog, select the file 
C:\2007 IUTC\WS13-Storm Drainage Layout\drainage.dgn. 

 

After MicroStation and InRoads have started, load the Project Defaults for this workshop. 

3. Select File > Project Defaults. 
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 Starting InRoads Storm & Sanitary 

4. On the Set Project Defaults dialog, select WS 13-Storm Drainage Layout from the 
Configuration Name list box. 

 

5. Select Apply and then Close. The parameter files are loaded and the directory paths are 
set as defined in the WS 13-Storm Drainage Layout project default. 

6. Select File > Open. On the Open dialog, set the Files of type to Projects(*.rwk) and 
then select the file C:\2007 IUTC\WS 13-Storm Drainage Layout\WS13.rwk. 
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 Starting InRoads Storm & Sanitary 

7. Select Open and then Cancel. The following data files are opened: 
i90mrgol.dtm 
Existing I-90.alg 
I90 Drain.sdb 
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 Adding a Structure to the Structure.dat File 

Adding a Structure to the Structure.dat File 

Demonstrates how to add a new inlet to the standard structure file. 

 Exercise: In this exercise, you will add a new inlet to the standard structures file. 
After the structures are created in the structures.dat file, they are available to be 
placed into the network. 

1. Select Tools > Drainage > Structures File. 

2. On the Drainage Structures File dialog, change the Structure to Inlets. 

3. Highlight class Type J-2 and click the Sizes button. 

 

4. On the Sizes dialog, set the Type to Combination and select the New button. 

 

Sep-07 9 Storm Drainage Layout with InRoads Storm & Sanitary 

Copyright © 2007 Bentley Systems Incorporated 



 Adding a Structure to the Structure.dat File 

5. On the New Size dialog, enter a new 4’ x 2’ Combination inlet with a 4’ x 4’ vault and 2’ 
placement offset as shown below. 

 

Note: Make the Effective Length and the Effective Width equal to the Length and 
Width. 

6. On the New Size dialog, select Apply. 

7. On the Sizes dialog, select Apply. 

8. On the Drainage Structures File dialog, select Apply and Close. 

Sep-07 10 Storm Drainage Layout with InRoads Storm & Sanitary 

Copyright © 2007 Bentley Systems Incorporated 



 Creating a New Style 

Creating a New Style 

Demonstrates how to create a new style to display pipe centerlines in plan and profile views. 

 Exercise: In this exercise you will create a new style that will tell the program how 
to display pipe centerlines in plan and profiles views. The new style will use a 
Named Symbology that has already been created, and is stored in the 
Civil_WS13.xin file. 

1. Select Tools > Style Manager, and select the New button. 

 

2. On the New Style dialog, select the General leaf and make the following settings: 

Name:  Pipe_Center

Surface Feature:  On 
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 Creating a New Style 

3. Select the Surface Feature > Settings leaf, and make the following settings: 

3-D Plan display:  Line Segments:  On 

Annotation:  On 

Profile Display: Projected Line Segments:  On 

Annotation:  On 

                        
4. Select the Surface Feature > Symbology leaf, click in the Symbology Name field and 

select Pipe_Center_Proposed from the pull-down list. 

 

Note: This assigns the named symbolgy Pipe_Center_Proposed to the style 
Pipe_Center. The named symbology Pipe_Center_Proposed was previously 
created and provided in the Civil_WS13.xin file. 

5. Select Apply and then Close to create and save the new style. 

6. On the Style Manager dialog, select Close. 
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 Assigning Styles and Setting Layout Defaults 

Assigning Styles and Setting Layout Defaults 

Demonstrates how to assign a style when Areas are created. 

 Exercise: In this exercise, you will assign the style to be used when Areas are 
created. The active styles for drainage structures are set when you choose which 
structures from the structures.dat file the program will default to during layout. 

1. Select Tools > Drainage > Options and click on the Area tab. Set the following style for 
Areas:  Boundary Style:  Area. 

 

2. On the Drainage Options dialog, click on the Inlet tab and set the following: 

Structure Type:  Combination 

Class:  Type J-2 

Grate Size:  6.0 x 2.0   defaults to vault size 4.0 x 4.0 x 4.0 

Placement Offset:  2 

Location:  On Grade 

Connection Point:  Outside 
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 Assigning Styles and Setting Layout Defaults 

3. On the Drainage Options dialog, click on the Gutter Section tab and verify or set the 
following settings: 

Type:  Composite 

Gutter Width:  1.50 

Side Slope:  5.00% 

Longitudinal Slope:  Compute from DTM 

Transverse Slope:  User Value: 3.00% 

Roughness:  0.012000 

Maximum Spread:  5.00 

4. Select Apply to set the defined parameters. 

5. Select the Preferences button and select Save to store your changes to the “Default” 
preference. 

6. Select Close on the Preferences and Drainage Options dialogs. 

Note: The options set in Drainage Options are used as defaults when laying out 
structures. These can be changed at the time of layout by clicking on the Options 
button, and they can be changed for each individual structure by using the 
Edit/Review or Query commands. 
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 Laying Out the Drainage Network 

Laying Out the Drainage Network 

Demonstrates how to lay out a drainage network using the Multiple junctions layout 
command. 

 Exercise: In this exercise, you will lay out a drainage network using the Multiple 
Junctions layout command, and by laying out individual structures. 

1. Zoom In on the southern portion of Northwest Boulevard. 

2. Select Evaluation > Hydrology and Hydraulics > Trickle and verify or set the Surface 
to i90mrgol and Direction to Down. 

If you do not find Hydrology and Hydraulics under Evaluation, select Tools > Application 
Add-Ins and turn on the Hydrology and Hydraulics Add-in. 

3. On the Trickle dialog, select Apply and move the cursor over Northwest Boulevard. A 
dynamic line will display in the design file representing the flow path from the current 
position of the cursor. Pressing the <D> button on the mouse will place a graphic in the 
design file with the current MicroStation settings. Move the mouse to several areas in 
order to gain an understanding of where the rainfall runoff will go, and where inlets need 
to be placed.  <R> to exit command. 

 

Note: As you can see from the Trickle command, most of the runoff will flow to the 
right side of Northwest Blvd. as it is superelevated. Near the southern-most 
portion of the roadway, the road returns to normal crown and will need inlets on 
both sides of the roadway. 

4. When through evaluating the surface drainage, select Close on the Trickle dialog. 

5. Verify that Style lock is On and leave it on for this entire workflow. 
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 Laying Out the Drainage Network 

 

6. Select Drainage > Layout, and then click on the Multiple Junctions tab. 

7. On the Multiple Junctions tab, verify or set the following settings: 

Junction Type:  Inlet 

Alignment:  Northwest Blvd K 

Upstream Station:  0+00.00 

Downstream Station:  3+53.7 

Offset:  14.25 

Placement Interval:  50 

Compute Elevation from Surface:  i90 mrgol 

Add Connecting Pipes by Slope:  0.50% 

 

8. Select the Options button at the bottom of the Drainage Lay Out dialog and notice that 
the settings entered in the previous exercise are active and will be the structure type 
placed. This is where you can change the type of structure to be placed. 

9. Select Close on the Drainage Options dialog. 
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 Laying Out the Drainage Network 

10. On the Drainage Lay Out dialog, select Apply. This creates Inlets 50 – 57 and Pipes 50 – 
56. 

 

11. On the Drainage Lay Out dialog, select the Inlet tab. 

12. Click on the Northing/Easting/Elevation locate button to the right of the data fields. 

 

13. In the MicroStation key-in dialog, key in so=49.6,-10 and hit the Enter key. 

 

Note: This populates the Northing, Easting, and Elevations fields with the coordinates 
of the point at station 0+49.6 that is ten feet left of the alignment. It also reads the 
DTM for the longitudinal slope and transverse slope at that point. 
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 Laying Out the Drainage Network 

14. Select Apply to layout that inlet, IN58. 

 

15. To layout the next inlet, use the locate button again and key in so=100,-8.1. 

 

16. Select Apply to create IN59 and add it to the database. 

 

17. Select the Pipe tab and zoom in on the southern portion of the network. 
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 Laying Out the Drainage Network 

18. Lay out the following pipe, named P57 (see picture below): 

Upstream ID: IN58 (Keyin the ID or use the Locate button to select IN58) 

Downstream ID:  IN51 

 

19. Select Apply to create P57 and add it to the database. 

20. Lay out the following pipe, named P58: 

Upstream ID:  IN59 

Downstream ID:  IN52 

Slope:  1.0% 
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 Laying Out the Drainage Network 

21. Select Apply to create P58 and add it to the database. 

22. Window Area to the northern end of the network around IN57. 

23. Finally, lay out an outfall pipe, P59, from IN57 to specified coordinates as follows: 

Upstream ID:  IN57 

Downstream:  Northing:  671039.89 

 Easting:  720748.30 

 

24. Select Apply to create P59 and add it to the database. 

Notice that this placed a free-exit outfall pipe from Inlet 57 up to the northeast gore area 
of the intersection 

25. On the Drainage Lay Out dialog, select Close. 
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 Moving Drainage Structures 

Moving Drainage Structures 

Demonstrates how to check for any interference with existing utilities and check for proper 
locaton of inlets near intersections. 

 Exercise: In this exercise, now that we have quickly laid out the structures on our 
site, we need to go back and “fine tune” the locations of some of the structures. 

If you zoom in to the intersection of Ironwood Dr. and Northwest Blvd., you will see that the 
inlets placed by the multiple junction layout command are close, but need to be moved to a 
better location along the curb. 

1. Select Drainage > Structure > Move, and set the following settings: 

 

2. Select Apply and move IN52 to a location along the curb before the intersection begins. 

 

3. Continue the same process with inlet IN53 on the north side of the intersection, and move 
it away from the intersection. 

4. Move the most northern inlet in the network, IN57, back away from the intersection. 

5. Select Close on the Move Structure dialog. 
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 Creating a Drainage Profile 

Creating a Drainage Profile 

Demonstrates how to create a profile along the drainage network. 

 Exercise: In this exercise, you will create a profile along the drainage network to 
evaluate the system and look for potential problems. 

1. Zoom Out in your drawing file so that you can see the entire network that has been 
placed. 

2. Select Evaluation > Profile > Create Profile, on the General leaf, verify the following: 

Set Name:  NWdrain1 

Direction:  Left to Right 

Vertical Exaggeration:  2.0 

Surface Object:  i90mrgol 

 

3. Select the Source leaf, and verify or set the following settings: 

Create:  Network 

Alignment:  NWdrain1 

From:  IN50 

To:  P59 

Drainage Network Reference:  Network 

Start Station:  0.00 

Extend Axis:  0.00 
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 Creating a Drainage Profile 

 

4. Select Apply and place a <D> point in the design file to locate the lower left corner of 
the profile window.  Place the profile such that it is near the drainage network, but away 
from the existing graphics. 

 
5. On the Create Profile dialog, select Close. 
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 Evaluating the Profile and Making Changes 

Evaluating the Profile and Making Changes 

Demonstrates how to evaluate the profile and identify and correct problems. 

 Exercise: In this exercise, you will evaluate the profile, identify potential problems, 
and correct the problems. 

1. Zoom In on the profile window and review the results. 

2. Window Area to the left end of the profile window such that you can see at least the first 
three inlets, and toggle the Graphic Group lock Off. 

 
Looking at the profile, you can see three potential problems: 

1. The ground cover over the first pipe may be too shallow. 

2. The invert elevation of the second cross drain pipe may be too high. 

3. The third inlet, IN52, may be too close to an existing underground utility. 

Resolving Problem 1 

3. Select Evaluation > Profile > Check Pipe Cover, and set the following settings. 

 

4. Select Apply. The Results dialog is displayed with the report data. Review the report and 
note that the Minimum Pipe Cover is 1.5 ft and that the first pipe, P50, does not meet 
minimum cover. 
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 Evaluating the Profile and Making Changes 

 

5. Close the Results and the Check Pipe Cover dialoges. 

6. Select Drainage > Structure > Move in Profile. When prompted to Identify structure, 
select the middle of the first pipe in the profile and move it down about one/half the pipe 
diameter, but not lower than the invert in of the next downstream pipe. 

7. Place a <D> point to locate the new position, and then <R> to exit the command. 

 

8. Run the Check Pipe Cover command again and verify that the cover is now sufficient 
for that pipe. 

Resolving Problem 2 

9. Select Drainage > Edit/Review and <D> point on the end of the cross drain pipe in 
IN52 and then <D> to Accept when it highlights. The Edit/Review Pipe dialog is 
displayed for P58. 

10. In the Edit/Review Pipe dialog, note that the slope of pipe P58 is 0.9%. You can either 
enter a new Invert Out elevation or enter a new Slope for the pipe. Click in the Invert 
Out field, enter 668.30 and Tab out of the field. When you tab out, the Slope value is 
automatically calculated and updated. 

 

Note: Your Pipe Length and Slope Values will be different from the values shown due 
to moving IN52 earlier in the workshop. 

11. Select Apply to save the changes to the database, and then Close the dialog. 

12. Select Evaluation > Profile > Update Drainage Profile and select Apply. The new 
elevation of the cross drain pipe will be displayed in the profile. 
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 Evaluating the Profile and Making Changes 

13. Select Close to dismiss the Update Drainage Profile dialog. 

Resolving Problem 3 

14. Zoom Out until the plan view of the network is visible. 

15. In the InRoads Storm & Sanitary Explorer window, click on the Drainage tab to display 
the drainage database Text. 

16. Click on the Utilities leaf to display the utilities in the active database. The utilities are 
displayed in the right-side of the Explorer window. 

 

Note the different utilities and their associated shapes. 

17. Select Drainage > Utilities > View, and then select Apply to display the existing utilities 
into the drawing file. 

18. Window Area around IN52 and note the position of the inlet in relation to the existing 
telephone/cable line. 
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 Evaluating the Profile and Making Changes 

19. Select Drainage > Structure > Move and slide the inlet away from the phone line. 

Note: Be sure to set the Alignment to Northwest Blvd K. 

 

20. Select Evaluation > Profile > Update Drainage Profile and select Apply. The new 
location of the inlet will be displayed in the profile. 
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 Computing Flows Into the Network 

Computing Flows Into the Network 

Demonstrates how to analyze the DTM and automatically delineate drainage areas. 

 Exercise: In this section, we will use the Display Source Areas command to analyze 
the DTM and automatically delineate drainage areas. We will then attach those 
drainage areas to inlets and we will also inject flow directly in some inlets. 

1. Zoom In on the five northern most inlets in the network. 

2. In the MicroStation Key-in field, enter tx=0.5 and press the Enter key. The Display 
Source Areas command uses the active MicroStation settings, you may also want to set 
your active color, linestyle, and lineweight. 

3. Select Evaluation > Hydrology and Hydraulics > Display Source Areas and verify 
that surface i90mrgol is selected. 

4. Select Apply.  When prompted to Identify Point, snap to the origin of the cell for these 
five inlets and <D> point to place the source area. 

 

Hint: Make sure the active MicroStation snap is set to Origin Snap.   

 

The area created by the Display Source Areas command outlines the entire area of the surface 
that drains to the selected point. Since we have multiple inlets accepting flow, we need to 
subdivide the areas drawn by the Display Source Areas command. To do this, we will use the 
Create Region - Flood command in MicroStation 

5. On the Display Source Area dialog, select Close. 
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 Computing Flows Into the Network 

6. In MicroStation, use the PowerSelector and select the text next to each of the five areas 

created in the previous steps.   

7. In MicroStation, invoke the Create Region command either by keying –in create region 
flood, or by selecting the Create Region icon off of the Groups toolbox. 

8. Set the method to Flood, and make sure Keep Original is selected. 

 

9. At the prompt Create Region From Area Enclosing Point, <D> point inside each of the 
five areas and <D> to Accept. 

10. With the five original areas still selected, select the Delete Element command in 
MicroStation to delete the original areas created by the Display Source Areas command. 
Refresh the view, and only the new areas will display. 

11. In InRoads, select Drainage > Flows > Compute Flow and set the following settings: 

Runoff Coefficient:  0.90 

Time of Concentration:  5.0 

12. Click on the locate button next to Drainage Area and place a <D> point to identify the 
graphic representing the drainage area for the first inlet. Once accepted, the Drainage 
Area field is automatically filled updated with the calculated area. 
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 Computing Flows Into the Network 

13. Click on the locate button next to Attach To and place a <D> point to pick the 
corresponding inlet. 

 

14. Select Apply to add the Area/Inlet combination and the areas to the drainage database. 

15. Repeat this process for the remaining four inlets, then Close the dialog. 

16. In the InRoads Storm & Sanitary Explorer window, click on the Drainage tab, and then 
click on the Areas leaf to list all the Areas in the database. Verify that you have created 
all five areas and attached them to their corresponding inlet. 

 

For the remaining five inlets on the southern end of the network, we will inject 0.2 cfs of flow 
directly into each inlet. 

17. Window Area to the southern end of the network. 

18. Select Drainage > Flows > Inject Flow, click on the Attach To locate button and <D> 
point on IN50. 
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 Computing Flows Into the Network 

19. Click in the Storm Flow field, enter 0.200, and select Apply. The injected storm flow is 
attached to the inlet and stored in the database. 

 

20. Repeat the above process for the four remaining inlets. 

21. Select Close on the Inject Flow dialog. 

22. On the Drainage tab of the Explorer window, select the Inlets leaf.  Scroll down until 
inlets IN50 – IN59 are visible.  Verify that all the inlets display Area or Injected Storm 
in the Flow From column. 
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 Designing the Network 

Designing the Network 

Demonstrates how to design the network. 

 Exercise: After flows have been attached to the network, you can design the 
network. When the design network command is run, the program begins at the most 
upstream structure and travels downstream. The capacity of each structure is 
analyzed, and the appropriate size is selected from the structures file to handle the 
amount of flow specified. After the structures are sized, the program begins at the 
network outfall and calculates the HGL and EGL by adding each structure’s losses 
to the one below it. 

1. Select Drainage > Network > Design and verify or set the following settings: 

Tree Network Containing:  Select any structure in the network 

Generate Design Log:  On 

Generate HGL and EGL:  On 

Outfall Water Level:  Use Water Depth 

Trunk Line Path:  Greatest Flow 

 

2. Select Apply.  The network is designed, and the Results dialog displays the design log. 
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 Designing the Network 

3. Review the design log to see the results, and to look for warnings. 

 

4. Select Close on the Results and the Design Network dialogs. 

5. Select Evaluation > Profile > Create Profile and create a new profile that will show the 
results of the design.  All the settings should still be active from earlier, if not, go back to 
the section “Creating a Drainage Profile” for instructions. 

 

Note: This profile example was generated with a verticasl exaggeration of 5. 
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 Annotating Structures and Drainage Profiles 

Annotating Structures and Drainage Profiles 

Demonstrates how to annotate structures and drainage profiles. 

 Exercise: With Style Lock turned on, every structure’s annotation is controlled 
separately by the Style that is assigned to it. With Style Lock off, every structure is 
annotated as defined on the Annotate Structure dialog. 

1. For plan view annotation, select the Drainage > View > Annotate Structures command. 

2. Set the Structures for Annotation to Outfall and use the locate button to identify the 
last structure in the network profile, P59. 

3. Select Apply and the network structures in the plan view are annotated. 

 

4. Select Close on the Annotate Structures dialog. 

5. For profile annotation, select Evaluation > Profile > Annotate Drainage Profile. 

6. On the Annotate Drainage Profile dialog, identify the profile to be annotated, select 
Apply, and then Zoom In to the profile to view the annotation. 

 

7. Select Close on the Annotate Drainage Profile dialog. 
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 Editing the Network 

Editing the Network 

Demonstrates how to edit the network. 

 Exercise: If there are design changes to alignments or surfaces during the project 
that occur after the storm network has been placed, you can use the Move Network 
command to adjust the network to the new data.  In this workshop, we are going to 
simulate a design change that necessitates lowering the roadway by a half a foot. 

1. Select File > Open, set the Files of type to Surfaces (*.dtm) and open the file 
i90rev3.dtm. 

2. Select Evaluation > Profile > Create Profile, click on the General leaf and set the 
following settings: 

Set Name:  Revised Profile 

Surface Object:   i90mrgol – On 

   i90rev3 - On 

3. Click on the Source leaf, and verify or set the following settings: 

 

4. Select Apply and create a new profile. 

5. Window Area into the new profile. Notice that the rims of all the inlets need to be 
lowered to the new design surface. 
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 Editing the Network 

6. Select Drainage > Network > Move, and set the following settings: 

Structures:  Tree Network Containing 

 select any structure (from plan view) 

Rims to a new surface:  On 

Surface: i90rev3 

 

Note: You have the option to move the pipe inverts down by the same distance as the 
rims by selecting the Hold Distance From Rim To Connected Pipe Inverts toggle. 
We won’t do it in this exercise since we have no issues with our network 
violating minimum cover. 

7. Select Apply and the elevations of the inlets are changed. 

8. Run the Evaluation > Profile > Update Drainage Profile command. Make sure you 
select the Revised Profile set in the Profile Set list and select Apply. 

 

Notice all the inlet rims have now been adjusted to the new elevation. 
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 Creating Custom Reports 

Creating Custom Reports 

Demonstrates how to create custom reports. 

 Exercise: Working with the InRoads Storm & Sanitary Access database, we will 
easily create custom reports and queries on the database. 

1. Select Tools > Drainage > Reports. 

2. On the Drainage Reports dialog, click the Main tab, click the Structure Type option and 
select Inlets from the pull-down list. 

 

3. Click the Formats tab. 

4. On the Drainage Reports dialog, from the list of report templates, under the Structure 
column, find Inlets. Select Physical Data and click Edit. 
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5. On the Edit Report Format dialog, in the upper portion of the Report Data section, 
set the following settings: 

Lines per Page:  55 

Attribute:  Y 

Header:  Northing 

Column Width:  12 

Precision:  0.123 

 

6. Select Add and scroll down to the bottom to see that attribute Y was added to the list of 
attributes to be included in the report. 

7. Repeat the above with the following settings: 

Attribute:  X 

Header:  Easting 

Column Width:  12 

Precision:  0.123 

8. Select Add. 

9. Click the Sort button. 

10. Highlight the Y attribute in the list view. 

11. Click the Move Up button until the Y attribute is just below ID. 

12. Do the same for the X attribute. 
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13. On the Report Sorting dialog, make the following settings. 

Sort By:  Type   Ascending 

Then By:  Y   Ascending 

Then By:  ID   Ascending 

 

14. Select Apply. 

15. On the Edit Report Format dialog, select Apply and then Close. 

16. Click the Main tab, make sure that the Inlets are set to Physical data. Select Apply. 

 

17. On the Results dialog, select Save As to save the report. 

18. Click in the File name field and enter inlet.txt. 

19. Select Save. 

20. Close the Results and the Drainage Reports dialogs. 
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 Executing Queries 

Executing Queries 

Demonstrates how to execute queries to find structures that meet defined criteria. 

 Exercise: While working with a storm network, we will search the network to find 
structures that meet certain criteria. In this case, we want to highlight any pipes 
where the velocity is greater than 3 ft/sec. 

1. Select Tools > Drainage > Queries, and click the Queries tab. 

 

2. Click New, and set the following settings: 

Name:  Velocity > 3ft/sec 

Description:  Pipes V > 3 fps 

Structure Type:  Pipes 

 

3. Select Apply. The new query is entered into the list of existing queries. 

4. Select the query Velocity > 3 ft/sec and select Edit. 

5. On the Edit Query dialog, set the following settings: 

Attribute:  ID 

Operator:  >=  (greater than or equal to) 

Value:  P1 
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6. Click the Add option and then select the Add button to create the first entry in the query 
attribute list. 

7. Create the second entry by setting the following values: 

Attribute:  Velocity 

Operator:  >=  (greater than or equal to) 

Value:  3.0 

8. Click the Add option and then select the Add button to create the second entry. 

 

9. Select Apply, and then Close. 

10. On the Drainage Queries dialog, click the Main tab, and make the following settings: 

Structure Type:  Pipes 

Query:  Velocity > 3ft/sec 

 

11. Select Apply. 

12. In the Query Results section, the number of items that match the query is listed and the 
three buttons in that section become active. 
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 Executing Queries 

 

13. Select Change Symbology. 

14. On the Query Symbology dialog, toggle everything off, toggle on Pipe Outside, double 
click on Pipe Outside to edit the symbology. 

 

15. On the Line symbology dialog, click the Symbology Name pull-down and select Fill 
from the list. Select OK. 
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16. On the Query Symbology dialog, select Apply and then Close. 

 

Notice that the pipes that have a velocity of 3 ft/sec or greater have a different symbology. 

17. Close the Drainage Queries dialog. 
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 Module Review 

Module Review 

Now that you have completed this module, let’s measure what you have learned. 

Questions 

1. Which command is used to define new standard structures? 

2. When laying out a new structure like an inlet, manhole, or pipe, where does the user set 
the type of structure to be laid out? 

3. The Trickle command displays a flow path on a surface from a cursor position.  This 
command can be found under which pull-down menu? 

Surface 
Drainage 
Evaluation 

4. Specifying the Northing, Easting, and Elevation of a new inlet can be accomplished only 
by placing a data point in the design file. 

True 
False 

5. Plan annotation and profile annotation commands annotate only the highest invert into an 
inlet or manhole and the lowest invert out of the inlet or manhole.  

True 
False 
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Answers 

1. Which command is used to define new standard structures? 

Answer:  Tools>Drainage>Structures File 

2. The Trickle command displays a flow path on a surface from a cursor position. This 
command can be found under which pull-down menu? 

Answer:  Tools>Drainage>Options 

3. The Trickle command displays a flow path on a surface from a cursor position. This 
command can be found under which pull-down menu? 

Answer:  Evaluation 

4. Specifying the Northing, Easting, and Elevation of a new inlet can be accomplished only 
by placing a data point in the design file. 

Answer:  False, because you can also specify location by using the so= and xy= 
keyins in the MicroStation keyin window. 

5. Plan annotation and profile annotation commands annotate only the highest invert into an 
inlet or manhole and the lowest invert out of the inlet or manhole. 

Answer:  False, because these commands include a checkbox that allows you to 
annotate all the inverts at an inlet or manhole. 

Module Summary 

You are now able to: 

 Define standard structures 

 Lay out storm structures 

 Create drainage profiles 

 Design networks 

 Annotate drainage networks 

 Edit and update drainage networks 

 Annotate and report design data 
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