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VOLUME COMPUTATIONS FOR INROADS PRODUCTS 

WORKSHOP OBJECTIVES 

This workshop focuses on getting results from the End-Area Volumes command found 
in the InRoads Group of products.  You will cover a number of different topics from 
other commands while you build up the project data in preparation for using the End-
Area Volumes command.  In addition, you will be working with multiple subsurfaces 
and unsuitable materials as well as volume reporting.  In this workshop, you will: 

 Modify a template to include an undercut component 

 Run Roadway Designer using the modified template 

 Use the boundary of the design surface to create stripping features 

 Display cross sections of your design 

 Set up parameters for the End-Area Volumes command and run the command 

 View volume reports and save the XML data 

 Create a mass-haul diagram from the XML data 

Note This workshop covers intermediate topics using Bentley InRoads XM Edition V8.9 
running on MicroStation XM Edition.  It is assumed that you have a basic familiarity 
with InRoads commands from V8.7 or higher. 
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BEFORE YOU BEGIN 

Before beginning the exercises outlined in this workshop, you need to start InRoads 
and load the workshop files.  To do so, follow these steps: 

1. From the Start > Programs > Bentley > InRoads Group XM menu, select InRoads. 

2. Navigate to the workshop directory and select the volumes.dgn file from the 
MicroStation Manager.  This design file has a reference file attached showing some 
of the existing topological features which are stored in the DTM.  You may turn off 
the display of the reference file at any time, if you wish, by selecting File > 
Reference from the MicroStation menu and toggling off the checkmark in the 
Display column.  We only use this data for visual reference during the workshop. 

3. From the InRoads Explorer, select File > Project Defaults and set the Configuration 
Name to WS 15.  Close the Project Defaults dialog. 

 
Set Project Defaults 

Hint If WS 15 does not show up in your list, select the Import button from the Project 
Defaults dialog, navigate to the workshop directory, and open WS15.reg. 

4. Select File > Open and load the workshop files by selecting the project file named 
volumes.rwk.  This project file contains a geometry project, three surfaces, a 
template library and a roadway design file for use in the remainder of this 
workshop. 

5. Select Tools > Locks > Toolbar to turn on the Locks toolbar, if it is not already on. 

You are now ready to begin the exercises in this workshop.  If, for any reason, you 
must exit the software before the end of the workshop, simply repeat the steps in this 
section. 

If you are unable to complete an exercise as you proceed through this workshop, the 
completed files for that lesson are stored in subdirectories labeled with the exercise 
number.  For example, if you cannot complete Exercise 3, you can copy the completed 
files from the \Exercise 3 subdirectory to your working directory before beginning 
Exercise 4. 
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VOLUME COMPUTATIONS FOR INROADS PRODUCTS 

LESSON 1:  ANALYZING YOUR DESIGN DATA 

LESSON OBJECTIVE: 

In this lesson, you will become more familiar with the project data you will be using 
during this workshop.  You will display your geometry and some surface data as well as 
create a profile along the centerline. 

 EXERCISE 1:  DISPLAYING YOUR DESIGN DATA 
In this exercise, you will display some of the data making up your design project. 

1. You will notice a number of topological features displayed in the attached reference 
file.  This project involves the resurfacing and relocation of a rural two lane road 
and a new creek crossing.  The resurfacing portion has already been completed 
and the design surfaces have been merged into the existing ground surface.  You 
will be completing the relocation during this workshop. 

2. Select Geometry > View Geometry > Horizontal Annotation from the InRoads 
Explorer menu.  Keyin CL reloc in the Horizontal Alignments Include field and 
select Apply.  You should see a mint green line representing the centerline of the 
relocated portion of your design. 

3. Select Geometry > View Geometry > Stationing and select Apply.  Window in to the 
beginning of your alignment and note that it begins at Station 5+884.  Pan along 
the alignment, if you wish.  Fit your view. 

4. Select Evaluation > Profile > Create Profile and verify that all three surfaces – 
limestone, shale and existing – are selected.  Select Apply and place the profile 
below your plan graphics.  You will notice that your existing surface is represented 
by a red line, the limestone subsurface by a gold line and the shale subsurface by 
a light pink line.  The limestone and shale surfaces are not continuous along the 
length of your profile. 

5. Select Geometry > View Geometry > Vertical Annotation and select Apply.  As you 
can see, this project includes a bridge from Station 6+538 to Station 6+866. 

 
Vertical Alignment 

6. Select Surface > View Surface > Perimeter and Surface > View Surface > Contours 
to display your existing surface. 
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LESSON 2:  ADDING AN UNDERCUT COMPONENT TO THE TEMPLATE 

LESSON OBJECTIVE: 

A frequent requirement for rock excavation is to cut away additional rock material 
beneath the road surface and to fill this area back in with normal fill which can be 
compacted.  This is typically referred to as "undercut." 

This lesson will guide you through the steps required to add an undercut component to 
your template which will only be activated when the bottom of the aggregate base 
component falls below the shale surface.  The new component will be controlled by null 
points and display rules. 

 EXERCISE 2:  TEMPLATE OVERVIEW 
In this exercise, you will analyze an existing template contained in your template library. 

1. Select Modeler > Create Template from the InRoads Explorer menu and expand 
the root folder.  You will notice that your library already contains a number of end 
conditions, pavements, templates, etc. 

 
Template Library Contents 
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2. The template you are going to use in this workshop is located in the Templates 
folder and is called 2 Lane Rural w\Subsurface.  Make it the active template by 
double-clicking it in the treeview on the left side of the dialog.  Turn off the Display 
Point Names option, if you wish. 

 
2 Lane Rural w\Subsurface 

3. Spend a few moments getting familiar with this template.  You will notice that in 
addition to the usual pavement and base components, it contains a number of 
slope options for fill situations (the bright pink lines) and several options for cut 
situations.  In addition to a flat bottom ditch, the cut options also include teal lines 
which target the active surface, gold lines which target limestone and light pink 
lines which target shale. 

4. Select the Test button at the bottom of the template display window. 

5. Keyin a slope of 2% in the Use Surface Slope field and select <Active>-Surface in 
the Available Targets list.  Then select the Draw button. 

6. Move the surface line up and down in the display window to see the effect of depth 
on the fill slopes and how the template behaves in a cut situation.  Place the line 
near the top of the display window. 
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7. Now select limestone-Surface in the Available Targets list and Draw it.  See the 
effect on the template as you move it up and down.  Place the limestone surface 
line below the active surface line.  Notice that the limestone components contain a 
segment that follows the top of the limestone surface for 1 meter before testing for 
the next target. 

8. Next, select shale-Surface in the Available Targets list and Draw it.  Note the 
changes in the sideslopes.  The shale components contain a v-bottom ditch at the 
top of the shale surface before testing for the next target. 

 
Testing the 2 Lane Rural w\Subsurface Template 

9. If you like, Reset the display and test the template with just the active surface and 
the shale surface to verify that these conditions are accounted for.  Close the Test 
dialog. 

 EXERCISE 3:  CREATING NULL POINTS FOR CONTROL OF THE UNDERCUT 
COMPONENT 
A null point is a template point that is purposely not related to any particular 
component.  It is most often used as a reference for controlling other points.  In this 
exercise, you will create null points for control of the undercut component. 
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1. Select Tools > Options from the Create Template menu and turn on the Apply 
Affixes option.  Key in L for the Left Prefix and R for the Right Prefix. 

 
Setting Affixes 

2. Display the Dynamic Settings dialog by clicking the Toggle Dynamic Settings 
Dialog button at the bottom right of the template display window. 

 
Template Window Toolbar 

3. Set the Y Step to 1.0000 and key in control in the Point Name field.  Make sure 
Apply Affixes is toggled on. 

 
Dynamic Settings for the Null Points 

4. Right-click the display area of the Create Template dialog and select Add New 
Component > Null Point. 

 
Adding a Null Point 
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5. Place three null points at an elevation of approximately -3, two below the shoulder 
points and one below the center.  The exact location isn't important because you 
will use constraints to precisely locate the null points. 

 
Three Null Points 

6. Window in so that you can see the three null points and the driving surface points 
in your display window.  Right-click the left null point and select Edit Point. 
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7. Verify that the name of the point is Lcontrol and set the Type for Constraint 1 to 
Horizontal and its Parent 1 to LOS4, either by selecting it from the dropdown list or 
by using the Locate button.  Set the Type for Constraint 2 to Project to Surface 
and its Parent 1 to Any Direction.  Keyin a Value of 0.0000 for Constraint 1 and 
select shale for Constraint 2.  Select Apply to save your changes. 

 
Edit Point Properties for Lcontrol 

8. Follow a similar workflow for the right control point (Rcontrol) and use ROS4 as 
Parent 1, 0.0000 as the first Value and shale as the second Value.  For the center 
control point, rename it CLcontrol and use CL as Parent 1, 0.0000 as the first 
Value and shale as the second Value. 

9. Save your template library. 

 EXERCISE 4:  CREATING AN UNDERCUT COMPONENT 
In this exercise, you will create an undercut component below your aggregate base 
(cyan colored) component. 

Note Window in so that you can see the right side of the Pavement, base and 
aggregate base components.  If your point names are not displayed, toggle their 
display on by selecting the Display Point Names option. 

Hint You may want to maximize your Create Template dialog because you will be 
snapping to multiple existing points in the next steps. 
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10. If the Dynamic Settings dialog is not already displayed, display it by clicking the 
Toggle Dynamic Settings Dialog button at the bottom right of the template display 
window. 

 
Template Window Toolbar 

11. Key in 0.0000 in the Y Step field, and undercut in the Point Name field.  Set the 
key-in type to xy= on the Dynamic Settings dialog. 

 
Dynamic Settings for the undercut Component 

12. Right-click the template display window and select Add New Component > 
Unconstrained. 

 
Adding an Unconstrained Component 

13. In the Current Component area of the Create Template dialog, key in undercut in 
the Name field and choose undercut in the Style list. 

14. Before placing the first point, right-click in the template display window again and 
turn on the Mirror toggle, if it is not already on. 

 
Mirror On 
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15. On the Dynamic Settings dialog, keyin 0,-0.4750 in the value field and select the 
ENTER key.  Your first point will display in the template display window below point 
CL3. 

 
Precision Keyin 

16. Place the next point below REP3 and then a point at approximately the same slope 
intersecting with the blue ditch foreslope line.  Again, the exact location will be 
controlled by constraints.  Now snap to the other points making up the edge of the 
shoulder and aggregate layers in the following order: ROS, ROS1, ROS2, ROS3, 
ROS4, REP3 and CL3. 

Note Do not snap to the null points named RN1 and RN2.  If you did snap to the null 
points, simply select the Undo button from the template window toolbar and begin 
this exercise again. 

 
Placing the Undercut Component 
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17. Now right-click in the display window and select Finish. 

 
Finished 

18. Right-click and edit the first point you placed as part of the undercut component 
just below CL3.  Change its Name to CLundercut and set up the remainder of its 
properties as shown in the following figure: 

 
Editing CLundercut 

Hint Don't forget to select Apply after setting each point's properties. 
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19. Set the properties for the other four points along the bottom of the undercut 
component as follows, beginning at the far left: 

Name:  Lundercut1 
Constraint 1 Type: Vector-Offset 
Parent 1:  LEP3 
Parent 2:  LOS4 
Value:  -0.2000 
Constraint 2 Type: Vector-Offset 
Parent 1:  LOS 
Parent 2:  Lditch foreslope 
Value:  0.0000 

Name:  Lundercut 
Constraint 1 Type: Horizontal 
Parent 1:  LEP3 
Value:  0.0000 
Constraint 2 Type: Vertical 
Parent 1:  LEP3 
Value:  -0.2000 

Name:  Rundercut 
Constraint 1 Type: Horizontal 
Parent 1:  REP3 
Value:  0.0000 
Constraint 2 Type: Vertical 
Parent 1:  REP3 
Value:  -0.2000 

Name:  Rundercut1 
Constraint 1 Type: Vector-Offset 
Parent 1:  REP3 
Parent 2:  ROS4 
Value:  0.2000 
Constraint 2 Type: Vector-Offset 
Parent 1:  ROS 
Parent 2:  Rditch foreslope 
Value:  0.0000 

20. When you have finished modifying the points, right-click the orange line between 
CL3 and CLundercut and select Merge Components. 

21. Double-click the orange component and change its Name back to undercut. 

 
Edit Component Properties for undercut 
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22. Select the Active Template tab at the bottom of the treeview.  Expand the 
Components folder and select the undercut component.  Your finished component 
should look like the figure below.  Save your template library. 

 
Finished Undercut Component 

 EXERCISE 5:  ADDING DISPLAY RULES 
Adding a display rule to one or more components in a template allows you to apply one 
template that changes based on what is occurring at a particular station.  It frees you 
from knowing where a change in conditions might require a different template and 
allows the rules within a template to make the modifications for you.  In this exercise, 
you will create display rules that will prevent the undercut component from displaying 
except when any two points along the bottom of the aggregate base component are 
below the shale surface. 

1. First, Test the template to see how it behaves before you apply any display rules.  
As currently defined, the undercut component is displayed no matter how high or 
deep the driving surface. 

2. Double-click the undercut component and select Edit beside the Display Rules 
field.  Select Add below the Template Display Rules list. 

3. Create three rules with the following parameters: 

Name:  Rule1  Rule2  Rule3 
Type:  Vertical Vertical Vertical 
Between:  LOS4  ROS4  CLundercut 
And:  Lcontrol Rcontrol CLcontrol 
Condition:  > 0.0000 > 0.0000 > 0.0000 
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4. In the Conditional Expression field type in or use the buttons to add the following 
expression: 

(NOT Rule1 OR NOT Rule2) AND NOT Rule3 

Since the control points have been constrained to follow the shale surface, the 
conditions you have just created have the effect of limiting the display of the 
undercut component unless the centerline point of the bottom of the undercut 
plus either of the two bottom-most points of the aggregate base component is 
below the shale surface.  This prevents undercut conditions unless at least half of 
the roadway is affected. 

5. Select OK on both dialogs and Test your template.  Enter a value of 25% in the 
Use Surface Slope field.  Draw the active surface, then the limestone surface, 
then the shale surface.  Slide the shale surface up and down.  Notice that the 
undercut component does not appear until display rules created above are 
satisfied. 

 
Testing the Display Rules 

6. Close the Test dialog and save your template library. 
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7. On the Create Template dialog, make sure your active tab at the bottom of the 
treeview is set to Library, right-click the 2 Lane Rural w\Subsurface template in 
the treeview and select Template Documentation Link. 

 
Template Documentation Link 

8. On the Template Documentation Link dialog, select the Browse button beside the 
File Name field.  Navigate to the workshop directory and select the file named 
2LaneRuralWSubsurface.chm. 

 
Adding a Documentation Link 

9. Select the Open Link button and view the documentation created for this template. 

Note This file was created by modifying the HTML output from the style sheet named 
TemplateComponentDetails.xsl in the \XML Data\TemplateLibrary 
directory. 

10. Save your template library again.  This link is now saved with your library and will 
be available to anyone using the library. 
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LESSON 3:  RUNNING ROADWAY DESIGNER 

LESSON OBJECTIVE: 

This lesson will guide you through the steps required to use your modified template in 
the Roadway Designer. 

 EXERCISE 6:  SYNCHRONIZING THE TEMPLATE DROPS 
In this lesson, you will synchronize your roadway design file with your template library. 

1. From the InRoads Explorer, select Modeler > Roadway Designer.  Spend a minute 
getting familiar with your design.  Select the first button on the toolbar – Manage 
Corridors.  You will notice that your Corridor named CL-278 has already been 
created.  Close the Manage Corridors dialog. 

 
Manage Corridors Button 

2. Select the second button on the toolbar – Template Drops.  Notice that template 
drops have also already been specified but several of them are red.  This is 
because they no longer match what is stored in the template library due to the 
changes you made in the last lesson. 

 
Template Drops Button 

3. Highlight each of the red entries in the Current Template Drops list and select 
Synchronize with Library.  Close the Template Drops dialog. 

Hint You can change multiple entries at once by using the CTRL key to select multiple 
entries in the list. 

4. On the Roadway Designer dialog, select Process All.  Take a few minutes to 
navigate through the various stations and review your design. 

At Station 5+930, the template first dips below limestone, and you can see the 
result of the limestone end condition.  At Station 5+970, the template first dips 
below shale, and you can see the result of the shale end condition.  Notice, 
however, that neither the right bottom aggregate base point nor the center 
undercut point is below the shale, so the undercut component is not displayed.  
At station 5+980, the right bottom aggregate base point is below the shale, but the 
center undercut point still is not.  By the time you reach 5+990, though, both the 
right aggregate base point and the center undercut point have fallen below the 
shale surface, so you now see your undercut component. 

5. Save your Roadway Design file. 
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 EXERCISE 7:  CREATING THE DESIGN SURFACE 
In this lesson, you will create the design surface and modify its properties before 
saving it. 

1. On the Roadway Designer dialog, select the second to last button on the toolbar – 
Create Surfaces. 

 
Create Surfaces Button 

2. Setup the surface parameters to match the following figure and select Apply. 

 
Create Surface Dialog 

3. Close the Create Surface dialog and the Roadway Designer dialog.  Be sure to 
save your roadway design, if prompted. 
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4. From the InRoads Explorer menu, select Surface > Surface Properties.  In the 
Surface field, select design.  On the Advanced tab, set the Symbology fields for 
both Cross Sections and Profiles to design.  Select Apply to save the changes and 
Close the dialog. 

 
Design Surface Properties 

5. Select File > Save > Surface and save the surface as design.dtm. 
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LESSON 4:  EVALUATING THE DESIGN 

LESSON OBJECTIVE: 

One of the methods an engineer typically uses to evaluate the success of his design is 
to produce and review cross sections along the alignment.  In addition, he calculates 
the volumes of earthwork involved.  This lesson will guide you through this process 
using InRoads commands. 

 EXERCISE 8:  CREATING TOPSOIL STRIPPING FEATURES 
In this exercise you will create features to represent the areas to be stripped of topsoil 
for your project. 

1. If design is not your active surface, make it active by selecting Surface > Active 
Surface. 

2. Select Surface > Feature > Feature Selection Filter and set the Filter Name to 
exterior only.  Select the OK button. 

3. Select Surface > View Surface > Features and select Apply.  The exterior 
boundary from the design surface is displayed in yellow in your design file (but 
displayed in blue in the image below for visibility). 

 
Exterior Boundary from Design Surface 

4. Window in to the area near the beginning of the bridge. 

Hint If you haven't already turned off the display of the reference file, you may wish to 
do so now.  You may also wish to temporarily turn off the display of the stationing 
level. 
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5. Use MicroStation commands to delete the narrow bridge portions near the center of 
the boundary, place lines across the openings of the two shapes and create closed 
shapes from them like the following figure. 

 
Closed Shapes Representing Stripping Areas 

Hint The MicroStation commands most likely to be useful here are:  Partial Delete from 
the Tools > Main > Modify toolbox, Place Line from the Tools > Main > Linear 
Elements toolbox and Create Complex Shape Automatic from the Tools > Main > 
Groups toolbox.  Be sure to click to accept the closed shape.  The shape should 
change to the active color and linestyle if it is closed.  Also, be sure to turn off 
Graphic Group lock when deleting the unneeded portion of the exterior boundary. 

6. Select File > Import Surface > From Graphics and setup the parameters according 
to the following figure: 

 
Import Surface from Graphics 
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7. Select Apply and select the first shape, then repeat for the second shape.  Delete 
the two shapes from graphics and restore the display of the stationing level, if it is 
off.  Also, turn the Graphic Group lock back on. 

8. Select Surface > Feature > Feature Selection Filter and set the Filter Name to 
Unsuitable. 

 
Feature Selection Filter for Unsuitable 

Notice that this filter includes only features whose Styles are muck, waste or 
stripping. 
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9. Select Surface > View Surface > Features.  Right-click in the list, choose Select All 
and then select Apply.  There are four features that meet the unsuitable criteria – 
the two dark green stripping features you just created, a brown muck feature near 
the final curve and a purple waste feature representing asphalt to be removed near 
the start of the relocation. 

 
 

10. Select File > Save > Surface and save the existing surface. 

 EXERCISE 9:  CREATING CROSS SECTIONS 
In this exercise, you will create cross sections along your proposed realignment. 

1. Select Evaluation > Cross Section > Create Cross Section.  Verify that all four 
surfaces are selected on the General leaf. 

2. On the Controls > Critical Sections leaf, verify that the Horizontal Event Points 
option is selected. 
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3. On the Custom leaf, select the Import button and open the volumes.xsc file.  
Highlight all five entries in the Station list and toggle the Crossing option on in the 
Features group.  Select the Update button and then the Save button to save your 
changes. 

 
Custom Cross Sections 

4. Select Apply and place the cross sections above your plan graphics.  Close the 
dialog. 

5. Select Evaluation > Cross Section > Cross Section Viewer to view some of the 
cross sections. 

On Stations 5+884 through 5+960, you will see purple diamonds representing the 
edges of the waste asphalt to be removed.  You will also see green Xs 
representing the edges of the stripping feature you created on all stations.  On 
Stations 7+240 and 7+260, you will see a brown symbol representing the edge of 
muck to be removed. 

Hint If you do not see feature points for the stripping, waste and muck features, make 
sure your Feature Selection Filter is still set to Unsuitable and select Evaluation > 
Cross Section > Update Cross Section.  Set the Mode to Display On, and on the 
Crossing Features leaf, highlight the Surface existing and any features in the 
Feature list.  Select Apply.  You may also need to set the Mode to Refresh, 
highlight the Surface existing and any features in the Feature list, and select 
Apply once more. 
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 EXERCISE 10:  END-AREA VOLUMES SETUP 
The End-Area Volumes command has been redesigned beginning with V8.7, but all the 
options with which you are familiar can still be found, along with some new ones. 

In this exercise, you will begin to setup some of the parameters for end-area volumes. 

1. From the InRoads Explorer, select the Evaluation > Volumes > End-Area Volumes 
command. 

 
End-Area Volumes – General Leaf 

The default behavior is to include in the volume computations all the surfaces 
displayed on the cross section set, which are listed in the surfaces list, but you can 
exclude them from computations at this time, if you wish.  You can also limit the 
volume computations by Station Limits.  The Method and the Ignore Areas Smaller 
Than options are the same as in versions prior to V8.7. 

For this workshop, we want to include all four surfaces, so make sure they are all 
selected.  Also make sure the Create XML Report option is selected. 

2. Select Apply to see what your volumes are before any refinements are made.  
Page down to the bottom of the report and you should see a net volume of about 
129,000 m3. 
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Hint If you receive a warning from the Report Browser about setting a Style Sheet 
Default, select Yes on the warning box.  Once the Report Browser is displayed, 
navigate to the Evaluation folder, right-click MultipleMaterialVolumes.xsl 
and select Set As Default End Area Volume. 

 
Setting a Default Style Sheet 

3. Use the Cross Section Viewer to review the volume annotation displayed on your 
cross sections. 

 
Volume Annotation on Cross Section 

The cyan-colored areas are "normal fill" and the mauve-colored areas are "normal 
cut."  Everything else is a specific volume.  For example, areas below the limestone 
and shale surfaces are calculated as discreet volumes of limestone and shale, 
respectively, as are the components making up the template. 
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4. Return to the End-Area Volumes dialog and skip down to the 
Compaction/Expansion leaf.  The options on this leaf are very similar to those in 
previous versions.  Add a special compaction/expansion factor for the station range 
between a Start Station of 6+300 and a Stop Station of 6+480 to account for 
shrinkage of the replacement fill in the depression.  Set the Fill Factor to 1.7500.  
Select the Add button. 

 
Compaction/Expansion Factors by Station Range 

5. Select the Volume Exceptions leaf.  Again, this leaf is very similar to previous 
versions.  Since you have a bridge crossing a creek in your design, you will create 
a volume exception across that station range.  This means that no volumes at all 
will be calculated across the specified range.  Set the Start Station to 6+538 and 
the Stop Station to 6+866 and select the Add button. 

 
Volume Exceptions 

Note The only stations that will display in the station lists are those at the same locations 
where you created a cross section.  This means you must create a cross section 
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wherever you expect to calculate special volumes.  You can see a number of ways 
this can be accomplished on the Evaluation > Cross Section > Create Cross 
Section > Controls > Critical Sections leaf, such as creating cross sections at 
cardinal points, event points, key stations from Roadway Designer, etc.  In this 
case, your design includes Event Points at the beginning and end of the bridge. 

6. On the Added Quantities leaf, add Fill quantities of 1500.0000 at the bridge 
abutment Start Station 6+538 and 1000.0000 and the bridge abutment Stop Station 
6+866, both with Factors of 1.1000.  Select the Add button after each entry. 

 
Added Quantities 

Hint If you make a mistake, you can highlight the incorrect entry in the Added 
Quantities list, change the values, and then select the Change button. 
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7. Select Apply again and view the results of your modifications.  Note the adjusted fill 
beginning at Station 6+300.  Page down and notice that no volumes at all are 
calculated between Stations 6+538 and 6+866, except for the two added quantities 
you included.  You should now see a net volume of about 130,000 m3, an increase 
of about 1000 m3, mostly due to excluding the fill through the bridge. 

 
Volume Annotation after Modifications 

8. Because generating end-area volumes generally involves project-specific 
parameters, you store the data in an EAV file rather than in the XIN file.  On the 
End-Area Volumes dialog, select File > Save and save your end-area volumes 
parameters as volumes.eav. 

9. Use the Cross Section Viewer to view the cross sections and volumes at some of 
the locations where you have modified the end-area volume parameters. 

 EXERCISE 11:  UNSUITABLE MATERIALS AND CLASSIFICATIONS 
InRoads now offers two ways to specify unsuitable materials – by Feature and by 
Station range.  The important concept to remember with both is that the volumes 
resulting from these methods are simple volumes calculated by dropping vertically 
down a specified depth below the existing surface across the width of the feature or 
between catch points for the Station method. 

For the Station method, you can also specify a Fill Depth, in which case, a vertical 
height is calculated.  You can specify a different Cut Depth and Fill Depth for each 
station range you create. 

For both methods, the style of the selected features will be reported as a material. 
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In this lesson, you will learn how to specify unsuitable materials using the Feature 
method and you will learn about the various classifications used by InRoads. 

1. Select the Unsuitable Materials by Feature leaf.  The first thing you will notice is 
that the feature list is labeled Available Closed Features.  This means that any 
feature you intend to use as an unsuitable feature must be closed. 

Hint If your Feature Selection Filter is still set to Unsuitable, you will see only four 
features.  If your filter is not currently on, you may want to set it to Unsuitable 
again to limit the features displayed. 

2. Set the Surface field to the surface containing the unsuitable materials.  In your 
case, the features are in the existing surface, but they could be in a different 
surface or even in several surfaces.  However, the depth will always be calculated 
to whichever surface whose Surface > Surface Properties > Type is designated as 
Existing.  Set the depths for your unsuitable materials as follows: 

 
Adding Unsuitable Materials 

Hint If the two stripping features are not listed, it probably means they were not 
completely closed when you created them.  To quickly fix this, select Surface > 
Feature > Feature Properties and highlight the two stripping features.  Change 
the Feature Type to Interior and select Apply.  Then change the Feature Type 
back to Breakline and select Apply again. 
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3. Select the Classifications leaf and review the parameters that have automatically 
been created for what you have done so far.  Note the choices available to you 
under the Classification heading.  Ignore means the surface, material or component 
will not be calculated at all.  Unclassified is for normal cut and fill, and Unsuitable is 
automatically set for any material specified by the two Unsuitable Materials 
methods.  Surfaces whose Type is set to Substratum are automatically designated 
as Rock, but you could change it here, if you wish.  Components contained in a 
surface whose Type is set to Design are automatically designated as Designed 
here.  The last option, MDC, is a very specialized calculation and will not be 
covered in this workshop. 

 
Classifications 

4. Notice also that all objects, except the surface designated as Existing, can be 
Included or Excluded from the Mass Ordinate.  This gives you even more flexibility 
in how your volumes are calculated and reported.  Set the Mass Ordinate option to 
Include for the undercut component and set the Fill Factor for the existing 
surface to 1.2500. 
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5. Select the Annotation leaf and toggle on the Tabulated Area and Tabulated Volume 
options. 

 
Including Tabulated Area and Volume Annotation 

6. Save your EAV file and select Apply once again to see the final volumes for your 
design.  You will notice that your report now contains several additional columns of 
data for the additional materials you have specified.  Your final net volume should 
be about 112,000 m3. 
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7. Use the Cross Section Viewer to view some of your cross sections.  Notice the new 
areas for the stripping, muck and waste unsuitable features.  These areas are 
now no longer part of "normal cut" and "normal fill," but are calculated and reported 
as discreet areas and volumes.  You can also the Tabulated Area and Tabulated 
Volume displayed at each cross section for each object in your end-area volumes 
set. 

 
Final Volume Annotation 

 EXERCISE 12:  MORE REPORTS AND MASS-HAUL DIAGRAM 
In this lesson, you will view more of the volume reports delivered with the software.  
You will also save your data to an XML file from which you will produce a mass-haul 
diagram. 

1. In the Report Browser, select MultipleMaterialVolumes.xsl, if it is not already 
selected.  Select File > Save As and save the file as MultipleMaterials.htm.  You 
can double-click the file to open it in your web browser, if you like. 

2. Up until now, you have focused on the Multiple Material Volumes report.  This 
report lists normal and adjusted cut and fill, plus adjusted added volumes and 
adjusted values for other objects.  However, if you want to see every volume 
contained in your dataset and how it has been applied to the mass ordinate, a good 
report to use is the one called Volumes.xsl. 

3. Next, select VolumesToCSV.xsl.  This style sheet outputs the XML data to a CSV 
file suitable for importing into a database or spreadsheet program such as 
Microsoft® Office Excel.  Select File > Save As and save the file as VolumeCSV.txt.  
Notice how the Report Browser automatically knows when to save the report as an 
HTML file and when to save it as plain text. 
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4. A number of reports are not suitable for complex datasets containing added 
quantities or multiple materials.  If you are not seeing the numbers you expect to 
see, try right-clicking the style sheet and select Style Sheet Help.  This small Help 
file will give you information specific to the style sheet you are using at the moment. 

 
Style Sheet Help 

5. Right-click BasicVolume.xsl and select Style Sheet Help.  The following window will 
display: 

 
Style Sheet Help for BasicVolume.xsl 

6. Many of the cross section reports found in the Evaluation folder can also be viewed 
because the cross section XML data file and the end-area volumes XML data file 
use the exact same schema, or storage structure. 

7. Spend a few minutes viewing various reports in the Evaluation folder. 

8. Scroll to the bottom of the style sheet treeview and select raw-xml.xsl.  This style 
sheet always displays the actual XML data produced by the InRoads software.  
Select File > Save As and save the file as EAVolumes.xml.  Once again, the Report 
Browser knows to save the report as an XML file because of the style sheet you 
are using to display the data. 
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9. Return to InRoads and select Evaluation > Volumes > Mass-Haul Diagram.  Place 
your cursor in the Mass-Haul Data File field and select the Browse button to open 
EAVolumes.xml. 

 
Mass-Haul Diagram Dialog 

10. Select Apply and place the mass-haul diagram in your design file. 

 
Mass-Haul Diagram 

As you can see, this project has a surplus of material along most of its length.  You 
can also clearly see the station range where you applied your volume exception for 
the bridge. 
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SUMMARY 

This workshop covered a number of intermediate concepts relating to the End-Area 
Volumes command in the InRoads Group of products.  The following commands and 
concepts were covered: 

 Working with multiple subsurface layers in profile view and in the template library 

 Creating an undercut component on a template 

 Creating null points for control of the undercut component 

 Creating display rules 

 Adding a documentation link to a template 

 Running Roadway Designer 

 Synchronizing template drops 

 Creating the design surface 

 Evaluating the design 

 Creating topsoil stripping features 

 Creating cross sections 

 Running the End-Area Volumes command 

 Adding Compaction/Expansion factors by station range 

 Adding a Volume Exception and Added Quantities by station range 

 Specifying Unsuitable Materials by feature 

 Reviewing Classifications 

 Reviewing and saving volume reports 

 Creating a mass-haul diagram 
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