
 

Finishing the Model 

Module Overview 

The focus of this workshop is to concentrate on design issues that occur during the final 
design process which need to be addressed in order to complete proposed grading for the 
project. The workshop will explore doing this with a variety of tools including the Roadway 
Designer, the Apply Template tool, and site tools. 

 

Module Prerequisites 

 Familiarity with the overall InRoads Product. 

 A firm understanding of the Roadway Designer and template creation in InRoads 8.7 and 
higher. 

 Knowledge of the InRoads’ site tools. 

Modules Objectives 

After completing this module, you will be able to: 

 Incorporate radius returns into an existing Corridor. 

 Target Styles to increase productivity in the Designer. 

 Learn to use the Apply Template Tool. 

 Use Site tools to complete your design. 
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Introductory Knowledge 

Introductory Knowledge 

Before you begin this module, let’s define what you already know. 

End Conditions can target the style of particular features in your DTM? 

 True 
 False 

Site tools only found in InRoads Site? 

 True 
 False 

Point Controls and Parametric Constraints are the only external influence on Template points. 

 True 
 False 

Site tools are only productive for site development? 

 True 
 False 

Feature Lock allows for only one feature to be designed at a time? 

 True 
 False 
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 Introductory Knowledge 

Answers 

Can End Conditions target the style of particular features in your DTM? 

True 

InRoads’ End conditions can target a style that is defined for multiple features in a 
surface. This prevents you from targeting each feature individually. 

Site tools are only found in InRoads Site? 

False 

The Site tools are found also in InRoads & InRail. 

Point Controls and Parametric Constraints are the only external influence on Template points. 

False 

Style & Project to Surface constraints can act as external control for points within a template. These 
constraints obtain values from surfaces and geometries as Point Controls do. 

Site tools are only productive for site development? 

False 

Site tools are valuable assets in complementing your corridor design. This workshop will display this. 

Feature Lock allows for only one feature to be designed at a time? 

False 

The Feature Lock allows InRoads to scan for Features in the active DTM, and ignore any MicroStation 
Graphics.  
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Introductory Knowledge 

 

Before You Begin 

Before beginning the exercises outlined in this workshop, you need to start InRoads and load 
the workshop files.  To do so, follow these steps: 

1. From the Start > Programs > Bentley > InRoads Group XM menu, select InRoads. 

2. Navigate to the workshop directory and select the proposed.dgn file from the 
MicroStation Manager.  This design file has several reference files attached showing 
some of the existing topological features which are stored in the DTM and also 
displays proposed pavement markings.  You may turn off the display of the reference 
files at any time, if you wish, by selecting File > Reference from the MicroStation 
menu and toggling off the checkmark in the Display column.  We only use this data 
for visual references during the workshop. 

3. Select File > Open and load the workshop files by selecting the project file named 
finishing.rwk.  This project file contains a geometry project, an existing surface, a 
template library and a roadway design file for use in the remainder of this workshop. 

4. Select Tools > Locks > Toolbar to turn on the Locks toolbar, if it is not already on. 

You are now ready to begin the exercises in this workshop.  If, for any reason, you must exit 
the software before the end of the workshop, simply repeat the steps in this section. 

If you are unable to complete an exercise as you proceed through this workshop, the 
completed files for that lesson are stored in \Finished subdirectory labeled with the exercise’s 
topic.  For example, if you cannot complete Driveways, you can open the completed files 
from the \Finished\Driveways subdirectory and continue with the exercise. 
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 Adding Radius Returns at Intersections 

Adding Radius Returns at Intersections  

In this exercise you will take the Horizontal and Vertical alignment of the radius returns and 
assigns them to the design. Existing point controls are adjusted and priorities are set to ensure 
accurate modeling. 

 

 Adding Point Controls 

5. Return to the Roadway Designer. Select the CL-south corridor. 

6. Select the Point Controls . 

7. Add a point control for the edge of pavement points on the template. 
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Adding Radius Returns at Intersections 

 

Hint You can use the Select button to identify the template point and the alignment. 

 Add the point controls. 

Note: Note the use of the secondary alignment option. This option will model 
orthogonal to the radius return. 

8. Revise the Stations or change Priorities on the controls that are in conflict.   

 
9. Process the stations and note the change in the way the template changes within the intersection at 

the north end of the corridor. 
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 Driveways 

Driveways 

This exercise will demonstrate a procedure that will allow End Conditions to determine 
where to place depressed curbing instead of full curbing to accommodate for driveway 
entrances. After the depressed curbing is placed at a driveway location then the End 
Conditions can continue to test for different tie in situations that are relevant for only when a 
driveway is present. This method can be quite useful on large corridors, where many 
driveways exist. This is because this workflow’s End Conditions target a Style and not just an 
individual feature. This eliminates the mapping of each individual driveway as a type of 
external control within the Roadway Designer.  

Note: The main goal of this lab is to display the functionality of End Condition using a 
Style as a target. This Style can exist in an ALG or a DTM, but it must be active 
for it to operate correctly. 

 Exercise: In this section we will modify the first template drop in our corridor to 
allow it to adjust the end condition solution if a driveway is found. 

10. Window your view to the beginning of the CL-south corridor alignment. There are driveways in the 
location, on the left and the right of the baseline. The drive openings are marked with annotation that 
resides in the Proposed.dgn. 
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Driveways 

11. Go to Reference Display in MicroStation and shut off the references. This will make the following 
steps easier by isolating the graphics. 

12. In InRoads go to File>Import>Import Geometry>From Graphics.  

13. Import the right driveways. Enter a Seed Name of Drive Rt with a feature style of Drive_Rt. 

 

 

14. Repeat this process for the left driveways. Enter a Seed Name of Drive Lt with a feature style of 
Drive_Lt.  

15. Go to the Template Drop dialog, highlight the first template entry, and then press <Edit>. 

16. At this time we need to modify the template to include new End Conditions to determine when to use 
Depressed Curbing and Drive aprons. Right click in the template dialog and <Delete Components>, 
draw a line through the existing End Conditions and sidewalk. 
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 Driveways 

17. The End Condition will determine when to place the curbing so the current curbing components will 
need to be in the End Condition. Bring in the new End conditions from the Misc Components Folder 
on the left. You will notice two end conditions named Drives Lt and Drives Rt. Drag and drop the end 
conditions from the preview window into the template stored in the Roadway Designer. Both end 
conditions should be placed at the Sidewalk points. Your template should appear as below. 

 
18. Press the Template <Test> button. Observe the behavior of the template when there depressed curb 

styles are defined and when they are not. 

Hint: This workflow can easily modified to test to see if your proposed end condition is within 
the legal right of way. 

19. After observing the behavior of the template, press <OK>. 

20. The Driveways now appear in Designer, this will aid in seeing if the Design is appropriate. Cycle 
through the stations by the driveways. 

The template drop interval is set to 5m for this particular template drop, this may or may not satisfy the 
precision that is required to determine where our driveways are located. 

21. The design may call out that a template drop must occur at the beginning and end of each driveway 
location, increasing the accuracy of the model. First, go to File>Save in the Roadway Designer. 

22. Proceed to File>Import Geometry>From Graphics. Change the type Event Points and verify that 
the horizontal geometry is CL. 

23. Select the driveways graphically in the proposed.dgn and Press <Apply>. Remember to Accept your 
selection by clicking an additional data click. Right click to exit the operation and then Close the 
Import Geometry tool. 
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Driveways 

 
24. Return to the Roadway Designer. Verify the additional template drops at the beginning and end of 

each driveway location. 

25. Verify the Horizontal Event Points are turned on in the Roadway Designer options. 

Note: Note the processing at the beginning and end of each drive by implementing this 
technique. 

26. Save the Roadway Designer by going to File>Save. Then Close the Designer. 
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 Retaining Wall End Condition Override 

Retaining Wall End Condition Override 

 

 

27. Locate the area for a required retaining wall in the beginning of the CL-south corridor.  

28. Select the End Condition Exceptions tool and Add a Right Side Override. 
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Retaining Wall End Condition Override 

29. Select the End Condition Exception and Edit.  Delete the existing end condition solution.  

30. Edit the back of the sidewalk to maintain a 3.0m width by assigning constraints to that point.  

31. Select the Retaining Wall EC from the folder and drag and drop onto this point. 

 

 
32. Process stations through this area and examine the results. 
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 Apply Template Tool 

 

Apply Template Tool 

In this section, the Apply template tool will be used to generate a concrete curb island.  

 

Concrete Curb Template 

Note: This exercise will display the use the Apply Template Tool, it will use a 
MicroStation graphic that does not exist as a feature or as geometry. This 
provides the ability to perform grading task quickly and easily.  

 

Locate the traffic island layout at the north end of the project in proposed.dgn. This line in 
MicroStation is currently at elevation of zero. However, this line needs to be at the elevation 
of proposed surface. 

Note: The Apply Template tool can accomplish this as it is placed if the controlling 
point has a Project to Surface constraint added. 

33. Create a New surface from the Roadway Designer for the CL-north corridor. 
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Apply Template Tool 

 

34. View the Triangles for the new surface. 
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 Apply Template Tool 

35. Select the Surface > Design Surface > Drape Surface command. Use this command to drape the 
island graphic to the elevations of the proposed surface. 

 

36. Apply the command and select the island graphic. Close the dialog when complete. 

37. Use the Design Surface > Apply Template command to generate the features for the raised curb 
island.  

 

38. Follow the prompts and reject an unacceptable solution.  

39. Perform any analysis and evaluation to confirm your design. 
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Module Summary 

 

Module Summary 

You are now able to: 

 Use the power of point controls to model intersections.. 

 Place Depressed Curbing at driveway locations by targeting Styles within your End 
Conditions. 

 Use End Condition Overrides to establish preliminary wall layout and impact.. 

 Use Surface tools to complete a variety of design functions to finish your model. 
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