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Lesson Objectives
Lesson Objectives

Lesson Objectives

In this lesson we will…
• Learn different methods of Superelevation Input
• Learn the significance of Superelevation Sections
• Learn Different ways to edit Superelevation in the Roadway Designer
• Learn about Shoulder Rollover Locking
• Learn various examples of how Superlevation can be applied. 
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1 – 2 Copyright © 2006 Bentley Systems, Incorporated



Starting InRoads
Starting InRoads

Starting InRoads
1 Double-click the InRoads or InRoads Suite icon.

The MicroStation Manager appears.

If there is no icon, then an alternate path for launching InRoads is Start > Programs > 
Bentley > InRoads Group XM > InRoads 

Open a CAD File
1 Set the directory to the workshop directory
2 Open the CAD file SR 2067 Bypass.dgn

Opening the Project File 
1 From the InRoads menu, select File > Open
2 Set the Files of type to InRoads Files (*.rwk,*.dtm,*.alg,*.itl,*.sdb,*.xin)
3 Change the Look in directory to this workshop directory 
4 Select the file WS 12.rwk
5 Click Open. 
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Create Superelevation Wizard
Create Superelevation Wizard

Superelevation

Superelevation is created and applied by using the Roadway Designer after the corridor is 
created and the template drops are assigned. Superelevation is stored and saved in the 
Roadway Design file, and is applied to a corridor. 

The Create Superelevation Wizard is used to create superelevation. When superelevation 
is created, superelevation Point Controls will be automatically created and will be added 
to the Points Control dialog. Superelevation Point Controls are vertical controls. As in 
normal Point Controls, superelevation Point Controls automatically override template 
point constraints. 

Create Superelevation Wizard

The Create Superelevation Wizard walks you through the steps necessary to create and 
apply superelevation to the corridor. Select the Superelevation > Create Superelevation 
Wizard > Table command to start the Wizard. This brings up the Table Wizard dialog. 
InRoads 201 10/2/07
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Methods of Superelevation Input
Methods of Superelevation Input

There are several ways to define superelevaion:

Create Superelevation Wizard

The Create Superelevation Wizard walks you through the steps necessary to create and 
apply superelevation to the corridor. 

Creating Single Control Lines

This is a way to define superelevation manually. Each control line must be defined 
individually. Corresponding point controls must then be created, and assigned to the 
appropriate template point. 
10/2/07 InRoads 201
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Methods of Superelevation Input
Importing Superelevation from ASCII

This command creates superelevation control lines and assigns template point controls. 
The file imports pipe delimited format using the first three values only. Values used are: 
Station|Finished Grade Left|Finished Grade Right

Import Superelevation from Alignment

This command to import superelevation control lines from an alignment created from a 
previous version of InRoads.When you select the command, a prompt is only displayed if 
an alignment was found. 
InRoads 201 10/2/07
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Using the Create Superelevation Wizard, Table Method
Using the Create Superelevation Wizard, Table Method 

Table Wizard Dialog

The Table Wizard Dialog is used to input the general superelevation data. The general 
superelevation data includes the name and location of the superelevation rate table, and 
the parameters relating to the superelevation transitioning. The rate table is an ASCII file 
that contains superelevation rates and transition lengths based on design speed, which has 
the default extension of (*.sup). 

Basic Workflow
• Select the appropriate superelevation table name and location by selecting the Browse 

button next to the Table field.
• Set up the appropriate superelevation transitioning parameters.
• Click the Load Values From Table button. 
• Click the Next> button. This will bring up the Superelevation Section Definitions 

dialog.
10/2/07 InRoads 201
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Practice-Create Superelevation-Table Method
Practice-Create Superelevation-Table Method

Create Superelevation-Table Method
1 Select Modeler > Roadway Designer
2 Select Superelevation > Create Superelevation Wizard > Table 
3 This will bring up the Table Wizard dialog
4 Use the Browse button next to the Table field and select the 06_60.sup rate table 

from the workshop folder.
5 Click Load Values From Table.
6 Review the Superelevation Rates
7 Click Next> 

This will bring up the Superelevation Section Definitions dialog. 
InRoads 201 10/2/07
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Superelevation Sections
Superelevation Sections

Superelevation Sections

Superelevation Control Lines are grouped into sections and define a “Range of Interest” 
for these control lines. 

The Superelevation Section Definitions dialog is used to specify the pavement sections to 
superelevate, based on a cross section view. These sections are named during the process. 

For example, On a two-lane roadway, only one section is used. Multiple sections are used 
for divided roadways. 

When specifying pavement sections, the Crown Point, Left and Right Range Points are 
selected. These points can be selected directly from the cross section view windows or 
from their respective drop-down lists. 

There are no hard and fast rules for section creation. Superelevation Sections are simply a 
way to manage related control lines. Control Line points in a section cannot be constrained 
to control line points in different section. 
10/2/07 InRoads 201
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Superelevation Sections
 

Section and Control Line Naming

Each superelevation section and corresponding control lines are named so that they can be 
identified and modified in the roadway designer. When using the Wizard, InRoads 
attempts to give the control line a meaningful name by using the Section/Pivot Point/Point 
name. These names can be modified as desired. However, concise but intelligible names 
should be given so that they can be easily identified in lists and combo boxes. 

Superelevation Controls Dialog

The Superelevation Controls dialog shows the names of the Point Controls that are going 
to be automatically added to Point Controls dialog. The names can be changed selecting 
the Edit button. This is also where you can set the station rounding by using the Round 
Station to Nearest option. Station rounding allows you to round up the superelevation 
stations. For example, instead of the Full Superelevation station being computed as 
245+45.96, it can be 245+45.00, which rounded to nearest foot using a rounding value of 
0+01.00.
InRoads 201 10/2/07
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Superelevation Sections
Basic Workflow
• Review and edit the Superelevation Point Controls. 
• Toggle On the Round Station to Nearest option and select the rounding value, if 

station rounding is desired.

Click the Next> button. If there are superelevation overlaps, this will 
bring up the Fix Superelevation Overlap dialog.Setting the 
Superelevation Controls
10/2/07 InRoads 201
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Practice-Create Superelevation Sections
Practice-Create Superelevation Sections

Continue working on the last Practice activity. 

The Superelevation Section Definitions dialog should be shown still displayed from the 
last Practice activity.

Create Superelevation Section Definitions
1 Click the Add button in the Superelevation Section Definitions dialog

This will bring up the Add Superelevation Section dialog
2 Key-in Two-lane as the Name of the section
3 Use the Target button next to the Crown Point field and click the centeline point 

on the Cross Section View

This will return the Crown Point name as CL
4 Use the Target button next to the Left Range Point field and click the left edge of 

pavement point on the Cross Section View

This will return the Left Range Point name as LT_EOP
5 Use the Target button next to the Right Range Point field and click the right edge 

of pavement point on the Cross Section View

This will return the Right Range Point name as RT_EOP
InRoads 201 10/2/07

1 – 12 Copyright © 2006 Bentley Systems, Incorporated



Practice-Create Superelevation Sections
6 The Point Direction should be set to From Crown Point
7 The Number of Lanes should be set to 2
8 Station Limits should not be Toggled On, which will result in superelevating the 

entire corridor
9 Click OK

Review the Superelevation Controls
1 Review the information now in the Superelevation Section Definitions dialog.
2 In the Superelevation for Selected Section Area, click on the first entry in the Start 

Station column. 
3 Click Edit.
4 This will bring up the Superelevation Curve Information dialog. 

Notice that the start/stop stations, runnoff lengths and full super rates can be 
adjusted here. 

5 Click Close. 
6 In the Superelevation Section Definitions dialog, Click the Next> button

This will bring up the Superelevation Controls dialog
7 Review the information in the Superelevation Controls dialog.
8 Enable the Round Station to Nearest option and set the rounding value to 

0+01.00. 
9 Click Finish.
10 Since there is an overlap, this will bring up the Fix Superelevation Overlap dialog. 
11 We will use the Fix Superelevation Overlap dialog in the next practice activity. 
10/2/07 InRoads 201
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Fixing Superelevation Overlap
Fixing Superelevation Overlap

Fix Superelevation Overlap Dialog

If there is a superelevation overlap, the Fix Superelevation Overlap dialog will 
automatically appear. The Fix Superelevation Overlap dialog is used to resolve 
superelevation overlaps. An overlap occurs when there is not enough length to fit the 
superelevation transition lengths between curves, or the corridor alignment starts or ends 
in a superelevation transition. 

Superelevation overlaps can be resolved by either shifting the total transition length onto 
the next curve or previous curve, or by reducing the total transition length. 

To shift the transition, key-in the distance you want to shift the total transition in the Shift 
Transition Into Curve by fields, located in the Previous Curve area or Next Curve areas. 
The % Runoff on Curve and % Transition on Curve are used for readout only and will 
show you Runoff and Total Transition percentages on the curves as you shift the 
transitions. 

To reduce the total transition length, key-in the transition length reduction in the Reduce 
Transition Length by fields, located in the Previous Curve area or Next Curve areas. The 
new length will be reflect in the New Length field. As seen in other dialogs, you must 
move the cursor to another field or use the Tab key to update the values of other input 
fields. 
InRoads 201 10/2/07
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Fixing Superelevation Overlap
The New Length field can also be used to specify the new reduced length, without using 
the Reduce Transition Length by field, which will produce the same results. The diagram 
at the top of the dialog dynamically displays the overlaps and the results of shift and 
changing the transition lengths. Clicking on the diagram and holding down the left mouse 
button allows you to dynamically slide the transitions.

Basic Workflow
• To shift the transition onto a curve, key-in the shift distance in the Shift Transition 

Onto Curve by fields.
• To reduce the transition length, key in the transition length reduction in the Reduce 

Transition Length by fields.
• Click the Apply button.
• Click the Next> button to move to the next overlap if necessary.

Repeat for all overlaps.
10/2/07 InRoads 201
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Practice-Fix Superelevation Overlap
Practice-Fix Superelevation Overlap

Correcting a Superelevation Overlap

Continue working on the last Practice activity. 

The Fix Superelevation Overlap dialog should still be displayed from the last practice 
activity. 

Review the Superelevation Overlap
1 Review the superelevation overlap in the Fix Superelevation Overlap dialog

Reduce the Transition Length
1 Reduce the total transition length of the first curve by keying in 45.00 in the 

Reduce Transition Length by field in the Previous Curve area

Shift the Transition
1 Shift the transition onto the second curve by keying 45.00 in the Shift Transition 

Onto Curve by field in the Next Curve area
2 Click Apply, then Close.
InRoads 201 10/2/07
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Practice-Fix Superelevation Overlap
Review the Point Controls 
1 Select the Corridor > Point Controls command and review the new Point 

Controls relating to superelevation. 
2 When finished, close the Point Controls dialog. 

Review the Superelevation
1 Select the Display Superelevation button located on the bottom right hand corner 

of the Roadway Designer dialog
2 Select the Process All button. 
3 Select File > Save command to save the Roadway Design
10/2/07 InRoads 201
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Superelevation Views
Superelevation Views

Roadway Designer Superelevation Windows

After superelevation has been created using the Create Superelevation 
Wizard, you can view several new windows in the Roadway Designer by 
selecting the Display Superelevation button. 

The Display Superelevation button can be toggled On or Off at any time during the 
design. These windows are used to review and edit the superelevation. The display of each 
window is color coded. 

Superelevation Color Codes

When using the Display Superelevation button, color coded cross slopes are displayed in 
the Plan, Profile and Cross Section View Window. This allows you to visualize the slopes 
as the roadway transitions through superelevated areas. 

Slopes to the right that are between 0.5% and 10% will start as green and transition to blue 
as the slope approaches 10%. When the slope is greater than 10% to the right, the color 
becomes dark blue. 
InRoads 201 10/2/07
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Superelevation Views
Slopes to the left that are between 0.5% and 10% will start as yellow and transition to red 
as the slope approaches 10%. When the slope is greater than 10% to the left, the color 
becomes dark red. 

Slopes that are less than 0.5% will appear as a white color on either side of the centerline.
10/2/07 InRoads 201
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Superelevation Diagram Window
Superelevation Diagram Window

Superelevation Diagram View Window

The Superelevation Diagram View Window is located in the lower right hand corner of the 
Roadway Designer dialog. 

When in the Display Superelevation mode, superelevation control lines are displayed. 
The control lines are color coded for identification purposes only and are not related to 
slopes. The window also shows the location of the corridor’s alignment cardinal stations. 
The left axis shows the percent slope as it relates to the centerline of the corridor 
alignment. 
InRoads 201 10/2/07
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Editing Superelevation
Editing Superelevation

To edit the superelevation points, double-click on any point on the Diagram View to 
change stations, cross slopes and superelevation types. Superelevation points have 
constraints, like template points. Editing a constrained superelevation point may affect the 
location of the other points in the diagram. What you are able to edit depends on which 
point you select and the constraints on that point. 

Another technique to editing superelevation is using the Edit Curve Set Stations 
command. To access the command, right-click on the Superelevation Diagram View 
Window and select the Edit Curve Set Stations command. The Edit Curve Set Stations 
shows the superelevation stations and slopes in a tabular form, and allows you to edit 
superelevation stations and slopes.
10/2/07 InRoads 201
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Practice-Editing Superelevation
Practice-Editing Superelevation 

Editing Superelevation Interactively 
1 Select Tools > Options from the Roadway Designer menu. 
2 Enable Curve Set ID in the Display Area.
3 Click Ok. 

This will show the ID for each curve in the superelevation diagram view. 
4 Adjust the Superelevation View window of the Roadway Designer so the control 

lines and points are clearly visible for the first curve. 
5 Right Click on the green point located at Station 189+41, 5.5% cross slope (Full 

Super). This point belongs to the control line called Two Lane CL LT_EOP
6 Select Edit Point.

This will bring up the Superelevation Point Properties dialog. Notice the station 
and the cross slope can be modified here.

7 In the Edit Point Properties dialog, use the target button to select the red point at 
station 189+41 with a -5.5% cross slope (directly below the point that was edited 
in the previous step). Notice that the Station and Cross slope values cannot be 
modified. This point cannot be moved because it is constrained to the point above 
it. 
InRoads 201 10/2/07
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Practice-Editing Superelevation
8 Notice that one of the constraints is Mirror Cross Slope. A Mirror Cross Slope 
constraint causes a point’s cross slope value to be the same magnitude, but 
opposite sign of its parent point.

9 Use the Next and Previous buttons to navigate the Superelevation diagram and 
observe the point locations as well as the constraints. 

Notice all the points are a specified type, i.e. Normal Crown, Reverse Crown, Full 
Super. When the wizard is used, the type is automatically set but can be modified. 
The type is used primarily for reporting and display. 

10 Close the Superelevation Point Properties dialog. 
11 Adjust the Superelevation View of the Roadway Designer so that the control lines 

and points are clearly visible for the second curve. 
12 Right Click on the green point located at Station 208+38, 5.5% cross slope (Full 

Super). This point belongs to the control line called Two Lane CL RT_EOP
13 Select Move Point. 
14 The Dynamic Settings dialog box will appear.
15 Enter 1+00 for the Station Step and 1.0% for the Cross Slope Step. 

16 Move your cursor in the Superelevation diagram view. Notice that the location is 
now moving according to the station and cross slope increment specified.This is 
useful when precision is needed for point placement. 

17 Right Mouse Click to exit the Move Point command. 

Editing Superelevation in Tabular form
1 Right Mouse click in the Superelevation Diagram View, and select Edit Curve 

Set Stations. 
2 This will bring up the Superelevation Control Curve Set Edit dialog. 
3 Click the Show Curve Set Information button. 
4 Click the + button. This will add additional stations that can be modified. Red 

station text identifies stations beyond the current curve set.
5 Use the < Previous and > Next buttons to navigate to the each curve. Notice a box 

appears around the points that belong to the current curve set in the diagram view. 
6 Click Close. 
10/2/07 InRoads 201
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Creating Single Control Lines
Creating Single Control Lines

Creating Single Control Lines

Another method for defining superelevation in the Roadway Designer is to define 
individual control lines. Control lines can be copied from existing lines, or new lines can 
be created. Once the control line is created, points must be inserted one at a time with a 
specified station and cross slope. Points of a control line can then be constrained to other 
points. Since control lines belong to a section, either the name of the parent section that the 
new line will belong to, or enter a name and a new section will be created. 

If you select to copy from another control line, then you can set the maximum cross slope 
value. When copying from another super control line, a point with the maximum cross 
slope is inserted at every point where the copied control line has a full super point. A point 
with a normal crown value is inserted wherever there is a normal crown point in the copied 
control line.

Once a control line is created, it is displayed. When a control line is created, it has, as a 
minimum, two points; one at the start station and one at the end station of the corridor.

The name of the point indicates its parent control line name and station. This name is 
updated as the point is moved. The type can be “Undefined”, “Normal Crown”, “Super 
Runoff” (Cross slope of 0%), “Reverse Crown”, or “Full Super”. 
InRoads 201 10/2/07
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Creating Single Control Lines
If you copy another control line when creating a new one, all Normal Crown and Full 
Super points will be copied and assigned the appropriate types. Normal Crown points are 
shown by a vertical green line. Super Runoff points are represented by a vertical white 
line, Reverse Crown by a yellow line, and Full Super by a vertical dark blue line

Basic workflow
• Right-click in the superelevation display window.
• Select Create Single Control Line. 
• The Create Superelevation Control dialog box opens.
• At a minimum, enter the new control line name, the parent section name, and a normal 

crown cross slope. 
10/2/07 InRoads 201
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Practice-Create New Control Line
Practice-Create New Control Line

Disable the Point Controls
1 Select Corridor > Point Controls from the Roadway Designer menu. 
2 In the Horizontal and Vertical Controls list, Click on each X to Disable the point 

controls, then close the dialog. The ability to disable and enable point controls 
allow you to evaluate multiple design alternatives within a single corridor. 

Turn off the Control Line Display
1 Right Click in the Superelevation diagram view and select Superelevation 

Display list. 
2 Click None. 
3 Click Apply, then close the dialog. Notice the control lines for the Two Lane 

Section are no longer visible. 

Create Control Line for the LT_EOP
1 Right Click in the Superelevation Diagram view and select Create Single 

Control Line. 
2 In the Create Superelevation Control dialog, enter Manual CL-LT_EOP for the 

Control Line name
3 The Copy From should be set to None. 
InRoads 201 10/2/07
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Practice-Create New Control Line
4 Enter Manual for the name of the Parent Section. 
5 Click OK. A flat red line should appear in the Superelevation diagram view. 

.
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Inserting/Modifying Points
Inserting/Modifying Points

Inserting/Modifying points

To insert a point, right click on the control line and select Insert point. A new point is 
inserted at the location of the cursor. You are now able to place the point dynamically. 
You’ll remain in the insert point command until you Reset out of the command.

To modify a point, right click on the point and select the appropriate command (Move 
Point, Edit Point, Add Constraint, Merge Points, or Delete Point) from the menu.

When inserting or moving a point, the Dynamics Settings dialog box is displayed. This 
dialog box allows you to set up step values and locks for dynamic locating of points or key 
in a station and offset. When you type in a station and press the TAB or ENTER key, the 
point location is updated.

You can also edit the properties of a point. Hover over the point, right-
click and select Edit Point from the pop up menu.

You can also edit the properties of a point. Hover over the point, right-
click and select Edit Point. The Point Properties dialog. Point Constraints 
can be added as well as specifying the point type. 
InRoads 201 10/2/07
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Practice-Insert Points for LT_EOP
Practice-Insert Points for LT_EOP

Insert Normal Crown and Zero Slope Points
1 Right Click on the red line and select Insert Point. 

The Dynamic Setting dialog will appear. 
2 In the x+xx,x% field of the Dynamic Settings enter 187+41.00,-2.0%

3 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

4 In the x+xx,x% field enter 187+94.33,0.0%

5 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed. 

If you make a mistake, simply Right Mouse click and select Undo Last. You can 
also use the up arrrow on your keyboard to review previousy entered points.

Insert Reverse Crown and Full Super Points
1 In the x+xx,x% field enter 188+47.66,2.0%

2 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

3 In the x+xx,x% field enter 189+41.00,5.5%
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Practice-Insert Points for LT_EOP
4 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

5 In the x+xx,x% field enter 204+72.00,5.5%

6 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

Insert Reverse Crown and Zero Cross Slope
1 In the x+xx,x% field enter 205+44.34,2.0%

2 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

3 In the x+xx,x% field enter 205+85.67,0.0%

4 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

Insert Normal Crown Points
1 In the x+xx,x% field enter 206+27.00,-2.0%

2 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

3 In the x+xx,x% field enter 207+44.66,-2.0%

4 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

Insert Full Super Points for the Second Curve
1 In the x+xx,x% field enter 208+38.00,-5.5%

2 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

3 In the x+xx,x% field enter 225+98.00,-5.5%

4 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.
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Practice-Insert Points for LT_EOP
Insert Normal Crown Points
1 In the x+xx,x% field enter 226+91.34,-2.0%

2 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

3 In the x+xx,x% field enter 227+98.00,-2.0%

4 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

5 In the x+xx,x% field enter 258+92.00,-2.0%

6 Click the Enter key on your keyboard. Move your cursor and notice a point has 
now been placed.

7 Right Click and select Finish. Save the Roadway Design 
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Adding Point Constraints
Adding Point Constraints

Adding point constraints

Point constraints can be added either through the pop up menu, or on the Superelevation 
Point Properties dialog box. These point constraints are a subset of the point constraints 
available when creating templates with one additional constraint: Mirror Cross Slope, 
which is specific to the Superelevation controls. Available constraints are: Horizontal, 
Vertical, Slope, Vector Offset, and Mirror Cross Slope.

A point can be constrained to any other point that is in the same superelevation section, 
but not from one section to another. Constraints can be used to handle things such as 
planar lock (using the Mirror Cross Slope constraint), Maintaining a transition length 
(Horizontal constraint), constant Delta G (Slope), or linear transition (Vector Offset).
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Practice-Add Constraints for LT_EOP
Practice-Add Constraints for LT_EOP

Adding Point Constraints for the first curve. 
1 Edit the point located at station 187+94.33, 0% 
2 Change the Type to Super Runoff. 
3 In the Constraints area, set the Constraint 1 type to Vector Offset. 
4 For Parent 1, select Manual CL-LT_EOP 187+41
5 For Parent 2, select Manual CL-LT_EOP 189+41
6 Click Apply. Notice the point color change to yellow. 
7 Edit the point located at station 188+47.66, 2.0% 
8 Change the Type to Reverse Crown. 
9 In the Constraints area, set the Constraint 1 type to Vector Offset. 
10 For Parent 1, select Manual CL-LT_EOP 187+41
11 For Parent 2, select Manual CL-LT_EOP 189+41
12 Click Apply. Notice the has changed color from green to yellow. 
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Practice-Add Constraints for LT_EOP
13 Right Click on the point located at Station 189+41 5.5% and select Move Point. 
Do NOT actually click in the view to move the point to another location, but just 
move the cursor around and observe how the Super Runoff and Reverse Crown 
Points behave. 

14 Edit the Point located at Station 204+72, 5.5%
15 Change the Type to Full Super. 
16 In the Constraints area, set the Constraint 1 type to Vertical 
17 For Parent 1, Select Manual CL-LT_EOP 189+41
18 Set the Constraint Value to 0.0

Constrain the Points along the exit transition of the first curve. 
1 Edit the point located at Station 205+44.34 2.0% 
2 Constrain the point appropriately so that it will occur along the linear transition 

between the Full Super Point at Station 204+72 and the Normal Crown Point at 
Station 206+27. HINT: This Point will have two parents. 

3 Edit the point located at Station 205+85.67 0.0% 

4 Constrain the point appropriately so that, it will move along the linear transition 
between the Full Super Point at Station 204+72 and the Normal Crown Point at 
Station 206+27. HINT: This Point will also have two parents. 

5 Edit the remaining points for the first curve, and set the appropriate type. ie. Full 
Super, Reverse Crown, etc.

The points for the second curve will be constrained in a later exercise. 
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Practice-Create Control Line for RT_EOP
Practice-Create Control Line for RT_EOP

Create Control Line for the RT_EOP
1 Right Click in the Superelevation diagram view and select Create Single 

Control Line. 
2 In the Create Superelevation Control dialog, enter Manual CL-RT_EOP for the 

Control Line name
3 The Copy From should be set to None. 
4 Enter Manual for the name of the Parent Section. Because a control line belongs 

to a section, any of it's points can be constrained by any other points in that 
section. The points of a control line cannot be constrained by points from another 
section.

5 Click OK. A flat yellow line should appear in the Superelevation diagram view. 
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Practice-Create Control Line for RT_EOP
Use the Insert Point command to insert points at the following Station and Cross Slopes
• 187+41.00,-2.000% Normal Crown 
• 188+47.66,-2.000% Normal Crown 
• 189+41.00,-5.500% Full Super 
• 204+72.00,-5.500% Full Super 
• 205+44.34,-2.000% Normal Crown 
• 206+27.00,-2.000% Normal Crown 
• 206+38.00,-2.000% Normal Crown 
• 206+91.33,0.000% Zero Cross Slope 
• 207+44.66,2.000% Reverse Crown 
• 208+38.00,5.500% Full Super 
• 225+98.00, 5.500% Full Super 
• 226+91.34,2.000% Reverse Crown 
• 227+44.67,0.000% Zero Cross Slope 
• 227+98.00,-2.000% Normal Crown 

Constrain the Points for the first curve
1 Edit the Point at Station 188+47.66, -2% and constrain it Horizontally to the point 

directly above. The Type should be set to Normal Crown. The horizontal Value 
should be 0.0

2 Edit the Point at Station 189+41,-5.5%. Set the Type to Full Super. Use a Mirror 
Cross Slope Constraint and pick the point directly above it as the parent point. 
Also Constrain the Point Horizontally to the point directly above. The horizontal 
Value should be 0.0

Constrain the Points
1 Edit the Point at Station 204+72,-5.5%. Set the Type to Full Super. Use a Mirror 

Cross Slope Constraint and pick the point directly above it as the parent point. 
Also Constrain the Point Horizontally to the point directly above.

2 Edit the Point at Station 205+44.34, -2% and constrain it Horizontally to the point 
directly above. The Type should be set to Normal Crown. The Horizontal Value 
should be 0.0

3 Now constrain the points for the second curve. HINT: Use the point constraints of 
the previous curve as a guide. 

4 Edit the remaining points in the diagram and ensure the appropriate type is set. i.e. 
Full Super, Reverse Crown, etc. 

5 When finished, Save the Roadway design. 
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Practice-Create Control Line for RT_EOP
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Point Controls
Point Controls

Creating the point control

At any point after the superelevation control line has been created, you can create the point 
control.

Basic Workflow
• Click Corridor > Point Controls or, select the button.
• Identify the point to be controlled.
• Select Vertical mode.
• Select Superelevation as the Type.
• Select the new control line and identify the pivot (reference point).
• Click Process All to update the entire corridor. 
InRoads 201 10/2/07

1 – 38 Copyright © 2006 Bentley Systems, Incorporated



Practice-Create the Point Controls
Practice-Create the Point Controls

Create the Point Control for the LT_EOP
1 Select Corridor > Point Controls from the Roadway Designer menu. 
2 Select the Point LT_EOP
3 Set the Mode to Vertical. 
4 Select Superelevation as the Control Type. 
5 For the Superelevation Control, select Manual CL-LT_EOP.
6 Pick CL as the Reference Point, then click Add.

Create the Point Control for the RT_EOP
1 Select the Point RT_EOP
2 For the Superelevation Control, select Manual CL-RT_EOP
3 Click Add, then close the dialog.
4 Click Process All and Review the design. 
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Shoulder Rollover Locks

Shoulder Rollover Locks are used to limit the slope difference between the travel portion 
of the roadway and the adjacent shoulders during superelevation. This difference is the 
algebraic difference between the slopes, as a percentage. For example, if the cross slope of 
the travel portion of the road is -2.0% and the shoulder is -6.0%, then algebraic difference 
between the slopes is 4.0%. 

Superelevation rollover locks are applied after the superelevation has been defined using 
the Create Superelevation Wizard. The limit is set on the high side and low side of the 
roadway, and is input as an algebraic percentage. When the limit is reached, the travel 
portion of the roadway and shoulder will move together holding the limiting percentage 
difference between the roadway and shoulder. 

For example, if the road is -2.0% and the shoulder is -6.0%, then setting a high side 
difference of 6.0% would lock the road and shoulder together when the roadway slope was 
0% or greater. 

As with superelevation, Shoulder Rollover Locks produce template Point 
Controls that automatically override template point constraints. These 
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Shoulder Rollover Locks
will show up in the Point Control dialog after the Shoulder Rollover 
Locks are created.

Basic Workflow
• Create superelevation using the Create Superelevation Wizard.
• Select the Superelevation > Apply Shoulder Rollover Lock command. This will 

bring up the Apply Shoulder Rollover Lock dialog.
• Select the Shoulder Point from the drop-down list. 
• Key-in the Difference for the High Side and Low Side of the shoulders. 
• Click the Apply button.
• Repeat this for each shoulder.
• Select the Process All button and review the design.
• Save the Roadway Design. 
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Practice-Apply Shoulder Rollover Locks
Practice-Apply Shoulder Rollover Locks

Apply Rollover Locks

Continue working on the last Practice activity. 
1 Select the Superelevation > Apply Shoulder Rollover Lock command
2 Key-in 5.0% for the High Side Difference and leave the Low Side Difference at 

0%
3 Change the Control Line Name to LT_SHDR Rollover and click Apply
4 This will automatically change the Shoulder Point from LT_SHDR to 

LT_GUTTER
5 Change the Shoulder Point to RT_SHDR

6 Change the Control Line Name to RT_SHDR Rollover and click Apply, then 
Close.

7 Look in the Superelevation view of the Roadway Designer. Notice additional 
control lines appear. 
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Practice-Apply Shoulder Rollover Locks
Review the Points Controls
1 Select the Corridor > Point Controls command and review the new Point 

Controls relating to Superelevation

Notice that since we have two superelevation sections a total of four additional 
controls for the shoulder were created. Notice they are also a tan color. This 
happens when there are conflicting point controls.

2 Disable the Point controls belonging to the Two lane section. 

Review the Design
1 Process All and review the design
2 Save the Roadway Design
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Shoulder Rollover in the Template
Shoulder Rollover in the Template

Shoulder Rollover can also be assigned in the Template. This is accomplished by applying 
rollover values to a point that has a slope constraint. Setting Rollover values in the 
template can be used as an alternative to the apply shoulder rollover lock command in the 
Roadway designer. When rollover values are specified in the template, this does not create 
additional control lines or point controls. 
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Practice-Assign Shoulder Rollover in the Template
Practice-Assign Shoulder Rollover in the Template

Continue working from the last practice activity

Copy the corridor. 
1 Select Corridor > Corridor Management
2 Copy the Corridor and name it Rollover, then Close the dialog. 

Remove the Section and Point Controls
3 Right Click in the Superelevation diagram and select Superelevation Display 

List. 
4 Delete the Section called Manual. 
5 Select the Two Lane Section and Delete the control lines called Two Lane 

LT_SHDR and Two Lane RT_SHDR
6 Close the dialog. 
7 Select Corridor > Point Controls. 
8 Enable the two remaining point controls, then close the dialog. 
10/2/07 InRoads 201

Copyright © 2006 Bentley Systems, Incorporated 1 – 45



Practice-Assign Shoulder Rollover in the Template
Assign Shoulder Rollover
1 Select Corridor > Template Drops. 
2 In the Current Template Drops area, select the template drop and click Edit. 
3 The Editing Roadway Designer Template Drop dialog will appear. 
4 Edit the point called RT_SHDR. 
5 For Constraint 1, enable the checkbox next to Parent 2 and click the Rollover 

Values button. 
6 In the Rollover Point Properties dialog, set the High Side difference to 5%. 
7 Set the Reference Point to CL, then click OK. 
8 Click Apply, then Close the dialog. 
9 Test the behavior of the template. Right Click on the RT_EOP and select Delete 

Both Constraints. 
10 Right Click on the RT_EOP and select Move Point. Do NOT actually click 

anywhere in the view to move the point to another location, simply move the 
cursor and observe how the shoulder behaves. 

11 Click the Undo button in the bottom left of the view to add the constraints back. 
12 Repeat the previous steps to apply the shoulder rollover to the LT_SHDR. Set the 

High Side difference to 5%. The Low Side difference should be set to 0%.
13 When finished, click OK. 
14 Notice the name of the template in the Template Drops dialog is now red. This is 

because a change has been made to the template definition in the corridor, and no 
longer matches the template in the template library. 

15 Close the Template Drops dialog. 
16 Select Corridor > Point Controls. 

Notice there are still only two point controls. Also notice there are only two 
control lines for the LT and RT edge of pavement. One benefit of defining 
shoulder rollover in the template is there are no additional control lines, and if the 
shoulder treatment is standard from project to project, the values can be defined 
directly to the template. 

17 Close the Point Controls dialog. 
18 Click Process All and Review the design. 
19 Save the Roadway Design. 
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Import Superelevation from ASCII

Import Superelevation from ASCII

This command creates superelevation control lines and assigns template point controls. 
The file imports pipe delimited format using the first three values only. Values used are: 
Station|Finished Grade Left|Finished Grade Right. The corresponding point controls for 
each control line are automatically created. All the points of the control lines by default 
are unconstrained. 

Basic Workflow
• Create the corridor and assign template drops
• Select Superelevation > Import Superelevation from the Roadway Designer Menu. 

This will bring up the Import ASCII dialog.
• Select the Crown Point from the drop-down list. 
• Select the Left Range Point from the drop-down list. 
• Select the Left Range Point from the drop-down list. 
• Click the Browse button and select the appropriate file. 
• Click the Apply button.
• Select the Process All button and review the design.
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Practice-Import Superelevation
Practice-Import Superelevation 

Review the ASCII File 
1 Launch Notepad and open the file called Super.txt located in folder for this 

workshop. 
2 Review the stations and cross slopes. When finished, exit Notepad.

Copy the corridor
1 Select Corridor > Corridor Management. 
2 Copy the corridor called Rollover and name it ASCII

Remove the Section
1 Right Click in the Superelevation diagram and select Superelevation Display 

list. 
2 Delete the Section called Two Lane, then close the dialog. 
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Practice-Import Superelevation
Import ASCII File
1 Right Click in the Superelevation diagram view and select Import 

Superelevation. 
2 Name the Section ASCII
3 Select CL as the Crown Point. 
4 Select LT_EOP as the Left Range Point. 
5 Select RT_EOP as the Right Range Point. 
6 Click the Browse button on the right 
7 Select the file Super.txt and click Open. 
8 Click Apply, then close the dialog. 
9 Select Corridor > Point Controls. Notice point controls have automatically been 

created. 
10 Close the Point Controls dialog. 
11 Process All and review the results.
12 Close the Roadway Designer. 

13 Select File > Close > All from the InRoads menu to prepare for the next lesson. 
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Import Superelevation from Alignment

Import Superelevation from Alignment

The Import Superelevation from Alignment command is used to import superelevation 
control lines from an alignment created from a previous version of InRoads. In Prior 
versions of InRoads, superelevation was stored as a “child” of the horizontal alignment. In 
order to use this command, the geometry project with the old superelevation definition 
must be loaded. If an alignment is found then a prompt will display. Point Controls are not 
automatically created when using this command. 
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Multiple Shoulder Rollover
Multiple Shoulder Rollover

Multiple Shoulder Rollover

In order to use the Apply Shoulder Rollover command, the following criteria must be met. 
• It must be a point that has not been supered yet. 
• It is next to a point that has been supered or is a pivot point for superelevation
• It is not a pivot point of the adjacent supered point. 
• It is not an End Condition point. 

The template being used in this example has two shoulders, one paved and one unpaved. 
Each shoulder has specific rollover requirements. The paved shoulder, when in normal 
crown has a 4% slope. The unpaved shoulder, when in normal crown has a 6% slope. 

First Shoulder Segment-Low Side

Let’s assume that the specifications require that the paved shoulder begin rotating when 
the roadway cross slope is 4% . Therefore, the algebraic difference on the low side should 
be set to 0%
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Multiple Shoulder Rollover
First Shoulder Segment-High Side

Let’s assume that the specification require that the paved shoulder have a slope difference 
of 5% on the high side. This means that when the slope of the road is 1%, the shoulder will 
lock and roate with the road. However, the first shoulder, must not exceed 2% percent, 
therefore the maximum slope value on the high side should be set to 2% maximum slope. 

Second Shoulder Segment-Low Side

Assume that the specification require that the second shoulder must always follow the first 
shoulder. Therefore, the % difference to specify will be 0% relative to the first segment. 

Second Shoulder Segment-High Side

Assume that the specifications require the unpaved segment to have a 3% slope difference 
on the high side relative to the paved shoulder. This means that when the slope of the 
paved shoulder reaches 3%, it will lock and rotate. The maximum slope of the second 
shoulder should be set to -2%
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Practice-Multiple Shoulder Rollover
Practice-Multiple Shoulder Rollover

Multiple Shoulder Rollover
1 Open the file Examples.rwk located in the folder for this workshop. 
2 Select Modeler > Roadway Designer
3 Set the active corridor to Multiple Shoulder
4 Click the Display Superelevation button in the Roadway Designer. 
5 Right Click in the Superelevation View and Select Apply Shoulder Rollover. 
6 The point name should be NB_S1. 
7 Set the High Side Difference to 5%. Enable the maximum slope and key in 2%. 
8 Verify that the low side difference is 0%. Click Apply
9 Select the point SB_S1. Click Apply. 
10 Select the point NB_SHDR. 
11 Set the High Side Difference to 3%. Enable the maximum slope and set it -2%. 
12 Verify the low side difference is 0%
13 Click Apply. 
14 Select the point SB_SHDR. Click Apply. 
15 Process All and Review the Results. When finished, Save the design . 
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Using Superelevation to Control Sideslopes
Using Superelevation to Control Sideslopes

Superelevation control lines can be assigned to any point on a template. This means that 
control lines can also be an effective method of sideslope control. The control line can be 
created by using the Create Single Control line command. Once the control line is created, 
then a point control can be a created to control the desired template point. i.e. RT_Fill. 
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Practice-Create Control Line for RT_Fill
Practice-Create Control Line for RT_Fill

Create the Control Line
1 Change the Roadway designer view from Superelevation mode to normal mode. 

(click on the display Superelevation button.) 
2 Set the active Corridor to Super of Slope. 
3 Look at the cross section at Station 371+60. Notice the right slope is outside of the 

right-of-way. (The vertical purple line) This can be corrected by using end 
condition exceptions, but another alternative is to create a control line for the 
RT_Fill. 

4 Click the Display Superelevation button. 
5 Right Click in the Superelevation diagram view and select Create Single 

Control Line. 
6 Key In Right Slope for the Control Line Name
7 Copy From should be set to None. 
8 Key In Slope for the Parent Section name. 
9 Key In -50% for the normal crown slope, then click OK. Adjust the view so the 

new control line is visible.
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Practice-Create Control Line for RT_Fill
Move and Insert Points
1 Right Click on the first point of the control line that was just created and select 

Move Point.
2 In the Station,Slope field (x+xx,x%) Enter 370+60,-50%

3 Click the Enter key on your keyboard. 
4 Right Click on the last point and select Move Point
5 In the Station,Slope field (x+xx,x%) Enter 372+30,-50%
6 Use the Insert Point command to insert points at the following station, cross 

slope
• 371+10, -60%
• 371+80, -60%

7 Save the Roadway Design. 

Assign the Point Control 
1 Select Corridor > Point Control 

2 Select the Point RT_FILL 2
3 For the Mode, select Vertical
4 Set the Control Type to Superelevation. 
5 For the Superelevation, select Right Slope
6 For the Reference Point, Select NB_Outside_SHDR. 
7 Click Add, then close the dialog.
8 Process All and Observe the Results. Look at the cross section at station 371+60. 

The right slope should now be inside the right of way. 
9 When Finished, Exit InRoads and MicroStation. 
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