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Lesson Objectives
Lesson Objectives

Lesson Objectives

In this lesson we will…
•  Learn about template point constraints and components
•  Create template components
•  Create a complete template from the components

Starting Clean
1 Close MicroStation and InRoads.

Starting InRoads
1 Double-click the InRoads icon.

The MicroStation Manager appears.

An alternate path for launching InRoads is Start > Programs > Bentley > 
InRoads Group XM > InRoads.
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Lesson Objectives
Open a CAD File
1 Set the directory to C:\InRoads Training\InRoads 201\Practice\Practice Lesson 

03.
2 Open the CAD file SR 2067 Bypass.dgn.
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Constraints on Template Points
Constraints on Template Points

Constraints on Points

Point constraints are used to manage the behavior of template points. They are used so that 
if a point is moved in a template, either by the user editing the template or by the 
application of point controls during design processing, all the points related to the point 
being moved will behave in a predictable manner.

• A template point can have a maximum of two constraints on it.  A point with 
two constraints is considered “fully constrained.” A point that is fully 
constrained is represented by a red plus sign.

• A point the has only one constraint on it is considered “partially constrained” 
and is shown as a yellow plus sign.

• A point with no constraints (unconstrained) is shown as a green plus sign.

Constraints can also be labeled so that during the design process the value of labeled 
constraints may be changed. For example, the template may have a constraint label called 
Thickness that controls the thickness of the asphalt wearing surface. This thickness can be 
changed so that one template can be used for different asphalt depths, without having to 
edit the template.
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Constraints on Template Points
Types of Constraints

InRoads provides a variety of constraint types for roadway template design as described 
below:

Horizontal

The child point remains at the given horizontal distance from the parent point.

Vertical

The child point remains at the given vertical distance from the parent point.

Slope

The child point will maintain the given slope from the parent point.  Slope constraints can, 
additionally, have rollover values assigned to them.  Rollover values are used to set the 
slope constraint based on a high side slope difference and a low side slope difference, and 
a reference point which defines the controlling slope to the parent point. Slope constraints 
are absolute.  Slopes going from lower-left to upper-right are positive regardless of 
whether the child point is to the left or right of the parent.

Horizontal Maximum 

The child point has two parent points and remains at the given horizontal distance from the 
parent point that is farthest to the right (has the maximum horizontal or X value).

Horizontal Minimum

The child point has two parent points and remains at the given horizontal distance from the 
parent point that is farthest to the left (has the minimum horizontal or X value).

Vertical Maximum 

The child point has two parent points and remains at the given vertical distance from the 
parent point that is highest (has the maximum vertical or Y value).

Vertical Minimum 

The child point has two parent points and remains at the given vertical distance from the 
parent point that is lowest (has the minimum vertical or Y value).
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Constraints on Template Points
Vector Offset

The child point has two parent points and will be projected onto the vector defined by the 
two parents. If the offset is not zero, then the child point will maintain a perpendicular 
offset from the parent vector at the specified offset value. Negative values indicate an 
offset to the left of the vector defined by the parent points. Positive values indicate an 
offset to the right.

Project to Surface

This constraint must be used in conjunction with one of the previously defined 
constraints.  The other constraint will define the projection direction. The child point will 
then be projected to the surface with the name given when the design is processed. If the 
surface does not exist, or no solution is found, the point will remain where it is placed in 
the template.

Project to Design

This constraint is similar to Project to Surface, except that the point is projected to the 
design surface of the template. A projection value is given to indicate whether the 
projection is to be to the left or to the right. Again, the point must also be constrained by 
one of the previous constraints, excluding the Project to Surface, so that a direction for the 
projection may be determined. Again, if no solution is found, then the point will remain 
where it is placed in the template.  
InRoads 201 3/19/07

3 – 44 Copyright © 2007 Bentley Systems, Incorporated



Visual Indicators for Parent-Child Relationship and Horizontal Constraint
Visual Indicators for Parent-Child Relationship and Horizontal 
Constraint

Parent-Child Point Relationship

When a point is constrained, it is constrained by either one or two points.  Points are 
constrained in a two dimensional plane. Constraints can affect only the point’s offset and 
elevation, which is the X and Y coordinates in a cross section view. Point constraints are 
also directional. The direction forms a parent-child relationship between points. If point B 
is constrained by point A, point A is said to be the parent of point B. When viewing the 
constraints, the parent point has a blue arrow pointing to the child point. To see the 
constraints in a template, enable the Constraints radio button located in the Display 
portion of the Create Template dialog.

Horizontal Constraint

A horizontal constraint is when a child is horizontally constrained to the parent. When you 
move the parent point, the child point moves at a constant horizontal distance from that 
point, which is specified when the constraint is established. A white horizontal line 
crossing over the blue arrow indicates a horizontal constraint.
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Visual Indicators for Vertical, Horizontal, and Slope Constraints
Visual Indicators for Vertical, Horizontal, and Slope Constraints

Vertical Constraint

A vertical constraint is when a child is vertically constrained to the parent. When you 
move the parent point, the child point moves at a constant vertical distance to that point, 
which is specified when the constraint is established. A white vertical line crossing over 
the blue arrow indicates a vertical constraint.

Horizontal and Vertical Constraint

A horizontal and vertical constraint is when a child is horizontally and vertically 
constrained to the parent. When you move the parent point, the child point moves at a 
constant horizontal and vertical distance to that point, which is specified when the 
constraint is established. A white horizontal and vertical line crossing over the blue arrow 
indicates a horizontal and vertical constraint. When a point has two constraints, such as 
horizontal and vertical constraints, that point is fully constrained and is shown in red.
InRoads 201 3/19/07

3 – 46 Copyright © 2007 Bentley Systems, Incorporated



Visual Indicators for Vertical, Horizontal, and Slope Constraints
Slope Constraint

A slope constraint is when a child is constrained to the parent by the slope between the two 
points. When you move the parent point, the child point moves at a constant slope with 
respect to the parent point, which is specified when the constraint is established. A white 
diagonal line crossing over the blue arrow indicates a slope constraint. When a point has 
only one constraint, such as a slope constraint, it is called a partially constrained point and 
is shown in yellow.
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Practice - Observe Template Constraints Behavior
Practice - Observe Template Constraints Behavior

Open Project File
1 Select File > Open.
2 Open the Project File C:\InRoads Training\InRoads 201\RWK\Practice Lesson 

03.rwk.

Select Template
1 Select Modeler > Create Template. 
2 Double-click the Template named Constraints Behavior from the Constraints 

folder.

This makes the template Constraints Behavior the current template.
3 Enable the Constraints and Display Point Names in the Display portion of the 

Create Template dialog.
• Point 1 is the parent of Point 2.
• Point 2 is the child of Point 1.
• Point 2 is horizontally and vertically constrained to Point 1.
• Point 2 is the parent of Point 3.
• Point 3 is the child of Point 2.
• Point 3 is horizontally and vertically constrained to Point 2.
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Practice - Observe Template Constraints Behavior
Move Template Points
1 Right-click on Point 1 and select Move Point.

Observe how the Points 1, 2 and 3 move as a rigid body.
2 Right-click to exit Move Point.
3 Right-click on Point 2 and notice that Move Point is no longer available.

It is not possible to move a point that has 2 constraints.

Let’s see what happens when we remove the vertical constraint from Point 2.

Change Point Constraints
1 Double-click Point 2.

This will bring up the Point Properties dialog. 
2 Change Constraint 2 from Vertical to None and click Apply, then Close.

Notice the color of the point turned from red to yellow.

Move Template Points

1 Move Point 1.

Notice the horizontal distance between Points 1 and 2 remains the same.
2 Move Point 2.

Notice the horizontal distance between Points 1 and 2 remain the same.

Also notice that the horizontal and vertical distance remains the same between 
Points 2 and 3.

Change Point Constraints
1 Double-click Point 2 again.
2 Change Constraint 1 from Horizontal to  Slope and click Apply, then Close.

Move Template Points
1 Move Points 1 and 2.

Delete Component
1 Delete the component by right-clicking with your cursor directly over the 

component and selecting Delete Component.

Notice there is also a Delete Components command that is used to delete 
multiple components.
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Adding and Deleting Constrains Graphically
Adding and Deleting Constrains Graphically

Adding and Deleting Constraints

In addition to editing the template point constraints using the Point Properties dialog, you 
can right-click on any point to access Add Constraint or Delete Constraints. This is very 
handy for making quick adjustments to the template constraints. 

Delete Constraints removes all constraints from the point. Add Constraint lets you pick 
the type of constraint you want to add to the point. Full Constraint adds both horizontal 
and vertical constraints to a point. 

Right-click on the child point you want to constrain, select Add Constraint, and select the 
point constraint you want to add. Then click the parent point and  key in the offsets or 
slope values of the child point from the parent. Setting the appropriate constraints on 
points is important to achieve the desired results when pavement layers, superelevation, 
and transitioning are introduced to the design. Using the Point Properties dialog is helpful 
for adjusting point constraints after initial point placement.
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Pratice - Adding and Deleting Constraints
Pratice - Adding and Deleting Constraints

Continue working on the template library used in the last practice activity.

Delete Constraint
1 Select the Add and Delete Constraints template and make it the current template.
2 Enable the Components and Display Point Names options in the Display area of 

the Create Template dialog.
3 Right-click on the CL_AGGR_B_BOT point and select Delete Constraints.

Notice the color of the point turn from red to green.
4 Delete the constraints on the EOP_AGGR_B_BOT and SHDR_AGGR_B_BOT 

points.
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Pratice - Adding and Deleting Constraints
Add Constraints
1 Right-click on the CL_AGGR_B_BOT point and select Add Constraint > Full 

Constraint.
2 Click on the CL_AGGR_A_BOT point.

This will bring up the Add Horizontal Constraint dialog.
3 Key-in a Horizontal Offset of 0.0 and a Vertical Offset of -1.0 and click OK.
4 Right-click on the EOP_AGGR_B_BOT point and select Add Constraint > Full 

Constraint. 
5 Click on the EOP_AGGR_A_BOT point.

This will bring up the Add Horizontal Constraint dialog.
6 Key-in a Horizontal Offset of 0.0 and a Vertical Offset of -1.0 and click OK.
7 Right-click on the SHDR_AGGR_B_BOT point and select Add Constraint > 

Slope. 
8 Click on the EOP_AGGR_B_BOT point.

This will bring up the Add Slope Constraint dialog.
9 Key-in a Slope of -6.0% and click OK.
10 Right-click on the SHDR_AGGR_B_BOT point again and select Add Constraint 

> Slope.
11 Click on the SHDR_AGGR_A_BOT point.
12 Key-in a Slope of -25.0% and click OK.

Delete Components
1 Right-click on the Current Template Window and select Delete Components.
2 Hold down the left mouse button and draw a line across a few components.

Release the left mouse button when done.

To undo the deletion, press the CTRL+Z buttons on the keyboard.
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The Sign of the Distance and Slope
The Sign of the Distance and Slope

Component Slopes and Distances

When defining components with precision input, the sign of the distance is dependent on 
the parent-child relationship. The parent is always the first point placed when creating 
template components. The distance is positive if the parent has a lower X value than the 
child. The distance is negative if the parent has a higher X value than the child. The sign of 
the component slope is based on the mathematical slope.
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Simple Component
Simple Component

Template Components

A component is a set of points that define an open or closed shape. Each component, 
whether open or closed, can represent a different material or area of interest.  

Components are saved in the template library and are normally stored in a separate folder 
in the Template Library folder structure. 

To create a component, first select File > New Template and name the template 
component. Then, use Add > Simple or Add > Constrained to build the component. 
Each component has a name and an assigned feature style. 

There are five types of components created in InRoads: 
• Simple
• Constrained
• Unconstrained
• Null Point
• End Condition
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Simple Component
As you add template components, the area under the graph changes to allow for different 
types of component input. This is called the Current Component area.

Simple Component

A simple component typically represents a section of pavement or sidewalk. It is a closed 
parallelogram that is defined by slope, thickness, and width. The top points are 
constrained by horizontal and slope constraints.  The lower points are constrained to the 
points directly above them by horizontal and vertical constraints.
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Pratice - Creating a Template of Simple Components
Pratice - Creating a Template of Simple Components

Create a Template Name
1 Browse to the folder named Components in the Create Templates dialog.
2 Create a template named 12’ Concrete Pavement w/8’ Shoulder.

Start Dynamic Settings
1 Select Tools > Dynamic Settings. 
2 Disable the Apply Affixes option in the Dynamic Settings dialog.

Add Simple Component
1 Right-click on the Current Template window and select Add New Component > 

Simple.
2 Setup the Current Component portion of the Create Template dialog as follows:

Component Name: CONCRETE

Style:  P_ROAD_Concrete

Slope: -2.000%

Thickness: 1.000

Width: 12.000
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Pratice - Creating a Template of Simple Components
3 Place the component at the origin of the Current Template window.
4 Right-click again on the Current Template window and select Add New 

Component > Simple.
5 Setup the Current Component portion of the Create Template dialog as follows:

Component Name:  CONCRETE     

Note: Since this is the same name as the first component created, the name will 
automatically be appended with a 1 resulting in Concrete1 as the component name.

Style:  P_ROAD_Concrete 

Slope: -6.000%

Thickness: 1.000

Width:  8.000
6 Place the component at the right edge of pavement point of the Current Template 

window.

Save Template Library
1 Select File > Save in the Create Template dialog.
3/19/07 InRoads 201

Copyright © 2007 Bentley Systems, Incorporated 3 – 57



Template Point Names
Template Point Names

Template Point Names

Templates are used by the Roadway Designer to create surfaces of the proposed roadway.  
Each template point will be connected longitudinally to the next template drop, based on 
the interval, to form longitudinal breakline surface features. The names of those features 
will be the name of the template points. Therefore, establishing a standard naming 
convention for template points is important to the quality of the proposed surface. 

Likewise, individual component names will also appear in the ensuing surfaces. These 
components will be used for volume calculations, so standard naming conventions should 
be applied to ensure consistent results. 

When transitioning between two templates (going from a two-lane to a four-lane roadway, 
for example), the Roadway Designer will attempt to connect template points of the same 
name to model the transition. Template transitioning makes consistent template 
component and template point naming even more important. 
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Template Point Names
Each template point name and component name must be unique within a template. For 
accurate volume calculations and surface creation (especially during template transition), 
different templates should use consistent component and template point names. InRoads 
automatically appends the names if the same name is chosen during template creation. 
Also, InRoads provides for automatic prefixes and suffixes (such as LT_ and RT_) when 
components are created or added to the left or right side of the origin point. Prefixes and 
suffixes for template point names can be defined using Tools > Options in the Create 
Template dialog.

Editing template point names can be easily accomplished by right-clicking on a template 
point and selecting Edit Point. Double-clicking the point also invokes Edit Point. This 
brings up the Point Properties dialog, where the point name and surface feature style can 
be changed. After you change the point name, click Apply. The Next > and < Previous 
buttons help to change multiple points by moving from point to point within the same 
template. Enabling the Display Points Names option in the Display portion of the Create 
Template dialog will allow you to visually verify the point names. 

The Point Name List is used to create template point names. These names are then 
selected during component creation or editing to reduce time spent keying in the names. 
To add names to the Point Name List, right-click on Point Name List in the Template 
folders and select Edit, or double-click on Point Name List.
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Practice - Editing Template Point Names
Practice - Editing Template Point Names

Continue to work on the template named 12’ Concrete Pavement w/8’ Shoulder.

The template components have been added, but the names should be changed to reflect a 
standard naming convention.

Create Point Names
1 Right-click on the Point Names List and select Edit.

This will bring up the Point Name List dialog.
2 Key-in CL_CONC_BOT  in the Name field.
3 Select the Style P_COGO_MainCL and click Add.
4 Key-in EOP_CONC_BOT in the Name field.
5 Select the Style P_ROAD_EdgeOfPavement and click Add.
6 Key-in SHDR_CONC_BOT in the Name field.
7 Select the Style P_ROAD_Shoulder and click Add, then Close.
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Practice - Editing Template Point Names
Edit Template Points
1 Double-click the point located at the template origin.

This will bring up the Point Properties dialog.
2 Change the point Name to CL and click Apply.
3 Click the Next > button which will move you down one point. 
4 Change the Name as follows:  Click Apply, then Next > and repeat.

Name :

CL_CONC_BOT 

EOP 

EOP_CONC_BOT 

SHDR 

SHDR_CONC_BOT 
5 Close the Point Properties dialog.

Merge Components
1 Right-click on the vertical segment separating the road and shoulder and select the 

Merge Components command.

Now the name of the merged component is called CONCRETE.
2 Double-click on the component to verify the name.

Save the Template Library
1 Select File > Save in the Create Template dialog.
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Constrained and Unconstrained Components
Constrained and Unconstrained Components

Add New Component >  Constrained

Add New Component > Constrained is used to create open and closed shaped template 
components using precision input. You can access this command by either right-clicking 
on the Current Template window or selecting it from the pull-down menus.  

Examples of constrained components include median barriers, curb and gutter sections, 
retaining walls, and complex pavement sections.  

Constrained components are created with horizontal and vertical constraints already 
applied to each point.  

Both closed and open shaped components can be created. The option to make the 
component closed or open is selected by right-clicking on the Current Template window 
during component creation.  

When creating template points, the Dynamic Settings dialog is used to define point names 
and styles. The Dynamic Settings dialog can also be used to enter the precise location for 
the points.
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Constrained and Unconstrained Components
The basic workflow for creating constrained components is to:
• Select Add New Component > Constrained.
• Key-in the Component Name and select the Style in the Current Component area.
• Key-in the Point Name and select the Style in the Dynamics Settings dialog.
• Select the key-in type (hs= for example) and key-in the precision value (12.0,2.0% for 

example) in the Dynamics Settings dialog.
• Press the Enter or Tab key on the keyboard.
• Repeat these steps until the last template point is placed.
• Right-click on the Current Template window and select Finish.

Add New Component Unconstrained

Add New Component > Unconstrained is also used to create open and closed shape 
template components using precision input. You can access this command by either right-
clicking on the Current Template window or selecting it from the pull-down menus. 

This command works the same as using Add New Component > Constrained except the 
components are created without any constraints on the points. The constraints are added 
manually using Edit Point or Add Constraint, accessed by right-clicking on any 
template point
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Practice - Adding a Constrained Component
Practice - Adding a Constrained Component

Create a Template Name
1 Browse to the folder named Components in the Create Templates dialog.
2 Create a template named Curb.

Preparing Settings Before Component Creation
1 If the Dynamic Settings dialog is not displayed, select Tools > Dynamic Settings.
2 Toggle Display Point Names to desired settings.
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Practice - Adding a Constrained Component (continued)
Practice - Adding a Constrained Component (continued)

Creating a Constrained Component
1 Right-click on the Current Template window and select Add New Component > 

Constrained.
2 Setup the Current Component portion of the Create Template dialog as follows:

Component Name:  CONCRETE CURB

Style:  P_ROAD_ConcreteCurb
3 Setup the Dynamic Settings dialog as follows:

Point Name: SHDR  (Select from the list)

Apply Affixes: disabled

Precision Input: xy = 0,0

Press the Enter key

The default units for precision input are feet. You can enter other units with the proper 
specification, such as 6” instead of 0.5.

Watch the prompts in the lower left corner of the Create Template dialog. When 
creating a component using precision key-in, an ESC allows you to go back.
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Practice - Adding a Constrained Component (continued)
4 Set up the Dynamic Settings dialog as follows:

Point Name: TOC

Apply Affixes: disabled

Precision Input: xy = 0.07,0.5   (from similar triangles)

Press the Enter key.
5 Set up the Dynamic Settings dialog as follows:

Point Name: BOC

Apply Affixes: disabled

Precision Input: hs = 5.5”,0.0

Press the Enter key.
6 Set up the Dynamic Settings dialog as follows:

Point Name: BOC_BOT

Apply Affixes: disabled

Precision Input: dl = 0.0,-16”

Press the Enter key.
7 Set up the Dynamic Settings dialog as follows:

Point Name: TOC_BOT

Apply Affixes: disabled

Precision Input: dl = -7.75”,0

Press the Enter key.
8 Right-click on the Current Template Window and select Finish.
9 Enable the Display Point Names option.

Save the Template Library
1 Select File > Save in the Create Template dialog.
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Basic Component Creation Workflow
Basic Component Creation Workflow

Basic Component Creation Workflow
• Open the Template Library by selecting File > Open.
• Select Modeler > Create Template. This will bring up the Create Template dialog.
• Navigate to the template folder used for components.
• Select File > New > Template from the Create Template dialog. Name the new 

template, which is a component.
• Select Tools > Dynamic Settings if the Dynamic Settings dialog is not open.
• Select Add > Simple or Add > Constrained from the Create Template dialog.
• Add template components by using the Dynamic Settings dialog to specify the Point 

Name and Style, and the point locations.
• Select File > Save from the Create Template dialog to save the template library.
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Creating End Conditions
Creating End Conditions

End Conditions

End conditions are template components which are used to model cut and fill treatments.  
They are added to the end of simple, constrained, and unconstrained components. 

End conditions are created like other template components. End conditions consist of 
template points and individual components, and appear as line segments. They are 
different than simple and constrained components because they have the ability to target 
surfaces, elevations, alignments and surface features. 

An example of this targeting is a design criteria which specifies a 4:1 fill slope if a fill 
height under 6 feet is encountered and the target type would be the original ground 
surface.

To create an end condition, first select File > New Template and name the template. Then 
use Add New Component > End Condition to build the end conditions. End conditions 
are stored in the template library and normally are created in a separate folder in the 
template library. 
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Creating End Conditions
Target Types

Target types are specified in the Current Component portion of the Create Template 
dialog, which appears below the Current Template window during end condition creation. 

Target types are defined only for end condition components, and are a property of that 
component. To edit a target type, open the Component Properties dialog by double-
clicking on the component or by right-clicking on the component and selecting Edit 
Component.

A solution can intercept multiple targets and target types. A ditch design, for example, 
may intercept an alignment that represents the bottom of the ditch and then intercept the 
original ground surface to form the backslope of the ditch.

Surface – targets the active surface or any specified surface. Using the active surface 
as the target helps when you are applying the end conditions to different projects. This 
is because the end condition will still work even though the target surface name may 
be different, so long as it is designated as the active surface. 

Elevation – targets any specified elevation.
Feature XY – targets the horizontal offset of any specified surface feature.
Feature Elevation - targets the vertical elevation of any specified surface feature.
Feature XYZ - targets the horizontal offset and vertical elevation of any specified 
surface feature.
Alignment XY – targets the horizontal offset of any specified alignment.
Alignment Elevation - targets the vertical elevation of any specified alignment.
Alignment XYZ - targets the horizontal offset and vertical elevation of any specified 
alignment.
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End Conditions Settings
End Conditions Settings

End Condition Priority

Simple end conditions consist of cut and fill segments. When creating the roadway design, 
each condition will be tested in a specific order. That order is called the priority, which is 
numeric, and is assigned during end condition creation.  The most desirable conditions are 
assigned the lowest priority numbers. The most desirable condition, and the first condition 
to be tested, is a priority of 1. The next condition to be tested will have a priority of 2, and 
so on. 

For example, a design criteria calls for two fill conditions; 4:1 fill slope for an 8 foot fill 
height and a 3:1 fill slope for a 10 foot fill height. In this example, the target of each 
condition is the original ground surface. Each condition will be tested starting with lowest 
priority number. The first condition to successfully intersect the target, which is the 
original ground surface in this example, will be applied. 

Priority is used when more than one end condition starts at the same point. In order for an 
end condition segment to be placed and used in the design, a segment or one of the 
segments connected to that segment must successfully intercept its target. If a segment or 
its connected segments do not intercept their targets, that group of segments fails and the 
next group of segments, with the next higher priority, are tested. It is important that end 
conditions have at least one solution that will not fail to intercept their targets. 
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End Condition Settings

As you create the end conditions, there are several settings that will have to be considered 
to obtain the desired results. These settings are enabled or disabled and are set using the 
Dynamic Settings dialog during end condition point creation. To edit end condition 
settings, open the Point Properties dialog by double-clicking on the end condition point or 
by right-clicking on the point and selecting Edit Point.

Check for Interception – when checked on, the line segment will search for the 
specified target. If checked off, the line segment will be created at its full width 
regardless of whether it intersects the target, provided that one of the segments 
connected to this segment successfully intersects the target.
Place Point at Interception – when checked on, a point will be placed at the location 
of the interception. If checked off, the line segment will be created at its full width, 
provided that one of the segments connected to this segment successfully intersects 
the target.
End Condition is Infinite – when checked on, the line segment will automatically be 
extended to intercept the target. If checked off, the line segment will only extend to its 
maximum constraint to meet its target. This applies only to the last line segment in an 
end condition.
Do Not Construct – If checked on, the end point of the line segment will be used as a 
reference point to find a subsequent point. The point will be solved like any other end 
condition point, but that point will be skipped when drawing the final component 
segments. This is normally checked off and is used only for more complex condition 
testing.
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Practice - Creating End Conditions
Practice - Creating End Conditions

Create a New Template Name
1 Browse to the folder named End Conditions in the Create Templates dialog.
2 Create a template named Simple Cut and Fill.

Starting Dynamic Settings and Point Names
1 Select Tools > Dynamic Settings, if not already displayed. 
2 Enable the Display Point Names option.
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Practice - Creating End Conditions
Create End Condition Components
1 Right-click on the Current Template Window and select Add New Component > 

End Condition.

The example design criteria calls for a 6:1 fill slope at fill heights between 0’ to 
5’.

2 Setup the Current Component portion of the Create Template dialog as follows:

Name:  6:1 FILL FOR 30‘    

Style: P_ROAD_FillLine

Target Type: Surface 

Priority: 1

Surface: <Active>
3 Setup the Dynamic Settings dialog as follows:

Point Name: BOC   (select from list)

Apply Affixes: Disabled

Precision Input: xy = 0,0
4 With your cursor in the xy=0,0 field, press the Enter key on your keyboard.
5 Setup the Dynamic Settings dialog as follows:

Check for Interception: Enable

Place Point at Interception: Enable

End Condition is Infinite: Disabled 

Do Not Construct: Disabled

Point Name:  6:1 FILL   (key-in the name)

Point Style: P_ROAD_FillLine

Apply Affixes: Disabled 

Precision Input: hs = 30.0,-1:6
6 With your cursor in the hs = 30.0,-1:6 field, press the Enter key on your keyboard.
7 Right-click on the Current Template window and select Finish.
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Practice - Creating End Conditions
8 Right-click on the BOC point on the Current Template Window and select Add 
New Component > End Condition.

The example design criteria calls for a 3:1 fill slope for fill heights greater than 5’.
9 Setup the Current Component portion of the Create Template dialog as follows:

Name:  3:1 FILL 

Style: P_ROAD_FillLine

Target Type: Surface 

Priority: 1

Surface: <Active>
10 Setup the Dynamic Settings dialog as follows:

Check for Interception: Enable 

Place Point at Interception: Enable

End Condition is Infinite: Enable

Do Not Construct: Disabled 

Point Name:  3:1 FILL

Point Style: P_ROAD_FillLine

Apply Affixes: Disabled 

Precision Input: hs = 40.0,-1:3
11 With your cursor in the hs = 40.0,-1:3 field, press the Enter key on your keyboard.
12 Right-click on the Current Template Window and select Finish.
13 Right-click on the BOC point in the Current Template window and select Add 

New Component > End Condition.

The example design criteria calls for a 3:1 cut slope for all cut conditions.
14 Setup the Current Component portion of the Create Template dialog as follows:

Name:  3:1 CUT    

Style: P_ROAD_CutLine

Target Type: Surface 

Priority: 1

Surface: <Active>
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Practice - Creating End Conditions
15 Setup the Dynamic Settings dialog as follows:

Check for Interception: Enable

Place Point at Interception: Enable

End Condition is Infinite: Enable

Do Not Construct: Disabled 

Point Name:  3:1 CUT

Point Style: P_ROAD_CutLine

Apply Affixes: Disabled 

Precision Input: hs = 40.0,33.3% 
16 With your cursor in the hs = 40.0,33.3% field, press the Enter key on your 

keyboard.
17 Right-click on the Current Template Window and select Finish.

Save the Template Library
1 Select File > Save in the Create Template dialog.
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Practice - Adding a Ditch End Component
Practice - Adding a Ditch End Component

Continue to work on the end condition template named Simple Cut and Fill.

Create Ditch End Components
1 Right-click on the 3:1 FILL point in the Current Template window and select Add 

New Component > End Condition.
2 Setup the Current Component portion of the Create Template dialog as follows:

Name:  DITCH      

Style: P_ROAD_Ditch

Target Type: Surface 

Priority: 1

Surface: <Active>
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Practice - Adding a Ditch End Component
3 To place the second point, set up the Dynamic Settings dialog as follows:

Point Name: DITCH BOTTOM              (select from list)

Check for Interception: Disabled 

This forces this line segment to be placed.

End Condition is Infinite: Disabled

Do Not Construct: Disabled 

Apply Affixes: Disabled 

Precision Input: hs = 5,-1:4
4 With your cursor in the hs = 5,-1:4 field, press the Enter key.
5 Setup the Dynamic Settings dialog as follows:

Point Name: DITCH BACKSLOPE         (select from list)

Check for Interception: Disabled 

This forces this line segment to be placed.

End Condition is Infinite: Disabled

Do Not Construct: Disabled

Apply Affixes: Disabled

Precision Input: hs = 5,0
6 With your cursor in the hs = 5,0 field, press the Enter key.
7 Setup the Dynamic Settings dialog as follows:

Point Name: DAYLIGHT               (select from list)

Check for Interception: Enable 

Place Point at Interception: Enable

End Condition is Infinite: Enable

Do Not Construct: Disabled

Apply Affixes: Disabled

Precision Input: hs = 5,25%
8 With your cursor in the hs = 5,25.0% field, press the Enter key.
9 Right-click on the Current Template window and select Finish.

Save the Template Library
1 Select File > Save to save the template library.
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Testing the End Conditions

Testing End Conditions

End Conditions can be tested prior to and during during end condition creation.  Testing 
will simulate how the end conditions will behave during modeling, without using the 
Roadway Designer.  

To test that the end conditions produce the desired results, select the Test button located 
under the Current Template window. This brings up the Test End Conditions dialog. The 
window in the Test End Conditions dialog displays non-end-condition components as 
solid lines and end conditions as dotted lines. The scale of this window is dynamic and 
view controls are located at the bottom.  

To test the end conditions, select one of the available targets and select the Draw button 
located on the right side of the dialog. Move your cursor over the testing window. The end 
conditions will change from a dotted line to a solid line, revealing the final solution for the 
proposed target intercept. If there are any priority conflicts, you will receive a warning 
message. Select the Check Priorities button to review and edit the priority of each end 
condition.
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Practice - Testing the End Conditions

Continue to work on the end condition template named Simple Cut and Fill.

Test the End Conditions and Change the Priority
1 Select Test located under the Current Template window.

A warning will be given about the template having end condition priority 
conflicts.

2 Select Check Priorities on the right side of the Test End Conditions window.

Notice that BOC point is a bold white color, which is an indicator of the point that 
has the priority conflicts. 

3 Select Edit.

Notice that all the end conditions have the same priority number.
4 Put your cursor in each of the fields and notice the segments highlighting.
5 Assume that fill is the most desirable condition and change the Priority of the 3:1 

CUT to 3 and the Priority of the 3:1 FILL to 2.
6 Click OK, then Close.
7 Click Draw on the right side of the Test End Conditions window.
8 Move your cursor over the end conditions.
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Practice - Testing the End Conditions
9 Change the Use Surface Slope to 10.00% and click Draw again.
10 Move your cursor over the end conditions.
11 Close the Test End Conditions dialog.

Save the Template Library
1 Select File > Save to save the template library.
2 Exit MicroStation and InRoads.
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Basic End Condition Component Creation Workflow

Basic End Condition Component Creation Workflow
• Open the Template Library using File > Open.
• Select Modeler > Create Template. This will bring up the Create Template dialog.
• Navigate to the template folder used for End Condition components.
• Select File > New > Template from the Create Template dialog. Name the new 

template, which is an end condition component.
• Select Tools > Dynamic Settings if the Dynamic Settings dialog is not open.
• Select Add > End Condition from the Create Template dialog.
• Add end condition components by using the Dynamic Settings dialog to specify the 

Point Name and Style, and the point locations.
• Select File > Save from the Create Template dialog to save the template library.
3/19/07 InRoads 201

Copyright © 2007 Bentley Systems, Incorporated 3 – 81



Project Task
Project Task

Task Objective

Create a roadway template from scratch and use that template to create a roadway design.

Given Data

Working MicroStation File
• C:\InRoads Training\InRoads 201\Firethorn Road\Firethorn Road.dgn

Project File
• C:\InRoads Training\InRoads 201\RWK\Firethorn Road Task.rwk

The project file will load the correct preferences, geometry, and existing ground 
surface file. The individual files are listed below but do not need to be loaded 
individually if you load the project file.

Preference File
• C:\InRoads Training\InRoads 201\Standards\Preferences\InRoads Training.xin

Geometry Project
• C:\InRoads Training\InRoads 201\Firethorn Road\Firethorn Road.alg
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Project Task
Existing Ground Surface
• C:\InRoads Training\InRoads 201\Firethorn Road\Existing Ground Survey.dtm

Template Library
• C:\InRoads Training\InRoads 201\Firethorn Road\Template Standards.itl

Additional Project Data

Detail Sketches (located on the following pages)
• Roadway Detail
• Curb and Gutter Detail
• Cut and Fill Detail

Requirements
• Close and restart MicroStation and InRoads if they are running from a previous 

exercise.
• Open the “working” CAD file.
• Open the Project File (.rwk). 
• Create a complete template using the provided details.
• Create a roadway design and design surface.
• Create cross sections and run End-Area Volumes.
• Save all new or modified files.

Tips
• Create components separately.
• Toggle off Apply Affixes when creating components.
• Drag and drop completed components with Apply Affixes toggled on.
• Adjust template point locations or constraints using the Edit Point command if 

necessary.
• Test the end conditions prior to creating the surface model
• Use the Point Names List to create any missing point names and associated styles 

(most point names have already been created).

Questions

What is the total cut and fill based on the End-Area volume computation?

End-Area Cut Volume _______________

End-Area Fill volume _______________

How many components make up the final template? _______________

Assistance Video
Videos demonstrating how to complete this project are available if you need assistance.
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Project Task
1 From the InRoads menu, select Help > Training.
2 Select InRoads 201 for the Learning Module.
3 Select the Task 03 folder.
4 Double-click on the video to view.

Time Allowed
2 hours

Cleanup
When finished, exit MicroStation and InRoads.
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Roadway Detail
Roadway Detail
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Curb and Gutter Detail
Curb and Gutter Detail
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Cut and Fill Detail
Cut and Fill Detail
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Cut and Fill Detail
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