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Why You Need Civil AccuDraw

The identifying and placing of points are an intrinsic part of any
civil model.

Points make up a part of nearly every geometric construction,
like the start and endpoints of both horizontal and vertical lines
and arcs. They identify surveyed features, locate drainage
structures and delineate the vertices of terrain triangles.

MicroStation offers a variety of standard graphical snapping
conventions that are very helpful when it comes to locating or
identifying these points.

However, many times we’ll find these basic snapping tools are
not sufficient for more advanced placements.
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What is AccuDraw?

In cases where the standard graphical snapping conventions are not
enough, the MicroStation AccuDraw tool provides additional capabilities.

AccuDraw allows the user to provide precision input of point parameters
(e.g. coordinates, distance, direction, etc.) as well as providing point
Input based on relationships with other points or geometric entities.

However, as useful as AccuDraw is, it has limitations in the civil world.
For example, it is not able to recognize civil geometry, thus it's not able

to interpret station and offset information from a specified baseline.
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What is AccuDraw?

Civil Accudraw is designed to replicate those portions of Accudraw which
are relevant to a civil workflow as well as expand the capabilities to
identify and locate points based on civil constraints and input.
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What Civil AccuDraw does not do.

It does not create elements.

It is used in the creation of elements, but in and of itself it does not
create or draw anything. It just feeds input to other commands which

create elements.
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The Basics

 Activating, Controlling and Customizing Civil AccuDraw
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Activating the Civil AccuDraw toolbar

OpenRoads Modeling : Geometry : General Tools

:j OpenRoads Modeling v 5 Hl’-_O. & v » ’ =

File Home Terrain Geometry Corridors !

W & Import/Export ¥ Nt A
a2 5 S

44 Design Elements ~
Element ..., o Desion Element Civil Reports
Selection i... ¥ ®h Standards ~ Toggles ~ v

Selection General Tools
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The Civil AccuDraw toolbar

 Can be docked
* Provides access to all Civil AccuDraw functions.

« Changes based on the focused view.

2D Plan Profile Model View
Civil AccuDraw (=] Civil AccuDraw (=]
3o | © 0on @ -+ L ]84 2| =
3D Plan
Civil AccuDraw @

o [~ | ©on @+ 5 [t
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Settings

Civil AccuDraw toolbar

Civil AccuDraw ﬂ
R *5*(, O~ @ -+ L A0 AL -

\Mﬂrtcuts: Civil Acculraw Settir|5|5|
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Settings are similar to MicroStation AccuDraw

Operation Tab

Operation | Display " Comi'lilea|

[#] Auto Load [ ] Auto Point Placement
[¥] Hoating Origin [] Sticky Z Lock

[V] Context Sensitivity (] Always Show Compass
[«] Smart Key-ins [+] Auto Focus Fields

Operation |[‘.imli|3,r I Coordinates I Famiﬂ|

Default Origin: | View center on active 7~ | [«] Auto Load

[¥] Floating Origin

[«] Context Sensitivity
[¥] Smart Key-ins
Preserve Method Locks
[] Sticky Z Lock

[] Always Show Compass
[7] Show Accudraw Dialog
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Settings are similar to MicroStation AccuDraw

Display Tab

[ ] Delayed Update
[ ] Display Coordinates

Show Megative Angles
[+/] Pop-up Corfimations

These settings control the
heads-up dynamics.
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Operation | Display |Gmnilites I Favortes

lUse Default Values:

Compass
X duis: I LightCoral

Y Podis: [ ellowGreen

7 Lus: Il MediumOrchid

- ComflowerBlue

|4

Constraint Dynamics
Show Constraints:

Standard: [ Sitver
Hilite: [ White Smoke
Locked: - Blue

Distance

250.000

Direction

@@

45°00'00"

Z

0.0000

Enter End Point

Distance| 250.000 G

Bentley



Settings are similar to MicroStation AccuDraw

Coordinates Tab

Operation | Display | Coordinates |

Coordinate System
Rotation:
Type:

Unit Roundoff
Distance: [0.0000 | []
Angle: |00°0000" | []

Indexing

| Operation I[imlaﬂ Coordinates |Famiﬂ|
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Favorites (Civil AccuDraw only)

Support user-customized methods.

Civil AccuDraw Settings

|

| Dperation | Cisplay | Coordinates | Favorites |

Mame Ordinate 1

Distance-Direction  Distance
Digt-Dir Unlinked  Distance

Dist-Diist Distance
A *
DX DY DX
Station-Cffset Station
DettaStation-Cff set
My Favorite
Distance
| |precton
Station
Cffset
Delta Station
Delta COffset
DX

Ordinate 2
Diirection
Direction
Distance

Comman Origin

Yes
Mo
Mo
Yes
fes
fes
Yes
Mo

lcon
&) Civil_Accudraw_DistanceDirection
G Civil_Accudraw_Distancelirection
@) Civil_Accudraw_DistancelDistance
= Civil_Accudraw_XY
14 Civil_Accudraw_DxDy
‘.I Civil_Accudraw_StationDffset
ﬁi Civil_Accudraw_DstationDffset
= Civil_Accudraw_XY
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Horizontal Methods
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Vertical Methods

\

tation | 1474+19. 1\\

Station

5
< lope |ESIEES
@ / Proflle
1368+89.77 Station
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Help!
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All settings are detailed in the OpenRoads Help.

@ OpenRoads Designer CONNECT Edition

=S a—]
R

_Hide Back Fonward Home  Prit  Options

Contents Index Search Favorites

0 OpenRoads Designer CONNECT Edition
[£] What's New?
Q Getting Started
@ The Ribbon
@ Fie

(1] Getting Started

[£] Selection

&3 General Tools
(23 General Geometry Import / Export
(£ General Geometry Design Element
(2 General Geometry Standards
{2 General Geometry Civil Toggles

Remove Rules

Deactivate Reference Rules
(Z2 Reports

(2 Horizontal

(£ Vertical

@ Conidors

@ Model Detaiing

@ Drawing Production

[£] Tool Index

[£] Keyin Index

Geometry

Activate Civil AccuDraw Toolbar

e
LN

Accesses Accudraw Commands.

You can access this tool from the following:

Civil Reports | Lines Arc
Toggles ~ v ¥ v

Civil Accudraw
Activate Rules
Deactivate Rules

Remove Rules

3
8
x
o

Deactivate Reference Rules

+ Ribbon: Geometry > General Tools > Civil Toggles split button

Click the Activate Civil AccuDraw Toolbar icon to access AccuDraw commands. Use Civil AccuDraw to allow precise input of points, whether the points are physical points or end
points of linear geometry. The Civil AccuDraw values can be persisted as rules on the points by locking both values in the Civil AccuDraw input.

Tools

Click the Toggle Civil AccuDraw icon to activate or deactivate AccuDraw.

© 2017 Bentley Systems, Incorporated
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File > Settings > User > Preferences > View Options - Civil

Settings to control the look and feel of the Cursor Prompt Dialog.

a Preferences [OpenRoads_Metric] X
Categol
£l | Name for Preferences: [ OpenRoads User Preferences
Database
Descartes
Help Settings A AL SRS
Input Cursor Prompt Dialog S e : %
Language - . Distance | 250.000 |
kl;”" ar;:l:eell Dialog Color [255.255,255] Direction| 45°00°00" @
O°”5:A e Text Color [0.0.0] i 7 1 —
peration i | 10.0000
Position Mapping % X - —
Raster Manager . 4 |Enter End Point I
Reference : " |Distance| 250,000 14
Render b }
Ribbon Selected In Property Pane Color || [255.255.255] % i
Spelling Selected Color [ [255.165.0] ¥ ?
Tags Manipulator Font i . ‘
Text d Manipulator Font Scale 1.0000 Vi 2
Update Settings Manipulator Transparency 30.0000 A h2
View Options Use Shaded Manipul True el Gl
View Options - Civil
- f Superelevation Settings v
v

Focus Item Description:

Bentley
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File > Settings > File > Design File > Civil Formatting
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Coordinate Settings

a Design Fife Settings

Lategory Coordinate Setti an N
Active Angle el o
Active Scale P XY
Angle Readout Precision 10.1234
Axis = =
Civil Formatting Ratio Settings (Distance:Offset) -~
Color 1D
Fence Precision 0.123
Grid . 2 &
lsometric Station Settings
Locks S+5SS
Snaps Format Delimiter +
Stream Precision 0.123
Views Equation By Name
Working Unit

ARG Radius Settings ~

Arc
Degree Of Curve Length 100.00000m
Radius Tonale Char ld N
Focus ltem Description
Select category to view.
[ ok || cancel
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Settings > Design File > Civil Settings

| WWW.BENTLEY.COM

Profile (slope) Settings

a Design File Settings

Qat.egory I Precision 0.123 A
Active Angle Equation By Name
Active Scale
Angle Readout Radius Settings ~
Axe Arc
(vl Eoimatting Degree Of Curve Length | 100.00000m
Color Radius Toggle Char d
Fence
Grid Spiral Settings ~
ot ST oo |
Locks
Snaps Profile Settings ~
Stream 0123
VIE'WS. : Slope Format Percentage
Wesking Units Slope Precision 0.12

Ratio Format Run:Rise

Ratio Precision 0.123

Vertical Curve Parameter For Kvalue v

Focus Item Description
Select category to view.
ok || Cancel
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Settings > Design File > Civil Settings

Station Settings

ﬂ Design File Settings X
Sategory I Coordinate Settings AN
Active Angle T i
e | rrre—

Q:I/TIF ormatting Ratio Settings (Distance:Offset) -~
e | r—
I(z::\etri g Station Settings -~

Locks s+sSS
Snaps Format Delimiter +
Stream Precision 0.123
Views Eguation By Name
Working Unit
R Radius Settings ~

Arc
I Degree Of Curve Length 100.00000m
Radius Tonale Char ld ¥

Focus Item Description

Select category to view.

[ ok | cancel

Bentley
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Settings > Design File > Working Units

| WWW.BENTLEY.COM

- dX, dY, dStation, Length, Profile Offset, etc.

- —
d Design File Se

ttings

Category

Active Angle
Active Scale
Angle Readout
Axis

Civil Formatting
Color

Fence

Grid

Isometric
Locks

Snaps

Stream

Views
Working Units

Linear Units
Format: IMU .

Master Unit: ’h/letg[s—v‘ Label: ‘A"lij
Sub Unit: |Millimeters v | Labek  mm |
Accuracy: {6153;‘:5 "A}

i Custom \

Advanced Settings

Resolution: 10000 per Distance Meter

Working Area:  9.0072E+08 Kilometers
Solids Area: 1 Kilometers
Solids Accuracy: 1E-08 Meters

| Edt |
Focus Iltem Description
|Select category to view.
0OK | ’ Cancel
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Settings > Design File > Angle Readout

| WWW.BENTLEY.COM

ﬂ Design File Settings

Category

Active Angle
Active Scale
Angle Readout
Axis

Civil Formatting
Color

Fence

Grid

Isometric
Locks

Snaps

Stream

Views
Working Units

Format DDMMSS ~

Accuracy: (0.1 v

~Brrection Mode: [aimmith
Base:  North ~| [90°00'00" |
w_gockwise

l/,

Focus Item Description

Select category to view.

Cancel

© 2017 Bentley Systems, Incorporated

Bentley



Tips and Tricks

The cursor prompt dialog can be changed to a fixed box dialog by
pressing the down arrow on keyboard.

|Enter End Point |
Distance| 1343966 4p

Station |
Offset |0.0000

B Civil AccuDraw - ©
Station | 000.00

Element 4
Offzet  |0.0000

Element 4
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Tips and Tricks
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Pressing the space bar on your keyboard opens a direct pick menu.
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1 Toggle Civil AccuDraw
2 Shortcuts &' 1 Civil AccuDraw Settings
3 Distance-Direction E‘ 5 LETFIEEL
4 Dist-Dir Unlinked ©* 3 SetOrigin
5 Dist-Dist "" 4 Show Shortcuts
46 XY —| 5 LockIndex
'_,“r i DXDY T & Rotate Compass to North
8 Station-Offset El 7 Rotate Compass to View
ii/"’if 3 Deltatation-Offset D £ Rotate Compass to Base
T. 0 My Favorite “ 9 Rotate Quick
";l 0 Rotate Compass to Element
LI 0 Rotate View to Compass
%} W Go To Tool Settings Dialog
11 E Switch Dialog Mode
9/} B Civil AccuDraw Help
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Why You Need Civil AccuDraw ...

Communicates Precision Input

* Provides point input (e.g. coordinates, distance, direction, station,
offset, etc.) to any MicroStation or Civil command or construction

which requires a point.
— Note: Civil AccuDraw is not limited to only civil commands. It can
also be used with MicroStation commands.

Communicates Design Intent

« Civil commands can persist the Civil AccuDraw input as rules on the
points.

Bentley
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Precision Input

* Providing point input (e.g. coordinates, distance, direction, station,
offset, etc.) to any MicroStation or Civil command or construction
which requires a point.
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Horizontal Geometry (e.g. Right of Way)

 Existing Right of Way

— Using coordinate (X,Y) input into Elements by Pl command
« Easements

— Based off existing Right of Way

— Station/offset input (updates!)
» Parcels

— Using X,Y for points

— Using distance, direction
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Profiles

» Special Ditch Grades
— Station / Elevation
— Station / Slope

« Subsurface Design Profiles
— Profile offsets

« Bridge Deck Clearances
— Profile offsets
— Station/ dZ, Z
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Why You Need Civil AccuDraw ...

Communicates Precision Input

* Provides point input (e.g. coordinates, distance, direction,
station, offset, etc.) to any MicroStation or Civil command
or construction which requires a point.

— Note: Civil AccuDraw is not limited to only civil commands. It can
also be used with MicroStation commands.

Communicates Design Intent

« Civil commands can persist the Civil AccuDraw input as
rules on the points.

Bentley
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Design Intent

« Design Intent is the act of preserving the rules and relationships
creating during the design process in order to maximize the
downstream benefits of automated updates.
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Automatic Updates

Everyone wants software that will automatically update the
design whenever a change is made in order to eliminate
errors.

However, if not done correctly, what most people don't
realize Is that automatic updates can generate just as
many errors and omissions as it eliminates.

The reason for this is simple — if you are going to update a
design correctly, then the software must remember the
engineering decisions (i.e. the design intent) that originally
went into the creation of those elements and components.

If you don't, then any updates you do will involve
assumptlons and guessing which will obviously lead to
additional errors and omissions.
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How Do | Communicate Design Intent?

How do | communicate to the software what I'm intending to do?

This is the key to using Design Intent properly — making sure that,
as a user, I'm able to store rules and relationships that effectively

communicate how | expect that design to update.

Bentley
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Design Intent for Free

In many cases, there is nothing for you as a user to necessarily think
about or consider. You just get the proper rules and relationships as part
of the commands you are using.

 Terrain Models
— Update from Source
— EXxisting ground line from terrain

* Vertical Geometry
— Complex from Simple

* Horizontal Geometry
— Gaps, Offsets, Trimming, etc.

Bentley
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MicroStation Snaps

MicroStation snaps are a simple yet incredibly powerful way of
communicating your design intent to the software.

- Key Stations

Driveway

sidewalk sidewalk
| 5feet | | 5feet |
Paint "TRAFFIC YELLOW"

top of curb

Bentley
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Civil AccuDraw

However, there are times that, in order to communicate your design
Intent, you need more than just a simple MicroStation snap. In these
scenarios, Civil AccuDraw becomes an indispensable tool, because the
parameters you use with Civil AccuDraw are persisted as part of the
rules.

Station Offset Rule J
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Civil AccuDraw

An example from Horizontal geometry.

* Tying the Turn Lane to the Crosswalk
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Civil AccuDraw

An example from Vertical Geometry.
* Minimum Vertical Clearance
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