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InRoads Tips 

Explorer Tips 

You can display a short-cut list of appropriate commands in the Explorer by clicking 
the right mouse button. 

You can open data files by dragging them from the File Manager or the Windows 
Explorer and dropping them into the InRoads Explorer.  Appropriate files include 
projects (*.rwk), surfaces (*.dtm), alignments (*.alg), and libraries (*.tml or *.rwl). 

You can dock a toolbar on the Explorer window by dragging the toolbar over the 
edge of the window or by double-clicking on the title bar of a toolbar. 

The Write lock status displays at the bottom of the Explorer.  You can click this status 
field to turn the lock on or off. 

You can save feature filter definitions for later use and switch between them on the 
Explorer.

You must turn on the Feature Filter lock in order for a filter to be applied. 

File Tips 

You can double-click on a file name in the Open dialog box to immediately open it. 

The Project File (.rwk) is an ASCII file that you can edit.  It defines which files the 
software loads for a particular project. 

You can use the File > Import > Surface DEM command to load data from 7.5 minute 
topographic quadrangle files 

Surface Tips 

You can only empty the default surface -- never completely delete it. 

Surface points are displayed at their respective elevations in the drawing file unless 
you turn on the Planarize option and specify an elevation. 

You can add the points from a cross section surface to a DTM by using the 
Evaluation > Cross Section > Cross Section to Surface command. 

You can fit just the active surface (rather than all graphic entities) in a view by using 
the Surface > Fit Surface command. 

You can use the Surface > Design Surface > Drape Surface command to lay 
graphics on a surface.  This command copies the new draped element to a target 
layer/level and retains the original graphic data. 

You can compress a new surface formed by merging two previous surfaces.  Use the 
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You can see the changes made by using the Add Surface Point command by 
deleting the triangles and redisplaying them.  The points you added will be 
incorporated into your surface whether you change the graphic display or not. 

Surface > Utilities > Compress Surface command. 

If you experience problems merging two surfaces, you may have crossing breaklines 
in your drawing file.  See View Crossing Segments for details on how to locate and 
fix crossing breaklines. 

You can use the Label Contours command to enhance annotation of displayed 
contours. 

You can add new gridded points to a surface by using a surface that already contains 
data as the destination surface for forming a gridded model 

You can scale triangles as you display them if the Planarize option is off. 

You can scale a surface perimeter as you display it if the Planarize option is off. 

You must edit points in a plan view. 

You can remove breaklines and exterior boundaries from your surface file by using 
the Surface > Edit Surface > Delete Linear Feature command. 

You can track various surface and project information at the position of the cursor by 
using the Tools > Tracking command. 

Many surface editing commands also operate on native graphics.  Use the Locate 
lock to toggle between Locate Features and Locate Graphics modes. 

If you are operating on linear features only, it is useful to set up a filter which 
excludes random point features. This prevents them being located when you select a 
feature from the screen. 

The software has the ability to store feature data in the DTM without affecting the 
triangulation.  Use this for underground utilities, striping, etc. 

Random point features can be displayed with lines connecting the points, but will still 
be treated as random when triangulated. 

Linear DTM features have a point densification property which improves the definition 
of the surface without increasing the size of the DTM.  This is useful for features with 
long straight sections. 

There are two ways to represent a surface in cross sections.  If your model is well 
defined by longitudinal linear features, you can force the cross sections to recognise 
only the features, ignoring any triangle legs not along a feature. Select Surface > 
Surface Properties to choose how your surface will be represented. 

You can use Surface > Design Surface > Set Slope Along Feature to set the 
elevation of all the points of a feature to the same elevation.  Just set the target point 
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to the first point and set the elevation, then set the target point to the last point and 
set the elevation. 

When using Surface > Design Surface > Set Slope Along Feature command, the 
disabled fields will update with new values when valid values are put in the input 
fields.

When using the Surface > Edit Surface > Edit Feature Point command, you can edit 
multiple points of a single feature and only select the Apply button when you are 
done editing all the points. 

Using the "More" option on the Surface > Edit Surface > Edit Feature Point command 
allows you to move a point a precise distance, direction, and slope from either the 
point before or after it. 

To add points to the end of a feature, use the Surface > Design Surface > Place 
Feature command with the Append option turned on.  If you want to add points to the 
start of the feature, first use the Surface > Edit Surface > Reverse Feature Direction 
command to reverse the order of the points. 

The Surface > Edit Surface > Partial Delete and Break Feature commands honor the 
Point Snap lock. 

The Surface > Design Surface > Sloped Surface and Longitudinal Feature 
commands dynamically display the possible solutions.  You do not need to know on 
which side you want to place the results ahead of time. 

When locating a feature, the feature does not have to be displayed in the graphics 
file.

You can toggle the Locate lock between Locate Features and Locate Graphics while 
selecting elements during the Surface > Design Surface > Transverse Feature, 
Longitudinal Feature, and Sloped Surface commands without exiting the commands. 

When running Surface > Design Surface > Apply Decision Table, if you don’t specify 
a Final Intersection Name, the TC name from the final intersecting segment at will be 
used. 

Geometry Tips 

The last geometry project you created is the active project by default. 

The last geometry you created, whether it was a project, horizontal or vertical 
alignment, or superelevation, is the active geometry type by default. 

You can create an alignment as you define coordinate geometry points with the 
Traverse command.  Store the first two points as an alignment and then use the Add 
After option on the Traverse command. 

You can specify a distance for coordinate geometry commands by typing d1 2.  The 
software will use the distance between points 1 and 2 as the current distance. 
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You can specify a bearing or azimuth for coordinate geometry commands by typing 
a1 2.  The software will use the bearing between points 1 and 2 as the current 
bearing. 

You can use wild cards to specify multiple alignments or point names.  For example, 
lot* will select all point names that start with the letters lot.

You can indicate a curve to the left by entering a negative radius length. 

You can type bearings without the special characters.  For example, you can type 
s45 35 45E and the software will automatically convert it to S 45^35'45" E when 
you press the TAB key. 

Asymmetrical vertical curves are broken into two parabolic curves when exported to 
an ASCII file, and are therefore also imported as two curves from an ASCII file. 

The Curve Calculator computes a radius for you when you have two other pieces of 
curve information.  This is handy when setting or revising arcs. 

You can transform geometry projects from imperial to metric units by using the 
Geometry > Locate > Transform command.  You can transform surface data by using 
the Surface > Utilities > Transform Surface command. 

You must have a geometry project open before you can create geometry reports. 

The Point Snap lock and Write locks control the function of the Geometry > Inverse 
Direction command as well as many other commands. 

You can set an alignment point based on an existing alignment that is loaded in 
memory by using Station and Offset.  When in Add PI or Move PI, type 
so=station, offset, [(elevation, existing alignment name, 
geometry project name)].

You can display elements and on-alignment points by using the Geometry > View 
Geometry > Active Horizontal command.  You can display detailed annotation by 
using the Geometry > View Geometry > Horizontal Annotation command. 

You can import graphics to an alignment in your Geometry Project file. 

As you add new geometry to an alignment, the software assigns that alignment's 
style to the new elements. 

When using Tracking with Point Snap on, you can select only cogo points.  For 
general elevation and slope tracking along a surface, turn off the Point Snap lock. 

When selecting a station for a range with Point Snap on, you can select only cardinal 
points along an alignment.  With Point Snap off, you can select intermediate stations 
along an alignment. 

When tracking with Point Snap on, you can track only cardinal points along an 
alignment.  With Point Snap off, you can track intermediate stations along an 
alignment. 
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When choosing Block or Cell as the Symbol Type for points in the View Vertical 
Annotation command, the block or cell is defined by the setting in Geometry > View 
Geometry > Point Symbology 

Evaluation Tips 

A profile must be owned by the active horizontal alignment for profile annotation to 
work properly. 

Features added to profiles will display with the same exaggeration as the profile. 

You can transfer planimetric data to your cross sections and profiles by using the 
Evaluation > Profile > Add Feature to Profile and Evaluation > Cross Section > Place 
Feature in Cross Section commands. 

You can generate cross sections along any line or polyline by using the Evaluation > 
Cross Section > Create Cross Section command. 

You can create binary report files with Create Cross Section, End-Area Volumes and 
Roadway Modeler commands.  You can then generate text reports from these binary 
files using the Tools > Reports > General tab. 

When calculating End-Area volumes from cross sections, the InRoads family of 
products automatically draws the cut and fill areas at the same exaggeration as the 
cross sections.  However, the true area is used and annotated in the volume 
calculations.  Your CAD software calculates the area based on the exaggerated 
shape, not the true shape. 

When adding graphical elements to cross sections, make sure the active elevation is 
near the elevation at which the cross sections were plotted.  This will ensure the 
additions will display when using the Cross Section Viewer or Add Surface to Cross 
Section commands. 

Features can be placed in a cross section set at creation or added later by selecting 
the Evaluation > Cross Section > Update Cross Section command. 

You can control the symbology for each surface in a cross section set by setting the 
surface's Cross Section Symbology in Surface > Surface Properties. 

You can control the display characteristics of features in cross section sets using the 
Tools > Feature Style Manager. 

You can use the Evaluation > Cross Section > Update Cross Section command to 
refresh surfaces and features in existing cross section sets by selecting the Refresh 
option.  You can add surfaces and features to existing cross section sets by selecting 
the Display On option and you can remove surfaces and features from existing cross 
section sets by selecting the Display Off option. 

You can edit a feature directly in the Cross Section set instead of modifying the plan 
representation and updating the cross section set. 
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Features can be modified by 6 methods -- Offset, Elevation, Offset/Elevation, Delta 
Offset/Delta Elevation, Width/Slope from Left and Width/Slope from Right. 

Features can be placed directly in the cross section set at a desired offset/elevation. 

Features can be deleted from your DTM by identifying them in a cross section. 

Only the highlighted surfaces on the Profile Controls tab will be used to determine if 
the profile needs to shift when running the Evaluation > Plan and Profile Generator 
command. 

When running the Evaluation > Plan and Profile Generator command, turn Generate 
Sheets off and run Plan Only method until you have all the plan views at the desired 
locations.  Then use the Plan and Profile method in the Use Plan Views mode to 
create the associated Profile views. 

Modeler Tips 

Right-of-way definitions can be used only when the method of controlling the side 
slopes is cut-and-fill or material table. 

You can write your template points to the drawing file while processing a Modeler 
command.  Turn on the display Transition Control Lines toggle and the Write lock. 

The slopes of template segments are measured going away from the centerline.  Up 
is positive and down is negative. 

By default, the slopes of template segments are calculated from pivot to range when 
using the Superelevation command.  If the pivot is on the range point, a zero-percent 
slope is reported.  To prevent this, define the crown point on the template and then 
the slope will be calculated from the crown point to the range. 

More predictable feature names will be generated if unique Left and Right Prefixes 
are specified on the Modeler > Roadway Modeler > Advanced Page.  When unique 
prefixes are specified, all Features are prefixed.  If left blank, prefixes of L_ and R_ 
will be used only if there is a naming conflict. 

When adding features to an existing design surface, leave the Add Exterior Boundary 
option off and turn on the Create Cut and Fill Features option on the Modeler > 
Roadway Modeler command.  See the Reference Guide for how these features can 
be used to create an exterior boundary feature. 

When adding features to an existing design surface using Modeler > Roadway 
Modeler, setting the Modify mode for Duplicate Feature Names will modify existing 
features by removing existing feature points in the range of the current modeler run 
and replacing them with the new points. 

New features created by the Modeler > Roadway Modeler command will have a 
description indicating from which modeler run they were created.  On the first 
modeler run, the features will have description “Created by Roadway Modeler1”.  The 
next time it will be “Created by Roadway Modeler2”. 
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Tools

To see all settings on the Tools > Options > General tab, be sure to select each item 
in the Category list. 

You can create your own hot keys by selecting the Tools > Customize > Keyboard 
tab.

You can create your own macros by selecting the Tools > Customize > Macros tab. 

You can reset your toolbars and menus to their default settings by selecting Reset All 
on the Tools > Customize > Toolbars tab. 

You can do a Partial Export from the Tools > Customize > Export tab in order to save 
your current toolbars, hotkeys, macros, and menus while importing additional ones. 

A feature's style not only controls its symbology; it also controls whether it can be 
displayed in a 3-D/Plan view as well as in a cross section set.  It also controls the 
ability to annotate the feature in either environment.  To change a feature's style, 
select the Tools > Feature Style Manager command. 

General Interface Tips 

You can select multiple files in a list by clicking the first file in the list, pressing and 
holding the Shift key, then clicking the last file in the list. 

You can select random files in a list by pressing and holding the Ctrl key then clicking 
the files individually. 

You can get help on the active dialog box by clicking the Help button or by pressing 
the F1 key. 

You can add your own notes to the Help file.  Click Edit > Annotate from the Help 
window, and type your note.  The Help system will attach a paper clip containing your 
notes to the Help topic. 

You can search for any word or phrase in the online Help file.  Click the Find button 
on the Help window and follow the instructions on the dialog box. 

The green text in Help is more than decorative.  It indicates a jump to related 
information.

You can copy text from the Help topics.  Select the text you want to copy and press 
Ctrl + C.  Change focus to the document into which you want to paste the text and 
press Ctrl + V. 

You can create a customized list of frequently used Help topics.  Open the topic and 
click the Favorites tab.  Click the Add button to add a topic and create a customized 
list of help topics.  Once the topic is defined, select the topic from the list and click the 
Display button to easily display your frequently used topic information. 

You can set the On Top/Not on Top status of Help windows by selecting Options > 
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Keep Help on Top from the Help window and choosing an option. 

The small button with the target on it next to key-in/input fields allows you to select 
graphics or a coordinate location in the drawing. 

Feature Tags are non-graphic attributes that can be assigned to graphic data. 

The software supports many formats for keyed-in data.  See Key-Ins for more 
information.

You can add or subtract from an angle value while keying it in by adding a + or - and 
the amount to be added or subtracted.  The software will automatically do the math 
before sending the value to the command. 

You can manipulate graphics without changing the data files that are stored in 
memory.

If you want to run more than one InRoads product at the same time, select Tools > 
Application Add-Ins to turn on other InRoads products loaded on your workstation.  
The menus change to include commands for all products currently turned on. 

You can create an icon on your desktop for starting an InRoads product.  You can 
even specify that your InRoads product start in your project directory by default.  For 
the basic steps in configuring an icon, see Setting Up an Icon for Your InRoads 
Product. 

If you are using AutoCAD, the software assigns several APPIDS each time you start 
it.  If you should accidentally purge these APPIDS, simply exit and restart the 
software, and they will be reassigned automatically. 

Use the Feature Filter to control the features displayed in all commands. 

If you see many dithered features in the Features lists throughout the product, it 
means that the Feature's style is preventing it from being displayed via that 
command. 

You can use the Input button to select a feature if you do not know the feature name. 

Technical Support Tips 

You can keep yourself informed and on top of the latest information through the 
Internet.  Connect to Bentley Online at http://www.bentley.com.  See How to Reach 
Bentley for more details. 

You can find additional information on procedures and tips in the README.TXT file 
in the product directory. 


