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1 Introduction

In this chapter the basic InRoads functionality and interface will be discussed. The 
topics discussed include:

• InRoads Products

• Starting InRoads

• InRoads Interface

• Toolbars

• Dialog Boxes and Target Buttons

• Application Add-Ins

InRoads Products
The InRoads family of products are powerful civil engineering tools that facilitate 
workflow and enable free movement of projects between MicroStation and 
AutoCAD. Data can be exchanged between departments, clients or suppliers without 
translation issues.

The InRoads product line includes InRoads, InRoads Bridge, InRoads Site, InRoads 

Storm & Sanitary, InRoads Survey and InRail. These products run independently or 
simultaneously. 

The MicroStation Civil Extension is either a subset of InRoads or Geopak which 
allows MicroStation users to expand the features of MicroStation while 
complementing GEOPAK or InRoads workflows. The MicroStation Civil Extension is 
available at no additional cost to MicroStation Subscribers.

The following topics are intended to provide insight into concepts, functions and 
terminologies relating to the tools used to accomplish basic roadway design tasks. 
These topics provide a basic overview and will not describe all aspects of each tool 
or tool setting in extended detail. Additional information regarding dialog box settings 
and tool definitions is available in InRoads Help, which will be discussed later in this 
chapter.
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Starting InRoads

InRoads Setup 

InRoads is a window based program that interfaces directly with CAD platforms such 
as MicroStation and AutoCAD. InRoads provides a number of ways to change the 
startup configuration for specific project requirements. 

Selecting a CAD Platform 

Before InRoads can be started, a CAD platform must first be selected. To select the 
default CAD platform, select Start > Programs > Bentley Civil Engineering > Select 
CAD Platform.

Launching InRoads

You can launch InRoads using one of the following methods:

• Select Bentley > InRoads Group from the Windows Start menu, then select 
the InRoads item. 

• Double Click on the InRoads Shortcut created on your desktop

• If already in MicroStation you can launch InRoads by selecting Utilities > MDL 
Applications and selecting Civustmk.ma from the c:\Program 
Files\Bentley\Civil\Bin folder

• If already in AutoCAD you can launch InRoads by selecting CivACAD2004MK 
from the c:\Bentley\Program Files\Bentley\Civil\Bin folder. The actual name of 
the application file to load may vary slightly depending on what version is 
installed on your system. 
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Specifying the Default Directory 

Upon installation, the default location for opening files is the data directory of the 
product, typically C:\Program Files\Bentley\Civil \Data You can specify a different 
location for InRoads to look by first creating a shortcut on your desktop. Then right-
click on the shortcut and select Properties from the pop-up menu. In the target field 
of the Shorcut, key in the desired directory. 

InRoads Interface

InRoads Explorer

Once InRoads has been launched, the InRoads Explorer displays. The InRoads 
Explorer is the means by which InRoads design tools are accessed. Details related 
to design data that is loaded can be reviewed edited or processed. 

InRoads Explorer

The InRoads Explorer is divided into four major parts: Workspace bar, Feedback 
pane, Menu bar, and Status bar. Each part of the InRoads Explorer is described 
below.

Menu bar

 Workspace bar

Status bar

 Data Type buttons
 Scroll bar

Feedback panePop-up menu
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Workspace bar - The Workspace bar is the control center for all InRoads project 
data. The Data Type buttons along the bottom of the Workspace bar are used to 
select the type of project data displayed in the Workspace bar. The most common 
data types are Surfaces and Geometry. Depending on the project needs, however, 
additional data types (such as Survey, Typical Sections, Roadways, or Drainage) 
may be used.

The hierarchal view of the data shown in the Workspace bar has controls to view 
components of the data. For instance, selecting the plus sign adjacent to each 
surface displays the feature types contained in the surface.

The red box indicates the “active” data. Making data “active” is an important function 
in InRoads and will be discussed in a later section. 

Feedback pane - The Feedback pane displays details about the data selected in the 
Workspace bar. For example, when the Cogo Buffer is selected in the Workspace 
bar, all of the points and their coordinates in the Cogo Buffer are displayed in the 
Feedback pane.

Menu bar - The Menu bar contains menus for all of the tools available for the active 
InRoads modules. The InRoads software is composed of several modules including 
InRoads, InRoads Survey, InRoads Storm & Sanitary, InRoads Site, InRoads 
Bridge, and InRail. In addition, there are optional add-in components that can be 
activated as necessary. Therefore, the menus displayed will vary depending on 
which modules and add-in components are active. 

When using the InRoads module there are eight menus: File, Surface, Geometry, 
Modeler, Evaluation, Drafting, Tools and Help. Each main menu contains the viewing 
and editing commands related to them. For example, any commands related to 
editing or viewing a surface can be found on the Surface menu. Likewise, commands 
related to evaluating a model, such as Cross Sections or Profiles, are found on the 
Evaluation menu. 

Many menus are shared across multiple InRoads modules. For example, when using 
InRoads Survey, the File, Surface, Geometry, Evaluation, Tools, and Help menus 
are still present. However, some menu items that do not pertain to Surveying are not 
shown and some additional menu choices are added.
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Status Bar - The Status bar is the location where InRoads messages, prompts, and 
errors are displayed. If InRoads requires that something be located or identified 
graphically, prompts display on the MicroStation Status Bar. 

Scroll bars - When resizing the InRoads Explorer, some data may not be visible 
either in the Workspace bar or Feedback pane. Scroll bars enable viewing of 
additional data. 

Pop-up menus - The InRoads Explorer enables access to functions by way of 
context sensitive Pop-up menus. These menus display when clicking the right 
mouse button anywhere in the InRoads Explorer. Menu options may differ 
depending on the item selected.

TIP: Right-click on the data type in the Workspace bar to easily select a different 
data type.
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Toolbars
Commands can be accessed from the Menu bar or through toolbars. InRoads comes 
with built-in toolbars that can be docked in the InRoads Explorer. To open InRoads 
toolbars, select Tools > Customize from the InRoads menu. On the Toolbars tab of 
the Customize dialog box, select the check box next to the toolbar name to be 
displayed. 

Opening the Design Surface toolbox from the Customize dialog box
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Dialog Boxes
When a tool is selected using a tool button or from the InRoads menu, a dialog box 
will likely display from which more options relating to the command can be specified. 
The following example identifies the controls and functions that are common to many 
InRoads dialog boxes. 

Sample dialog box

Tabs - The tabs are used to access additional categories of settings related to each 
tool. 

Radio toggle - A group of options in which only one can be selected have radio 
toggles. Selecting an option deselects all other options in that group. 

Text Entry field - A Text Entry field is used to enter text. In most Text Entry fields, 
wildcard characters can be used. For example, to select all alignments, an * can be 
entered. To select all alignments that begin with the letter b, enter b*. Another 
method for entering data in a text entry field is to use the Graphic Select or Target 
button.

Graphic Select button - Also called the Target button, the Graphic Select button is 
used to select location data from the CAD file such as a Cogo point, surface feature, 

Radio toggle

Text Entry field

Tabs

On/Off toggle boxes

Graphic Select button
Select field

Button
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or an alignment. The Graphic Select button can also be used to pick distances, 
angles and bearings. 

Select fields - Select fields have a list of more than one item from which to choose. 
The arrow next to the box indicates that there are other possible selections. 

Toggle boxes - Toggle boxes can be independently enabled or disabled. If a toggle 
is light gray in color, the toggle is deactivated and unavailable as a means of 
selection. Toggle boxes become deactivated when their functionality is not relevant 
based on another setting.

Buttons - Buttons generally appear at the bottom or right side of a dialog box and are 
used to either process a command, save/recall settings or preferences, or close the 
dialog box. Depending on the tool, an Apply and/or OK button may be present. The 
function of these buttons is to:

Apply – Process the dialog box contents

OK – Process the dialog box contents and close the dialog box

Each dialog box also typically includes a Help button and may include other buttons 
to access additional functionality.

Application Add-Ins
Application Add-Ins are used to add other tools and applications to the InRoads 
interface. Depending on the tool being added, new items appear in existing InRoads 
menus, or a new item is inserted in the main InRoads menu bar. To access the 
Application Add-Ins dialog box, select Tools > Application Add-Ins from the InRoads 
menu.

Using the Application Add-Ins tool, multiple InRoads modules can be run 
simultaneously in one interface. For instance, if InRoads is running and Storm & 
Sanitary is also needed, simply select the item from the list in the Application Add-ins 
dialog box. A new menu item called Drainage appears on the main InRoads menu 
bar.

A valid license is required for all InRoads modules activated through the Application 
Add-Ins tool.
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To unload a menu item, simply uncheck the item that you wish to unload from the 
list, and it will no longer be available in the menu. 

Application Add-ins dialog box

The Command area at the bottom of the Application Add-Ins dialog box shows the 
InRoads modules (InRoads, InRoads Survey, InRoads Storm & Sanitary, etc.) that 
include licensing for the highlighted add-in. 

If an X appears under an InRoads module icon, the selected add-in is licensed for 
that module. For instance, as shown in the illustration above, the Active Project 
Settings Add-In is available for all the InRoads modules. To the left of the icons, the 
Command column indicates where the add-in will appear in the InRoads menu.
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2 File Operations

In this Chapter topics related to InRoads file operations will be discussed. The topics 
discussed include:

• InRoads File Types

• File Operations

• Saving Data

• InRoads Options

InRoads File Types
The InRoads road design process uses several different file types. Understanding 
the purpose of each is important to understanding how InRoads functions. Below is a 
list of the primary file types used in the road design process. Additional file types are 
introduced when other InRoads modules are invoked.

Project Data Files

Surface File (.dtm) – Stores point, breakline, boundary, and triangle data defining 
existing ground and design surfaces. Multiple surface files may be open at the same 
time. 

Geometry File (.alg) – Stores geometric data such as horizontal and vertical 
alignments, COGO points, and superelevation definitions. Multiple geometry files 
may be open for editing at the same time. 

Template Library (.itl) – Stores templates made up of components. The components 
of a template can be open or closed. A simple closed component is used typically to 
represent a section of pavement. An end condition is a special open-shaped 
component which define how side slopes are designed. Only one template library 
may be open for editing at a given time. 

Roadway Design File (.ird) – Stores information defining which templates are applied 
at which station along an alignment. Only one roadway design file may be open for 
editing at a given time. 

XML Data (.xml) – Stores the bulk data required to build InRoads reports. See the 
Style Sheet files below for additional information.
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Group Storage Files

Project File (.rwk) – An easy method to load and save a number of InRoads data files 
in a single operation. No InRoads data is stored in this file, it is just an ASCII file that 
lists the other InRoads data files (.ini, .alg, .dtm, .tml, .rwl) used for a project.

Resource Files

InRoads Preference files control how data will appear when it is displayed in the 
CAD file. Preference files store data related settings and dialog box settings for later 
retrieval. Listed below are just a few of the parameters that are stored in preference 
files. 

• How a surface will appear when viewed in plan profile and cross section.

• How geometry, such as alignments and points, will appear when viewed in 
plan and profile. 

• How Profile and Cross Section grid spacing, text labels and axis symbology 
will appear. 

• Parameters and values that have been entered and selected in dialog box 
fields, which can be saved for later recall (for example, annotation related 
parameters such as viewing stationing and curve data). 

• Numerous settings are saved to the InRoads preference file and provide a 
powerful means by which to implement project specific and company 
standards. 

Preference (.xin) – Stores the preferences accessible on each dialog box, feature 
style definitions, and named symbology definitions. Also stores preferences for 
geometric (point, line, curve, and spiral) elements. These style definitions are used 
when the geometric elements are displayed in the graphics file.

Drafting Notes (.dft) – Stores note definitions created with the various note 
placement tools found on the Drafting menu.

Style Sheets (.xsl) – A definition file that formats data in an .xml file into a finished 
report.
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File Operations
All InRoads data is stored in external files. Files that are “open” in InRoads for editing 
are stored in virtual memory. Graphical representations of the data are viewed using 
the MicroStation. Using MicroStation tools to modify graphical representations of 
InRoads data (such as contours or triangles) has no effect on the InRoads data. 
Likewise, using the MicroStation delete tool to remove graphics does not affect the 
InRoads data. For example, if the graphics that represent a surface (such as 
contours or triangles) are deleted, the InRoads .dtm file is not modified.

Opening Files

InRoads files are opened by selecting File > Open from the InRoads menu. This 
“loads” the file to virtual memory and makes it available for modification and 
evaluation. 

When an InRoads data file is open, it is visible in the Workspace bar of the InRoads 
Explorer. In cases where more than one type of data can be loaded, a red box 
appears around the icon representing the “Active” file. Operations are performed on 
the active file.

For instance, when using the Triangulate Surface tool, there is a list box to choose 
the appropriate surface to triangulate. Surfaces that are currently loaded are 
available to choose. Unless a different surface is selected, the “Active” surface 
automatically displays as “selected” in the list. 

Workspace bar (from InRoads Explorer) and Triangulate Surface dialog box

In the illustration above, three surfaces are loaded in InRoads: Default, and Existing. 
The active surface is Existing. To change the active surface, right-click on the 
surface in the Workspace bar and select Set Active from the Pop-up menu. 
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Creating New Files

New InRoads files can be created by selecting File > New from the InRoads menu. In 
the New dialog box, use the tabs to select the data type to create. Next, key in the 
desired name, complete the other parameters, and select the Apply button. Data 
types for all currently loaded InRoads modules will be present. The data appears in 
the Workspace bar of the InRoads Explorer. This means that this data is currently in 
virtual memory, or “loaded” in InRoads.

This tool does not create or store the InRoads data to the computer hard drive; it only 
exists in virtual (or temporary) memory. Unless saved as described below, the 
InRoads data will be lost when InRoads is closed.

New dialog box

When InRoads starts, a blank data file named “default” is loaded for each data type. 
The “default” data files enable immediate use of InRoads without first creating data 
files using the New tool. The best practice, however, is to use the New tool to create 
the data type with a meaningful Name and Description.

Saving Files 

InRoads data files are not saved automatically. Any data created or changed is 
stored in virtual memory until it is saved to disk.

It is important to note that when an InRoads file is created, the name specified is the 
internal name of the file, which will appear in the Workspace bar. When the file is 
saved to disk, the name used is the external name. This name, along with the file 
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extension, is shown in the Windows Explorer or when the File > Open option is 
selected. The internal and external file name can be different, but it is recommended 
that they be the same whenever practical. 

To save an InRoads file to disk that has not previously been saved, use the following 
procedure.

1 Select File > Save As from the InRoads menu.

2 Select the appropriate file type from the Save as type field.

3 Enter the File Name to create.

4 Click Save.

Save As dialog box

Previously Saved Files

There are two methods to resave previously saved InRoads data file.

• Set the InRoads Data File to save as the Active file for that data type. 
Select the File > Save > {File Type} menu item. 

• Right-click on the data file to be saved in the Workspace bar and select the 
Save option. 

Using either method, a confirmation message showing the path and file saved 
displays in the InRoads Status bar.
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Deleting InRoads Files

To remove a file from the InRoads Explorer, right-click on the file name in the 
Workspace bar, then select Delete from the Pop-up menu. This removes the data 
from virtual memory. If the file has been previously saved to disk the InRoads data is 
preserved in the disk file. If the InRoads data has not been saved to disk, the data is 
lost.

An alert box confirming the deletion of the InRoads data is displayed prior to the 
removal of the data.

Confirmation dialog box

Closing InRoads Files

A file can also be removed from the InRoads explorer by selecting File > Close from 
the InRoads explorer menu. If the file has been previously saved to disk the InRoads 
data is preserved in the disk file. If the InRoads data has not been saved to disk, the 
data is lost. Each InRoads data file can be closed separately or all the InRoads data 
files can be closed at one time by selecting File > Close > All. 

An alert box confirming the closure of the InRoads data is displayed prior to the 
removal of the data.

Multiple configurations of Project Defaults can be created and saved under different 
names for later retrieval. The Project Defaults tool is run by selecting File > Project 
Defaults.

The Set Project Defaults dialog is used to set up the initial location for loading/saving 
all files for a project. The path for all file types can be set to the same location or 
separate paths can be set for each file types.
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Exiting InRoads
To exit InRoads select File > Exit from the InRoads menu. If data that is currently 
loaded in InRoads that has not been saved to disk an alert appears allowing the data 
to be saved. Click Yes to save only the InRoads data shown in the alert. Click Yes to 
All to save all currently loaded InRoads data. If the file has not been previously 
saved to disk, the Save As dialog box appears to specify the name and location to 
save the file. 

InRoads question dialog box

Another method to exit InRoads is by selecting the “Close” icon indicated by an “X” in 
the top right corner of the InRoads Explorer. When this method is used to exit 
InRoads, an alert dialog box confirming the intent to exit InRoads appears. 

InRoads question dialog box
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Saving Data
When an InRoads data file is created or loaded from disk, it resides in the computer’s 
memory. Data written to the data file while using InRoads is not saved to the hard 
drive. That data is held in memory until a command is executed to save the data to 
disk. Because the data resides in two possible locations, disk and memory, there are 
two file names. 

The Internal file name is the name given to a data type when it is created in InRoads 
with the File > New tool. This is the name that appears in the InRoads dialog boxes.

The External file name is the name given to the data type when it is stored on the 
disk. This is the file that has the extensions defined above such as .alg for geometry 
files.

Why does InRoads have two file names? Previous versions of Windows only 
supported file names with a maximum of 8 characters plus a 3 character extension. 
This is known as 8.3 file format. For most, eight letters is not enough to describe the 
files purpose. InRoads added the independent Internal file to overcome this 
limitation.

Although it is not required, it is recommended to use the same name for both the 
Internal and the External file names.

InRoads data files are saved using the File > Save As tool. When invoked, the Save 
As dialog box appears. Select the type of file to save from the Save as type pick list. 
Once the type is selected, choose the Internal file name to save from the Active pick 
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list. The File Name field is automatically populated with the Internal file name plus 
the appropriate file extention.

The Save As dialog box

Right-click on the Internal file name of any data type in the InRoads Explorer to open 
a shortcut menu that has a link to the Save As tool.
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Options
General InRoads Parameters are set using the Options tool (Tools > Options). The 
Options dialog box has multiple tabs that can be used to modify such settings as 
Units, Formats, Scales, Precision (number of decimal places), as well as other 
general settings that affect the look and feel of InRoads dialog boxes and tools. 
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EXERCISE: LOADING INROADS DATA

1 Double Click on the InRoads Civil Extension Icon

2 The MicroStation Manager dialog box appears.

3 Set the directory to C:\BE Data\{Course #}\Data 

Where {Course #} is the folder specified by your instructor. 

4 Select the file Workingfile.dgn

5 Click OK to open the file. 

6 MicroStation and InRoads are activated.
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Loading the Preference File

When InRoads starts, two required files are a preference file and a geometry style 
file. If a Project Default is not set or if the file listed in the Project Default is no longer 
located in the directory specified, InRoads will load the file 

C:\Program Files\Bentely\Civil\Data\civil.xin

1 In the InRoads Explorer select File > Open from InRoads Menu

2 Set the Files of type option to Preferences (*.xin)

3 Load the file Civil.xin from the C:\BE Data\{Course #}\Data folder.

4 In the File > Open dialog, select the file Civil.xin 

Loading Survey Data DTM Surface

The existing surfaces provided by the survey group also need to be loaded. 

1 Using the File > Open tool, load the file Existing.dtm from the C:\BE 
Data\{Course #}\Data folder.

The preference file and one surface have been loaded into InRoads.

2 Select File > Close > Surfaces from the InRoads menu. 

3 In the Close All Surfaces prompt, click Yes. 
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3 Viewing Surfaces

In this Chapter topics related to viewing InRoads Surfaces will be discussed. The 
topics discussed include:

• Introduction to locks

• Surface Overview

• The InRoads DTM

• Surface Files

• Surface Properties

• View Surface Tools
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Introduction to Locks
InRoads locks control how InRoads tools behave when viewing, selecting or 
evaluating data. Because locks affect nearly every tool in InRoads, it is important to 
understand how locks work. Below is a brief introduction to the locks.

InRoads has two basic types of locks. There are locks that have an enabled/disabled 
state. There are also locks that switch between two or three different modes, but are 
always active. 

Locks Toolbar

Locks are accessed by selecting Tools > Locks from the InRoads menu. However, 
since the status or mode of the locks is frequently adjusted while running InRoads, 
the best practice is to display the Locks toolbar for easy access to the locks. The 
Locks toolbar is displayed by selecting Tools > Locks > Toolbar.

Locks toolbar 

A lock is enabled when the button appears depressed. Visually, the button will have 
a lighter background when depressed or enabled. In the above example, the Style, 
Write, and Station locks are enabled. Three of the locks cannot be enabled or 
disabled. Instead, the Pen/Pencil, Locate, and Snap locks are always enabled, but 
can be togged between multiple modes. The graphic icon of the lock changes when 
it is set to a different mode.

Locks

Write Lock  – The Write lock controls how InRoads generates graphics. There 
are two modes for this lock; enabled (display and write) or disabled (display-only). 

Enabled - Graphics created by the InRoads tools are written to the CAD file. The 
view of the graphics is modified using the CAD viewing tools such as Zoom and 
Window. The graphics remain in the CAD file until deleted using the CAD Delete 
command or an InRoads tool to regenerate the graphics (see Pen/Pencil lock).

Disabled - Graphics generated by InRoads are temporary. They appear in the CAD 
file in a display-only mode. That is, the generated graphics display, but are not 
written to the CAD file. Using any of the CAD viewing tools removes the graphics 
from the display because the elements have not been written to the drawing file. 
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The display-only mode is useful for viewing large amounts of data and then quickly 
removing that data from the screen. Since the display-only mode does not write 
graphics to the CAD file, this mode also keeps the size of the CAD files smaller.

An easy way to determine if the Write lock is enabled is to look at the Pen/Pencil and 
the Delete Ink locks that are just to the left of the Write lock on the toolbar. When the 
Write lock is disabled, the Pen/Pencil and Delete Ink locks display as grey toned. 
When the Write lock is enabled, the Pen/Pencil and Delete Ink locks display in color.

Pen/Pencil Lock   – The Pencil/Pen lock controls what happens when 
graphics are redisplayed from InRoads. For example, when surface or geometry 
graphics are redisplayed, the setting of this lock determines if the previously 
displayed graphics is deleted prior to creating the new graphics.

The Pencil/Pen lock is only available when the Write lock is enabled. Also, the 
Pencil/Pen lock only applies to plan display. It does not apply to cross sections or 
profiles. There are two modes for this lock; Pen mode or Pencil mode.

Pen  – Graphics created in the CAD file are permanent and will not be deleted the 
next time InRoads is used to draw the same graphic. This is analogous to drawing in 
“ink” on a paper whereby the ink is not typically deleted when new graphics are 
added.

Pencil  – Graphics created in the CAD file are permanent but will automatically be 
deleted the next time INRoads is used to draw the same graphics. This is analogous 
to drawing with a pencil on paper whereby the pencil is easily removed when new 
graphics are added.

For example, consider a workflow where a single alignment is revised and displayed 
numerous times.

1 Lock is set to Pen mode.

2 Alignment is displayed.

3 Alignment is revised.

4 Lock is set to Pencil mode.

5 Alignment is displayed second time.

Both the original and the new alignment display exist in the CAD file. Even though 
the current mode is Pencil, this has no impact on the alignment drawn in step 2. The 
alignment graphics are controlled by the setting of the lock when those graphics 
were created and thus are Pen or “ink” graphics, which are not deleted automatically.
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6 Alignment is revised.

7 Alignment is displayed a third time.

8 The original alignment drawing in step 2 and the new alignment drawn in step 7 
are both displayed in the CAD file. The alignment drawn in step 5 is automatically 
deleted before the new alignment is drawn because the lock was set to Pencil 
mode when the second alignment was drawn.

Most InRoads users use the Pencil mode most of the time. Use of the Pen mode is 
limited to special situations.

Delete Ink Lock  – The Delete Ink lock controls whether graphics displayed in 
Pen mode are deleted when new graphics are drawn. This lock affects the behavior 
of the Pen/Pencil lock when set to Pen mode. There are two modes for this lock: 
enabled or disabled. 

Enabled – Graphics drawn in “ink” using Pen mode are automatically deleted when 
new graphics are drawn. In other words, when this lock in enabled, graphics drawn 
in Pen mode behave the same as graphics drawn in Pencil mode.

Disabled – Graphics drawn in “ink” using the Pen mode are not deleted when new 
graphics are drawn. InRoads operates as described in the Pen/Pencil lock section.

Locate Lock   – The Locate lock determines whether to snap to graphics 
displayed in the CAD file or to snap to the position occupied by an InRoads feature in 
the active surface when a target button is used to specify a position in the graphics 
file. Target buttons are found throughout the interface. Each button is indicated by 
the crosshair icon.

There are two modes for this lock: Locate Graphics or Locate Feature. 

Locate Graphics  – This seeks the nearest displayed graphics.

Locate Feature  – This seeks the position of the nearest feature in the active 
surface. The feature does not need to be displayed graphically to be located and will 
be located if it exists in the DTM.

Snap Lock    – The Snap lock controls how InRoads snaps to geometry 
points or elements in the active geometry project when a target button is used to 
specify a position in the graphics file. Target buttons are found throughout the 
interface. Each button is indicated by the crosshair icon.
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There are three modes for this lock: No Snap, Point Snap, or Element Snap.

Toggling on the Point icon (icon to far left) enables snapping to geometry points. 
Toggling on the Element icon (middle Icon) enables snapping to geometry elements 
(Line, Arc, Spiral). Toggling on the None icon (icon to the right), indicates that 
InRoads will not snap to geometry points or geometry elements. 

No Snap  – InRoads does not try to locate the nearest geometry point or element. 
The graphically selected coordinate or element is selected.

Point Snap  – This enables users to snap to a point in the active geometry. Use 
this lock to aid the placement process of geometry elements. For example, when a 
target button in a dialog box is selected followed by clicking in the CAD file, InRoads 
will locate the closest geometry point to the graphic location selected. The 
coordinates of the closest geometry point, not the graphic location, are retuned. The 
geometry point does not need to be displayed graphically to be located. 

Element Snap  – This enables users to snap to a geometry element (line, arc, 
spiral) in the geometry project. Use this lock to aid in using the direction, distance, 
length, radius, and/or angle of an existing geometry element to design a new 
element. The software snaps to the element nearest the data point placed in the 
CAD file.

Station Lock  – The Station lock controls how InRoads determines station 
intervals when a horizontal alignment begins at an odd-numbered station. This lock 
applies to InRoads tools such as generating cross sections, running the Roadway 
Modeler, or generating station based reports.

There are two modes for this lock: enabled or disabled. 

Enabled – If the first station is an odd-numbered station, the software forces all 
subsequent stations to even-numbered stations. For example, if the first station is 
2+38 and the station interval is defined as 50, the software performs the command 
action at stations 2+38, 2+50, 3+00, 3+50, ....

Disabled – The software does not force stations to even-numbered stations if the first 
station is an odd-numbered station. For example, if the first station is 2+38 and the 
station interval is defined as 50, the software performs the command action at 
stations 2+38, 2+88, 3+38, 3+88, ....

Report Lock  – The Report lock controls whether or not the command displays 
output in a dialog box as command calculations are performed. 

There are two modes for this lock: enabled or disabled. 
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Enabled – The command processes, stores results and display the results in an 
output dialog box.

Disabled – The command processes and stores results without displaying them in an 
output dialog box.

Feature Filter Lock  – The Feature Filter lock provides the ability to limit or filter 
the InRoads Surface and/or InRoads Survey features affected by InRoads tools. For 
example, a feature filter can be used to limit the surface features available for display 
and manipulation to only those that define pavement edges. Limiting the available or 
active features makes it easier to process just the desired data.

This lock works in conjunction with the Feature Selection Filter (Surface > Feature > 
Feature Selection Filter) for surfaces, and the Survey Feature Filter (Survey > Survey 
Feature Filter) for InRoads survey data. These tools are covered in detail in later 
chapters that focus on the respective functions.

There are two modes for this lock: enabled or disabled.

Enabled – This applies the active Feature Selection Filter and Survey Feature Filter. 
Only those features that satisfy the filters are available for processing and display.

Disabled – This ignores the active Feature Selection Filter and Survey Feature Filter. 
All features in the active surface or survey Fieldbook are available for processing 
and display.

Style Lock  – The Style lock controls where InRoads reads the display 
preferences for the View Surface and Annotate Cross Section tools. The effect of the 
Style lock is different for each of the tools as described below. For both sets of tools, 
the lock has two modes: enabled or disabled.

View Surface Tools

The View Surface tools such as parameters, triangles and contours use the Style lock 
to determine if the Tools dialog box is displayed.

Enabled – No dialog box appears for the selected tool. InRoads determines the 
symbology to use to create the graphics by searching in the following order:

If the active surface has a named symbology preference specified in the Surface 
Properties dialog box (Surface > Surface Properties) and the View Surface tool has a 
saved preference of the same name, the symbology definitions in the saved 
preference are used.

If the View Surface tool has a saved preference matching the name of the preferred 
preference in the options (Tools > Options), it is used.
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The default saved preference for the View Surface tool is used.

Disabled – A dialog box for the selected tool appears when it is activated. The 
symbology for all graphics created by the tool is defined in the dialog box.

Annotate Cross Section Tools

Enabled – The symbology for the point, segment, and feature annotation is taken 
from the named symbology specified in the Surface Properties dialog box (Surface > 
Surface Properties).

Disabled – The symbology is taken from the feature style associated with each 
feature in the surface. Because each feature can have a unique feature style, it is 
possible for the annotation for each feature to be displayed with different 
symbology.The InRoads road design process uses several different file types. 
Understanding the purpose of each is important to understanding how InRoads 
functions. Below is a list of the primary file types used in the road design process. 
Additional file types are introduced when other InRoads modules are invoked.
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Surface Overview

Surface vs. Digital Terrain Model

InRoads uses the terms surface and digital terrain model interchangeably. There is 
no difference between the two. Both terms refer to a triangulated model representing 
a physical surface such as existing ground or proposed pavement.

Current versions of InRoads software typically use the term surface instead of digital 
terrain model or DTM. However, many other software applications refer to their 
models as digital terrain models. Therefore, both terms are used interchangeably.

Digital Terrain Model Overview

What is a Digital Terrain Model?

A digital terrain model (DTM) is an electronic approximation of the ground surface for 
a given area. Stated another way, it is a database of coordinates (often linked 
together into line strings or shapes) that represent real world objects. 

Why is a DTM an approximation and not an accurate model? To find this answer, 
first consider how many points are on a single grain of sand. The answer is an 
infinite number, assuming the points are infinitely small. To physically or 
electronically model a grain of sand, it is necessary to define the size of point used in 
the model. Based on the point size, sufficient sampling of the grain of sand can be 
made to define an approximate model of the grain of sand. However, the model can 
always be more accurate by defining a smaller point size.

Creating a DTM is very similar to modeling a grain of sand, just on a bigger scale. 
The DTM is defined by a series of points, just like the model of the grain of sand. 
Understanding the relationship between the DTM point definitions and accuracy of 
the DTM is the key to understanding how to create and work with accurate DTMs.



© 2005-2006 Bentley Systems, Incorporated 35

2006 BE Conference
Introduction to InRoads Fundamentals

The InRoads DTM
Many different software packages use DTMs to store terrain data and most do it in a 
similar fashion. Although the algorithm used to triangulate the surface may vary, the 
basic definition is similar using points, line strings, and shapes.

Some civil design tools use a Triangulated Irregular Network (TIN) as their DTM 
model. While the TIN model provides an accurate terrain model, it is limited in its 
usage beyond the model. The coordinate points, line strings, and shapes are loaded 
into the DTM and triangulated. However, once loaded, this DTM does not store any 
information about the origin or purpose of each coordinate. For example, the DTM 
cannot distinguish between a line string representing a curb and a line string 
representing a fence. Since the DTM cannot tell one line string from another, the 
DTM cannot graphically display the individual DTM elements symbolized to 
represent the purpose of the element.

However, the InRoads DTM is different. It is a feature based DTM. A feature based 
DTM not only stores the coordinate data, it stores feature data (structure and 
appearance) with each element stored in the DTM. Since the feature data is included 
with the elements in the DTM, each element is evaluated or displayed using 
appropriate symbology. For example, when the DTM features are displayed, a water 
line will look different from an edge of pavement or a curb line.
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The InRoads DTM also stores data that does not contribute to the terrain surface, 
but is valuable to the design process. For example, the location of a culvert, 
waterline, or guardrail can be stored in the DTM even though these elements should 
not be included in the surface model. Since the DTM stores the true three-imensional 
location of all points, utility or planimetric data is also stored in its true three-
dimensional location.

There are many benefits to storing data in the DTM that does not contribute to the 
terrain surface. First, any data in the DTM can be displayed in a plan view, profile 
view or cross section view. Therefore, it is very simple to show the location of a 
waterline or guardrail in the plan view, as well as on the profiles and cross sections if 
the data is included in the DTM. Another use of including the data in the DTM is for 
design decisions. For example, if the right-of-way line is stored in the DTM, the 
roadway modeler can make decisions to determine the best side slope so that the 
toe of the slope does not fall outside of the right-of-way.
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What is a Feature?

In InRoads, a feature defines the structure and appearance of elements. 

Which elements? In InRoads, features relate to elements stored within a DTM and to 
survey data when using InRoads Survey. Since the survey data is a common source 
of the DTM, the two components are closely related.

Structure – The structure component of the feature defines how the points behave 
and relate to one another. Using a feature, points with the same characteristics and 
purpose are grouped to electronically replicate real world objects. For example, 
consider a collection of survey points collected along the flow line and the back of a 
curb and gutter section. If each point is independent of each other point, the resulting 
DTM may not accurately model the curb face because the triangulation routine does 
not understand how the points relate to one another. However, when the points are 
grouped as a feature, the points more accurately model the curb face by defining a 
line string along the flow line and another line string along the back of the curb.

Appearance – The appearance component of the feature defines the symbology 
(color, weight, and so on) used to display the coordinate points. If required per the 
structure component of the definition, the symbology of lines connecting the 
coordinate points is also defined by the feature.

Other examples of features are the edge of a roadway or the bottom of a ditch. 
These features represent either the existing or the proposed roadway. These 
examples of features are all linear connected features (flow line of a gutter or edge of 
a roadway). However, features can also contain related points that are not linearly 
connected. For example, all trees or random elevation shots on a project can be 
collected into a single feature. Although each tree is its own object and is 
represented individually in the drawings as a cell, the trees are all grouped into a 
single feature in the DTM for easier tracking and management of the data.

InRoads features are at the core of virtually every InRoads process from importing 
survey data, through design, cross sections, profiles, and reporting. Features are the 
backbone of the InRoads DTM.
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InRoads Feature Terminology

InRoads and InRoads Survey use the term “feature” to refer to different components 
of the software. Below are brief definitions of feature as it applies to different uses 
that will be encountered when using InRoads.

Survey Feature – Survey features define how elements appear in the graphics file 
when they are imported from raw data sources, such as data collectors, and 
processed with InRoads Survey. 

In addition to the appearance definition, the survey feature also contains parameters 
about the contents and purpose of the survey data. Examples are how a point should 
be connected to previous points and which codes a surveyor uses to collect a point 
that InRoads will interpret as this feature. 

Survey features are defined in a Survey Feature Table file which has a default 
extension of .fwf.

Feature Code – Feature code is the code a surveyor enters into a data collector to 
identify a point. The feature code is matched to the survey feature name when the 
survey data is imported using InRoads Survey.

Feature – InRoads uses the term feature to refer to the contents of a DTM. Every 
coordinate in a DTM is part of a feature. The features within the DTM define how 
each point behaves and how it influences the triangulated model resulting from the 
DTM. The DTM feature indirectly defines the appearance of the graphics by linking 
to a feature style.

Features are stored in the Surface or DTM file which has a default extension of .dtm.

Feature Style – Feature styles define how a point or a series of points are displayed 
in the graphics file. For example, whether the feature displays in plan view, profile 
view, or cross section view. The feature style links to a named symbology definition 
that defines the appearance of the graphics.

Feature styles and named symbology are both stored in the InRoads Preference file. 
This default name for this file is civil.ini.

Feature Type – The feature type defines the structure of the feature which can be 
individual points, linear or a closed area. This definition controls how features affect 
the triangulated model.
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The following illustration shows the relationship of InRoads features and the 
associated feature preferences in InRoads Survey and InRoads software.

Relationship between InRoads features

The illustration shows two distinctly separate uses of Features within the InRoads 
software. 
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Feature Types

A common component of Survey features and DTM features is the feature type or 
point type the feature represents (InRoads uses both names interchangeably). A 
feature defines the structure of the coordinate points that belong to the feature. 
Ultimately, the coordinate points are used to create a DTM. The feature type 
specifies how the coordinate points are interpreted and related to each other within 
the DTM. InRoads supports five point types: Random, Breakline, Contour, Interior 
Boundary, Exterior Boundary, and Do Not Triangulate.

Random Points – Random points, also called spot points, represent non-uniformly 
spaced points that have no directly relationship to other points. When a triangle 
model is created from random points, the DTM system determines how to connect 
the points. Triangulating random points typically results in a less accurate model 
than one created using breakline point types. Random points are typically used to 
supplement breaklines.

Random points triangulated

Breakline Points – Breakline points represent a linear discontinuity in a surface such 
as a ridge, ditch, edge of pavement, or curb. The breakline feature type specifies that 
all points in the feature are connected as a linear segment. When the DTM model is 
created, the triangles are formed so that no triangle crosses any breakline segment. 
Therefore, the breakline holds a linear relationship that might otherwise be lost 
during triangulation.
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In the following illustration, the random points are replaced by breaklines passing 
through the same locations as the random points. The resulting triangles more 
accurately model the linear relationship of this segment of a roadway.

Breakline points triangulated

Contour Points – Contour points behave exactly the same as breaklines. Contour 
points are special breaklines where all of the points in each contour line are at the 
same elevation.

Interior Boundary Points – Interior boundary points represent undefined areas in a 
DTM. For example, the footprint of a building or body of water is specified as an 
interior boundary. No triangles are created inside the interior boundary. The interior 
boundary must be a closed shape. A DTM can have more than one interior 
boundary, but they must not overlap.

Interior Boundary points triangulated

Exterior Boundary Points – Exterior boundary points represent the outer extent of the 
DTM. No triangles can exist outside of the exterior boundary. The exterior boundary 
must be a closed shape. Only one exterior boundary can exist in a DTM.
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Do Not Triangulate – Sometimes it is desirable to include points in a DTM that do not 
influence the surface model. For example, underground utilities and other 
planimetrics can be included in the DTM even though they do not contribute to the 
surface model.

Why include points in the DTM that do not contribute to the surface model?

InRoads can display any feature in the DTM in plan, profile, or cross section views. 
Therefore, including planimetric features such as utilities and fences in the DTM 
allows those elements to be easily shown on cross sections and profile views as well 
as in the plan view display.
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How Features are Defined

InRoads uses the term feature to describe an element in a DTM file. Every element 
in the DTM belongs to one and only one feature. A feature is a named set of 
coordinate points in a DTM. By itself, a coordinate point is just that, a single location 
in space unrelated to all other points. However, when a set of related points is 
grouped into a feature the result has far more meaning than the points themselves. 

The grouping defines which points to connect together, the linear relationship of the 
points, and the order of the points. Most importantly, the feature identifies the 
purpose (structure) and graphical display (appearance) of the points.

Although the feature is stored in the DTM, not all of the feature parameters are 
stored in the DTM. The feature parameters are stored in both the DTM and the 
civil.ini file. The feature parameters are distributed across the two files so that 
common parameters can be reused without duplicate setup.

Feature Properties

The Feature Properties tool is used to view and edit the parameters of a feature 
stored in the DTM file.

Sample Feature Properties dialog box
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A list of individual features stored in the surface are displayed on the Tools dialog 
box. Remember, all coordinate points used for a DTM must be stored in a feature. It 
is common to have multiple features in a DTM that represent the same type of 
element in the surface. However, all features must have a unique name. For 
example, in a surface, there might be four edge of pavement features named EOP1, 
EOP2, EOP3, and EOP4. Each one represents a different edge of pavement.

Each feature has a feature style linked to the respective feature. In the example, all 
four edge of pavement features are linked to the feature style named EOP. In this 
case, the feature name and the style name were substantially similar. However, the 
names do not need to be the same or similar.
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Surface Files

Creating a Surface

A new blank surface is created using the File > New tool and selecting the Surface tab. 
This tool only creates the surface in memory; it does not save the surface to disk. 
That must be done as described in the following section.

The name specified when creating a new surface is the “internal” name. This is the 
name that is visible in the InRoads Explorer and other dialog boxes. Although it is 
recommended that it should be, the internal name and the disk name of a surface 
are not required to be the same.

InRoads can have more then one surface in memory at a time. These surfaces are 
tracked by their internal name given when creating the DTM. No two surfaces can 
have the same internal name. Names are case sensitive, so Existing is not the same 
surface as EXISTING.

Setting the Active Surface

Whenever a Surface is loaded or created in InRoads, a red box appears around the 
icon representing “Active” surface. Operations are performed in the active surface.

When a surface tool is selected, surfaces that are currently loaded may be available 
to choose. Unless a different surface is selected, the “Active” surface automatically 
displays as “selected” in the list.

To make a surface active, simply right mouse click on the surface name in the 
workspace area of the InRoads explorer and select Set Active from the pop-up 
menu. Or select Surface > Active Surface from the InRoads menu, select the surface 
from the list, then click Apply to make it active. 

Setting a Surface Active
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Saving Surface Data

Once the surface is created it must be saved to disk. By default, surfaces have a 
.dtm extension. When saving the surface, it is recommended that the same name be 
used for the surface file as the internal surface name. For example, a surface named 
Existing will be saved out as Existing.dtm.

Surfaces and Locks

There are three InRoads locks that are important when working with surfaces: the 
Write lock, the Feature Filter lock, and the Style lock. For a discussion on these 
locks, please see the beginning portion of this chapter.
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Surface Properties
The Surface Properties dialog box gives a general overview of the surface data and 
display properties. The name and surface type, as well as the total number of each 
feature type, and triangle total can be reviewed in the Main tab. The elevation range 
of points in the surface is also easily visible in the surface properties. In the 
Advanced tab, controls are available which allow the appearance of the surface in 
profile and cross section to be modified. To access the surface properties, select 
Surface > Surface Properties or Right-Click on the name of the surface in the 
workspace area of the InRoads Explorer and select Properties from the shortcut 
menu. 

The preference option is used to assign a preference name to the surface, which 
controls how a surface will appear when using the View Surface tools and the Style 
Lock is on. 

Surface Properties dialog box
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View Surface Tools
The View surface tools allow surface data to be displayed as graphics in the CADD 
file and provide an excellent means of surface analysis and visualization. The view 
surface tools also work in conjuction with the locks mentioned earlier in the chapter, 
which control how the graphics are displayed,refreshed, and removed. To access 
the View Surface tools, select Surface > View Surface from the menu. 

Sample Feature Properties dialog box

View Perimeter

The View perimeter tool displays the outermost edge of the triangulated surface as a 
closed shape in the CADD file. 

This command computes the perimeter of the active surface in one of two ways. If an 
exterior boundary exists for the surface, the command displays it as the perimeter 
because no valid triangles exist outside of this closed shape. If an exterior boundary 
does not exist, the software works its way around the edge of the model, making 
sure not to use any deleted triangles. This path is displayed as the perimeter.
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To View a surface perimeter, select Surface > View Surface > Perimeter, select the 
surface from the list, then click Apply. 

View Contours

The View contour tool displays contour lines in the CADD file for the active surface. 
Major and minor contour lines are displayed per the interval specified in the main 
tab. Contour elevations can be labled as well. The contours are computed by 
interpolating the points along the edges of each triangle and connecting the points. 

To view the contours of a given surface, select Surface > View Surface > Contours, 
select the surface from the list, then click Apply. 
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View Triangles

The View Triangle tool displays all or a portion the triangles that are contained in a 
given surface in the CADD file. The appearance of the triangles can be controled by 
editing the symbology in the main tab. To view the triangles of a surface, select 
Surface > View Surface > Triangles, select the surface, then click Apply. 

View Features

Each feature of a given surface, such as breaklines, random points, boundaries etc. 
can be displayed in plan view by using the View features tool. How each feature is 
displayed is controlled by the symbology assigned to the feature style. If a feature 
shows up gray in the list, it means the plan display is disabled for that feature style. 
To edit a feature style, click on the name of the feature and click the Edit Style 
button. To display features select the feature from the list, then click the Apply 
button. 
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Update 3D Plan Surface Display

The Update 3D Plan Surface Display is used to display or remove surface data from 
the file. More than one surface can be selected at a time and more than one type of 
data ie. contours, triangles can be displayed or removed in one step. The Mode 
option is used to control whether surface data is turned on or off.

The surfaces area displays all the surfaces that are currently loaded and ready to be 
selected. Below the surfaces area, controls are available which allow data to be 
inabled or disabled. When data such as contours are enabled, it can either be turned 
on or off (depending on the mode). To run the command, click the Apply button. 
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EXERCISE-SURFACE REVIEW AND DISPLAY

Loading a Survey Data DTM Surface

1 From the InRoads menu, select File > Open.

2 Browse to the folder C:\BE Data\{Course #}\Data\

3 Set the Files of type to Surfaces (*.dtm)
4 Select the file T2005_HillCL_Survey_Final.dtm

InRoads File Open dialog 

5 Click Open. The DTM is loaded into InRoads.

Notice that the dialog box does not close so that additional surfaces can be loaded if 
necessary.

6 Select the file T2005_HoyP_Survey_Final.dtm

7 Click Open.
8 Click Cancel to close the dialog box.

In a later exercise we will learn to setup InRoads so that several files can be opened 
simultaneously. 

There are now two surface files in InRoads memory. The last file open is now the 
active surface. 
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1 Review the InRoads Explorer dialog box.

2 Select the Surfaces tab on the bottom of the Workspace bar on the left side of 
the dialog box.

There are now three surfaces loaded in InRoads. The Default surface is created 
when InRoads starts. The other two surfaces are those that were loaded in the 
previous steps.

InRoads Explorer showing two surfaces loaded

The T2005_HoyP_Survey_Final surface is the active surface. The active surface is 
identified by the red box around the surface icon in the InRoads Explorer.

The active surface defines which surface data is edited or viewed when the 
appropriate tools are invoked. The active surface is redefined with the Surface > 
Active Surface tool or by right-clicking on the desired surface name and selecting Set 
Active from the shortcut menu.

Review Surface Properties

Immediately after loading a surface it is a good idea to review the surface’s 
properties. This is a quick check to verify the surface.
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1 Select Surface > Surface Properties.

The Surface Properties dialog box appears.

Surface Properties dialog box

2 Review the Minimum and Maximum coordinate in the lower left corner of the 
dialog box.

3 Check that the coordinates are in the correct area of the project. Make sure to 
check the elevation range. This is an easy method to spot elevation bust 
problems in the surface.

4 Also review the Data Totals section on the right. Most surfaces will contain 
random and breakline points. If these are missing, there might be a problem. 
Verify that the surface contains triangles. If not, it will need to be triangulated.

5 Change the Surface option to the T2005_HillCL_Survey_Final.

6 Review the contents of this surface.

7 Close the Surface Properties dialog box.
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Set Active Surface

When the surface was changed in the Surface Properties dialog box, it also changed 
the active surface. 

1 Right-click on the T2005_HoyP_Survey_Final surface in the InRoads Explorer.

2 Select Set Active.

3 The T2005_HoyP_Survey_Final surface is now the active surface.

Write Lock

Before displaying any graphics the Write lock needs to be understood. The Write 
lock defines if the graphics is created in the CAD file or only temporarily displayed on 
the screen. When InRoads generates graphics and the Write lock is disabled, the 
graphics are temporary and will “disappear” when any view commands (fit, zoom, 
refresh) are performed in the graphics software.

So in other words, any graphics that InRoads generates when the Write lock is 
disabled are only temporary graphics. If the Write lock is enabled, the graphics are 
written to the CAD file so a view command will not cause the InRoads’ displayed 
graphics to disappear. The Write lock only affects InRoads generated graphics, 
anything done within MicroStation, like Place Line, is not affected.

The Lock Toolbar

It is convenient to display the InRoads Lock toolbar docked to the InRoads Explorer. 
This allows much easier access to the locks than using the pull down menus.
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1 From the InRoads menu select Tools > Locks > Toolbar.

If there is a check mark next to Toolbar, then the Locks toolbar is already displayed. If 
there is no check mark, select the menu item to have the Locks toolbar displayed. 

InRoads Explorer showing the Locks toolbar

Selecting Tools > Locks > Toolbar is the same as selecting Tools > Customize and toggling 
on Locks on the Toolbar tab.

2 Drag the Locks toolbar and dock it to the InRoads Explorer just below the pull 
down menu if it is not already there.

Using the Write Lock

Which is the Write lock and how do I know it is on?

Good question. The Write lock is located at about the middle of the buttons on the 
Locks toolbar. Graphically it looks like a pen and pencil crossed.

When the Write lock is enabled, it appears depressed and has a lighter background. 
In addition, the two buttons to the left will be active and displayed in color. 
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When the Write lock is disabled, it does not appear depressed and has a darker 
background. Another easy way to tell the Write lock is disabled is that the two 
buttons to the immediate left of it are grayed out when it is disabled.

1 Enable the Write lock. 

Locks Toolbar with Write lock enabled

2 Disable the Write lock.

Locks Toolbar with Write lock disabled

Three buttons to the left of the Write lock is the Style lock. 

The Style lock is used with surfaces. Surfaces can have preferences associated with 
them. When a view surface tool is used with the Style lock enabled, the dialog box 
for the command will not be displayed, but rather your surface data will be displayed 
in the graphics file without any further input from you. The Style lock bypasses the 
dialog box and displays the active surface, automatically determining what 
symbology to use.

3 Enable the Style lock if it is not already enabled.

The background of the Style lock will be a lighter color and the button will appear 
depressed when it is enabled.

Surface Display

1 Select Surface > View Surface > Contours.

What just happened? No prompt or dialog boxes appeared and the graphic contours 
were created. How did InRoads know what to do? Because the Style lock is enabled, 
the contours displayed using predefined preference associated with the surface. The 
contours are created for the active surface.

2 Fit the graphic view.
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Notice that the contours disappear. The data that created the contours is not gone, 
just the graphics have disappeared. This happened because the Write lock was 
disabled when the graphics were created so they were defined as temporary 
graphics.

3 Disable the Style lock. 

Both the Write lock and the Style lock should be disabled.

The Contour dialog

1 Select Surface > View Surface > Contours.

The View Contours dialog box appears because the Style lock is now disabled. 
When the Style lock is enabled, InRoads uses predefined preference settings 
instead of displaying the dialog box.

The View Contours dialog box

2 Click Apply.

3 The contours display again.

4 Fit the graphic view.

5 Again, the contours disappear because the Write lock is still disabled.
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Loading a Preference

1 With the View Contours dialog box still open, click Preferences.

Preferences dialog box

2 Select the Preference named Finished Surface.

3 Click Load.
4 The preference is loaded into the View Contours dialog box. The preference 

contains stored definitions for all of the options and parameters in the dialog box.

5 Click Close to close the preference dialog box.

View Contours dialog box after loading the Finished Surface preference

6 Click Apply on the View Contours dialog box.

7 The contours display differently from before.

8 Update the graphic view. The contours disappear again because the Write lock is 
still disabled.
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Changing the surface displayed

So far all that has been displayed is the surface T2005_HoyP_Survey_Final. Next 
you are going to change the surface and see what the other surface looks like.

1 With the View Contours dialog box still open, change the Surface option to 
T2005_HillCL_Survey_Final.

The View Contours Dialog box while changing the Surface to display

2 Click Apply. 

3 The contours for the southern half of the interchange display.

4 Zoom in or window area around where the contours are displayed. 

5 Yes, the contours will disappear.
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6 Click Apply again.

View of the contours for surface L2005_HillCL_Survey_Final

7 Update the graphic view.

Enabling the Write Lock

1 Enable the Write lock.

Locks toolbar set with Write lock enabled,
Pencil mode enabled and the Style lock disabled

2 Toggle the Pen/Pencil toggle to Pencil mode.

3 Click Apply on the View Contours dialog box.

4 Update the graphic view.

5 Notice that the contours do not disappear this time. They are written to the design 
file because the Write lock was enabled when they were created. But what is the 
Pencil toggle? With Pencil, if the display setting are changed and the same item 
is re-displayed, the graphics will erase automatically before being redrawn.
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Changing the Contour Interval

1 On the View Contour dialog box, change the Interval to 0.50.

2 Set the Minors per Major to 1.

Modified Interval and Minors per Major options

3 Click Apply.

4 Notice that the old contours are erased before the new ones are displayed.

Resetting the display preference

1 With the View Contours dialog box still up, click Preferences.

Preferences dialog box

2 Select the Preference named Existing Surface.

3 Click Load
4 Close the Preferences dialog box.

5 Click Apply on the View Contours dialog box.
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6 Again, notice that the old contours are erased before the new ones are displayed. 
The new contours display using the original display.

7 Close the View Contour dialog box.

Deleting Surface Display Graphics

As with many things with InRoads there are a few ways of doing things. To delete the 
displayed contours, the MicroStation Delete Element tool could be used. There is 
also an InRoads tool that will do the same.

1 Select Surface > Update 3-D/Plan Surface Display. 

2 Set the Mode to Display Off.
3 Enable the Contours option.

4 Select the Surface T2005_HillCL_Survey_Final

Update 3-D/Plan Surface Display

5 Click Apply
6 The contours are erased.

7 Close the Update 3-D/Plan Surface Display dialog box.

8 Although it would have been as easy to use the MicroStation Delete Element tool 
to delete the contours in this situation, that will not necessarily be true as the 
design gets more complex and contains more graphics. This tool is useful in 
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those situations when graphics cannot easily be selected. In addition, this tool 
can be used to create the contour or other surface display graphics.

9 Now it is your turn

10 Try the Surface > View Surface > Triangles and Surface > View Surface > 
Perimeter tools.

11 Experiment with the Write lock. Enable and disable the lock to control the triangle 
and perimeter displays.

12 Select File > Close > Surfaces. Click the Yes button in the Close All Surfaces 
dialog box. 
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4 Viewing Geometry

In this Chapter topics related to viewing Viewing Geometry will be discussed. The 
topics discussed include:

• What is a Geometry Project

• Loading a Geometry Project

• Viewing Geometry

• Profiles

• Viewing Vertical Alignments

• Geometry Reports

The Geometry Project

What is a Geometry Project File?

The geometry file contains geometry elements, which include coordinate geometry 
points, horizontal alignments, and vertical alignments. The geometry file is frequently 
referred to as the geometry project.

In InRail, the geometry project also contains rail specific components such as cant 
alignments and turnout geometry. When saved to disk, the geometry file has a .alg 
extension. Think of it as an abbreviation for alignment.

In addition to the geometry elements, the geometry file also stores stationing 
information for the alignments including the starting station, station equations, as 
well as important points along the alignment know as Event Points.

Event Points are a method to locate important locations along an alignment. These 
points are either based on a station and offset or on fixed coordinates. The station 
and offset method allows the point to move as the alignment definition is changed. 
Fixed coordinate event points do not move when the alignment is changed. These 
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points are not necessary Cogo (coordinate geometry) points but they are points in 
the geometry file that have a coordinate associated with them.

What is the Geometry Project File structure?

A geometry project is similar in concept to a database. It stores and organizes point 
information. There may be several geometry projects opened in InRoads, but only 
one can receive input at a time. This is called the active geometry project.

A geometry project is organized into hierarchal categories starting with the Cogo 
point buffer and horizontal alignments. Only one alignment can be manipulated 
within a project at a time. This is the active alignment.

Vertical alignments, horizontal alignment event points, stored as subordinates or 
children to horizontal alignments. Vertical event points are children to vertical 
alignments. The purpose of the parent-child hierarchical structure is to avoid 
confusion or mistakes that can occur if a vertical alignment is used with an non-
matching horizontal alignment.

Geometry Project organizational chart

As shown in the diagram above, multiple horizontal alignments can exist in a 
geometry project. Each horizontal alignment can have multiple vertical alignments.
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Each horizontal alignment must have a unique name. Geometry names are case 
sensitive. What an alignment is named is up to the user but it is recommended that 
the names of the alignments give a clue to what the alignment is. An good example 
would be the following alignment names: 

• I65 NB Alt 1

• I65 SB Alt 1

• I65 NB Alt 2

• Oak Street

Even though the following are legitimate alignment names, it is recommended that 
they not be used in a single geometry project because confusion might occur.

• oak street

• OAK STREET

• OaK StREET

Every Geometry project has two names. One name is used and seen when the 
geometry project file is opened in InRoads. The other name is the name see when 
listing geometry files on a disk drive. By default, the name that is displayed when the 
files are listed on the storage media, or hard drive of the computer, has a .alg 
extension. These two names, the one that InRoads displays and the file on the hard 
drive, do not have to be the same. However, it is recommended that the names be 
the same. If there is a Project Identification Number used for the project like 1345-
2005 then a good choice for the Internal geometry project name is 1345-2005 and 
1345-2005.alg for the geometry file name on the disk drive. This will lead to less 
confusion especially months after a project is done or if someone unfamiliar with the 
project needs to use the files.

Storing Geometry Points

It is important to understand that InRoads has two primary storage locations for 
coordinate data within the geometry project. Some points are stored in an area 
called the Cogo Point Buffer while others are stored in the horizontal alignment 
definitions. The creation method determines where a geometry point is stored. 

Cogo Point Buffer

The Cogo point buffer stores geometry points. Geometry points are named 
coordinate points that can be used for geometric calculations or alignments. 

All Cogo points must have an alphanumeric or numeric name.
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All InRoads Cogo points are stored with three coordinates, the Northing, Easting and 
Elevation (or X, Y, and Z, if you prefer). However, the elevation can be set to 0 when 
working in a 2-dimensional environment or with data that does not have a known 
elevation.

When Cogo points are used in a horizontal alignment that has an associated vertical 
alignment, the Cogo points do not inherit the elevation of the vertical alignment. The 
points can be updated with the vertical alignment elevation but it is not automatic. In 
other words, the elevation the point is created at remains the same in the geometry 
project unless it is updated.

It is suggested that Cogo points that will be used in an alignment be named using 
numeric names only. Otherwise there is the possibility of getting an Invalid Cogo 
description error. The reason that alpha characters are not suggested for alignments 
is because the characters L, R, S, M, and C have special meaning to alignments 
which if used in the point name can confuse the software.

Most traditional Cogo commands like Locate and Fit Curve automatically create 
points in the Cogo buffer. However, some commands like Traverse and Locate do 
not always behave as one might expect.

The Traverse command has four options that define where a point is stored. The To 
Cogo Buffer and Radial options store the points in the Cogo buffer as single points. 
The Before Alignment or After Alignment options create points in the active 
horizontal alignment. All four methods create points with names.
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Horizontal Alignment Points

If the point is created using one of the horizontal alignment commands, the point is 
automatically stored in a horizontal alignment, not in the Cogo buffer. 

Unlike a Cogo point, horizontal alignment points do not require a name. InRoads 
allows this capability because alignments typically contain many points that are 
referenced by their station location, not a point name. Only those points that need to 
be named are stored in the Cogo buffer. This multi-location storage model also 
keeps the Cogo buffer cleaner and easier to use by not including all of the PC, PT, 
PI, … points from each horizontal alignment.

Converting Between Point Types

InRoads includes geometry tools to create Cogo points from horizontal alignment 
points as well as define alignments from Cogo points. Therefore, there is no 
limitation in how the points are stored, it is simply a method developed to be most 
flexible to the needs of InRoads users.

Loading a Geometry Project

To load a geometry project, select File > Open. More than one geometry project can 
be loaded into InRoads at a time. When a geometry project is loaded, the name of 
the geometry project will be visible in the workspace bar of the InRoads explorer, 
when the Geometry data type button is selected. 

Like Surfaces, the Active geometry project is indicated by the red rectangle around 
the icon. With a geometry project however, “children” of the geometry project such 
as the horizontal alignment can be made “active”. 
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In turn, “children” of the Horizontal alignment can then be made active such as the 
vertical alignment. 

The horizontal annd vertical alignment 

In the example above, the active horizontal alignment is Ramp B2. The Ramp B2 
horizontal alignment has one vertical alignment, which is also set active. 

Viewing Geometry Tools

The view geometry tools can be used to display and annotate geometry data in the 
CADD file. The geometry viewing tools can be accessed by selecting Geometry > 
View Geometry. 
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View Active Horizontal 

The View Active Horizontal tool displays the active horizontal alignment. It is 
important to remember that this tool only displays the linear element representing the 
alignment, and does not label or display alignment stationing. To view the active 
horizontal alignment, select Geometry > View Geometry > Active Horizontal or right 
click on the name of the horizontal alignment and select View from the shortcut 
menu.

Selecting Geometry > View Geometry Active Horizontal 

A profile must be created before the View Active Vertical tool can be used. This tool 
will be covered in a later section. 
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View Horizontal Annotation

The View Horizontal Annotation tool can be used to display both the active horizontal 
alignment and alignment labels, such as curve data and distance and bearing of 
linear elements. The View Horizontal annotation tool can also be used to annotate 
multiple alignments and cogo points in one step. 

The View Horizontal Annotation dialog box
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View Stationing

The View Stationing tool displays the stationing of the active horizontal alignment. A 
drop down list and target button is available to specify the alignment to in which to 
display station annotation. The Limits area allows a station range to be set in which 
the station text will only be displayed. The distance between stations can be 
controlled with the Interval option. The appearance of different stationing parameters 
such as major stations, minor stations, cardinal stations, leaders, ticks etc. can all be 
controlled in the symbology area. 

To view alignment stationing, select Geometry > View Geometry > Stationing. 

The View Stationing dialog box

Viewing Geometry and Locks

There are three InRoads locks that are important when working with surfaces: the 
Write lock, the Pen/Pencil Lock, and the Station lock. For a discussion on these 
locks, please see the Viewing Surfaces chapter.
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Profiles

A Profile is a series of elevations extracted along a baseline at a specified station 
interval. In InRoads, the Profile is comprised of two parts, the profile window and 
profile data. The profile window refers to the graphics representing the bottom, left 
and right axes, and grid lines. The profile data is typically a line that refers to the 
terrain model elevation information. The profile data is updated with new surface 
information as it is obtained. 

Example of an InRoads Profile

Multiple plots of profile data representing different surfaces can be displayed in a 
single InRoads profile window. 

After a profile is created, existing vertical alignments can be displayed or new vertical 
alignments designed within the window.
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Creating a Profile 

A profile is created using the Create Profile tool (Evaluation > Profile > Create Profile) from 
the InRoads menu. 

The Main tab of the Create Profile dialog box defines the path the profile follows, as 
well as the surfaces to display on the profile. Define the path the profile follows using 
one of the four methods provided in the Source section of the dialog box. 

A profile can follow a horizontal alignment if one exists. Otherwise, the profile can 
follow a graphic line from the CAD file, an interactively defined multiple point line, or 
the path can be read from an ASCII file. The Multipoint option is useful for stream 
profiles as well as non-corridor projects, such as retention ponds or building sites. 

Main tab of the Create Profile dialog box

Profile Sets 

When a profile is created, a unique name is assigned to it. The name of the profile is 
entered in the Set Name field. Set Name defaults to the active horizontal alignment 
name. Having a unique name for each profile allows InRoads to track different 
profiles when more than one exists in a CAD file. The desired profile is identified by 
name (or by selecting it graphically) by other profile tools, such as Annotate Profile. 
Profile Symbology

The profile Symbology area at the bottom of the Create Profile dialog box specifies 
which surfaces to display in the profile window. More than one surface at a time can 
be displayed by selecting the check box next to each surface name. 
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The symbology used to display the surface in the profile is not defined in the Create 
Profile dialog box. Instead, this symbology is defined as part of the surface. Use the 
Properties Button to modify the surface symbology definitions. This will open the 
Surface Properties dialog box. The profile definitions are located on the Advanced 
tab of the dialog box. Here, the Named Symbology that defines how the surface will 
appear in a cross section and profile is defined. 

Profile Controls

The Controls folder on the Create Profile dialog box includes controls for the station 
and elevation limits, clearance and exaggeration of the profile. 

The Elevation and Station limits can be enabled or disabled. When enabled, they 
limit the size of the profile to the specified range.

When enabled, the Window Clearance option specifies additional grid above and 
below the calculated elevation range in the profile window.

Controls folder of the Create Profile dialog box

Displaying Features in Profiles

The Features tab of the Create Profile dialog box is used to display surface features 
on the profile. Surface features include triangulated features, such as edges of 
roadway and ditches, as well as features excluded from triangulation, such as 
underground utilities.
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Crossing and projected features can be displayed on the profile. The crossing 
feature option displays a symbol at the location a feature crosses the profile path. 
The projected feature option displays features offset from the profile baseline by 
projecting them onto the profile window. They are displayed as linear graphics along 
the profile.

Features tab of the Create Profile dialog box

To display features in profiles, the Crossing Features or Projected Features option 
must be enabled.

Profile Bandwidth

The Profile Bandwidth options restrict which features (or portions of features) are 
projected onto a profile based on their offset from the profile location. 

The profile bandwidth is defined by two offsets from the profile. The values define the 
left and right edges of the bandwidth envelope. Negative offset values are left of the 
profile, and positive values are right of the profile. For example, to restrict the 
features to those within 15 feet of the profile, define the Left Offset as -15.0’ and the 
Right Offset as 15.0’

If only one offset is defined, the bandwidth is infinite on the opposite side. For 
example, if the Left Offset is defined as -15.0’ and the Right Offset is disabled, all 
features within 15’ of the left side of the profile and all features, regardless of their 
offset, on the right side of the profile are projected onto the profile. 

Both values can be positive or negative if only a bandwidth on one side of the profile 
is desired.
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The bandwidth option also includes the ability to specify whether the features inside 
the bandwidth envelope or those outside the bandwidth envelope are to be projected 
onto the profile. 

The final parameter is Clip Features. If Clip Feature is enabled, only the portions of 
the features that exist inside or outside the bandwidth envelope (depending on 
whether the Inside Band or Outside Band option is selected) are displayed. If Clip 
Features is disabled, any feature that has at least some portion inside or outside the 
bandwidth envelope (depending on whether the Inside Band or Outside Band option 
is selected) is displayed in its entirety. 

The Bandwidth options are only available when the Projected Features option is 
enabled and one or more Projected Features are selected. 
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Profile Offsets

The Offsets tab is used to extract surface data at a specified offset from the baseline. 
The drop-down list contains names of the surfaces that are currently loaded. To 
display an offset, enable the check box for the respective offset in the Symbology 
area. 

The offset distances and symbology cannot be defined in the Create Profile dialog 
box. These are defined on the Advanced tab of the Surface Properties dialog box. 
Otherwise, the tool is invoked by selecting Surface > Surface Properties.

Offsets folder of the create profile dialog box
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Annotating Profile Features

Features displayed in a profile can be annotated with the Annotate Feature in Profile 
tool (Evaluation > Profile > Annotate Feature in Profile). Point and line segment features can 
be annotated with parameters such as station, offset, elevation, length, and feature 
name. The feature must exist in the profile window before it can be annotated. 

The Main tab of the Annotate Feature in Profile dialog box
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Profile Annotation

The Annotate Profile tool (Evaluation > Profile > Annotate Profile) is used to annotate 
vertical alignments on, above, or below a profile window. There are numerous types 
of annotations available. Some of the most useful annotations are listed below.

• Station (cumulative, interval, or number)

• Superelevation Diagram

• Curvature Diagram

• Elevation (existing or proposed)

• Cut Depth or Fill Height

• Template Names and Backbone Widths

• Site Distance

• Design Speed 

Main tab of the Annotate Profile dialog box
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Viewing Vertical Alignments

After a profile is created, an existing vertical alignment can be displayed in the profile 
window. To view an existing vertical alignment Select Geometry > View Geometry > 
Active Vertical, or right click on the vertical alignment name and select View from the 
shortcut menu. 

Selecting View Active Vertical

This tool will only display the vertical alignment linear elements and will not annotate 
the alignment. 
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View Vertical Annotation

The View Vertical Annotation tool is used to view and annotate a vertical alignment 
within an existing profile window. To access the View Vertical Annotation tool, Select 
Geometry > View Geometry > Vertical Annotation. The Limits option is used to 
specify the station range that will be used to annotate the vertical alignment. 
Numerous types of annotation are available and includes the following:

• Vertical Curves

• Site Distances

• Tangent Slopes and Lengths

• Vertical PI, PC and PT Stations
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Geometry Reports

Fixed Format or “quick” geometry reports

Fixed Format reports can be viewed for an active horizontal or vertical alignment. 
Select Geometry > Review Horizontal to display a fixed format horizontal alignment 
report. Select Geometry > Review Vertical to display a fixed format vertical alignment 
report. When this tool is selected a dialog box will display showing the alignment 
information. 

The data that is displayed can be printed and saved to a text file, or displayed as text 
in the CADD file. The Mode Options can be used to display different alignment 
information, such as curve data or just one element at a time. If the Element Option 
is selected, the Next, Previous, First, Last and Select Buttons become available. 
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XML Reports

Creating XML Reports

Overview

The XML tools are an add-in application and must be activated before they can be 
used. Once activated, there are two XML reporting tools added to the Tools menu: 
XML Reports and View XML Reports.

The XML Reports tool creates the XML data file from InRoads data such as surfaces 
and alignments. This tool has many different options to control what data is written to 
the XML data file. The second tool, View XML Reports (Bentley InRoads Report 
Browser), formats the report by reading the data from an XML file and the report 
structure from an XSL file. The result is the final report. The following illustration 
show the process of creating a Report using XML.

XML Report generation process in InRoads

XML Reports Tool

The XML Reports tool extracts data from InRoads and builds an XML data file that in 
turn is formatted into a report. Not all of the data in the XML data file needs to be 
used in the XML report.
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The XML Reports dialog box is divided into seven tabs. Each tab corresponds to a 
different type of data that is exported to the XML data file.

The name and location of the XML data file is specified in the File Name field at the 
bottom of the dialog box. The File Name field is displayed on all seven tabs.

Main Tab

The Main tab creates an XML data file containing data from the active geometry 
project and from all loaded surfaces. The check boxes allow you to control which 
areas of the geometry project are written to the XML data file and if surface data is 
saved with or without feature information. 

Using the Main tab, individual alignment and surfaces cannot be saved to the XML 
data file. Exporting everything to the XML data file may be convenient for report 
building because all data is contained in a single XML file and is ready for formatting. 
However, because the XML data file is an ASCII text file, writing large quantities of 
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data to it can be slow. Therefore, it is recommended to only write the necessary data 
to the XML data file using one of the other tabs whenever possible.

Main tab of the XML Reports dialog box

Geometry Tab

The Geometry tab creates an XML data file containing data from the active geometry 
project. However, unlike the Main tab, the Geometry tab allows the selection of 
which horizontal alignments and Cogo points are written to the data file. In addition, 
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you can select when to include other information such as vertical alignments, 
superelevation, and event points.

Geometry tab of the XML Reports dialog box

When enabled, the Interval field adds additional points, called computed event 
points, to the XML data file. The field specifies the distance between the points. 
Computed event points are calculated along each selected horizontal alignment.

The Limits option restricts the station range of data written to the XML data file for 
horizontal alignments, vertical alignments and event points. Cogo points are not 
affected by this option.
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Several reports resulting from Geometry data are shown below.

Horizontal Alignment report

List Coordinates report
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Station Offset Tab

The Station Offset tab creates an XML data file that contains station and offset data. 
The offsets are calculated from a singe base alignment or surface feature. Offsets 
can be calculated to any number of offset alignments and/or features. 

The offset is always measured from and perpendicular to the base alignment or 
feature. The stationing is measured along the base alignment/feature when Station 
Base is selected and along the offset alignment/feature when Station Offset is 
selected.

Station Offset tab of the XML Reports dialog box

When enabled, the Interval defines the distance between each offset measurement. 
The Offset option causes the offset distance to be measured to a point offset by the 



© 2005-2006 Bentley Systems, Incorporated 91

2006 BE Conference
Introduction to InRoads Fundamentals

distance specified from the offset alignment or feature. When disabled, the offset 
distance is measured to the offset alignment or feature.

Several reports resulting from Station Offset data are shown below. This is only a 
small sample of the type of reports that can be created.

Sample Station Offset report

Station Offset report along a single alignment
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Clearance Tab

The Clearance tab creates an XML data file containing clearance values. The 
clearance data file contains the distance from various points (cardinal points along 
alignments, feature points, and Cogo points) to the selected (From) alignment or 
feature. Each point is projected to the alignment/feature to determine a station and 
an offset.

Clearance information for multiple alignments, features, and Cogo points can be 
created in a single XML data file.

The clearance data file contains one clearance value for each point, unless an 
optional offset line is defined. When an offset line is used, the data file contains two 
clearance values for each point.

Clearance tab of the XML Reports dialog box
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A sample report resulting from Clearance data is shown below.

Clearance report

Stakeout Tab

The Stakeout tab creates an XML data file containing stakeout information. The 
stakeout can be computed from either a base alignment or an occupied point/
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backsight point combination. Stakeout information for multiple alignments, features, 
and Cogo points can be written to the data file at once.

Clearance tab of the XML Reports dialog box

The Interval option defines the distance along the alignments and features between 
points computed in the stakeout data file. The Offset option causes stakeout data to 
be computed for points offset from the selected features and alignments by the 
specified value. A negative value is offset to the left and a positive value is offset to 
the right looking up station.
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A sample stakeout report is shown below.

Stakeout report
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Legal Description Tab

The Legal Description tab creates an XML data file containing information on closed 
alignments and features. The two types of features that are considered closed 
features are interior boundaries and exterior boundaries.

Optionally, one or more reference alignments can be specified. When reference 
alignments are included, a legal reference element is added at the start and end 
point of each reported element. The legal reference contains the name of the closest 
reference alignment alon‘g with the corresponding station and offset of the point.

Clearance tab of the XML Reports dialog box
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A sample property description is shown below.

Property Description report.
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Surfaces Tab

The Surfaces tab creates an XML data file containing information about the features 
in the selected surface. 

The features included in the XML data file are selected from the feature list. When 
the Include Feature Points option is enabled, the coordinates of the points that define 
each feature are included in the data file. When this option is disabled, the data file 
will contain information about each selected feature (including how many points 
compose the feature), but will not describe every point specifically.

Surface tab of the XML Reports dialog box
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Viewing XML Reports

After an XML data file is created, a report is created from the data. The report is 
created by applying an style sheet (XSL file) to the XML data. The XSL file defines 
the format of the report. An HTML interpreter such as Internet Explorer is used to 
display the resulting report.

InRoads includes the Bentley InRoads Report Browser to interpret XSL and view 
reports generated from XML data. This tool will open automatically when an XML file 
is created using the XML Reports tool or it can be open by selecting Tools > View XML 
Reports.

When activated, the Bentley InRoads Report Browser page is blank as shown below.

Blank Bentley InRoads Report Browser window

There are only four options on this page. 

The XML data file can be opened using File > Open. 

On the left of the window is a listing of XSL files used to format a report. 

Selecting File > Print Preview opens a new window displaying the results of the report 
without the header and footer information that appear on this window. 

The Tool > Format Options define the precision (number of decimal places) of reported 
values, station formats, and so on. 
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Source

When the Bentley InRoads Report Browser is opened directly from the XML Reports 
tool, then the source XML data is already defined. If opening the Bentley InRoads 
Report Browser page by selecting Tools > View XML Reports, the source XML file must 
be opened manually. To open the source file, select File > Open. The data in the XML 
data file must be compatible with the XSL file specified in the Format field or no 
report is created.

Format

The format field specifies the XSL or style sheet that defines the format of the report. 
InRoads delivers a wide variety of style sheets for common report formats. The 
delivered style sheets are located in one of the XML Data folders within the software 
installation folder. By default InRoads installs to the folder C:\Program 
Files\Bentley\Civil\.

Within the XML Data folders there are sub-folders organizing the XSL files by type.

In its simplest form, a style sheet is a list of instructions that tell a display device how 
to format XML documents and their content. Several style sheets can exist for a 
document allowing that document to be rendered by a wide range of formatting 
devices from Web browsers to printers, XSL can be thought of as a language that 
can do the following:

• Transform XML into HTML

• Filter and sort XML data

• Address parts of an XML document

• Format XML data based on the data value, like displaying negative numbers 
in red

XSL files can also be developed and customized for your specific needs.

Format Options

The format options ({Tools > View XML Reports >}Tools > Format Options) define the 
number of decimal places and format for different values that appear in the reports. 
Not all reports contain all of the format options listed.
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When a format option is changed, the report immediately updates.

Format Options window

Output Friendly Version

The Bentley InRoads Report Browser window is designed for on-screen viewing of 
XML reports. The File > Print Preview command is used to see what the file will look like 
when it is printed. When File > Print Preview is selected, a new window appears 
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displaying the report with no other peripheral headers, footers, and so on. From the 
Print Preview window, the report can be sent to the printer.

Print Preview window

On the Bentley InRoads Report Browser, the options to print and save the file are 
available on the File menu. To get the best results, always save the file to either a 



© 2005-2006 Bentley Systems, Incorporated 103

2006 BE Conference
Introduction to InRoads Fundamentals

Text or Web Page, HTML only format. The Web Page, HTML only format can be 
edited with Microsoft Word or Excel. 

The List Coordinates report in Excel

If saved in HTML format, the file can also be viewed directly in the browser window. 

The List Coordinates report in Internet Explorer
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A report can be exported to Microsoft Excel by right-clicking in the right pane of the 
report browser. In the shortcut menu, select Export to Microsoft Excel. Once this 
option is selected, The text will be automatically be imported into Excel. 
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EXERCISE-VIEWING GEOMETRY

Annotate the Horizontal Alignment

1 Continue in the design file workingfile.dgn in the C:\BE Data\{Course #}\Data 
Folder. 

2 Click the Preferences data type button in the bottom of the InRoads explorer and 
verify Civil.xin is loaded from the C:\BE Data\{Course #}\Data Folder.

3 If it is not currently loaded, select File > Open in the InRoads menu and open the 
file Civil.xin in the C:\BE Data\{Course #}\Data Folder

4 Select File > Open and change the files of type to Surface (*.dtm)
5 Browse to the path C:\BE Data\{Course #}\Data

6 Select the file Existing.dtm, then click Open. 
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7 Change the Files of type to Geometry (*.alg)

8 Browse to the patch C:\BE Data\{Course #}\Data\

9 Select the file Ramp and Mainline.alg ,then click Open.

10 Click Cancel. 
11 In the bottom left of the InRoads explorer, click the Geometry data type button. 

The Geometry project that was just open is now visible. 

12 Right click on the name Ramp and Mainline and select Set Active from the 
shortcut menu. 

13 Click on the plus sign next to the name Ramp and Mainline to expand the 
Geometry project. 

The Ramp and Mainline Geometry Project
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14 Right-Click on the Ramp B2 alignment name and select Set Active from the 
shortuct menu. 

15 Enable the Write Lock. 

16 Select Geometry > View Geometry > Horizontal Annotation

17 Click in the Include field under Horizontal Alignments, then click the Filter button

18 Hold the ctrl key down on the keyboard and select First Ave Exist, I-90 and 
Ramp B2 from the Available field. 

19 Click Add, then click OK. 

20 Click in the Include field under Cogo Points.

21 Click the Filter button. 

22 Hold the ctrl key down on the keyboard and In the Available field Click 
100,100,200,201 then click the Add button. 

23 Click OK.
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24 In the Display area, enable Points, On Alignment and Elements.

25 In the Annotate area, enable Points and Elements.

26 Disable all other options. 

27 Click Apply. 

28 Close the View Horizontal Annotation dialog box. 
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Viewing Stationing

1 Enable the Station Lock

2 Select Geometry > View Geometry > Stationing

3 Click Preferences.
4 Select DOT New, then click Load.
5 Close the Preferences dialog box. 

6 In the Horizontal Alignment field, select Ramp B2.

7 For the Interval, Key in 100. 

8 Click Apply. 

9 Close the View Stationing dialog box. 
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Creating a Profile

1 Use the Zoom Out tool in MicroStation so that the view is similar to the illustration 
below.

2 Select Evaluation > Profile > Create Profile

3 Click the Preferences button. 

4 Select the DOT New Preference, then click Load. 

5 Close the Preferences dialog box. 
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6 In the Surfaces area, enable Existing. This controls which surface will display in 
the profile window. 

7 Click the Source option on the left.

8 Enable Alignment and select Ramp B2. 

9 Click Apply. The Create Profile dialog box will collapse. 

10 Click in the upper right corner of the MicroStation View 1. 

11 The profile will display as shown in the illustration below. Click Close.
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View Vertical Annotation

1 Select Geometry > View Geometry > Vertical Annotation.

2 Ensure that the Horizontal, Vertical and Profile Set all say Ramp B2. 

3 Disable Station Limits. 

4 Load the DOT New Preference. 

5 Click Apply. 

6 Close the View Vertical Annotation dialog box. 
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Creating Geometry Reports

1 On the left side of the InRoads Explorer right click on Ramp B2 horizontal 
alignment and select Review from the shortcut menu. 

2 A fixed format horizontal alignment report displays as shown in the illustration 
below.

3 Close the Review Horizontal dialog box. 
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4 Select Geometry > Review Vertical from the InRoads menu. A fixed format 
vertical alignment report displays as shown in the illustration below.

XML Reporting

1 Select Reports > XML Reports. The XML report dialog box displays. 

2 Click the Main tab. 

3 In the Report On area, enable Geometry Project, Horizontal Alignments, 
Vertical Alignments, and Cogo Points. Disable all other options. 

4 Click in the File Name field at the bottom of the dialog box, then click the Save 
Button. 

5 In the Save As dialog box, browse to the C:\BE Data\{Course #}\Data\ folder. 

6 In the File name field key in Geometry.xml

7 Click the Save button. 
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8 The XML Report Browser displays. 

9 On the left, click the Geometry folder and select HorizontalAlignmentReview. A 
Horizontal Alignment Report displays as shown in the illustration below. 
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10 Select List Coordinates.xsl

11 The List Coordinates report displays as shown in the illustration below.

12 Close the Report Browser dialog box. 
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5 Loading More Than One File at Once

In this Chapter, topics related to Loading multiple InRoads files will be discussed. 
The topics discussed include:

• Project Defaults

• The InRoads Project File 

Project Defaults
Project Defaults define where items InRoads files are located as well as the default 
InRoads preferences to load when InRoads is started. For instance, to open a 
project file without using Project Defaults it is necessary to navigate to the folder that 
contains the file manually. If a Project Default Configuration existed for the project, 
InRoads could automatically navigate to the correct folder when the File > Open or 
File > Save command is executed.

Multiple Project Default Configurations can be created allowing an easy method to 
work on multiple projects. By selecting the correct Project Default Configuration, 
InRoads looks to the correct folders for the respective project and loads the correct 
preference files automatically.

Project Default Configurations are stored in the registry file on the computer. They 
can be exported to another computer to share a project setup as necessary.

EXERCISE-CREATING A PROJECT CONFIGURATION

1 From the InRoads menu select File > Project Defaults. 

2 The Set Project Defaults dialog box appears. Near the top of the dialog box is the 
Configuration selection pick list. An existing configuration is selected from this list 
and made active by clicking Apply. A new configuration is defined by clicking 
New.
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Create New Configuration

1 Click New.

2 Enter Introduction to InRoads in the New Configuration dialog box.

New Configuration dialog for Project Defaults

3 Click OK.

4 The Set Project Default dialog box updates with the new configuration name 
active. The remaining fields are blank since they have not yet been defined.

Project Defaults after creating a new configuration
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The Set Project Defaults dialog box is divided into two primary sections: Default 
Preferences and Default Directory Paths. 

The Default Preferences identify InRoads preference files that are loaded when the 
Project Default configuration is loaded. 

The Default Directory Paths identify folder locations where InRoads files are located. 
This section does not identify specific files, instead it lists folders where these types 
of files are located. The specific files to be loaded for a project are identified using a 
Project (.rwk) file as discussed later in this chapter.

Depending on which files will be actually utilized in your project, it is not necessary to 
define all of the entries. 

1 Click in the Preference (.xin) field.

2 Click Browse.

3 Browse to and select C:\BE Data\{Course #}\Data\

4 Click in the Projects (.rwk) field.

5 Click Browse.

6 Browse to the folder C:\BE Data\{Course #}\Data\

7 Click Open.

8 Repeat steps 7 through 10 for the following definitions.

Table Property Folder Name

Surfaces (*.dtm) c:\BE Data\{Course #}\Data\

Geometry Project (*.alg) c:\BE Data\{Course #}\Data\

Template Library (*.itl) c:\BE Data\{Course #}\Data\

Roadway Design (*.ird) c:\BE Data\{Course #}\Data\

XML Data (*.xml) c:\BE Data\{Course #}\Data\
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Sample Project Defaults

1 Click Apply.

2 InRoads will use these settings until they are changed. The specified preference 
files will automatically be loaded when InRoads is activated and the remaining 
folder locations will be the defaults when using the File > Open and File > Save 
tools. 

3 Click Close to dismiss the dialog box.
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InRoads Project File
InRoads Project files are one of the most useful production tools in the software. The 
project file does not actually contain any project data. Instead, it is an ASCII file 
listing the other InRoads data files used for the project. Instead of having to load and 
save each data file individually as was done in the first few chapters of this course, 
the Project file allows this to be done in a single operation.

EXERCISE-CREATING PROJECT FILES

The project file can be created from within InRoads or with a text editor.

Before the Project file can be created, the data files must be loaded into InRoads. 
The preference files have already been loaded. The Existing surface was created 
and saved previously. Now all that is needed is to create the Project file. 

1 Select File > Save As. 

2 Set Save as Type to Projects (*.rwk).
3 Click Options.

The Project Options dialog box appears. This dialog box defines which loaded data 
files are written to the Project file.

Project Options with the project surface selected

4 Select the Surfaces tab.

5 The one surface currently in memory is displayed. The Default surface is created 
by InRoads automatically when it is activated. The other surface was loaded in 
the beginning of this exercise, and the Existing surface was loaded in an earlier 
exercise. Click the check box in the Add column for the Existing surface.
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6 A check in either column includes the data file in the project file. Which columns 
are checked tells InRoads how it can use the data files

7 A check mark in the Add column indicates the data file is loaded when the Project 
file is loaded or opened. However, that data is not saved to disk when the Project 
file is saved.

8 Since this is the existing survey data, it should not be changed during the design 
process.

9 Select the Geometry Tab.

10 Click the check box in the Add and Update column for the geometry project 
Ramp and Mainline 

11 Select the Preferences tab.

12 Click the check box in the Update column for the preference file.

13 The check box in the Add column is automatically checked. Which columns are 
checked tells InRoads how it can use the data files

14 A check mark in the Add column indicates the data file is loaded when the Project 
file is loaded or opened.

15 A check mark in the Update column indicates the data file is saved when the 
Project file is saved. If this column is not checked, the data file is loaded into 
InRoads, but any changes to the data are not saved back to the disk drive. 
Essentially, the data is read only.

16 Click OK.

17 The Project Options dialog box closes.

18 In the Save As dialog box, browse to the C:\BE Data\{Course #}\Data\
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19 Enter InRoads Lesson 05.rwk in the File Name field.

Saving IUTC Lesson 05 Project File

20 Click Save.

21 The project file is saved to the disk.

22 Exit the Save As tool.

Creating in Text Editor

A project file is an ASCII file that can be edited using a text editor such as Notepad. 
Opening the IUTC.rwk file created above in Notepad shows the contents to be the 
same data files stored in the project file.

The file T2005.rwk opened in Notepad

The first line in the file is an identifier marking this as a project file. The Next line 
starts with a three letter designator identifying the type of data file. In this case the file 
is a Preference file or a General settings file.

The next line that starts with GEO is Geometry style file.

The third line that starts with DTM is the surface file.
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Following the three type identifier is the path and data file name. There must be at 
least one space between the identifier and the path. The file path can be entered as 
an explicit name, a relative path, or a logical path.

Explicit Name: c:\BE Data\C1TNC104\Data\Existing.dtm

Relative Path: .\InRoads\Existing.dtm 
where the .\ means “from the active directory in the Open dialog box”. 

Logical Path: \\File Server\Projects\C1TNC104\Data\Existing.dtm
where Projects is the name of a share on the computer named File Server.

Below is listed the name of identifiers that might be seen in a project file:

RWK: Header, always will be on the first line of the Project File

GEN: General or Civil preference file

GEO: Geometry Style preference file

DTM: Surface file

ALG: Geometry file

RWL: Roadway library file

TML: Template library file

Reviewing the IUTC Lesson 05.rwk file, notice that the .dtm file has an N after the file 
path. The N indicates that this file is set to Add mode, but not Update in the Projects 
Options dialog box. This means that the file will be loaded, but not written back to the 
disk during the save operation.
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Using Project Files

Once a project file is created, loading data files into an InRoads session becomes 
much easier. Simply open one project file and all of the associated data files 
automatically load.

1 Select File > Close > All from the InRoads menu. Click Yes at the prompt dialog 
box to close all files. 

2 This will close all previously loaded data files.

3 In the InRoads Explorer select File > Open

4 Set the Files of type to Projects (*.rwk).
5 Set the Look in folder to C:\BE Data\{Course #}\Data

6 Select the file InRoads Lesson 05.rwk 

InRoads Open dialog box set to open a project file

7 Click Open.

8 Two preference files and one surface file are loaded into InRoads.

9 Close the dialog box.
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