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LESSON NAME: ASSEBMLING TEMPLATES USING COMPONENTS  

LESSON OBJECTIVE: 
In this portion of the workshop, you will assemble a template using previously created 
template components (parts).  You will use the newly created template to develop a 
proposed roadway design. 

> EXERCISE: GETTING STARTED 

1. Start InRoads and MicroStation by selecting the InRoads icon on the desktop or 
on the Start menu 

2. Open the MicroStation file C:\ BE data\Civil\<course number>\design.dgn 

3. Select the File>Open command from the InRoads pull-down menus 

Highlight Template C:\ BE data\Civil\<course number>\Relocation.rwk 

Click Open 

Click Cancel 

This will open: Relocation.alg, Template Standards.itl, Relocation.ird, Original.dtm 
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THE CREATE TEMPLATE DIALOG 

 

The Create Template dialog is primary place for creating and editing templates.  The 
file extension for the Template Library is .itl (InRoads Template Library). 

On the left side of the dialog, you will find the Template Library area, which contains a 
“Windows like” folder structure.  The root folder is the name and location of the 
InRoads Template Library that is currently open.  Only one template library may be 
open at a time.  To navigate the folder structure, simply double-click the folders you 
want to open or close.  Inside any folder, you can create and organize your 
Templates and Sub-Folders.  The organization of the folder structure is completely 
user definable.  The folder structure also supports common Windows functions, like 
drag and drop, cut and paste, etc.  Most common commands can be accessed by 
using a right-click on the folders and templates.  If you double-click a template, it 
becomes the Current Template and is signified by a Red box around the template 
icon.  The Current Template is also identified in the Current Template area next to the 
Template Library area. 
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Under the Template Library area is the Preview area.  When you highlight a 
Template, the Template will be seen in the Preview area.  You can use the Preview 
to assemble Templates from their parts or components.  This is accomplished 
through “drag and drop.”  The Cyan box in the Preview represents the insertion point 
for any drag and drop operation.  You can change the insertion point location by 
simply clicking on the Preview.  

In the center of the Create Template dialog, is main graph for creating Templates.  
The graph uses its own graphics engine and is not a MicroStation view.  The 
Dynamic Origin (center point) of the graph (0,0) is marked with a Violet box.  The 
Dynamic Origin is used as reference point and can be moved to any location in the 
graph.  The template graph displays the Current Template.  At the bottom of the 
graph, there are numerous view commands (similar to MicroStation View 
commands).  There are two buttons that look like the MicroStation View Previous and 
View Next command, however, they are used to Undo and Redo template creation 
operations.  In the graph area, you can right-click to access commands and you can 
double-click elements in the graph for editing purposes. 

Individual parts of the template are called components.  Components are logical parts 
of a template.  Portions of the template that are separated into components are 
normally based on tabulation considerations.  Examples of components include curb 
and gutter, median barrier, pavement layers, cut and fill slopes, and ditches.  

As you add template components, the area under the graph change to allow for 
different types of component input.  This is called the Current Component area.   

There is a Dynamic Setting dialog which will be used for precision inputting of 
template segments and for dynamically selecting names and options when creating 
templates.   
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> EXERCISE: NAVIGATING THE CREATE TEMPLATE DIALOG 

1. Select the Modeler>Create Template command 

  

2. Select the Tools>Dynamic Settings command 

          

 The settings for the Dynamic Settings dialog are accessed using the 
Tools>Options command  
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3. Double-click the Template Library folder to expand it 

         

 

4. Highlight the Templates folder 

 Select the File>New>Template command 

 Key in the name two-lane 

          

 

 The Template Icon will now have a red box around it to signify it is the Current 
Template (you can double-click the any template to make it the Current Template) 

 This will bring up the template graph on the right pane and two-lane is the Current 
Template 
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5. Check Off the Display Point Names option 

6. Double-click the Components folder to expand it 
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TEMPLATE POINTS 

As is past versions of InRoads, template point names represent the names of Digital 
Terrain Model (DTM) features that are generated when the template is used to create 
a model of the roadway.  This modeling process is now accomplished using the 
Roadway Designer command (previously called the Roadway Modeler).  Template 
point names are assigned during the template creation process.  These names can 
be modified at any time. 

 

TEMPLATE COMPONENTS 

Templates are now made up of components.  A Template Component is a group of 
template points that make up an open or closed shape.  Each component has a 
name, description and style.  Components can represent any roadway feature, such 
as curb and gutter, layer of pavement, cut and fill condition, sidewalk, etc.  During the 
roadway design process, template components will be used to generate a DTM of the 
top layer of the design.  Components that have subgrade points will be added to the 
DTM as non-triangulated points.  Previous DTM challenges, such as designing 
vertical slopes and undercuts, are simplified using components.  This results in only 
having one DTM that contains all modeled layers of the design.  Components are a 
child of the DTM. 

A template can be constructed of numerous components.  Components can be 
organized into the Template Library folder structure to be used as “parts” to assemble 
a complete template.  To assemble a Template, simply “drag and drop” any 
previously created template components from the Preview window into the graph, 
which displays the Current Template. 
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> EXERCISE: ASSEMBLING A TEMPLATE 

1. Highlight the 11’ Two-Lane w/shoulder Component (single-click the 11’ Two-Lane 
w/shoulder template) 

This will bring it up in the Preview window 

2. Select the 11’ Two-Lane w/shoulder Component from the Preview window by the 
Centerline selection point 

        

3. Holding the left mouse button down, drag and drop the Component to the Dynamic 

Origin (center mark)  on the two-lane graph  

The X, Y coordinates on the Dynamic Setting dialog will show X: 0.00 and Y: 0.00 
when you are on the Dynamic Origin 
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4. Again, select the 11’ Two-Lane w/shoulder components from the Preview window 
by the Centerline selection point 

Holding the left mouse button down, drag the components onto the graph and      
right-click (still holding down the left mouse button) 

Select the Reflect option with your left mouse button 

Move the components to the Dynamic Origin on the two-lane graph (the point 
marker “+” will turn white when you are on top of the connection point) and left-click 
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5. Click the Fit icon  at the bottom of the graph 

Your template should look like this now 

 

6. To create a single component out of each pavement layer, place your cursor on the 
center line of the component, as shown below 

 

Right-click at that location and select the Merge Components command 
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The Component will now look as shown below 

 

7. Repeat this procedure on the bottom pavement layer 

  

8. To change the name of the top Component, double-click the top pavement layer, as 
shown below 

Change the Name: to Asphalt in the Component Properties dialog 

Click OK 
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9. To change the name of the bottom Component, double-click the bottom pavement 
layer, as shown below 

Change the Name: to Aggregate in the Component Properties dialog 

Click OK 

  

10. Check On the Display Point Names option and review the Template 

Check Off the Display Point Names option when done 
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11. To add the next component, select the Concrete Curb & Gutter component 

         

Holding the left mouse button down, drag the component onto the graph and right-
click (still holding down the left mouse button) 

 

Select the Mirror option with your left mouse button 

Right-click again and toggle Off the Reflect option (the Mirror option should now be 
the only option checked On) 
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Move the component to the RT_Shoulder point mark on the two-lane graph (the 
point marker “+” will turn white when you are on top of the connection point) and left-
click 

 

Your template should now look like what is shown below 

Use the Zoom In Y Direction icon  and the Zoom Out Y Direction icon  to 
change the vertical exaggeration of the template graph 
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12. To add the cut/fill end conditions, navigate to the End Condition folder and select  
the Simple Cut/Fill end condition 

Holding the left mouse button down, drag and drop the Simple Cut/Fill end 
condition to the RT_BOC point on the two-lane graph (Mirror option toggled On) 

You may want to zoom into the RT_BOC point 

Select the File>Save command from the Create Template dialog 
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  THE ROADWAY DESIGNER 

   

The Roadway Designer combines alignments, surfaces, and templates to create a 
model of the proposed roadway.  It is also where superelevation is created and 
applied to the design.  The Roadway Designer replaces the Roadway Modeler 
command and Roadway Libraries in previous versions of InRoads.  The file extension 
for the Roadway Design is .ird (InRoads Roadway Design). 

The Roadway Designer dialog has three different viewing areas.  They represent the 
plan, profile and cross section views of the design.  These views use their own 
graphics engine, like the Create Template dialog, and are not MicroStation views.  
The views only show what is related to the design, and not what is displayed in the 
MicroStation design file.  Each view can be manipulated separately and their contents 
are controlled by Corridor and Active Surface. 
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A Corridor is defined by using the Corridor>Corridor Management command.  To 
create a Corridor, simply name the Corridor, select a horizontal and vertical 
alignment, and the station limits of the project.  A single InRoads Roadway Design file 
(.ird) can store all the Corridors of a highway project.  The next step is to assign 
templates to the corridor.  This is accomplished using the Corridor>Template Drops 
command. 

The Template Drops command is used to assign previously created templates to 
specific stations in the Corridor.  The Template Drops command replaces some of the 
functionality in the Roadway Definition commands from previous version of InRoads.  
To create Template Drops, simply select the appropriate Template from the InRoads 
Template Library, the station where the Template is applied, and the modeling 
Interval.  The final result is a station and template list.  For the purposes of testing a 
newly created template, we will skip to the Corridor>Create Surface command, which 
is the last command in the Corridor commands. 

The Create Surface command combines the Corridor and Template Drops data to 
create a surface model of the Roadway Design.  The Create Surface command 
replaces the Roadway Modeler command found in previous versions of InRoads.   As 
in previous versions, the nose of the templates (X,Y=0,0) will ride on the horizontal 
and vertical alignment (3D flight path).  This will create a single surface consisting of 
the top surface of the Roadway Design and the subgrade Components, which will be 
“Exclude from Triangulation” points and children of the top surface.  Components can 
be displayed in cross sections and used for volume calculations. 
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> EXERCISE: USING THE ROADWAY DESIGNER 

1. Select the Modeler>Roadway Designer command 

2. Select the Corridor>Corridor Management command from the Roadway Designer 
dialog 

 

3. Set up the Manage Corridors dialog as follows: 

Click Add  

Click Close  
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4. Select the Corridor>Template Drops command 

 Navigate to the Templates folder and highlight the two-lane template 

 Setup the Template Drops dialog as shown below 

 Click Add  

 Click Close  
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5. Select the Corridor>Create Surface command 

Set up the Create Surface dialog as shown below 

Click Apply 

Click Close 

 

6. To save the Roadway Designer file, select the File>Save command from the 
Roadway Designer dialog 

Close the Roadway Designer dialog 
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> EXERCISE: CREATING CROSS SECTIONS 

1. Select the Evaluation>Cross Section>Create Cross Section command from the 
InRoads pull-down menus 

2. Setup the General options tab as follows 

 

3. Select the Include options tab on the left pane of the Create Cross Section dialog 

Toggle On the Components option 

Click Apply 

To create the cross sections in MicroStation, click on the MicroStation View where you 
want the lower left hand corner of the cross sections to appear 
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4. To view the cross sections, select the Evaluation>Cross Section>Cross Section 
Viewer command 

 
Click Close 
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LESSON NAME: CREATING TEMPLATE COMPONENTS  

LESSON OBJECTIVE: 
In this portion of the workshop, you will create individual template components.  
You will combine the newly created template components to develop a new 
template. 

CREATING TEMPLATE COMPONENTS 

There are five types of Template Components: Simple, Constrained, Unconstrained, 
Null Point, and End Condition. 

Simple  

A simple component typically represents a section of pavement.  A simple component 
is a closed parallelogram (4 points) that is defined by the slope and thickness.   

Constrained  

A constrained component can be an open or closed shape.  It consists of points that 
are all restricted to the movement of the first point.  A constrained point is typically 
used to manage the behavior of other points in the template.   When a point (parent) 
is moved, any constrained point (child) also moves.  This restriction only affects the 
offset and elevation (x,y) of the restrained point and, the relationship is unidirectional 
(movement of child point does not move the parent point).   

Unconstrained  

An unconstrained component is open or closed-shaped with no movement 
restrictions.   

Null Point  

A null point is a template point that is used as a reference for controlling other points.  

End Condition  

An end condition is a special open-shaped component that targets a surface, a 
feature of a surface, an elevation, or an alignment (it replaces the former Cut/Fill, 
Material, and Decision tables).  The integrity of end conditions can now be routinely 
tested while the roadway template is being created.  
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Once created, components can be modified as desired.  There is no limit to the 
number of points or components in a template.   

> EXERCISE: CREATING TEMPLATE  COMPONENTS 

1. Select the Modeler>Create Template command 

Highlight the Components folder 

Select the File>New>Template command 

Key in the name 10’ Two-Lane w/shoulder 

2. Toggle Off the Apply Affixes option in the Dynamic Settings dialog. 

3. Right-click on the empty 10’ Two-Lane w/shoulder graph and select the Add New 
Component>Simple command 

This will bring up the Current Component information fields below the graph 

 

 

 

 

 

 



2006 BE Conference  

© 2005-2006 Bentley Systems, Incorporated    27 

TEMPLATE CREATION FOR THE INROADS ROADWAY DESIGNER 

4. Setup the Current Component information fields as shown below 

If the Name: is blank, the component Name will use selected Style for the name 

 

     Right-click on the graph and check Off the Mirror option 

     Click on the Dynamic Origin on the 10’ Two-Lane w/shoulder graph  

The X, Y coordinates on the Dynamic Setting dialog will show X: 0.00 and Y: 0.00 

Click the Fit icon  at the bottom of the graph 

5. Right-click again on the 10’ Two-Lane w/shoulder graph and select the Add New 
Component>Simple command 

Setup the Current Component information fields as follows 
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Click on the right pavement edge on the first component as shown below (the “+” will 
become white when you are on top of the point) 

 

Use the Zoom Out icon  

6. Right-click again on the 10’ Two-Lane w/shoulder graph and select the Add New 
Component>Simple command 

Setup the Current Component information fields as follows 
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Click on the centerline bottom of the Bituminous lay on the top layer as shown below 

 

 

7. Right-click again on the 10’ Two-Lane w/shoulder graph and select the Add New 
Component>Simple command 

Setup the Current Component information fields as follows 
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Click on the right bottom pavement edge of the Bituminous lay on the top layer as 
shown below 

 

8. To create a single component out of each pavement layer, place your cursor on the 
vertical edge of pavement line of the component, as shown below 
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Right-click at that location and select the Merge Components command 

    
Repeat this procedure on the bottom pavement layer 
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9. To change the point names, double-click the centerline point as shown below 

Setup the Point Properties dialog as follows: 

Key in the Name: CL  

Change the Surface Feature Style: Centerline 

Click Apply 

   Click Next> 
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10. Finish changing the point names as follows: 

Clicking Next> will move to each point, starting from top to bottom and left to right 

Click Apply after you finish setting up each point Name and Style 

Click Close when you are done changing all the point names 

Name:     Surface Feature Style: 

CL     Centerline (done in last step) 

CL_Asphalt_Bot    Centerline 

CL_Aggr_Bot   Centerline 

EOP     EOP 

EOP_Asphalt_Bot  EOP 

EOP_ Aggr _Bot   EOP 

Shoulder    Shoulder 

Shoulder_Asphalt_Bot  Shoulder 

Shoulder_Aggr_Bot  Shoulder 

11.    Check On the Display Point Names option and review the components 

 

12.    Select the File>Save command from the Create Template dialog 
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> EXERCISE: CREATING END CONDITIONS 

1. Highlight the End Conditions folder 

Select the File>New>Template command 

Key in the Name: Fill Ditch 

Fill Ditch is now the Current Template 

 

2. To create the first point of the fill condition (-1:4 side slope for 20’), right-click on the 
Fill Ditch graph and select the Add New Component>End Condition command 

This will bring up the Current Component fields below the graph 

Setup the Current Component fields as shown below 
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Setup the Dynamics Settings dialog as shown below 

With the focus on the Dynamics Settings dialog (dialog Title Bar is blue), press the 
Enter button on your keyboard 

     

(X: and Y: readings, on the Dynamic Settings dialog, are the coordinates of your 
cursor on the graph and will vary for each person; the precision input with override 
these readings) 

3. To place the last point of the first segment, setup the Dynamic Settings dialog as 
shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 
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4. Right-click on the graph and select the Finish command (you can also execute the 
Finish command by pressing the Enter key on the keyboard, without using a right-
click) 

      

5. To create the second fill condition (-1:4 side slope for 25’), right-click again on the Fill 
Ditch graph and select the Add New Component>End Condition command 

This will bring up the Current Component fields below the graph 

Setup the Current Component fields as shown below 

Click on the Start point of the first segment on the Fill Ditch graph (X,Y=0,0) 
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6. To place the last point of the second segment, setup the Dynamic Settings dialog as 
shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

     Right-click on the graph and select the Finish command 

     

Use the Fit   icon to adjust your graph 

7. To create the third fill condition (-1:3 side slope for 30’), right-click again on the Fill 
Ditch graph and select the Add New Component>End Condition command 

This will bring up the Current Component fields below the graph 

Setup the Current Component fields as shown below 

Click on the Start point of the first segment on the Fill Ditch graph (X,Y=0,0) 
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8. To place the last point of the third segment, setup the Dynamic Settings dialog as 
shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

     Right-click on the graph and select the Finish command 

 

9. To create the forth fill condition (-1:2 side slope with guiderail), right-click again on the 
Fill Ditch graph and select the Add New Component>End Condition command 

This will bring up the Current Component fields below the graph 

Setup the Current Component fields as shown below 

Click on the Start point of the first segment on the Fill Ditch graph (X,Y=0,0) 
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10. To place the next point (-4% slope for 5’), setup the Dynamic Settings dialog as 
shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

 

11. To place the last point (-50% slope for infinite width), setup the Dynamic Settings 
dialog as shown below: 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

Right-click on the graph and select the Finish command 

      



2006 BE Conference  

© 2005-2006 Bentley Systems, Incorporated    40 

TEMPLATE CREATION FOR THE INROADS ROADWAY DESIGNER 

12. To create the first point of the Fill Ditch Component (-50% slope for 5’), right-click 
again on the Fill Ditch graph and select the Add New Component>End Condition 
command 

 This will bring up the Current Component fields below the graph 

 Setup the Current Component fields as shown below 

 Click on the Fill4 point on the Fill Ditch graph  

 

13. To place the next point on the Fill Ditch Component (-50% slope for 5’), setup the 
Dynamic Settings dialog as shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 
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14. To place the next point (0% slope for 5’), setup the Dynamic Settings dialog as 
shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

      

15. To place the last point (50% slope for infinite width), setup the Dynamic Settings 
dialog as shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

Right-click on the graph and select the Finish command 
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16. To create a cut condition (1:4 side slope with infinite width), right-click  again on the 
Fill Ditch graph and select the Add New Component>End Condition command 

This will bring up the Current Component fields below the graph 

Setup the Current Component fields as shown below 

Click on the Start point of the first segment on the Fill Ditch graph (X,Y=0,0) 

  

17. To place the last point (25% for infinite width), setup the Dynamic Settings dialog 
as shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

Right-click on the graph and select the Finish command 
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18.    To test the Fill Ditch End Condition, select the Test button below the graph 

This will bring up the Test End Conditions dialog 

Click the Draw button in the lower right-hand corner of the dialog 

Move your cursor up and down to test the Fill Ditch End Condition 

 

Change the Use Surface Slope angle to 20.00% and click the Draw button again 

Test the Fill Ditch End Condition again 

 

> EXERCISE: ASSEMBLING THE 10’ TWO-LANE W/SHOULDER TEMPLATE 

1. To create a new template, highlight the Templates folder 

Select the File>New>Template command 

Key in the name two-lane modified 

Check On the Display Point Names option 

Toggle On the Apply Affixes option in the Dynamic Settings dialog. 
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2. Drag and drop the 10' Two-Lane w/shoulders component from the Components 
folder to the Dynamic Origin of the two-lane modified template 

Right-click on the graph and Toggle On the Mirror option 

  

3. To add a clear zone segment (6% slope for 4’), right-click on the two-lane modified 
graph and select the Add New Component>Constrained command 

Setup the Current Component fields as shown below 

  

 Click on the RT_Shoulder point on the two-lane modified graph 
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4. To place the last point, setup the Dynamic Settings dialog as shown below 

With the focus on the Dynamics Settings dialog, press the Enter button on your 
keyboard to place the complete this segment 

 Right-click on the graph and select the Finish command 

          

 
 
 
 
 
 
 
 
 

 



2006 BE Conference  

© 2005-2006 Bentley Systems, Incorporated    46 

TEMPLATE CREATION FOR THE INROADS ROADWAY DESIGNER 

5. To add the end conditions, drag and drop the Fill Ditch end condition from the End 
Condition folder to the RT_Clear Zone point of the two-lane modified template 

The Mirror option should still be Toggled On 

 
 

6. Use the Test button to check the End Conditions. 
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> EXERCISE: USING THE ROADWAY DESIGNER WITH THE TWO-LANE MODIFIED TEMPLATE 

1. Select the Modeler>Roadway Designer command 

2. Select the Corridor>Corridor Management command from the Roadway Designer 
dialog 

3. Setup the Manage Corridors dialog as shown below 

Click Add  

Click Close  
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4. Select the Corridor>Template Drops command 

 Navigate to the Templates folder and highlight the two-lane modified template 

 Setup the Template Drops dialog as shown below 

 Click Add  

 Click Close  
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5. Select the Corridor>Create Surface command 

Set up the Create Surface dialog as shown below 

Click Apply 

Click Close 

 

6. To save the Roadway Designer file, select the File>Save command from the 
Roadway Designer dialog 

Close the Roadway Designer dialog 
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7. Use the Evaluation>Cross Section>Create Cross Section command to create 
cross sections 

8. Use the Evaluation>Cross Section>View Cross Section command to evaluate the 
two-lane modified design 
 


