
  

 

 

 
 
 
 
 
 
 

Workshop on the Bentley User Group Denmark meeting 2006 

 
 
 

Introduction to InRoads Roadway Designer  
Hands-on class sponsored by the Bentley Institute 

 
Presenter: Robert Nice 

 
 

Bentley Systems Sweden AB 
Gamla Brogatan 36-38 
111 20 Stockholm 
Sweden 
www.bentley.se  



BENTLEY USER DK MEETING 2006  

© 2005-2006 Bentley Systems, Incorporated    2 

INTRODUCTION TO INROADS ROADWAY DESIGNER

  



BENTLEY USER DK MEETING 2006  

© 2005-2006 Bentley Systems, Incorporated    3 

INTRODUCTION TO INROADS ROADWAY DESIGNER

LESSON NAME: WHAT HAS CHANGED 

LESSON OBJECTIVE: 
In this lesson the student will learn what changes have occurred in InRoads with respect 
to the Roadway Modeler and the new Roadway Designer.   In short the Define Roadway, 
Superelevation and Roadway Modeler have been replaced with the new Roadway 
Designer. 
On-Line Help Topic: Search on "Roadway Designer" 

> EXERCISE: GETTING STARTED 
This exercise will guide you through the steps to get started 
1. Go to Start>Programs>Bentley>InRoads Group v8.8>InRoads. 
2. When the MicroStation Manager appears select the file 

C:\BE Data\Civil\C1TNC106/data/C1TNC106.dgn and press OK. 
3. When InRoads appear go to File>Open from the InRoads menu. 
4. When the Open dialog appears select the file  

C:\BE Data\Civil\C1TNC106/data/C1TNC106.rwk and press OK. 
Opening the RWK file opened the following files. 
C1TNC106.alg 
C1TNC106.itl 
Original.dtm 
Civil.xin 

5. Select Modeler from the InRoads menu.  Notice that there are now only three 
options where there used to be many.  The new options are Create Template, 
Roadway Designer and Express Modeler. 

 
6. Select the ESC key to get rid of the menu. 
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LESSON NAME: NAVIGATING THROUGH THE CREATE TEMPLATE COMMAND 

LESSON OBJECTIVE: 
This lesson will take you through how you would navigate the Create Template 
command.  
On-Line Help Topic: Search on “Create Template” 

> EXERCISE: NAVIGATING TEMPLATES 
This exercise will take you through how templates are created and how the new 
Create Template command works. 
1. From the InRoads menu go to Modeler>Create Template. 
2. When the Create Template command opens you will see in the left had pane 

what template library is loaded. 

 
3. Double click on the library name to expand it.  You should now see three 

folders called Backbones, End Conditions, and Templates. 
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4. Double click on the Backbones folder.  You should now see two different 

backbones. 

 
5. Double click on the backbone called Two Lane.  You should now see the 

backbone in the right hand window. 

 
6. Double click on the End Condition Folder and then double click on each end 

condition. 
7. Double click on Fill_With_Ditch and select the Test button on the lower right 

side of the Create Template dialog. 
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8. When the Test End Condition dialog appears enter -10% in the Use Surface 
Slope field. 

 
9. Select the Draw button and move your cursor around in the window.  Note 

what the end condition is doing. 
10. Select Reset. 
11. Change the Use Surface Slope field to 10% and select the Draw button again 

and see how the end condition reacts. 
12. Close the Test End Conditions dialog. 
 
 

LESSON NAME: BUILDING TEMPLATES 

LESSON OBJECTIVE: 
This lesson will take you through how you would build a temple with the Create Template 
command.  
On-Line Help Topic: Search on “Create Template” 

> EXERCISE: BUILDING TEMPLATES 
This exercise will take you through how templates are built and how the new 
Create Template command works. 
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1. Right click on the Templates folder and select New and then Template. 

 
2. When the template is created type in the name 2Lane and then press the 

Enter key.  You now have a template called 2Lane, however, it is an empty 
template. 

3. From the menu on the Create Template dialog select Tools>Dynamic 
Settings 

4. When the Dynamic Settings dialog appears set the X and Y Step to 0.1.  
Leave this dialog up but move it over to the side. 

5. From the menu on the Create Template dialog select Tools>Options. 
6. When the Options dialog appears turn on the Apply Affixes and key in the 

following: 
Left Prefix:  L_ 
Right Prefix:  R_ 
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7. Select OK. 
8. Drag the Two Lane template from the Backbone section of the Template 

Library. 
9. While holding the left mouse button down click the right mouse button and 

select Mirror if it is not already checked. 

 
10. Make sure the green cross hairs line up inside the small square and then let go 

of the left mouse button.  Your new template should look like the following. 
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Hint If you make a mistake you can select Edit>Undo to back up. 

11. Next drag and drop the Combined end condition onto the top right point of the 
subgrade. 

 
12. Test the template. 
13. Right click on the vertical lines between the left and right backbone and select 

Merge Components. 
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14. Now you have a finished template. 
15. Create a 4Lane template using the Four Lane backbone and the Combined 

end condition. 
 

 

 

 

 

 

 
 
 

LESSON NAME: BUILDING A CORRIDOR 

LESSON OBJECTIVE: 
This lesson will take you through how to setup and apply the templates that you built to a 
corridor. 
On-Line Help Topic: Search on “Roadway Designer” 

> EXERCISE: BUILDING CORRIDORS 
This exercise will take you through setting up a corridor in Roadway Designer. 
1. From the InRoads menu go to Modeler>Roadway Designer. 
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When the Roadway Designer opens you will see three panes in the window. 
The top left pane is the plan view.  The bottom left is the profile view.  The right 
pane is the cross section view. 

 
2. To create a corridor select Corridor>Corridor Management from the menu 

on the Roadway Designer. 
3. Enter Route1 in the Name field and select Add. 
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4. Close the Corridor Management dialog. 
5. On the Roadway Designer dialog click the Fit on the plan and profile panes.  

You should now see the plan view of the alignment and the profile view of it. 
6. To apply templates to the corridor go to Corridor>Template Drops. 
7. Key in 12+34 in the Station field for the first station. 
8. Set the Interval to 10.00. 
9. Expand the Library Templates tree and highlight the 2Lane template you 

created. 
10. Select Add. 

 
11. Key in station 25+00 and select the 2Lane template again and select Add. 
12. Add the following template drops: 

Station 30+00 Template: 4Lane 
Station 55+00 Template: 4Lane 
Station 60+00 Template: 2Lane 

13. Close the Template Drops dialog. 
14. Select the Process All button. 
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LESSON NAME: TEMPLATE TRANSITIONS 

LESSON OBJECTIVE: 
This lesson will take you through how to handle template transitions that you defined in 
the corridor. 
On-Line Help Topic: Search on “template transitions” 

> EXERCISE: TEMPLATE TRANSITIONS 
This exercise will take you through defining template transitions.  The reason you 
will need to define transitions is because when transitioning between one template 
and a template that has more segments in it the Roadway Designer does not 
know how to connect the segments.  This is because there may be more than one 
way to connect them. 
1. From the Roadway Designer double click on the west yellow shape in the 

plan view.  This will bring up the Edit Transition dialog. 

 
2. To edit the transitions click on the bolded tic mark and then connect it to the 

desired transition location by clicking on it. 
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3. Finish defining the transitions. 
4. Select OK. 
5. Now you see the cross section view that is half way trough the transition. 
6. At the bottom of the Edit Transition Midpoint dialog you will see a slider bar.  

Try moving the bar to the left and right.  Is anything happening? 
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7. The reason nothing is happening is because of the constraints on the template 

points.  To modify the constraints right click on the right lane line point and 
select Edit point. 

 
8. In the Point Properties dialog set the Constraint 2 to None. 
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9. Select OK.  
10. Try sliding the Transition bar again.  What is happening? 
11. Correct the constraint on the left lane line point. 
12. When completed click OK on the Edit Transition Midpoint dialog. 
13. Correct the west transition with the same steps as above. 

 
 
 
 
 
 
 
 
 
 
 
 

LESSON NAME: EXAMINING THE CORRIDOR 

LESSON OBJECTIVE: 
This lesson will take you through how to navigate through the corridor. 
On-Line Help Topic: Search on “Roadway Designer” 

> EXERCISE: CORRIDOR NAVIGATION 
This exercise will take you through the navigation tools in the Roadway Designer. 



BENTLEY USER DK MEETING 2006  

© 2005-2006 Bentley Systems, Incorporated    17 

INTRODUCTION TO INROADS ROADWAY DESIGNER

1. From the Roadway Designer click on the Process All button. 
2. At the bottom of the Roadway Designer dialog there is a station value with 

advancing arrows on either side of it. 

 
3. Clicking on the arrows move along the stations. 
4. Notice in the plan view and the profile view there is a yellow line across the 

alignment and the profile.  This line represents where the cross section view is. 
5. Double click in the plan view.  Notice that the line moved to the place on the 

alignment that was orthogonal to your double click. 
6. Try the same in the profile view. 
7. Now using your left mouse button click and hold on the yellow line in the plan 

view and drag it along the alignment. 
8. Try the same in the profile view. 

LESSON NAME: SUPERELEVATION 

LESSON OBJECTIVE: 
This lesson will take you through how to setup superelevation. 
On-Line Help Topic: Search on “Superelevation” 

> EXERCISE: SUPERELEVATION 
This exercise will take you through defining and setting up superelevation. 
1. On the Roadway Designer click the Display Superelevation button on the 

bottom right of the dialog. 
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2. The top left pane is the plan view.  The bottom left pane is the cross section 
view.  The top right pane is the profile view and the bottom right pane is the 
superelevation diagram. 

 
3. To set up super elevation we must first calculate the superelevation rates.  

Right click on the superelevation diagram pane and select Create 
Superelevation Wizard>AASHTO.  This will bring up the AASHTO Wizard. 

 
4. First we need to compute the rates.  Click the Rate Calculator button. 
5. When the Rate Calculator appears Edit each record and set the design speed 

to 55. 
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6. When editing is complete select Apply and then Close. You will be returned to 

the AASHTO Wizard. 
7. Move the yellow navigation line to somewhere where the 2Lane template 

exists. 
8. Select Next. 
9. Select Add. 

10. When the Add SuperElevation Section dialog appears select the   button 
beside the Crown Point field and select the crown point in the cross section 
view. 

11. Do the same for the Left Range Point and Right Range Point by selecting 
the edges of pavement. 

12. Turn on the Station toggle and key in the 12+34 for the Start and 25+00 for 
the Stop. 
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13. Move the yellow navigation line somewhere where the 4Lane template 

exists. 
14. Repeat the process for identifying the points and set the station range to 

25+00 through 60+00. 
15. Move the yellow navigation line somewhere where the 2Lane template 

exists. 
16. Repeat the process for identifying the points and set the station range to 

60+00 to 75+12.802.  Don’t forget to move the yellow navigation line to the 
2Lane section. 

17. Your Superelevation Section Definitions should look as follows: 
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18. Select Next. 
19. Select Finish. 
20. Select Process All. 
21. Spend some time navigating through the panes and looking at the model. 

Notice in the plane view that the cross slope is denoted by colors. 

 
 
 
 

LESSON NAME: GENERATING A SURFACE MODEL 

LESSON OBJECTIVE: 
This lesson will take you through how to generate a surface from your roadway design. 
On-Line Help Topic: Search on “Create Surface” 
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> EXERCISE: CREATE SURFACE 
This exercise will take you through defining and setting up the Create Surface 
command. 
1. On the Roadway Designer click the Corridor>Create Surface. 
2. Set or enter the following values: 

Name:    Design 
Empty Design Surface: On 
Add Exterior Boundary: On 
Style:    Exterior Boundary 
Triangulate:   On 

 
3. Click Apply. 
4. Click Close. 
5. Collapse the Roadway Designer. 
6. From the InRoads menu select Surface>View Surface>Features. 
7. Set the Surface to Design. 
8. Click Apply. 
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9. Click Close. 
10. Using MicroStation examine the features displayed in the DGN file. 

 


