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Introducing InRoads 

Welcome to InRoads®! The latest in transportation engineering software by Bentley Systems, 
InRoads is a one-stop solution for transportation engineers and civilworks professionals. InRoads 
provides a comprehensive set of tools for transportation system design, civil and site engineering for 
roadways, highways, waterways, and airports. Developed using the familiar Microsoft® Windows®, 
standards, InRoads runs on the Windows 2000 Professional and Windows XP Professional 
operating systems. 

InRoads lets you work in a graphic environment to create a 3-D digital surface, create horizontal and 
vertical alignments, cut profiles, define template criteria and roadway conditions, generate cross-
sections and 3-D model, calculate volumes, generate reports, evaluate the design, and create plan 
and profile sheets.  These extensive features, along with additional application add-in tools, make 
designing a complex highway system or simply laying out a small subdivision an interactive and easy 
process. 

With InRoads, you can continue using the computer-aided design (CAD) platform with which you are 
familiar. When starting the product, you can select AutoCAD® 2004, 2005, or 2006, or MicroStation 
V8® 2004 Edition and MicroStation V8® XM Edition, as your CAD engine.  This multiple CAD 
environment is a hallmark feature of civil engineering solutions by Bentley Systems. 

InRoads and the Bentley InRoads Group 
The InRoads product group consists of a single source tree of civil engineering applications 
designed to run on MicroStation or AutoCAD.  This single source tree approach provides 
unprecedented integration among individual products allowing a single installation regardless of 
which product is used and complete data integration across all products. 

A single installation of InRoads provides access to any InRoads product based on the license key 
provided.  The complete InRoads group consists of the following products:  
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• InRoads Survey 

• PowerSurvey 

• InRoads Storm & Sanitary 

• InRoads Bridge 

• InRoads Site 

• InRoads 

• Bentley InRail 

• InRoads Site Suite 

• InRoads Suite 

• Bentley InRail Suite 

• MicroStation Civil Extension - InRoads 

InRoads Survey – Provides data transfer and reduction from total stations, GPS, and other raw data 
sources.  InRoads Survey includes a complete set of tools for adjustments, data analysis and editing 
of raw input data.  Also included are tools for coordinate geometry and DTM display.  InRoads 
Survey allows you to save data in geometry and DTM file types for further usage by other 
applications within the InRoads product group.  InRoads Survey does require that a copy of 
MicroStation or AutoCAD be present on the local machine.  

PowerSurvey – Is the same product as InRoads Survey with the exception that it contains its own 
graphic engine (Bentley’s PowerDraft). It does not require MicroStation or AutoCAD.  

InRoads Storm & Sanitary (S&S) – Provides the ability to create physical 3-D models of storm, 
sanitary or combined sewer systems within the MicroStation or AutoCAD environment.  DTMs and 
alignments or precision key-in can be used to create the models.  S&S provides the ability to analyze 
or design these systems, create plan, profile and plan and profile drawing sets, and detailed 
reporting of analysis, bill of materials or user-defined reporting of any attributes of the system.  S&S 
includes a complete set of hydrological tools and pond routing tools. 

InRoads Bridge – Provides a complete set of tools for defining bridge geometry and extruding 
models along that geometry.  InRoads Bridge provides the ability to report on clearances, girders, 
beams, screed elevations, placement locations and so on.  Steel (AISC) and concrete (AASHTO) 
members are supported as well as many user-defined shapes.  

InRoads Site – Provides tools for coordinate geometry, horizontal and vertical alignments, DTM 
creation and analysis, ROW, lot and parcel creation, plan and profile creation and many more design 
tools.  InRoads Site is designed to meet all of the site designers’ needs.  

InRoads - InRoads is the flagship product of the InRoads product group and is a complete roadway 
design solution.  It contains simple (PI method) and complex (design by elements) geometric design 
capabilities and DTM creation, analysis and viewing including hydrologic analysis.  InRoads also 
contains the ability to form 3D models relative to horizontal and vertical geometry by applying a set of 
rules and decisions (templates) to those alignments and applying those decisions to DTMs and 
intelligent features.   InRoads further provides all the tools necessary for extraction of cross sections 
and profiles and creation of finished drawings.  InRoads provides a robust set of reporting tools.  
InRoads does contain all the functionality of InRoads Site.  

Bentley InRail  – Is an extension of the InRoads product for the rail industry.  Bentley InRail  
contains all the functionality of InRoads plus additional curve transitions such as half-sine, bi-
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quadratic, Bloss and more.  Bentley InRail includes rail switch and cross-over libraries for AREA, 
German Rail and others.  You can also create custom libraries. Bentley InRail includes a module for 
light rail manufacturing to support the creation and detailing of light rail hardware. It also contains 
special tools for tunnel analysis.  

InRoads Site Suite – Is a single product containing all the functionality of InRoads Site, S&S and 
InRoads Survey.  

InRoads Suite – Is a single product containing all the functionality of InRoads, InRoads Bridge, 
InRoads Site, S&S and InRoads Survey.  

Bentley InRail Suite – Is a single product containing all the functionality of Bentley InRail, InRoads, 
InRoads Bridge, InRoads Site, S&S and InRoads Survey. 

MicroStation Civil Extension - InRoads – Is a limited set of civil design and production tools to 
create advanced coordinate geometry, perform horizontal and vertical alignment design, create and 
review digital terrain models.  Civil Extension allows you to perform a wide range of plans production 
activities. 
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InRoads: What’s New? 
In this release, InRoads offers several new commands and enhanced features: 

  General Enhancements 

• Added MicroStation XM to the list of supported CAD platforms including 
MicroStation 2004 Edition and AutoCAD 2004\2005\2006.  

• Added support for ProjectWise XM when used with MicroStation XM. 

  File Menu  

• Modified the Open dialog to display all InRoads format files by default. 

• Added a toggle to Import Surface from Graphics that imports only the vertices 
of the target element (not every triangle crossing point on elevations from 
surface). 

• Import > Surface Advanced. Added Vertices Only to Import Surface Advanced 
> Import Rule > Process Settings > General. 

• Import > Surface > Surface Advanced > Rules > Edit Import Rule > Cell 
Names. Now displays the cells in the design file in the Available List. 

• Translators > Import SRV. Added a Parent field to designate the Parent on the 
features. 

• Translators > Import AMSA. Replaced numeric codes 1-10 with point numbers 
301-310. 

• Import > LAS Data. Added the ability to add additional files to the same feature. 

• File > Project Defaults. Added a prompt to confirm deletion when selecting the 
Delete button. 

  Surface Menu 

• View Surface > Components. Components can now be selectively chosen for 
display. 

• Edit Surface > Delete Feature Points. Added a fence option. 

• Feature > Feature Selection Filter. Added the ability to filter based on 
Component Name. 

• Edit Surface > Edit Feature Point. Highlighted points now persist when views 
are changed during Feature Point Edit. 



June 2007  Bentley InRoads Roadway Designer Tutorial                                                                                               
 

Bentley Systems, Incorporated                                                                   5 

 

  Geometry Menu 

• View Geometry > Stationing > Cardinal Stations. Added the ability to place point 
abbreviation before and after station annotation. This is enabled with a setting 
in the Tools > Variable Manager. 

• View Geometry > View Vertical Annotation > Curves > Circular Curve. Added 
Tangent Slope Distance to this tab for both tangents. 

• Utilities > Assign Names > Alignments. Added a method to interactively rename 
alignment points. 

• View Geometry > View Active Vertical Alignment and Vertical Annotation.  
Changed the element type to Polyline from 3D Polyline for vertical alignments in 
AutoCAD. 

• View Geometry > Stationing. Added an option to planarize stationing. 

• View Geometry > Vertical Annotation. Added an option to place vertical 
alignment annotation at a constant offset from the top of profile grid. 

• View Geometry > Vertical Annotation. Added the ability to annotate vertical 
point of beginning (VPOB) and vertical point of ending (VPOE).  This is enabled 
with a setting in the Tools > Variable Manager. 

Bentley InRail and Bentley InRail Suite 

• View Geometry > Rails. Added the ability to create a surface from the rails. The 
Append to Surface option creates a feature in the surface with the name of the 
alignment and overwrites any existing feature with the same name. 

• Horizontal and Vertical Regression > View Regression Points. Display 
Unacceptable Slew Points has been added to both commands. This 
displays/annotates points that have a value larger than the Acceptable Slew. 

• Single Horizontal and Vertical Element Regression. These commands now 
allow dynamic element adjustments. 

• Horizontal Regression > Horizontal Curve Diagrams. Additional design 
information can be plotted including Slews, Cant and Elements. 

• Horizontal Regression > Convert Rails to Centerline.  Enhanced the creation of 
horizontal, vertical and cant alignments from the rail data. 

• Superelevation > Compute Cant from Existing. Added a command to make use 
of the existing cant alignment created in the Convert Rails to Centerline 
command. 

• Turnouts > Create Turnout. Added Diamond Crossings as Type conforming to 
United Kingdom rail practice as defined in the Track Design Handbook. 

• Turnouts > Create Switch & Crossing Connection. Now allows creation of 
turnout – connection – turnout where the two turnouts are positioned based 



Bentley InRoads Roadway Designer Tutorial  June 2007 

                                                                                                                         

6  Bentley Systems, Incorporated 
 

upon a known length. 

• Light Rail Manufacturing > Annotate Rail Offsets. Added the capability to 
annotate the offset from a control baseline to near rails. 

  Drainage Menu 

• Drainage > Edit/Review > Inlet > Gutter tab. Added locate buttons for the slope 
fields. 

• Drainage > Network > Renumber. Areas can now be renumbered. 

• Tools > Drainage > Structures File. The Drainage Structures File and the Sizes 
dialog boxes are now re-sizeable. 

• Structure > Extend Culvert in Profile. Added the ability to extend Free Entrance 
and Free Exit ends of Pipes and Channels.  

  Survey Menu 

• Survey to Surface. Added an option for Parent to identify data moved to the 
surface at the time of the command's execution. 

• Import Survey Data > TSS. When using the convert.exe on the TSS import, the 
intermediate file (if specified) is used; otherwise, the TMP environment variable 
is used. 

• Fieldbook Data. Added the ability to do point comparisons in the fieldbook, 
along with comparing check shots to backsights. 

• Network. The dialog portions can now be independently resized. 

• Fieldbook Data. The station and observation portions can be independently 
sized. 

• Fieldbook Data. Added the ability to display Attributes and/or Notes in the lists 
for stations and observations. 

• Fieldbook Data. Added the ability to edit survey attributes once they are defined 
(the attribute name, type, description). 

• Inverse Survey Data. Added the ability to report directions as bearings. 

• Survey Data to Surface. Added the ability to replace existing features in a 
surface that already exist with Append, Replace or Rename. 

• Rotate Graphics on Dual-Coded Survey Points. Added the ability to rotate cells, 
symbols, and custom operations on dual-coded points relative to the first code 
on the point. This is enabled with a setting in the Tools > Variable Manager. 
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  Evaluation Menu 

• Create Cross Sections > Include. Added an option to adjust cross section vertical range 
for non-triangulated crossing features. 

  Modeler Menu 

• Create Template. Added the capability to unmerge component points. 

• Superelevation sections can now be renamed. 

• Roadway Designer > Superelevation Wizard > Table Method. Added an Edit 
button on the Superelevation Sections Definitions dialog. 

• Create Template > Library View. Enabled the F2 key to the rename function for 
folders and templates. 

• Create Template > Apply Feature Name Overrides. Now displays points that 
have an override in red in the list box. 

• Create Template. Provided a mechanism to select the components to merge 
when there are multiple coincident components. 

• Create Template. Provided a mechanism to select the point to merge when 
there are multiple coincident points. 

• Create surface > Alternate Surface option. Implemented an exterior boundary 
for these surfaces. 

• Roadway Designer. Added a status bar indicating Template change. 

• Create Template. Added an option to delete the constraint on all points in a 
template. 

• Roadway Designer. Added the display of horizontal and vertical cardinal points 
on plan and profile views. Hovering cursor shows point names and stationing. 

• Create Template. Added the ability to break a component into two components. 

  Drafting Menu 

• Place Coordinate Grid.  Added this option for the creation of a plan coordinate 
grid for drawings. 

• Place Notes. Added Keywords for Pay Item Name, Pay Item Code, Pay Item 
Description, Pay Item Unit. Also added Keywords for Pay Item Block and Pay 
Item Endblock so that multiple pay items on a single feature can be annotated. 
For example: {PAYITEM_BLOCK} {PAYITEM_UNIT} {PAYITEM_CODE} 
{PAYITEM_ENDBLOCK} 

  Tools Menu 

• Named Symbology > Points. Cell levels can now be maintained or overridden 
with a setting in Variable Manager. Previous versions of InRoads placed cells 
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on the level defined in the Point Symbology and ignored the levels defined in 
the cells. Now if the setting is set to Retain Cell Levels, the level field in Point 
Symbology is grayed out. 

• Survey Options > General > Chord Height.  Option has changed to disallow the 
value of zero, and to show all significant figures. Previous preferences with less 
than zero are set to 0.0001. 

• Options > Tolerances.  Option has changed to disallow the value of zero, and to 
show all significant figures. Previous preferences with less than zero are set to 
0.0001. 

• Style Manager> New Style.  Modified the command so that after clicking Apply 
on the dialog, the name is cleared for another new style to be created. 

• Tracking > Tracking. Change the Symbology button name to Settings. 

• Tracking > Symbology > Settings. Rearranged the settings for Point and Text 
Named Symbology. 

• Added the ability for Horizontal Tracking to also track in the profile and for 
Vertical Tracking to track in the horizontal. This is enabled with a setting in the 
Tools > Variable Manager.  

Experienced users will continue to find advanced programming features such as the Run Macro 
command that allows software customization for specialized environments.  

About Your Documentation 
To assist the beginning through advanced user, InRoads provides three complementary forms of 
documentation: 

•   Tutorial. This introductory material provides step-by-step instructions for learning how to create a 
new roadway design surface. The tutorial is delivered with the product in PDF format. 

•   Bentley InRoads Help.  Delivered with the product in HTML format, this comprehensive online 
reference material consists of help topics that detail each command and dialog box parameter 
within the product. 

•   Bentley InRoads Group XM Reference Guide. Available, by free download (for SELECTservices 
customers), in PDF format. This document contains all InRoads help topics. It is available to all 
customers in printed form by purchase only. 
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Product Training: Learn It Your Way 
In addition to the documentation provided with your software, the Bentley Civil InRoads Group, in 
conjunction with Bentley Institute, offer various levels and methods of product training. For training 
facility information or a complete listing of training courses, visit the Bentley Systems website at 
http://bentleyinstitute.bentley.com/. 
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Typeface Conventions Used in InRoads 
Documentation 

 
ALL CAPS Keyboard keys 

If keys are separated by a comma, press them in sequence.  For 
example:  ALT,F5.  If they are joined by a plus sign, press them at the 
same time. 

For example:  CTRL+z. 

Bold 
Unserifed 
Type 

An item in the graphical interface, such as the title of a dialog box or a 
tool.  Paths through menus use right angle brackets between items you 
click. 

For example:  Click File > Open to load a file. 

Courier 
Type Information you type. 

For example:  Type breaklines.dat  in the dialog box field. 

Italic type A document or section title, the first occurrence of a new or special 
term, directory and file names, or information about what the software 
is doing. 

For example:  The civil.xin file contains preference settings. 
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What You Need to Know Before Working with InRoads 
While InRoads is a comprehensive design package, it is also an intuitive product in which a new user 
could become productive in a short time with some assistance.   

The documentation and tutorial in InRoads assume that you have: 

•   A basic understanding of the computer operating system 

•   The ability to move around in the Windows environment 

•   Working understanding of your CAD system 

•   General knowledge of engineering concepts and terms 
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1 Getting Started 

InRoads can be installed on Intel-based hardware using the Windows 2000 Professional or Windows 
XP Professional operating system. The following instructions assume that you have already installed 
one of these operating systems on your machine.  You must also have installed CAD software on 
your machine.  InRoads will run on AutoCAD 2004/2005/2006 and MicroStation V8 2004 Edition or 
XM Edition.  See the CAD Package Requirements section that matches your operating system for a 
list of software tools. 

In Windows 2000 and Windows XP 
This section details what you need to efficiently run InRoads. 

CAD Package Requirements 
• CAD software (one of the following): AutoCAD versions2004/2005/2006, and MicroStation V8 

2004 Edition or XM Edition. 

• Pentium 200 Mhz minimum, 400 Mhz or more recommended 

• 512MB memory or more recommended 

• 310MB free disk space or more recommended 

• VGA or better 

• Access to a CD-ROM drive 

• Mouse or compatible digitizer for input 

• Compatible plotter or printer for output (optional) 

Downloading from the CD 
Prior to installing InRoads, make sure you have exited all other civil engineering software. In 
Windows 2000, the setup program automatically starts when the CD is loaded. If Autoplay is not 
enabled on your system, follow the steps below. 

1. Insert the CD in your CD-ROM drive. 

2. From the Start menu, click Run. 

3. In the Run dialog box, type d:\install.html, where d: is the letter assigned to your CD-ROM drive. 

4. Click OK and follow the instructions on the screen. 
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Downloading Across the Network 
If you are downloading InRoads across a local area network, mount the shared network CD drive 
and double-click on install.html from the InRoads Explorer or File Manager. Or, navigate to the 
product directory and run Setup.exe. 

Starting InRoads 
Once you have successfully downloaded the software, you are ready to start the product. 

1. From the Start menu, click Start > Programs > Bentley >  InRoads Group XM > InRoads. 

2. MicroStation users must first select a design file.  Navigate to a design file or demonstration 
directory and select a file or create a new one. 

         AutoCAD automatically opens with a default drawing file at startup. 

The InRoads menu is displayed. 

  

You have successfully installed InRoads, selected your CAD platform, and opened a drawing/design 
file. 

Exiting InRoads 
To exit InRoads and leave the CAD software running, select File > Exit from the InRoads menu. 

To exit InRoads and the CAD software, select File > Exit from the CAD main menu.   If you exit the 
CAD software prior to exiting InRoads, the product will also exit.  You are prompted to save any open 
files. 
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Using InRoads 
An Overview 

From project definition to plan and profile sheet creation, InRoads provides the tools you need to 
create highways, roads, and other construction and transportation engineering projects. In addition, 
several add-in applications are available to assist you in completing specific civil engineering 
production tasks. The advanced programming tools offer ways to customize your work environment 
to accomplish unique tasks or meet customer deliverables.  

Starting with geometric, alignment, and surface point data, you can do the following: 

• Graphically represent the base map ground surface, topographic features, and property 
boundaries. Display and analyze surface contours, slope vectors, and other terrain data. 

• Review existing or legacy plans to identify new controls. Through an iterative process, generate 
preliminary plan sheets, create new horizontal and vertical alignments, specify roadway 
templates and design file criteria. You can also compute volumes and generate reports. 

• Generate a 3-D model of the design. Generate cross-sections, compute triangle volumes, 
calculate end-area volumes, make modifications, and redesign as needed to meet 
specifications. 

• Prepare and plot plan and profile drawings. Generate final reports for production requirements or 
customer deliverables. 

The results of your project can be stored for future use and integrated with other Bentley Systems 
civil engineering and GIS industry solutions. 

Basic Concepts in InRoads 
There are a few concepts to review prior to using InRoads. Some of these concepts concern tools 
that provide more flexibility in the way you work, such as customized toolbars. Others are simply 
ways of thinking about features, preferences and symbology: how they interact with each other and 
how they function within the DTM. The next several topics discuss basic concepts in InRoads. 
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Digital Terrain Model 
A computerized model of a 3-D ground surface is a visual representation of triangle and point data. 
This data, in x,y,z numerical coordinates, defines the Digital Terrain Model (DTM), also commonly 
referred to as a surface.  

        
 

In InRoads, the DTM remains an integral and important part of your project. Feature data resides in 
the DTM and profiles, cross-sections, volumes and other design analysis and computations are 
performed on the data in the DTM. This functionality allows you to place features, execute 
commands, view surface properties, make design modifications all in the design surface. The DTM 
requires fewer interactions with graphical menus and dialog boxes while expanding the function 
and definition of the traditional design feature. 

Types of DTM Display 
In the InRoads project, surface representation and features can be displayed in three different 
views or modes: 3-D Planimetric, Profile, and Cross Section. 

• 3-D planimetric view, commonly referred to as plan, is a top-level aerial view of the entire 
surface. 
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This view allows you to see any of the point types (random, breakline, contour, and so on) in 
the digital terrain model. 

 
• Profile is an extracted side view of the vertical elevation of a surface along an entire active 

horizontal alignment (or just a portion of it).  A legend, correlating surface line symbology, 
surface name and the scale used on the profile, can also be displayed. 

  
• Cross Section is a portion of the roadway model at a specified location. Displayed in individual 

graphic windows, each section shows surface configurations perpendicular or at a skew angle to 
a linear feature, such as the horizontal alignment (often the centerline of the roadway). Cross 
sections differ from profiles in that they show detailed sections of the surfaces, from one station 
to the next transverse to an alignment; profiles show surface elevations longitudinally along an 
entire alignment. 

  

Together, these display modes allow you to view, evaluate, and design your project from various 
important perspectives. Objects in the DTM can be represented in one view or all of these views.  
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Symbology 
Symbology (line style, weight, color and so on) can be defined for any surface object or feature. 
Uniquely specifying symbology for objects or features allows for quick identification within the model 
as well as uniformity across the project. In InRoads, symbology can be set in three ways: named 
symbology using the Name Symbology Manager, Named Symbology Tools, and basic command-
level symbology. 

Named Symbology Manager 
The Tools > Named Symbology Manager allows you to define and name symbology settings for 
surface objects and features. These settings, along with many other preference settings, are stored 
in the *.xin preference file. This customizable file contains basic default settings, including 
predefined symbology, and is delivered when you install InRoads. These predefined symbology 
settings are displayed when you access Named Symbology Manager. 

  

By clicking New, you can define additional symbology. 

  

New symbology is first given a name. Providing a name allows you to associate the symbology with 
a feature or object and later reference the symbology by this name. 
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By double-clicking on an item or selecting the item and clicking the Edit button, you can set 
symbology for lines, text, and points in one or all three of the views. 

  

Once you have defined symbology for more than one representation (line, point or text) or for more 
than one view (plan, profile or cross section), you actually have a set of symbology. In Named 
Symbology Manager, you create named symbology sets. 
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Defined symbology is considered initialized after you click Apply. Default symbology applies when 
specific symbology for plan, profile or cross section is not defined. If default symbology is not 
defined, the system settings delivered with InRoads apply. 

  

For more details about this command, see the Named Symbology Manager online help topic.  

Named Symbology Tools 
•  The Tools > Named Symbology Tools provides various methods of managing existing named 

symbologies. The following commands are not available when running AutoCAD.  

•  Verify Named Symbology. Use this command to verify the existence of fonts, text styles, line 
styles, levels and/or cells defined in named symbologies. When you click OK, this command 
prints a report showing you the named symbologies that have levels and/or cells not found. 

•  Global Named Symbology Edit. Use this command to change all occurrences of a particular 
value in the .xin file. An example is text height and width. 

•  Export Named Symbology to CSV. Use this command to export named symbologies to a file 
(or files) you designate. Recall that a named symbology stores a large set of parameters that 
define exactly how a point, line, or piece of text will appear in plan view, in profiles, and in cross 
sections.  
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•  Import Named Symbology from CSV. Use this command to import named symbologies into 
the Named Symbology table in the .xin file from separate line, text, and point files, or from one 
file. A named symbology stores a large set of parameters that define exactly how a point, line, or 
piece of text will appear in plan view, in profiles, and in cross sections. 

For a more detailed description of these commands, see the associated topics in online help. 

Command-level Symbology 
While InRoads provides the opportunity to name symbology, you are not required to do so. You can 
continue to select local symbology at any time. You can also use the Preferences button that 
appears on most dialog boxes to create or modify basic preferences at any time. For example, 
Surface > View Surface > Triangles. 

  

Features in the DTM 
In InRoads, features are key to the design process. A feature is a unique instance of an item or 3-D 
entity that is represented in the DTM by lines, points, or text. A line is actually a linear segment. 
Points can be represented as symbols or cells. Annotation is considered text. The following are 
examples of common road design features: 

• A single random point 

• A single interior boundary 

• A flowline 

• A single curb line 

• A single utility (pipe, pole, manhole) 

• A collection of utilities (poles, manholes) 

A feature then is any single component that is part of the DTM. Further, for features such as 
random points, you can store more than one random point feature type in a DTM. This flexibility 
allows you to control the display of the random points in the surface separately from other features, 
such as manholes. 

In InRoads, features can be created or imported into the DTM with a level of “intelligence”; that is, 
they know what they are and how they are to display. 
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Intelligent Features 
Whether you begin your design by using Surface > Design Surface > Place Feature or File > 
Import > Surface, you can indicate what a feature is before it becomes a part of the active surface. 
You can provide a feature name and description, select a feature style, indicate the point type, and 
specify whether or not it is to be triangulated. 

                

All of this information is associated with the feature and available for quick reference once it 
becomes a part of the surface. 

The key to working with features in the surface is determining how the features will display. How a 
feature is represented and where it displays can be specified by a style. Feature styles are created 
and organized by the Style Manager. 

Style Manager 
A style uniquely defines how a feature is represented and determines the symbology for its display. 
Once defined, the style is one-to-many; meaning any one style can be used to display many 
features. For example, a style for centerline could be used for both the roadway centerline as well 
as for any other secondary road centerline. Once styles are created, they can be used by all areas 
of the product: Surfaces, Geometry, and Survey. 

When you select Tools > Style Manager, any predefined styles currently in the.xin preference file 
are displayed.  
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Click New to create additional styles. 

 
A style includes a unique name and description (optional). The New/Edit Style is a dual view dialog 
box (tree view on the navigation or left pane and a list view on the contents or right pane). This 
gives you the ability to organize styles in different folders, called categories in the .xin file. The user-
defined organization of the styles is stored in the .xin file along with the styles themselves. 

Next, provide more details about how the features that use this style will be displayed in graphic 
view (as a line segment, point annotation, or attached tag). For example, to see the features using 
this style displayed in Plan, Cross-Section, and Profile, check the following options: 
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You can also modify the named symbology associated with the style. For geometry features, 
settings for points, lines, arcs, and spirals are also defined. 

 



 June 2007  Bentley InRoads Roadway Designer Tutorial                                                                                                                           
 

Bentley Systems, Incorporated                            25 

For survey features, codes, attributes, and custom operations can also be specified. 

 
Once all style settings and options are selected and you click Apply, the new style is added to the 
preference file. 
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Feature styles can also be created or modified from the New Style button that appears on many 
Surface > Design Surface commands. 

   

For more detailed information about style settings and options, see the Style Manager online help 
topic. 
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View Surface Features 
Features that are a part of the active surface can be displayed for review. To see the features, use 
the Surface > View Surface > Features command. 

 
After choosing a surface, you can select individual features from the list, select all of the features or 
click Filter to build a feature selection set to view. 
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Viewing Surface Features Using the Feature Selection Filter 
The Filter option on the View Features dialog box is a shortcut to the Surface > Feature > 
Feature Selection Filter command. This command allows you to quickly specify a feature 
selection set. 

  

By clicking Save As, the filtered selection set can be saved and associated with a name for future 
reference. 
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Before clicking OK, make sure the Feature Filter Lock is on. If the filter lock is not on, filters 
are not applied. Turn on this lock by clicking Tools > Locks > Feature Filter Lock.  

 

When you click OK, selected features are listed in the View Features dialog box. When you click 
Apply, these features are displayed. 

Once features are in the surface, you can display and modify feature properties. 
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Feature Properties 
The Surface > Feature > Feature Properties command allows you to edit feature properties. Use 
this command to change the feature name, modify the description or style, and set the criteria for 
triangulation. You can take action against all features in the surface, against a filtered feature-
selection set, or against selected features. 

  

 

Once features are defined or modified and displayed, you can annotate them within the design file. 
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Annotating Features 
The Surface > View Surface > Annotate Feature command allows you to annotate features within 
the DTM. 

  

Click Apply to display the annotation. 
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Preferences 
Preferences allow you to define everything from general operating parameters (like units of 
measure, decimal places to display, stationing format, and symbology) to specific instructions as to 
which settings apply to a particular design surface. In InRoads, preferences are a flexible system 
that can be considered as a single group of information that is simply defined in four different ways: 

 

Preferences

Basic
Preferences

Preference
Manager

Surface
Preferences

Preferred
Preferences

 

Basic Preferences 
Basic preferences are settings that are defined at the command level. These values are set on the 
individual command dialog box located on most InRoads menus. 

 
Basic preferences govern general operating parameters such as units of measure, stationing 
format, decimal places, local symbology, and so on. 
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Settings that have been selected across the various tab options can all be saved to a preference 
set. Preferences are stored in the civil.xin file. When you want these configured settings for a 
particular design session, you can load the saved file from the Preferences dialog box. At start up, 
all available preference files currently in the civil.xin are listed in the Preferences dialog box. 

You can create or modify basic preferences at any time from the Preferences dialog box. 
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Preference Manager 
You can set basic preferences for every command under each InRoads menu, as previously 
described, or you can globally set all of these values (in addition to other detailed settings required 
by some commands) in one place at one time, using the Tools > Preference Manager command. 
Preference Manager acts as a global editor that allows you to specify preferences across all 
functional areas of InRoads.  

 

  

In Preference Manager, begin by selecting an area of InRoads for which you want to specify 
preferences. Second, type a unique name for a new preference set, or you could select an existing 
preference set from the list (any setting change will modify the set). 

Notice that in the Status field, it is indicated whether or not a preference object has already been 
defined for this preference set (either at the command dialog box or in Named Symbology 
Manager). If initialized is displayed, preferences for the object have already been defined; however, 
you can modify the settings here and associate them with the new preference set. This is helpful if 
you want to standardize preferences across a design session or meet a specialized customer 
deliverable. 

To set preferences, double-click on an object (or select it and click Edit). 
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Individually set each value for an object. Or you can select a named symbology. If you choose a 
named symbology, the values previously defined in Named Symbology Manager populate the 
dialog box: 

  

You must individually save each object preference. 

  

When you have selected and saved all of the preferences, click Close to dismiss Preference 
Manager: 
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Named preferences are saved and stored in the civil.xin file. 

Surface Preference 
A surface preference is a named preference that you want to associate with a surface. When a 
preference is associated with a surface, all of the settings and display characteristics that were 
previously defined will be active for the surface. 

 

The Tools > Locks > Style command must be on. If Style Lock is not on, the basic 
preferences from the command dialog box apply. 
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A surface preference can be specified when creating a surface with the File > New > Surface 
command. 

       

In addition, you can change surface preferences at any time during a design session using the 
Surface > Surface Properties command. 

  

If, during a design session, you choose a different surface preference, use the Surface > Update 
3-D/Plan Surface Display command to refresh the graphic display with the new preferences. 
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Preferred Preference 
The preferred preference is the default global preference set. At start up, the preferred preference 
is the system Default (these are selected settings delivered with InRoads). If you have created a 
named preference set and desire to have it as the default, access the Tools > Options > General 
tab. For Category, select Settings. 

  

When specifying a preferred preference, if the Refresh Command Settings on Preference 
Change toggle is on, all of the InRoads commands that are affected by the preference change are 
updated to reflect the new preference settings. If a command dialog box does not have a named 
preference corresponding to the preferred preference, the system defaults continue to apply for that 
dialog box. 
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Click Apply to activate the preferred preference. 
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Locks 
In InRoads, there are several lock features that work together with Named Symbology Manager, 
Preference Manager, and Style Manager to streamline your required interaction with the software. 

  

For quick access to the lock commands, select Tools > Locks > Toolbar. 
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Feature Filter Lock 
The Feature Filter lock works in conjunction with the Surface > Feature > Feature Selection 
Filter command to automatically make available a filtered feature-selection set. When you create a 
selection set using the Feature Selection Filter command, it is assigned the name <Unnamed> if 
you do not use the Save As button to provide a name. 

  

Not only is the feature-selection set saved to the civil.xin file, the name assigned to the set is listed 
in the Feature Filter List located on the Locks toolbar. 

  

When the Feature Filter toggle is turned on, these selection sets are now available for display 
without any further interaction with the Feature Selection Filter dialog box. 
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Subsequently, when the Surface > View Surface > Features command is selected, only those 
feature types specified in the selection set are available for display. 

  

Click Apply to display the features in the surface. Or, you could use the Locate button to identify 
features (of the filtered type) by datapoint in the surface. 

 

When the Feature Filter lock is off, defined feature selection sets are not available or 
applied. 

 

Feature Highlight Lock     
The Feature Highlight lock turns on or off the Feature Highlight lock. Use this command to highlight 
selected features in plan view. 

When the lock is on, any commands that include a feature list field highlights the feature in plan 
view when it is selected in the list. While this primarily affects Surface commands, it also applies to 
Evaluation commands that include feature lists. 
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Style Lock 
The Style lock works together with Preferences, Preference Manager and Style Manager to 
automatically display global preference settings and defined features styles. As previously detailed, 
preference settings are defined at the local command dialog box or globally in the Preference 
Manager. 

    
 

Styles are created and named using the Tools > Style Manager > New command. 
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Once preferences and feature styles have been defined, you can turn on the Style lock toggle to 
have these settings automatically display during the design session, without any further interaction 
with command dialog boxes. 

   

When the Style lock is on and a command is selected, data preferences are active and displayed; 
no dialog box is presented. When Style lock is off, each time a command is selected a dialog box 
is presented allowing you to define display preference and style. 

This command allows you to reduce required interaction with InRoads commands. 

Pencil/Pen Mode 
When graphics are generated and written to the design/drawing file, the Pencil/Pen mode is 
available. These modes allow you to write to the design/drawing file in either temporary or 
permanent form. This idea is similar to drawing on a sheet of paper with pen or pencil. When 
writing in pencil, you can quickly erase a drawing to remove it. In contrast, writing in ink (pen) is a 
more permanent form that must be deleted to be removed. Similarly, in InRoads graphics written in 
pencil are not retained between iterations of display, and graphics written in ink are retained each 
time the object is displayed. 

For example, if you turn on Pencil mode and select the InRoads Surface > View Surface > 
Perimeter command, the graphic is displayed and written to the CAD design/drawing file. 
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Then, using a CAD manipulation command such as Move, relocate the graphic. Next, select 
Surface > View Surface > Perimeter to display it again. The previous graphic is “erased” and only 
the most recent graphic appears. 

 

The Pencil/Pen mode that is active when the graphic is initially displayed determines whether 
or not it is erased when it is redisplayed. 

 

  

Graphics written in Pencil mode are retained only until the next time the same graphic is selected 
for display. 

During a design session in Pencil mode, there may be an occasion where you do not want 
pencil graphics to automatically be erased. To override this action, select the Tools > 
Options > General tab. For Category, select Settings and turn on the Omit Automatic 
Graphics Refresh toggle. All graphics, written in pencil or ink, will be retained until you 
manually delete them. 

In contrast, if in Pen mode you select Surface > View Perimeter, the graphic is displayed and 
written to the design/drawing file. 
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Then, using the CAD Move command, you relocate the graphic. Next, select Surface > View 
Surface > Perimeter again. Both graphics appear. The first is retained because it was written in 
ink, the second appears because it is the most recent. 

  

All graphics written in Pen mode are retained until they are deleted. Graphics can be manually 
removed using the CAD Delete command or by activating the InRoads Delete Ink lock. 

 

Delete Ink Lock 
Turn on this toggle to quickly remove all graphics that were previously written in ink. 

For example, if you have three iterations of a graphic that was written in ink, all three graphics 
appear in the design/drawing file. 
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Then, if you turn on the Delete Ink lock and select the command again, only the current graphic is 
displayed. 

  

All of the previously displayed graphics are deleted. To override the Delete Ink lock, select the 
Tools > Options > General tab. For Category, select Settings and turn on the Omit Automatic 
Graphics Refresh toggle. All graphics, written in pencil or ink, will be retained until you manually 
delete them. 

Locate Graphics/Features 
During an InRoads design session, you create, edit and manipulate objects in two different 
environments: the CAD design/drawing file and the DTM model surface. Objects located in the 
CAD design/drawing file are referred to as graphics. Objects located in the DTM model (design 
surface) are referred to as features. The Locate Graphics/Locate Features mode lets you quickly 
specify the environment from which to select objects. 

   
 

For example, if you toggle to Locate Graphics and select the Surface > Design Surface > Set 
Elevation command for a Single graphic element, you are prompted to identify an element within 
the CAD design/drawing file.  
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While remaining in the same command dialog box, you can toggle the mode to Locate Features. 

   
 

The dialog box options dynamically change. You can now identify features in the surface. 
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Identify and locate individual features or select all available features in the surface. 

While an alignment (*.alg) is another way to manipulate objects during a design session, the 
geometry data in the alignment is not accessible from the Locate Graphics/Locate 
Features command.  

Point/Element/No Snap Lock          
This lock is a three-way toggle that allows you to specify the snap mode when working with feature 
and geometry data. 

• Point Snap. This lock allows you to snap onto any point contained in the geometry project. This 
mode is helpful when placing geometry elements. For example, if you want to input point data 
into a dialog box, toggle this lock on and place a data point in the design file. InRoads will find 
the closest point and display the point data in the dialog box. 

• Element Snap. This lock allows you to snap or lock onto any geometry element (any object that 
would require multiple data points to define) in the geometry project. This mode is helpful when 
using the direction, distance, length, radius, and/or angle of an existing geometry element to 
design a new element. When this lock is on, InRoads snaps to the element nearest the data 
point you place in the design file 

• No Snap. This mode disables both point and element snap.  

Station Lock 
This on/off lock is applicable only when the first station specified on the horizontal alignment is an 
odd-numbered station (for example, 2+39) and you are generating cross sections, executing the 
roadway designer, or generating station type reports. When this lock is turned on, InRoads applies 
a given command action to the first station, and then forces all subsequent actions to even-
numbered stations. For example, if the first station 2+39 and the station interval is defined as 50, 
InRoads performs the command action at stations 2+39, 2+50, 3+00, and so on. When the Station 
lock is turned off and the first station is odd-numbered, InRoads applies the command action to 
odd-numbered stations only (for example, 2+39, 2+89, 3+39) and so on. 

 Report Lock   
This on/off lock is used by several commands to control whether or not the output displays in a 
dialog box as the command calculations are performed. If this lock is off, the command processes 
and stores results without displaying them in an output dialog box. 
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General InRoads Review 
InRoads includes a wide-range of functionality, features, and commands that are accessible to 
several areas of the product. 

Comprehensive Data Structure   
The data structure for InRoads accommodates the intelligence needed to perform sophisticated 3-
D design operations such as earthwork analysis, profile generation, and superelevation. Its ability to 
maintain double-precision numbers is not dependent upon the CAD platform. As you place or 
locate design elements or coordinate geometry points, InRoads tools accommodate double-
precision input. Even graphical selection tools automatically snap to points and elements in your 
geometry project with double-precision accuracy. 

Horizontal and Vertical Alignments   
Alignments continue to represent longitudinal features, such as centerlines, lanes, access ramps, 
and ditch grade lines. The horizontal and vertical geometry of an alignment is designed separately, 
with the vertical being a child of the horizontal. There are no restrictions on how many vertical 
alignments you can attach to a horizontal alignment. Alignments are designed using the geometry 
component of InRoads, which has an array of features for locating points and designing the 
curvilinear geometry through them. 

InRoads automates the creation of horizontal and vertical geometry. In the initial design phase, you 
can use a backdrop of graphics such as a DTM, aerial photo, MicroStation graphics, and so on. 
You can define curve and tangents, in any order, with or without automatic spiral placement, and if 
you need to add spirals, you can do so as you define the circular curves. 

When the rough geometry is complete, you can begin to refine the alignment. You can dynamically 
manipulate elements or use precision key-ins. The software provides immediate visual feedback 
and automatically adjusts the geometry throughout the alignment, maintaining coincidence and 
colinearity between all the elements where appropriate. 

Roadway Templates  
Templates are among the most powerful features of InRoads’ corridor design capabilities. 
Contrasted with alignments, which represent longitudinal geometry, roadway templates represent 
transverse geometry. Templates, which are the backbone of road design, are made up of points 
and components.  

Points 
The points of a template represent breakline features that will be created when the template is 
processed using Roadway Designer. Points have a name and feature style; there is no limit to the 
number of points in a template. Once processed in Designer as features, they are saved to the 
design surface.  

Components 
A component is a set of points that define a open or closed shape. Each component, whether open 
or closed, can represent a different material or area of interest. Components are named and have 
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an assigned feature style. There are 5 types of components created in InRoads: Simple, 
Constrained, Unconstrained, Null Point, and End Condition.  

A simple component typically represents a section of pavement. It’s a closed shape (4 constrained 
points) that can define the slope and thickness of the component. A constrained component 
consists of points that are all restricted to the movement of the first point. A constrained point is 
typically used to manage the behavior of other points in the template. When a constrained point 
(parent) is moved, any related point (child) also moves. This restriction only affects the offset and 
elevation (x,y) of related point and, the relationship is uni-directional (movement of child point does 
not move the parent point). An unconstrained component is open or closed-shaped with no 
movement restrictions. A null point is a template point that is purposely not related to any particular 
component. It’s most often used as a reference for controlling other points. An end condition is a 
special open-shaped component that targets a surface, a feature of a surface, an elevation, a 
surface with a specific material, or an alignment (it replaces the former Cut/Fill, Material, and 
Decision tables). The integrity of end conditions can now be routinely tested while the roadway 
template is being created.  

Once created, components can be modified as desired. There is no limit to the number of points or 
components in a template. 

When templates are paired with horizontal and vertical alignments and superelevation, they define 
the surface of a corridor. Templates are flexible design components that allow you to model simple 
constructs such as ditches and sidewalks to the more complex multilane highways with 
superelevated curves and variable side slopes. 

Evaluation 
InRoads provides tools to make preliminary evaluation of your model quick and simple. In addition 
to the dynamic display in Create Template that allows you to evaluate the roadway as it is being 
designed, the following tools allow you to evaluate various aspects of the design: 

Display triangles and slope vectors and view them from any angle. 

• Produce contours, cross sections, and profiles to compare original surfaces with design 
surfaces. 

• Compute volumes using the triangle, grid, or end-area method. 

• Produce Mass-Haul diagrams. 

Superelevation  
Superelevation refers to the banking applied to offset the lateral acceleration that vehicles 
experience when going around curves. More specifically, it is the transverse slope between the 
inner and outer edges of a banked curve. InRoads accommodates all commonly used methods of 
calculating superelevation rates, including the five AASHTO methods and numerous international 
methods. Plus, InRoads gives you control over how superelevation is achieved longitudinally along 
an alignment, with parametric control over transition lengths and methods of transition.  

The Roadway Model  
Roadway Designer pulls together all of your design data to create the corridor model. The designer 
uses a roadway definition to place appropriate templates and side slopes at intervals and at critical 
design points along the alignment. In addition, it applies superelevation and adjusts the templates 
to the longitudinal features as necessary, as well as checks right-of-way limits. The end result of 
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this is a DTM for each of the layers in the proposed corridor surface. These layers are comprised of 
3-D linear features and xyz random points, providing a full 3-D model of the proposed roadway. The 
model features can then be displayed in the CAD design/drawing file.  

For simple projects, InRoads provides Express Modeler, which produces a model quickly, with only 
minimal information. You need only to provide an existing surface, a horizontal alignment, and a 
single template. You can also provide a vertical alignment, but InRoads will use elevations derived 
from a horizontal alignment if no vertical alignment is provided.  

Drawing Production  
Plan and profile drawings are easily generated from InRoads graphics. You can create construction 
documents, such as plan/profile, cross sections, and detail sheets.  

Reports  
Reporting in InRoads is flexible and comprehensive. You can produce reports on any data that you 
have created or manipulated in the course of a project. Reports include listings of coordinate 
geometry points, alignment clearances, and earthwork data. InRoads also allows you to track your 
design activities. You can save your activities as report files or append them to other report files; 
they are invaluable for project documentation. All reports are generated in ASCII format for easy 
manipulation in a text editor or word processing program.  

Visualization  
Designs produced with InRoads can be used with visualization software to create photo-realistic 
images, which help your project team or client better visualize the design. Bentley Systems also 
complements InRoads with a range of applications for editing and manipulating images to create 
photomontages or video presentations. These capabilities help you prepare presentations for non-
technical audiences. 
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Getting Around in InRoads 

Using the Interface 
InRoads utilizes the Windows Explorer environment for file management. It works like the Explorer 
in the Microsoft Windows environment. By either clicking the plus sign (+) in the square next to an 
item or double-clicking on the name, a subgroup of items displays just like a directory tree. The 
InRoads Explorer provides a quick view of files that have been loaded and are available in a 
working session. 

 
From the InRoads Explorer, you can “tear away” the left-pane Explorer tree, now referred to as the 
Workspace Bar: 

 
 

 
 
 
 
 
 

There are several unique advantages of the Workspace Bar. First, major objects are represented 
by tabs at the bottom of the view. Each tab corresponds to a particular view of the overall Explorer 
hierarchy. Second, by clicking a tab, such as the Surfaces, you’ll see all (and only) the surface 
objects in the project. 
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Workspace Bars can be docked anywhere on the screen for easy access. 

To return the Workspace Bar back to the Explorer, click and drag the box to the desired location: 

When you are in the Windows Explorer, you can drag and drop your InRoads data directly to the 
InRoads Explorer. The status of the data is displayed in the bottom portion of The Explorer window. 

  

 
 

In the Explorer, you can access additional options that are available for an entity. For example, if 
you select (highlight) a surface and right-mouse click, a pop-up menu appears with additional 
options for surfaces. 

  

The additional options that are available depend on the entity that you select. In the Explorer, you 
can also access the following shortcuts: 

• Review file revision data. 
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• Click File > Open, then right-mouse click to access additional file and mailing options. For 

example, to email an InRoads project file: 
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The Explorer can be moved to a convenient location on the screen to make common tasks faster 
and easier. 

Accepting/Rejecting Solutions 
If MicroStation is your CAD platform and you are using the default mouse configuration, you accept 
an InRoads solution by clicking the left mouse button. You reject an InRoads solution by clicking 
the right mouse button. 

If AutoCAD or is your CAD platform, you accept an InRoads solution by clicking the right mouse 
button, by typing accept or a, or by pressing Enter. You reject an InRoads solution by typing 
reject or r. 

On both CAD platforms, you exit an InRoads command by pressing Esc. 

Using Access Control 
Access control allows you to share files among multiple users while controlling read-write access to 
the data. Using access control, you can essentially “lock” your data so that another user cannot 
overwrite it while you are working on it. The other user can open the data (read-only access) but 
cannot make changes to it while you have it opened with read-write access. Likewise, if another 
user has some data opened with read-write access, your only option is to open the data with read-
only access. 

Access control works with individual horizontal alignments, the cogo buffer, and preference files. 
However, with preference files, you lock the entire file! not individual preferences. When you have 
read-write access to a horizontal alignment, you also have read-write access to all data associated 
with the horizontal alignment: vertical alignments, superelevations, vertical event buffers, and 
horizontal event buffers. 

To set the access status, right-mouse click the horizontal alignment, cogo buffer, or preference file 
in the Explorer. When the menu appears, select either Read-Write or Read-Only. The status is 
reflected in the Explorer. 

For more information about access control, see the Bentley InRoads Group XM Help. 
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Menus 
The Explorer contains menus that are the primary source of interaction with InRoads. 

The menu titles reflect the functions used during the design process. They help you navigate to 
groups of commands used for a specific task. A small right arrow by a command indicates an 
additional menu with commands.  
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Menus and Application Add-Ins 
InRoads is delivered with several additional software modules that allow you to complete 
specialized or advanced tasks, including data translation. To access these features, select Tools > 
Application Add Ins. 

  

By default, these additional commands do not appear on InRoads menus because they are “turned 
off”. However, when you select add-in applications, menus are dynamically updated and the 
commands are listed on the appropriate menu. For example, by default the Geometry menu does 
not include the Horizontal and Vertical Elements Add-In. If you select it to turn it on and click OK, 
the command is dynamically added to the menu. 

 
 
 
 
 
 
 
 

 

 

Add-in applications can be turned on and off at anytime during a design session. 
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Customize Menus 
You can also create customized InRoads menus using the Tools > Customize > Command tab.  

  

This command allows you to group specific commands together on a menu. First, select the menu 
on which to place the commands. 

  

Then, drop and drag the selected command onto the menu. 

 
 
 
 

 

 

 

The command is added to the menu. 
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Customize Toolbars 
With the Tools > Customize > Toolbars command, you can select predefined toolbars to display 
that provide quick access to frequently used commands. There are toolbars for specific groups of 
menu commands, such as View Surface. 

 

 
 

There are also predefined toolbars for common design workflows. The commands on the workflow 
toolbars may not appear together on any one menu or all of the available commands may not 
appear, but some are grouped together on the toolbar for a specific function. For example, Design 
Roadway. 

           

If a predefined toolbar does not meet your design needs, you can create customized toolbars for 
unique workflows. Select Tools > Customize > Toolbars > New. Enter a toolbar name and click 
OK. 

  

 
Click the Commands tab. Select commands from the list to drag and drop onto the toolbar.  
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With customized toolbars, you can step through the design process from surface creation to plan 
and profile sheet generation using a single toolbar. 
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Once toolbars are displayed, they can be moved to a convenient location on the screen or they can 
be “docked” onto the Explorer. To dock a toolbar, click and hold on the toolbar, drag it to the 
Explorer and release it. 

 

 

 
Docked toolbars remain in the Explorer until you delete them. 

To remove a docked toolbar, click on it and drag it away from the Explorer and click the X button. 
Or, to remove all customized toolbars and menus, click Tools > Customize > Toolbars > Reset 
All. 

Customize Commands 
Use the Tools > Customize > Keyboard tab to create new keystrokes to activate InRoads 
commands. 

  

You can create new shortcut keys or modify existing ones. 

 



 June 2007  Bentley InRoads Roadway Designer Tutorial                                                                                                                           
 

Bentley Systems, Incorporated                            67 

Customize Macros 
Use the Tools > Customize > Macros tab to provide access to external software programs that 
can be run within InRoads. 

 
For example, click New to create a macro to run Notepad®, a Microsoft text editor, in a specific 
directory. 

  

Enter a macro name and click OK. Then click Browse on the Macros tab dialog to locate and 
identify the Notepad executable. This automatically populates the command field. Then specify the 
Argument (file on which to run the editor) and the initial directory (where the file is located). 
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Click Close. The name of the new macro appears in the Commands list. Drag and drop the new 
command onto a toolbar or menu. 

 
The Button Appearance dialog box appears. Select an icon to represent the command. 

  

The icon appears on the toolbar or menu where you dragged and dropped it. Double-click the icon 
to start the command. 
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You can also use the Tools > Customize > Macros command to run advanced software programs 
created with InRoads Suite SDK. InRoads Suite SDK allows you to call InRoads Group functions 
from your own programs written in Visual Basic, Visual C++, or MDL. Refer to Program 
Files\Bentley\InRoads Group V8.9\SDK\Help\SDK.HLP for more information about customizing 
InRoads using SDK. 

Exporting Custom Settings 
Once custom menus, toolbars and command-shortcut keys have been created, you can save all of 
the settings to a file for use in future design sessions. To access this command, select Tools > 
Customize > Export.  

  
•   Full Export – Use this option to save all custom settings. 

•   Partial Export – Turn on this option to individually choose which toolbars to save. You can also 
specify shortcut keys, macros, or both. 
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Importing Custom Settings 
Previously defined settings can be imported for a current design session. To access these settings, 
select Tools > Customize > Import. 

 

Click Browse to locate the settings file. 
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Using the Online Help System 
To display help when InRoads is active, click Help > Contents from the main menu. 

 
 

 
 

Bentley InRoads Group XM Help Topics 
InRoads is delivered with comprehensive online reference information for each command. This 
information is available through the InRoads Group XM help system. Help topics include brief 
overviews of the commands, detailed descriptions of dialog box options, and workflows that show 
how to use the command. 

InRoads allows you to design while integrated with other Bentley Civil applications. In this 
environment, you can access the online help topics for these applications in addition to InRoads 
help. 

If help was not installed on your hard drive during setup, you must have the InRoads CD in 
the CD-ROM drive or be connected to the network node containing the help files. 

•   Click the Contents tab to display the Contents page for InRoads Group XM help. This page is 
similar to a table of contents in that it lists everything that is available in the help files. Double-
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click a file to display it. After reviewing a topic, you can close it or print it.  

•   Click the Index tab to enter a command name, phrase, or word for which to search. This page 
is similar to a book index with items listed in alphabetical order. As you type a word, the list 
dynamically updates as the sorting feature narrows the search. Double-click the topic when it 
appears in the list, or click the Display button.  

•   Click the Search tab to access a full-text retrieval search. Full-text retrieval allows you to 
search for specific words instead of alphabetized categories. First, the software builds a 
database of words from all available help files. Once the database is compiled, you can search 
it for any key word. A workflow wizard steps you through this brief process. Double-click a 
located word or click the Display button to display the search results. 

To display Bentley Civil InRoads help outside of the product, from the Start menu, click All 
Programs > Bentley > InRoads Group XM > InRoads Group XM Help. 

InRoads Group XM help is context sensitive, which means that you can press F1 to display help for 
the active command or dialog box. You can also click the Help button on each dialog box.  

 



 

Bentley Systems, Incorporated      73 

1 Learning the Roadway 
Designer 

Overview 
Welcome to the InRoads Roadway Designer tutorial. In this chapter, you will complete a basic 
roadway designer session using Metric units.  See the Roadway Designer Tutorial (Imperial), for 
completing a workflow using Imperial units.  You can also use this tutorial if you are currently 
running AutoCAD. 

In this project, you will create a road design surface, beginning with two lanes along the centerline 
alignment baseline, from station 10+000.000 to 10+550.000, using the vertical alignment profile 
gradeline. Then, you will transition to four lanes, using the Superelevation Wizard to generate the 
vertical point controls for curve elevation.  You’ll complete the design with a transition back to two 
lanes using horizontal and vertical controls.  This process is interactive, meaning you can design, 
test conditions, create superelevation as desired before finalizing the new design surface.  

When the design surface is completed, you will create and review profile and cross sections. 

About the Tutorial Data 
The data required for this tutorial is delivered with InRoads Group version 8.9. The data resides at 
two locations: 

1. C:\Program Files\Bentley\InRoads Group V8.9\Sample Data\InRoads. 

2. C:\Program Files\Bentley\InRoads Group V8.9\data\metric. 

Be aware that there are several types of data located in these directories (*.xin, *.cel, *.tiw, and so 
on); you will not use all of this data.  You will be instructed to load specific data files for the tutorial. 

Once you have located the data files, you will store them in a working tutorial directory.  This will 
allow you to repeatedly practice learning the Roadway Designer without overwriting the original 
delivered sample data. 

Before Getting Started 
Create a tutorial directory on your local machine to store data files. For example, 
C:\Tutorials8.9\data.  

 Loading Data Files 
1. Start InRoads. 
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2. From C:\Program Files\Bentley\InRoads Group V8.9\Sample Data\InRoads open the road.dgn or 
road.dwg file. 

  Delete any graphics in the road.dgn or road.dwg file. 

3. Click File > Open. Load the following data files from Sample Data/InRoads: 

• original.dtm  (surface) 

• relocation.alg   (geometry project) 

• relocation.ird   (roadway design) 

4. Change directories.  From C:\Program Files\Bentley\InRoads Group V8.9\data\metric open the 
following data files: 

• civil_dgn.xin or civil_dwg.xin  (preferences) 

• DefaultTemplates.itl   (template library) 

Next, select the working units for the project. 

 Setting Working Units 
1. Click Tools > Options > Units and Format. 
2. Ensure the following settings are selected: 
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3. Apply; then, close the Options dialog. 

Once data files are loaded, begin the roadway design session. 

Creating a Corridor 
Road design begins with creating the roadway corridor.  A project must have one or more corridors 
to create a valid design from which a surface can be created. 

1. Click Modeler > Roadway Designer. 
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Notice that you can also directly open an .ird file using File > Open on this dialog box. 

 Throughout this tutorial, while command icons are primarily used, be aware that all commands 
can be accessed from the top-level menus in the main Roadway Designer dialog. 

2. Next, create the new corridor.  Click the Manage Corridors  button.  For Name, type 
RoadwayRoute1. 

3. Click Add. 

  
Notice that you can add, edit, or delete corridors from your design at any time during the design 
session from this dialog. 
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4. Close the dialog. 

The top-left window is the plan view and displays the alignment (baseline) of the active corridor 
in light blue.  The active surface perimeter is shown in white; the current station location is shown 
as a yellow line.  The bottom-left window is the profile view.  The large, top-right window is the 
cross-section view. 

  
5. Click File > Save As. 

6. Change locations to the local tutorial directory (Tutorials8.9\data).  

7. For Save As type, select Roadway Design (*.ird). 

8. For File name, type RoadwayRoute1.  

9. Save and close the Save As dialog.  

Now that an active corridor for this project is in place, add the template drops. 

Creating and Dropping Templates in the Corridor 
Template drops are used similarly to the previous typical sections functionality in InRoads (that is, 
the command was used to control the cross-sectional geometry of the corridor, roadway side 
slopes, roadside ditches, additional shoulders, retaining walls, berms, and so on). 

In version 8.7 and later, template drops comprise a series of points and components that represent 
breakline features that are processed using the Roadway Designer command. A component is a set 
of points that define an open or closed shape. Each component, whether open or closed, can 
represent a different material or area of interest.  Components are named and have an assigned 
style. There are 5 types of components created in InRoads: Simple, Constrained, Unconstrained, 
Null Point, and End Condition.  For more specific details on components, see the Create Template 
Overview help topic. 

Once stored in a template library (*.itl), templates can be copied from the template library into the 
roadway design file (Roadway Designer command).  This means that changes to the template in the 
InRoads Roadway Designer file will not affect the templates in the library. 

In this task, add two existing two-lane templates and create a single four-lane template to the new 
roadway corridor  

Plan view 

 Profile view 

Cross-
section view 
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 Adding An Existing Template 
1. Click the Template Drops button . 

  
2. In the Library Templates tree view, select Templates > 2 Lane Rural. 
3. Change the interval to 10 (the template is placed every 10 meters).  Add the first of two 2 Lane 

Rural templates at station 10+000.000. 

4. Click Add. 

  
Notice the selected template is displayed in the view on the right, and is added to the Current 
Template Drops list at the bottom of the dialog. 
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5. Similarly, add the second 2 Lane Rural template at station 10+300.000. 

  
6. Close the Template Drops dialog. 

  
In plan view, notice the visual cues (brown lines) that show the location of the two new 
templates.  In cross section the templates are displayed. 

Next, create a 4 Lane Rural template for the new corridor. 
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 Creating a Four-Lane Template 
1. Do not close the Roadway Designer command.  Click Modeler > Create Template. In the 

Template Library tree view, select Templates. 

2. In the Template Library tree view, select Templates. 

3. Right-click on Templates folder to display an additional context sensitive menu with options for 
New > Template. 

  
4. Name the new template.  Type 4 Lane Rural. 
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5. Click Tools > Dynamic Settings.  The settings here allow you to specify precision input (step 

increments) from the dynamic origin of the new template.  Select the settings as shown below: 

  
6. Close the Dynamic Settings dialog. 

7. Since you have added a new template to the default library, save the library file to the tutorial 
directory. 

8. Click File > Save As.  
9. For Save as type, select Template Libraries (*.itl). 
10. For File name, type RoadwayRoute1.  Save then close the dialog.  

11. Before placing the components, specify the identifying prefixes for each lane. Click Tools > 
Options.  Select the following settings: 
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12. Click OK to close the Template Options dialog. 

13. Next, drag and drop the first of two 3.7 meter lanes.  From the tree view, select Pavements > 3.7 
Travel Lane.  With a single click, drag the lane to the center of origin for 4 Lane Rural. 

While dragging (but before releasing it), right-mouse click to access the Mirror option. 

  
      Turn on the option to simultaneously place the Left and Right lanes as shown below: 

  
14. Fit the view. 
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15. Next, rename the REP (right edge of pavement) to RtLane (right lane) prior to adding the second 

lane. 

16. Right click on REP and select Edit Point. 

  
17. Change the name to RtLane. 
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18. Click Apply; then, Close. 

19. Repeat this process for LEP (LtLane). 

  
20. Now, drag and drop the second 3.7 meter Travel Lane at RtLane.  

21. Fit the view. 

22. Because Mirror is on, all 4 lanes should appear as shown: 
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23. Now would be a good time to save the new template.  File > Save. 

24. Typically, a 4 lane design will have a Shoulder for the outside edge of the roadway.  Add 
shoulders at both REP (right edge of pavement) and LEP (left edge of pavement).  In the tree 
view, select Pavements > 3 Shoulder. 

25. Drag and drop a 3-meter Shoulder onto REP.  Notice the names ROEP (right outside edge of 
pavement) and ROS (right outside shoulder ) are automatically given. 

  
26. Finally, add the end conditions to the outer shoulder of the roadway (ROS Unpaved).  Recall that 

end conditions allow you to define how the design will match up with the existing surface.  Drag 
and drop End Conditions > Variable slopes. 
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27. Fit the view. 

 \ 
28. Click the Test button to test the end condition for template 4 Lane Rural. 
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29. Click Draw then move the cursor over the display to dynamically test the condition.  Recall that 

non-solved end conditions, and their child components, display as dashed lines.  Solved end 
conditions will display as solid lines. Reset to finish. 

30. Close the Test End Conditions dialog. 

31. Save the template and close the Create Template dialog. 

 Adding Templates to Template Drops 
32. Now, add the new template to RoadwayRoute1 corridor in the Roadway Designer.  In the 

designer, click Corridor > Template Drops.   

33. In the tree view, select Templates > 4 Lane Rural. 

34. For Station, type 10+550.000. 

35. Set the Interval to 10. 

36. Click Add. 

Notice that the two 2 Lane Rural templates ITL indicators appear in red.  This occurs because 
these template drops were placed from a library that is now in a different location (see the Library 
column).  You can remove this indicator in the next two steps 

37. Select (highlight) one of the template drops and select the Change button. 

38. Repeat this for the second template drop. The templates have been “reloaded” from the current 
library. 



Bentley InRoads Roadway Designer Tutorial                                                           June 2007 
                        

88    Bentley Systems, Incorporated 

  
39. Close the Template Drops dialog.  Do not close the Roadway Designer. 

40. Save the roadway design file.  File > Save. 

Next, review and edit the transition between template drops. 

Editing Between Transitions: From 2 to 4 Lanes 
The Edit Transition command allows you to interactively modify existing backbone transitions 
between two template drops.   The backbone is considered to be the component of the template 
that is not an End Condition or child component.  In previous versions of InRoads, transition 
connectivity was determined by the software.  Now, the Roadway Designer makes connections 
based on matching point names between transition templates, and then allows you to adjust it as 
desired. 

 The Roadway Designer > Tools > Options > Display Transition Graphics option must be 
turned on to view transition graphics. 

1. In the Roadway Designer main dialog (right bottom), select the Process All button.  This action 
processes all stations of the corridor and updates all the display windows with the results. Close 
the Results dialog box. 
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Recall that brown bars appear at template drop stations.  Notice a yellow shape between the 
last two template drops.  This shape represents a transition region (shifting from 2 lanes to 4 
lanes).  The yellow color indicates that some, but not all, of the points have been connected and 
you have not yet reviewed the transition. 

2. Double-click anywhere on the yellow shape. 
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In this 3D view of the backbone transition, notice that the thick red point symbols (+) are points 
that have not been connected to a point at the other end of the transition. 
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3. You can move the templates to get a better view of how the points are connected.  To move a 

template, right click over one of the template points and select the Move Template command.  
Move the template so that it looks similar to template below; then, fit the view. 

  
Notice that you can pause the mouse over a point to display the point name. 
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4. To add a transition connection, left mouse click over the point (you must connect from the 
“unconnected” to the “connected”, that is, you must start in the 4 Lane Rural template bold points 
and connect backward towards the 2 Lane Rural template normal points). 

  
5. Make the following connections in the template.  Notice that there may be several points in close 

proximity.  Also, multiple points can connect to a single point. If you make a mistake or want to 
change connectivity, right click over the transition line and select Delete. Review the illustration 
below (by point names) to verify the correct connections. 
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The final connections should appear as shown: 

  
6. Now, test the connections.  Click OK on the Edit Transition dialog.  A second dialog displays 

revealing what the transition components and points will look like at the midpoint of the transition.  
If you need to make any connection correction, simply Cancel here and return to the Edit 
Transition dialog for more connections. When done, ensure that your connections appear as 
shown: 
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7. Although it appears that the software made a good “best guess” resulting in correct connections, 

recall that points also have constraints (that can restrict their movement).  In the transition from 2 
to 4 lanes, the outside lanes need to vary in width as you move along the transition.  Test this 
movement using the slider bar in the bottom of the dialog.  Move along the transition from 
beginning to end. Nothing happened.  You will need to remove any horizontal constraints from 
the REP and LEP points so that they can vary linearly along the transition. 

8. Turn on the Display Point Names option in the bottom left corner of the dialog. 
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9. At LEP (left edge of pavement), right click and select Edit Point. 
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10. Under Constraints, for Constraint 2, select None; then, OK. 

  
11. Repeat this process for REP.  Fit the view. Notice the symbols for these points changed from red 

to yellow.  This indicates they are no longer fully constrained (2 constraints); they are partially 
constrained (containing only 1 constraint: maintaining the slope). 
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12. Use the slider to test the transition again.  Movement at the lanes indicates the transition is 

correct.  Click OK to close the Edit Transition Midpoint dialog. 

13. In the Roadway Designer dialog, select Process All. Close the Results dialog box. 

14. Notice the yellow area in the transition is now dark blue.  This indicates that all points of the 
transition are connected. 
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 Other visual cues for transitions are Red, indicating none of the points are connected; Light 
Blue, indicating the transition has been reviewed or edited, however, one or more points 
remain unconnected. 

15. Move the station location back and forth along the transition region.  Notice how the transition 
appears; in both plan and cross section. 

16. To get a better view, right click in the cross section view and select Display Properties. Select the 
following settings; then, click OK to dismiss the dialog 
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17. Save the roadway design file. 

Next, add superelevation to the model. 

Creating Superelevation 
Superelevation is used to control the cross slope of roadways in areas of horizontal curves and 
spirals.  In the Roadway Designer command, superelevation control lines can be created and then 
used as vertical point controls to control the elevation of a point relative to another point in the cross 
section.  

For a typical two lane road, there are generally two super control lines; one for the left edge of 
pavement, and one for the right with the pivot point being the crown point of the road.  However, 
with the Roadway Designer superelevation functionality, there is no limitation on the number of 
control lines or pivot points.  In this task, add superelevation for both curves in the model. 

1. Change the cross section display.  In the view, right click and select Display Properties. 

2. Select the following settings; then, click OK. 
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3. Select the Display Superelevation button.  In superelevation mode, the views are displayed as 

shown below: 

  
The superelevation diagram is synchronized to display the same station range as the profile 
view.  The plan, profile, and cross section views now show cross slope values of the backbone 
of the template.  Colors from yellow to red indicate increasing slopes to the left. Colors from 

Plan view 

Cross section 
      view 

Profile view 

Superelevation 
     Diagram 
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green to blue indicate increasing slopes to the right.  White indicates a cross slope at or near 
0%. 

  
4. Right click in the superelevation display. Select Create Superelevation Wizard > AASHTO. 
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5. Next, redefine the maximum rates for the curves. Select Rate Calculator. 

You can also access the Rate Calculator from Geometry > Superelevation. 

  
6. Select (highlight) both curves. Click Edit 

7. In the Superelevation Rate Calculator Editor, select the settings shown below.  
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8. Click OK. 

  
Notice the speed and superelevation change. 

9. Click Apply; then, Close. 

10. Now, modify the Maximum Delta G to .65.  Recall that the Delta G is defined in the AASHTO 
design manual.  A lower Delta G results in longer runoff lengths. 
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11. Click Next. 

12. Under Sections, select Add.  

13. Here, define the superelevation section.  Select the settings as shown below: 

  
14. Click OK 

15. Under Superelevation for Selected Section, double-click on the first curve.   

16. The General Curve Information values are those calculated from the input provided in the newly 
created section.  For this section, use the spiral length (50.00) to calculate runoff. 
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17. Click Apply; then, Close.  

  
18. Click Next; then, Finish. 
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Notice that the Fix Superelevation Overlap dialog is displayed.  This occurs because there is 
only approximately 5 meters of tangent  prior to the incoming spiral (Review the alignment at 
Geometry > Review Horizontal with Mode set to Alignment).  This is an insufficient length to 
achieve the superelevation runoff.  You do not need to modify this overlap. 

19. Click Apply; then, Close.  

  
A control line is created for each point of the template that is superelevated.  For this alignment 
4 lines are created: Left Lane LEP, Right Lane LEP, Centerline Left Lane, and Centerline Right 
Lane, due to the template transition from 2 to 4 lanes. 

Notice in the first curve that runoff uses the spiral length of 50.00.  

20. Zoom in the superelevation display to view the control lines.   
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 Notice that superelevation in the first curve failed (Delta G at 0.00 throughout). This is due to 
the transition: the connection process referenced points in the template that do not exist.  You 
will fix this error later in the workflow. 

21. To display lines individually, right click in the display and select Superelevation Display List.  The 
multi-color lines are to only visually assist you in identifying the controls. For example, to see the 
Right Lane REP only: 

  
Click Apply; then, Close. Select the Process All button (to update all views) in the main dialog. 

  
22. Close the Results dialog. Fit the view. 
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So, the superelevation wizard completed two design tasks.  First, it calculated the runoff lengths 
for the curve. Second, it created control lines for each point to be superelevated. 

23. Save the roadway design file. 

Now that you have accomplished a transition from 2 to 4 lanes, apply roadway shoulder rollover 
locks. 

Applying Shoulder Rollover Lock 
Once you have created Superelevation for lanes in the alignment, you are ready define and apply 
control lines to handle shoulder rollover. 

1. In the Superelevation Display, right click and select Apply Shoulder Rollover Lock. 

2. For Shoulder Point, select LOS (Left Outside Shoulder). 

3. Under High Side, for Difference, type .05 and press Tab. 

  
4. Click Apply. 
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5. Repeat this process for ROS 

  
6. Click Apply, then Close. 

7. Now, view the control lines in the Superelevation Display.   Select Process All to update the 
view. Close the Results dialog. 

8. Right click and select Superelevation Display List. 

9. Select a shoulder control line and Apply.  For example, LOS: 

  
10. Close the dialog. 

11. Click Corridor > Point Controls to review the control points. 

12. Notice that the Superelevation Wizard assigned horizontal and vertical control names. The point 
controls should appear as shown: 
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13. Close the dialog 

At this point in the project, you have created a corridor, a new template with transition from 2 to 4 
lanes, created superelevation, and applied point controls for shoulder rollover. Next, continue using 
the Point Controls command to re-transition back to 2 lanes (7.4 meters to 3.7 meters) to complete 
the end of horizontal alignment in this project. 

Applying Point Controls 
In this task, resolve the superelevation error in the first curve; then, add new horizontal and vertical 
controls to transition back to 2 lanes. 

1. Turn off the Superelevation Display. 
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2. Select Corridor > Point Controls.  

3. In the next few steps, you will modify points in the 2-Lane portion of the alignment to correct the 
superelevation error in the first curve. Select LEP. 

4. For Start station, type 10+300.000. Ensure that all other settings are as shown: 

  
5. Click Change. 

6. Next, for Reference Point (for LEP), choose CL (Centerline). 

7. For Start station, type 10+000.000; for Stop station 10+300.000.  The settings for LEP should 
appear as shown below: 
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8. Click Add 

9. Now, repeat this process for REP. 

10. For Start station, type 10+300.000. 

  
11. Click Change. 

12. Next, for Reference Point (for REP), choose CL (Centerline). 

13. For Start station, type 10+000.000; for Stop station 10+300.000.  The settings for REP should 
appear as shown below: 
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14. Click Add.  Do not close the Point Controls dialog box. 

15.  Click on the 2-lane portion in Plan view. Notice the superelevation in the first curve: 

  
16. Finally, add new controls for the end of the alignment.  In the Point field, select LEP.  Select or 

key-in the additional settings as shown below: 
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This left edge of pavement point will control the lane width change from 7.4 to 3.7 meters. 

17. Click Add. 

18. Next, add a control that maintains the 3.7 meter width to the end of the alignment. Select the 
settings as shown below: 

  
19. Click Add. 
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    Do not be concerned if the stop station appears in red.  Zoom into the view and use the 
locate button to click precisely on the end of the alignment then; click the Change button. 

   
Repeat this process of adding controls for REP.  This right edge of pavement point will control 
the lane width change from 7.4 to 3.7 meters.  Notice that these are positive values. 
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20. Close the Points Control dialog box. 

21. Save the roadway design file. File > Save. 

Next, take a look at how display references are used in the Roadway Designer. 

Using Display References 
In prior versions of InRoads, right-of-ways (ROWs) were managed with rules to instruct the modeler 
how to handle a solution that extended beyond the ROW.  In the Roadway Designer, ROWs are 
now simply added as display references that you can interactively inspect and adjust using various 
tools during the design session. 

In this task, first create an alignment; then, display it as a reference in Roadway Designer. 

1. Collapse but do not close Roadway Designer. 

2. Click Geometry > Utilities > Parallel Horizontal Alignment. 
3. Select the settings as shown below: 
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4. Click Apply; then, Close. 

5. Return to the Roadway Designer 

6. Now, display the new alignment as a display reference.  Click Corridor > Display References. 

7. Select the settings as shown below: 
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8. Click Add; then, Close. 

9. In the cross-section view, right click and select Display Properties. 

10. Select the settings as shown below: 

  
11. Click OK 

12. Fit all views. 

  
13. Notice the reference (alignment) appears as a solid purple line in plan view; as a dashed purple 

line in cross-section. 

14. Step through the stationing to view the solutions relation to the right ROW.  Notice that from 
station 10+520.000 to  10+530.000 as well as from 10+540.000 to 10+730.000 the right side 
slightly exceeds the ROW.  There are several methods to fix this, from adjusting the alignment to 
adding a retaining wall. In the next task, fix it with an end condition exception. 

Defining End Condition Exceptions 
An end condition exception is an efficient method of modifying the behavior of an end condition 
solution without making additional template drops. 

1. Select  . 
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2. Select the settings as shown below: 

  
3. Click Add. 

4. Select (highlight) the entry, and select Edit. 

The Create Template command is activated. 

  
5. At the point: RCut2, right click and select Edit Point. 

6. Select the settings as shown below: 
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7. Click Apply; then, Close. 

To resolve the solution problem, notice that you have modified the slope constraint at the point. 

  
8. Click OK to close the Create Template dialog. 

9. Close the End Condition Exceptions dialog. 

Step through the stationing from 10+520 to 10+530.  The right side solution no longer exceeds 
the right ROW.  Also notice in plan view (zoom) that a light blue visual indicator appears in the 
station range to inform you that the transition has been edited. 
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10. Now, repeat the end condition process for station range 10+540.000 to 10+730+000.  Select . 

11. Modify the station range as shown below: 

  
12. Click Add. 
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13. Click Edit. 

  
14. Edit point RCut2. 

15. Select the settings as shown: 
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16. Click Apply; then, Close. 

  
17. Click OK on the Create Template dialog and Close on the End Condition Exceptions dialog. 
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18. Review the stationing across the alignment; the right of the solution does not exceed the ROW. 

19. Save the roadway design file.  

You have created a new corridor, created and edited a new  template, transitioned the roadway 
from 2 to 4 lanes, created superelevation, applied shoulder rollover locks, transitioned the roadway 
back to 2 lanes using horizontal and vertical controls, displayed a ROW reference, and corrected 
the solution using end condition exceptions.  In the final task, create the new design surface.  

Creating the New Surface 
Typically, the end result of a session in the Roadway Designer is the generation of a new design 
surface from which plan, profile, and cross section drawings are created.  Using the Create Surface 
command, you can either create a unified or merged surface from all corridors in a design, or create 
a separate surface for each corridor, which you will complete in this task. 

1. Click Create Surfaces . 

2. Select the settings as shown below: 
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3. Click Apply; then, Close 

4. Once processing is complete, close the Results dialog. 

5. Save the roadway design file. Close Roadway Designer. 

6. In the Explorer, locate the new design surface. 

  
7. Review the surface. 
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8. Generate cross sections and profiles: 

  

  
9. Save the surface. Click File > Save As > DesignRoadwayRoute1.dtm. 



 June 2007  Bentley InRoads Roadway Designer Tutorial 

Bentley Systems, Incorporated   127 

  
10. Close all dialogs. 
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