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Component Display Rules overview 
Component Display Rules allow the user to create variations to a template based on external 
influences such as H/V controls and end-conditions. This is a very powerful concept that allows 
the user to apply one template that will actually change based on what is happening at a 
particular station.  
 
This concept frees the user from knowing where a change in conditions might require a different 
template and allows the rules within a template to make modifications. 
There are two main parts to this functionality:  
First, there are the individual rules, which are stored on the template.  The following types are 
supported:  

� Horizontal 

� Absolute Horizontal (uses absolute values) 

� Vertical 

� Absolute Vertical 

� Slope 

� Absolute Slope 

� Component is Displayed 
All but the last are conditional expressions between points that use one of the <, <=, =, >=, > 
operators to compare the specified difference between the two points to a particular value. 
  
Example: Rule1 - Horizontal Difference between Point1 and Point2 is less than 10 
  Rule2 - Slope from Point1 to Point2 is greater than -10% 
  Rule3 – Slope from Point1 to Point2 is less than 10%  
The rule, in general has 5 components. 

� Name (no spaces allowed) 

� Type ( e.g. Absolute Horizontal Difference ) 

� Calculated value ( e.g. Point1.x – Point2.x ) 

� Test ( <, <=, =, > , >= ) 

� Test Value (e.g. 10 ) 

Introduction to Roadway Designer 
Component Display Rules 
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The second part of this functionality is the conditional expression that is stored on the 
component.  An example of a conditional expression is: 
  Rule1 OR (Rule2 AND Rule3)  

 

Module Objectives 

Upon completion of this module, you will be able to: 
 

� Define and explain some of the uses of Component Display Rules. 
  

� Develop a template that contains a set of Component Display Rules that 
automatically changes the template based on design conditions. 
 

� Apply the template to a design and review the results. 
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Introductory Knowledge 

Before you begin this module, let’s define what you already know. 
  Templates are created in the Roadway Designer file. 

  [ ] True 
  [ ] False  
  A copy of the templates are stored in the Roadway Designer file. 

  [ ] True 
  [ ] False  
   The template origin [0,0] represents which point: 

  [ ] The point of intersection of two vectors in a component. 
  [ ] A Required point in a template. 
  [ ] The point where the horizontal and vertical alignment is applied. 
  The dynamic origin is always the template origin 

  [ ] Yes 
  [ ] No 
  Component Display Rules are created in the Roadway Designer. 

  [ ] Yes 
  [ ] No 



Introductory Knowledge Answers 
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Introductory Knowledge Answers 

 Templates are created in the Roadway Designer file. 
This is False. Templates are created and saved in their own XML based file that has an 
ITL filename extension. 

  A copy of the templates are stored in the Roadway Designer file. 
This is True.  When you add a template drop to a corridor, the Roadway Designer make a 
direct copy of the template and adds it to the Roadway Designer. This is important to 
know when verifying template definition. If a change is made in a template after being 
added to a design, synchronizing between the ITL and IRD is recommended. 

   The template origin [0,0] represents which point. 
The [0,0] point of the template is the point of the Horizontal and Vertical alignment 
where the template is applied. It does not require a point at that location. All template 
point locations are computed relative to this point. 

 The dynamic origin is always the template origin 
 No. The dynamic origin is as its name implies, it is a dynamically applied location within 

the template. Component points can be placed relavtive to this origin which is similar to 
the tentative point snap in MicroStation. It can also serve as the insertion point location of 
a template when combining templates. 

  Component Display Rules are created in the Roadway Designer. 
No. Component Display Rules are created in the template library inside a specific 
template. They are applied directly to a component within a template and then the 
Roadway Designer acts on a set of points to determine the Component Display Rule. 



Topic: Adding a retaining wall template to an existing 4 lane template. 
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Topic: Getting Started 

Objective: 
Start InRoads and load data. 

 EXERCISE 1: STARTING INROADS 

1. Start InRoads by selecting Start > Programs > Bentley > InRoads Group XM > 
InRoads. 

2. Browse to the workshop folder and select “Model.dgn” 

3. After InRoads starts, from the InRoads Explorer window select File > Open…. 
Browse to the workshop directory and select “project.rwk”. 

Hint You can Drag and Drop files from the Windows Explorer directly to the 
InRoads explorer to load InRoads data files. 

Topic: Adding a retaining wall template to an existing 4 lane 

template. 

Objective: 
This lesson will take an existing template and combine another template that defines a median 
retaining wall. Then define a set of Component Display Rules displays this wall when the 
vertical elevation between the roadways is exceeded. 

 EXERCISE 2: COMBINING A TEMPLATE 

This exercise will copy an existing 4 lane template. The copied template will be edited and a 
median retaining wall template (group of components) will be added. 

1. Activate the Create Template dialog by selecting Modeler > Create Template. 
2. Navigate the tree view to the Typical Sections folder and select the “4 Lane” 

template. 
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3. Right-click and Copy the 4 Lane template and Paste it to the same location. 
This creates a template of the same name, incremented by “1”. 

 
4. Set the template “4 Lane1” active by double-clicking on the template name in 

the tree view.  

 

Note The active template is identified in the tree view by the red square 
highlighting the template icon. 
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5. Expand the “Components” folder and single-click select the “Median 

Retaining Wall” template. The retaining wall template should appear in the 
Preview Window at the same time the template “4 lane1” appears in the active 
template window. 
 

 



Topic: Adding a retaining wall template to an existing 4 lane template. 
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6. Turn on Display Point Names. Zoom in using the view control or middle 
mouse wheel on the point “RIS” 

 
6. Verify the affixes in the Tools > Settings. Drag and Drop the “Median 

Retaining Wall” from the right side insertion point onto the point “RIS”. 
The resulting typical section should appear similar to the following: 

 



Topic: Adding a retaining wall template to an existing 4 lane template. 
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 EXERCISE 3: CREATE A COMPONENT DISPLAY RULE. 

This exercise will create 3 display rules that determine when the retaining wall will be 
constructed if a certain set of criteria is met. 

1. Edit one of the retaining wall shoulders. Notice the parent component. 

 
Note The parent component “Retaining Wall Barrier”, tells the software that 

whatever action is applied to the parent component will also be applied 
to this “child” component.  

2. Cancel the Component Properties dialog. 

3. Right-click on the Retaining Wall Barrier component and select Set 
Component Display Rules. 
This will activate the Component Display Conditional Expression dialog. 
Notice the component name in the Conditional Expression portion of this 
dialog. 

 
4. Add a new Template Display Rule. Select the Add... Button at the bottom of the 

dialog. 

5. This rule checks to see if the bottom of the median ditch point “CMD” is 
above the “RIS” (Right Inside Shoulder) point. 
 
Key-in the Name: “CMD>RIS” 
Description: “Median ditch is higher than RT shoulder” 
Set the Type: Vertical 
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Between: RIS 
And: CMD 
>= -0.50 

 
6. Select OK to add this rule and dismiss that add dialog. 
7. Add a second rule that tests for the median ditch with the LIS (Left Inside 

Shoulder). 

 
8. Add a Third rule that determines whether or not the Retaining Wall Barrier is 

displayed. This rule is applied to the “Median” component. 
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9. Add the Conditional Expression to the “Retaining Wall Barrier” component. 
Because the retaining wall needs to be displayed when the CMD point is 
above either LIS OR RIS, both of the vertical tests are added. 
Select the first rule in the rules list and press Selected Rule.  
Select the OR button. 
Select the Second rule in the rules list and press Selected Rule. 

10. Evaluate the expression by using the [=] button. Note that this expression 
evaluates to “False”. 

 
11. Select OK to dismiss the Component Display Conditional Expression dialog. 



Topic: Adding a retaining wall template to an existing 4 lane template. 
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12. Set the component display rule for the Median component. Right-click Edit 
component on the Median ditch and select the Edit… button next to the 
Display Rules: read only field. 

 
13. Because we want the median to display when the Retaining Wall Barrier 

component is NOT displayed, add a NOT before adding the “component is 
displayed” expression. 

Notice that by adding the “NOT” to this expression, it evaluates to True even though the actual 
expression evaluates to False. 
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14. Select OK to dismiss the Component Display Conditional Expression dialog and 

OK to dismiss the Component Properties dialog.  

15. Turn on Display All Components. 
16. Move one of the unconstrained points to check your results. 

 
Results 

17. Save the ITL file by selecting File > Save. 



Topic: Combining Concrete Median Barrier to an existing 4 lane template. 
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Topic: Combining Concrete Median Barrier to an existing 4 lane 

template. 

Objective: 
This lesson will take the existing template from the previous exercise and add another template 
that defines a concrete median barrier. Then define a set of Component Display Rules that will 
display the concrete barrier when a minimum distance between roadways is met. 

 EXERCISE 4: COMBINING A TEMPLATE 

This exercise copies the existing 4 lane template. The copied template is edited and a barrier wall 
with shoulders is added. 

1. Activate the Create Template dialog by selecting Modeler > Create Template. 
Navigate the tree view to the Typical Section Folder and select the“4 Lane1” 
template. 

 
2. Right-click Copy the 4 Lane1 template and Paste it to the same location. This 

creates a template of the same name, incremented by “1”. 

3. Set the template “4 Lane11” active by double-clicking on the template name 
in the tree view.  

4. Expand the “Components” folder and single-click select the “Jersey Median” 
template. The Jersey Median template should appear in the Preview Window at 
the same time the template “4 lane11” appears in the active template window. 
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5. Drag and Drop the “Jersey Median” template to the 0, 0 point in the template. 

 
 

6. Select the Jersey Barrier LLIEP and right-click Move Point. Move the point 
LLIEP until it snaps to the LIEP point of the four lane template. 

Hint Use the mouse wheel while in the move point state to zoom in and out to 
center in on the LIEP point. 

7. Right-click on the LIEP point and Select Merge point. At the Delete Point 
selection dialog, delete LLIEP. 

Hint If you select the wrong point for merging, press the ESC key at the Delete 
Point selection dialog to prevent merging. If you have merged the 
incorrect point, you can always use the “undo” button located at the view 
control icon at the bottom of the template window.   
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8. Repeat the process for RIEP. Select the Jersey Barrier RRIEP and move it 

until it snaps to the RIEP point of the four lane template. 

9. Right-click on RIEP and Select Merge Points. 

10. Delete the RRIEP point. 

11. Save the Template file by selecting File > Save. 



Topic: Combining Concrete Median Barrier to an existing 4 lane template. 
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 EXERCISE 5: CREATING DISPLAY RULES 

This lesson assigns and edits Component Display Rules to automatically place the Jersey Barrier 
and its child shoulder components when the distance between the roadways is <= 20. (6.8m) 

12. Right-click on the Jersey Barrier and select Set Component Display Rules. 

13. Add a new Template Display rule.  

14. Key-in a Name: “JerseyBarrier” and a Description: Median is less than 20 wide. 
Set the Type: Horizontal between points RIEP and LIEP and key-in a value of 
20. 

 
The distances are measured based on the Horizontal offsets between the points. For example, in 
this case, the LIEP offset is -37.00 and the Right offset is 37.00. Since it is evaluated as 37- (-37) 
<= 20.0 then it is False.  
Another method of performing this operation is to use the Absolute Horizontal type evaluation. 
The “Absolute” evaluation performs the mathematical test on the points reducing each point to 
their absolute values. Included in this type is Horizontal, Vertical and Slope.  
In this case an absolute value allow you to choose either point regardless of the order even 
though one offset is negative and the other positive. 

15. Press OK to accept and dismiss the Display Rule dialog. 



Topic: Combining Concrete Median Barrier to an existing 4 lane template. 
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16. Select this rule from the list and add it as an expression for the Jersey Barrier 
component. Add the expression “AND NOT RetainingWallDisplayed”.  Click 
OK when finished. 
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The template should now contain dashed components of both types of walls within the median. 
Notice that the inside shoulders for the standard median ditch are displayed and we need those 
components to disappear when the Jersey Barrier is displayed. Also, the Median Ditch should not 
be displayed when the Jersey Barrier is displayed. 

17. Right-click Edit the left inside shoulder 
component named “AKG1”. 

18. From the Component Properties dialog, select Edit 
next to the Display Rules read only field. 

 
19. Add a new template display rule. 

Name: JerseyBarrierDisplayed 
Type: Component is Displayed 
Component: Jersey Barrier 

 
20. Press OK to add the rule and dismiss the Display Rule dialog. 

21. Add the opposite of this rule to the AKG1 component by using the NOT 
operator. 



Topic: Combining Concrete Median Barrier to an existing 4 lane template. 
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22. Press OK to add this rule to the component and OK to accept the edit to the 
AKG1 component. 

23. Add this rule for the right inside shoulder, AKG4. 

 
The median ditch component already has a rule that states that if the Retaining Wall is displayed, 
then the Median will NOT be displayed. You need the same type of rule to apply if the Jersey 
Barrier is displayed. 

24. Edit the Median ditch component and Edit the Display Rules for the Median. 
Since this component will NOT be displayed if either the Retaining Wall or the Jersey Barrier is 
displayed then an OR statement is required.  

25. Change the Conditional Expression for the Median component to the 
following: 
NOT (RetainingWallDisplayed OR JerseyBarrierDisplayed ) 

26. Select OK to accept the change and OK to dismiss the Component Properties 
dialog. 

 
Test this rule by moving the CL of the roadway points inward (towards the CL) 
until the rule conditions are met. 



Topic: Combining Concrete Median Barrier to an existing 4 lane template. 
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Results 

Hint You can also use the Test button to check the display rules. 

27.  Save the ITL file and Close the Create Template dialog. 



Topic: Evaluating the Design. 
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Topic: Evaluating the Design. 

Objective: 
This lesson takes the template from the previous exercises and applies it to the corridor design.  

 EXERCISE 6: REVIEWING EXISTING DESIGN. 

This exercise reviews the existing 4 lane design. The areas that apply the component display 
rules are noted and various design elements discussed. 

1. Activate the Roadway Designer dialog by selecting Modeler > Roadway 
Designer. 

Note the “Right of Way” reference in the Cross Section view of the designer.  
It shows the outside edges of pavement as well as the Northbound and Southbound centerlines. 
These points as well as the inside edges of pavement are controlled by a new type of constraint 
“Style Constraint”. The style constraint permits the designer to “target” a feature or alignment 
Style. This eliminates the necessity of adding point controls to vary edge of pavement widths and 
in this case the vertical alignment of each roadway. 

 
2. Window in on the plan view at the south end of the corridor (at the first 

Median crossover). Key-in station 705+00 in the Station navigation field and 
press tab. 

3. Note the automatic width change based on the LIEP and RIEP alignment 
“Styles”. 



Topic: Evaluating the Design. 
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4. Process ahead station to station 735+00 and note the issue with the median.  

This is the area that is addressed by the first component display rule.  
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5. Process to station 825+00. Note the median width in this area.  

Hint You can hover over a point to get tool tip information of the point offsets. 



Topic: Evaluating the Design. 
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 EXERCISE 7: REVISING THE DESIGN. 

In this lesson, the 4 lane design is updated with the template that contains the component display 
rules completed in the previous exercises. The areas that require design revision using 
component display rules are noted and various automated design elements reviewed. 

6. Use the Station Navigation arrow to go to the first station of the corridor. 

 
7. Activate the Template Drops dialog by selecting the icon on the main 

Roadway Designer dialog. 

 
8. Select the Current template Drop entry. 

9. Navigate the Tree view of the Template Library to the Typical Sections 
folder.  

 



Topic: Evaluating the Design. 
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10. Select the copied template from Exercise 4 “4 Lane11” and press Change. 

11. Close the Template Drops dialog. 

12. Key-in station 734+00 and check the results. 

 
13. Key-in station 825+00 and review the results. Process ahead and back several 

stations. 



Module Review 
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Module Review 

Now that you’ve completed this module, lets gauge what you’ve learned: 
 
 Where are component display rules stored? 

A. Inside the Roadway Designer 
B. On the Template component 
C. In the Template 
D. Inside the Geometry file 

 What is the difference between a Component Display Rule and a Component Conditional 
Expression? 
 

  
 What affect does a parent child component relationship have on component display rules? 

A. If a component is a child it is controlled by its parent’s Component Display Rule. 
B. Has no effect because the Component Display Rule always has priority. 
C. Should not be used in conjunction with a CDR. 
 

 Can you test component display rules within the create template command? 
A. Yes 
B. No  

 Name one way to test a component display rules affect on a template? 
 
 
 
 What is the use of the NOT expression? 

A. Exclusively used to evaluate to False. 
B. To perform the opposite evaluation of  a given rule. 

 
 When would absolute values in the Display Rule be needed? 

A. To check a distance or slope regardless of direction or offset. 
B. To provide a specific point order. 
C. Used only in Horizontal offsets. 



Module Summary 

 

 

Nov-08                                                                           29                           Introduction to Roadway Designer                  
                                                                                                   Component Display Rules  

Copyright © 2008 Bentley Systems, Incorporated 

Module Summary 

Component Display Rules are an extremely powerful function within the InRoads Roadway 
Designer. There is essentially no limit to how a set of rules can be created and applied to a 
design. 
More complex design solutions can be applied in an automated fashion with this product than 
with any previous product. This capability coupled with the interactive nature of the Designer 
permits the most innovative design solution to date. 
This workshop has taken you through the steps involved in creating, defining, and testing 
Component Display Rules. 
You are now able to: 

� Edit a template to include a median retaining wall to accommodate vertical 
grade separation. 

� Establish a set of rules to apply to the retaining wall when the vertical 
difference is exceeded. 

� Edit the template to include a concrete median barrier. 

� Set rules on the median barrier to establish the criteria when the median 
barrier should be placed in the design. 

� Update the Roadway Design with the new template containing Component 
Display Rules and reviewed the results. 
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Module Review Answers 

 Where are component display rules stored? 
C. The component display rules are store in the template. The conditional expression is stored 

directly on the template component.  
 
 What is the difference between a Component Display Rule and a Component Conditional 
Expression? 
The Component Display Rule performs a mathematical operation between two points or in the 
case of Component is Displayed checks to see if a component is displayed, and a Conditional 
Expression performs and evaluation of  a CDR or set of CDR’s on a component. 

  
 What affect does a parent child component relationship have on component display rules? 

A. If a component is a child of a component that contains a Conditional Expression, then it will 
be governed by the same set of rules. 

 
 Can you test component display rules within the create template command? 

A. Yes. There are two ways to check the CDR inside the template 
 
 Name one way to test a component display rules affect on a template? 

1. Use the Test function within the Create Template and toggle the display rule evaluation 
between True and False 

2. Release point constraints inside the template and move the point(s) till you get a change in 
the evaluation of the Conditional Expression. 

3. Apply the template to your design the contains sufficient controls to evaluate the changes in 
the Conditional Expression. 

 
 What is the use of the NOT expression? 

B. This operator does not necessarily always evaluate a conditional expression to False. It is 
intended to perform the opposite operation on the component based on the rule results. 

 
 When would absolute values in the Display Rule be needed? 

A. To check a distance or slope regardless of direction or offset. 


