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Lesson Name: Launching and Loading 

LESSON OBJECTIVE: 
In this lesson the student will launch InRoads Storm & Sanitary and load the project data.   

EXERCISE: LAUNCH AND LOAD 

This exercise will guide you through the steps to launch the software and load the data. 

1. Go to Start > Programs > Bentley > InRoads Group v8i > InRoads Suite. 

2. When the MicroStation Manager appears browse to the C:\2009 RBC\IW-3\DATA 
folder, select the file named IW-3_Drainage.dgn and click Open button. 
 

 
 

3. When the InRoads Explorer appears, select InRoads >File > Project Defaults. 
4. When the Set Project Defaults dialog appears select 2009 RBC IW-3 Drainage 

from the Configuration Name list.   

This tells InRoads what settings files to use and the starting directories in the 
various File Open and File Save As… dialogs. 

5.  Click Apply. 

6. Close the Set Project Defaults dialog. 

7. In the InRoads Explorer, select InRoads>File > Open. 

8. When the Open dialog appears select Files of Type: Project (*.rwk). 
9. Select the InRoads project file:  

C:\2009 RBC\IW-3\DATA\IW-3 Drainage.rwk and press Open. 

10. Click Cancel to close the Open dialog. 
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EXERCISE: VERIFY THE LOADED DATA AND SETTINGS 

1. This exercise will reviews the loaded data and settings. 

Opening the RWK project file opens the following files: 

Drainage IW-3 Drainage 

Surface design 

Geometry IW-3 Drainage 

Preference Bentley Training IW-3 

These steps should be performed by the user: 
1. Display Contours (Select InRoads > Surface > View > Contours). 
2. Optional but useful step: 

in the InRoads Explorer 
click on the Drainage 
workspace tab.  This 
provides some additional 
feedback when laying 
out drainage structures 

 

 

The following steps should already have been done as part of the class setup: 
1. Verify that the MicroStation Key in field is visible (MicroStation > Utilities > 

Key-in). 
2. Verify that the InRoads Style Lock is ON (InRoads > Tools > Locks > Style). 
3. Verify that a Cell Library is loaded (MicroStation > Element > Cell). 
4. Verify that the Callouts Reference file Display is ON. 
5. Verify the Cell Scale Factor is 1 (InRoads > Tools > Options >> Factors). 
6. Verify that the Hydrology and Hydraulics Application Add-In is enabled 

(InRoads > Evaluation > Hydrology and Hydraulics).  If not, select via 
InRoads > Tools > Application Add-In. 
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Lesson Name:  Using the Lay Out dialog 

LESSON OBJECTIVE: 
Lay Out some (random?) Inlets and a (random?) Pipe and Review their Settings. 

EXERCISE:  LAY OUT TWO INLETS IN LOCATIONS 

This exercise will guide you through the steps to Lay Out two Catchpit inlets in sump 
locations 

Click InRoads > Drainage > Lay Out. 
1. Select the Inlet tab. 

2. Click on the Graphic Locator button to the right 
of the Northing Easting and Elevation fields. 

3. Snap to the end of the Sump Catchpit 1 leader.  

 
4. Click Apply. 
Note that graphics for the inlet are placed and the form resets for the next inlet. 

5. Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

6. Snap to the end of the Sump Catchpit 2 leader.  

7. Click Apply. 

Note that graphics for the inlet are placed and the form resets for the next inlet. 

 

EXERCISE:  LAY OUT A PIPE 

This exercise will guide you through the steps to Lay Out a pipe between the two 
Catchpits. 

1. Select InRoads > Drainage > Lay Out. 
2. Select the Pipe tab. 

 

A pipe has two ends: the 
Upstream and Downstream end.  
This is the sole determinant of 
what direction the pipe flows.   

Each end of a pipe can be either 
attached to a structure or be 
unattached in free space. 

In this exercise we will be 
connecting each end of the pipe to 
an inlet. Be sure to select the 
Graphic Locators next to the ID 
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fields. 

3. Click on the Graphic Locator button to the right of the Upstream ID field. 

4. Click on the eastern catchpit (IN1).  A “snap” is not necessary. 

5. Click on the Graphic Locator button to the right of theDownstream ID field. 

6. Click on the western catchpit (IN2).  A “snap” is not necessary. 

7. The Upstream and Downstream ID fields should read IN1 and IN2, respectively. 

8. Click Apply. 

Note that graphics for the pipe are placed and the form anticipates that the Downstream 
Inlet will be the Upstream Inlet for the next pipe. 

9. Close the Drainage Lay Out dialog 

 

EXERCISE:  REVIEW THE STRUCTURES 

This exercise will guide you through the steps to review the structures just placed. 

1. Select InRoads > Drainage > Edit/Review. 

2. At the “Key in ID or identify structure” prompt select the first inlet. 
The Edit/Review Inlet dialog shows the attributes in the Inlet database record.  Some of the 
fields are editable, others are selectable, others are read-only.  Note the Type, Class, and 
size of the Inlet.  The data is segregated by functional categories by Tabs across the top of 
the form. 

3. Click the Edit Down button, which will review the data of the structure (the pipe) attached 
downstream of the current inlet. 

4. Click Close when done. 
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EXERCISE:  DELETE THE STRUCTURES 

This exercise will guide you through the steps to delete the structures we just placed. 

1. Select InRoads > Drainage > Structure > Delete. 

2. At the “Identify item to delete” prompt, select the eastern inlet (IN1). 

3. Accept the selection with a datapoint 

4. At the “Identify item to delete” prompt, select the western inlet (IN2). 

5. Accept the selection with a datapoint 

6. At the “Identify item to delete” prompt, select the pipe. 

7. Accept the selection with a datapoint 

8. At the “Identify item to delete” prompt, right-click (Reset) to exit the command. 

 

Lesson Name:  Lay Out structures with intentional settings 

LESSON OBJECTIVE:  
Learn how settings are defined and how to set them.  Lay Out structures with proper settings. 
The Drainage database stores a great deal of data for each drainage structure types it models.  
Pipes, for example, have over 70 storable attributes, inlets over sixty, plus user-definable fields.  
Laying Out structures would be a very slow process if the user had to answer fifty questions 
per structure.   
There is a spectrum of “volatility” in the information used to define structures.   

 
At one end of the spectrum is information that changes for every structure.  These are the 
settings available on the Lay Out dialog.  At the other end of the spectrum is information that 
seldom changes or changes only between different geographic or regulatory regions.  This 
information is located in files that the user can select, but seldom needs to edit.   

In between the most dynamic and the most static information is the information that varies 
less than always but more than seldom.  S&S groups most of the settings in the Drainage 
Options dialog.  
Any information required to place a structure, which is not specifically asked for on the 
Lay Out dialog, is taken from the Drainage Options settings or from support files.   
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EXERCISE:  LAY OUT TWO CATCHPIT INLETS IN THE PREVIOUS SUMP LOCATIONS 

This exercise will guide you through the steps to Lay Out two Catchpit inlets in sump 
locations, this time making sure that we are using proper settings. 

1. Select InRoads > Drainage > Lay Out. 
2. Select the Inlet tab. 

3. Click the Options button. 

4. The Drainage Options dialog opens to the Inlet tab.  There are many settings the 
user may adjust here.  To streamline the processes of defining and retrieving 
(Saving and Loading) settings most InRoads dialogs have a Preferences button. 

5. Click the Preferences button. 

6. The Preferences dialog lists the pre-defined Preferences for the parent dialog, 
Drainage Options.  Controls allow Loading, Saving, and Deleting the command’s 
Preferences. 

7. Select the IW-3 CatchpitSump3x3 preference, Click Load and then Close the 
Preferences dialog. 

8. Review the Inlet settings.   

9. Click on the Pipe tab to review the pipe settings that were also loaded as part of the 
IW-3 CatchpitSump3x3 preference. 

10. Review the settings under the other tabs. 

11. Click Apply and Close the Drainage Options form. 

12. In the Drainage Lay Out form click on the Graphic Locator button to the right of the 
Northing Easting and Elevation fields. 

13. Snap to the end of the Sump Catchpit 1 leader.  

14. Click Apply. 

Note that graphics for the inlet are placed and the form resets for the next inlet. 

15.  Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

16. Snap to the end of the Sump Catchpit 2 leader.  

17. Click Apply. 

18. Note that graphics for the inlet are placed and the form resets for the next inlet. 

19. Select the Pipe tab of the Drainage Lay Out dialog. 

20. Click on the Graphic Locator button to the right of the Upstream ID field. 

21. Click on the eastern catchpit (IN1).  A “snap” is not necessary. 

22. Click on the Graphic Locator button to the right of theDownstream ID field. 

23. Click on the western catchpit (IN2).  A “snap” is not necessary. 

24. The Upstream and Downstream ID fields should read IN1 and IN2, respectively. 

25. Click Apply. 
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Note that graphics for the pipe are placed and the form anticipates that the Downstream 
Inlet will be the Upstream Inlet for the next pipe. 

We will now place a free-exit outfall pipe discharging into the ditch next to the road. 

26. Click on the Graphic Locator button to the right of 
theDownstream Northing and Easting fields. 

27. Click on the “Outfall Pipe” leader. 
The Upstream and Downstream ID fields should read IN2 
and FREE_EXT, respectively.  The Slope field is negative, 
indicating that the pipe is going uphill (but still downstream). 

28. Key in 0.5% for the Slope. 

29. Click Apply. 

 

30. The graphics for the pipe are placed and the form anticipates that the Downstream 
Inlet will be the Upstream Inlet for the next pipe. 

31. Close the Drainage Lay Out dialog. 

32. Save your results in the drainage database by clicking InRoads > Save > Drainage 
Data.  It is a good idea to save the database whenever you’ve completed and 
verified any significant amount of work (there is no Auto-Save). 
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Lesson Name:  Displaying and Annotating Structures 

LESSON OBJECTIVE: 
Learn how to Display and Annotate Structures. 

EXERCISE:  DISPLAY THE DRAINAGE STRUCTURES 

All the information necessary to display the Storm & Sanitary structures is contained in the 

database.  The graphics are created from the database and not primary sources of 

information.  As such, they can be deleted or otherwise manipulated with CAD commands 

with no effect on the information in the database.  Manipulating the database information can 

only be accomplished using Storm & Sanitary commands. 

The InRoads Style Lock (InRoads > Tools > Locks > Style) affects how the structures are 

displayed.  For structure display we will limit our discussion to the Style Lock being ON. 

 

1. Window in to the Storm & Sanitary structures. 

2. Select MicroStation > Edit > Select All. 
3. Click the MicroStation Delete tool (or hit the Delete key).  This deletes all the 

graphics, but note that the InRoads Explorer still shows 2 Inlets and 1 Pipe (if the 
Drainage workspace tab is selected). 

4. Select InRoads > Drainage > View > Drainage. 
The structure graphics are displayed (or re-displayed) from information in the database.  
If the View Drainage dialog appears the Style Lock is OFF.  Close the dialog, turn the 
Style Lock ON and then select Drainage > View > Drainage again. 

The Storm & Sanitary junction structure (Inlets and Manholes) display is composed of a 
vault and an optional cell.  The inlets show inside and outside vault walls and a cell 
representing the inlet grate.  The Cell Scale Factor (InRoads > Tools > Options > 
Factors) is currently set at 1.0, which provides a true-scale representation of the grate.  
For large scale plots or projects it is often desirable to make the Cells much larger by 
increasing the Cell Scale Factor.  The vaults are always shown true-scale. 
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EXERCISE:  ANNOTATE THE DRAINAGE STRUCTURES 

This exercise shows the user how to display Structure information using the Annotate 
Structures tool and pre-defined Preferences. 
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Style Lock can affect Annotation symbology.  With Style Lock ON Storm & Sanitary reads the Style 

field in each data record and uses that definition for the structure’s annotation symbology; With 

Style Lock OFF all structures display according to the symbology as defined in the Symbology frame 

of the Annotation Structures 

 dialog.  The content does not change though the level, text style, size and orientation may. 

The text created by this command is typical MicroStation text.  It can be manipulated by the 

typical CAD commands.  The text size defined in the symbology is, like all InRoads text, multiplied 

by the Global Text Scale factor (InRoads>Tools>Options>>Factors).  It honors the InRoads 

Pencil/Ink toggle and the Delete Ink lock.  

Each structure’s text is a single Multi-Line Text node.  All structure annotation created by a single 

click of the Apply button is a graphic group.  When moving text around to minimize overlaps turn 

the Graphic Group Lock OFF. 

 

1. Window in to the Storm & Sanitary structures. 

2. Select Drainage > View > Annotate Structures. 
3. Click Apply. 

This command is for bulk 

annotation and is 

excellent for getting 

necessary information 

very quickly.  For final 

sheet callouts the 

InRoads Drafting Notes 

functionality is fully 

integrated with the Storm 

& Sanitary graphics and 

database.  Both 

methodologies can 

annotate any attribute in 

the database, including 

custom data fields.   
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The Structures are annotated according to whatever Annotate Structures Preference is 
active. 

Everything in the database may be annotated.  Because there are literally tens of 
thousands of combinations of attributes, suffixes, prefixes, etc., using Preferences is the 
only efficient way to use this command.  If you edit the settings to something you 
would like to use in the future Save them as a new Preference. 

4. Click the Preferences button. 

5. Load the Type and Size preference.   

6. Close the Preferences dialog. 

7. Click Apply. 

This Preference shows some structural information that can help determine if the 
structures you placed are the proper Type and Size.  You can use InRoads > Drainage 
>Edit/Review to make changes if necessary.  Change the Global Text Scale factor 

(InRoads>Tools>Options>>Factors) as necessary (make sure you leave the Cell Scale factor at 

zero). 

 

EXERCISE:  USE INROADS DRAFTING NOTES FOR INDIVIDUAL STRUCTURE CALLOUTS 

This exercise shows how the Storm & Sanitary database is integrated into the InRoads 
Drafting Notes functionality.  Notes provide “final sheeting” callouts, including frames and 
leaders with or without terminators .  Unlike the Annotate Structures tool, which is One-
Click-Many-Structures, Drafting Notes requires a click or two per structure.   

1. Window in to the Storm & Sanitary structures. 

2. Select InRoads > Drafting > Place Plan Note. 

 

The Drafting Notes 
definitions are stored in a .dft 
file, that has been specified as 
part of the InRoads Project 
Configuration.  Plan, Profile 
and Cross Section Notes all 
behave similarly, but due to 
slight variations in their 
respective dialogs, they are 
launched via separate menu 
items. 

The Note File list shows the 
contents of the active Drafting 
Definition file (*.dft).    

 

3. In the Note File list expand the file to the subfolders Plan, Profiles, and Sections. 

4. Expand the Plan folder. 
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5. Select Structure ID and All Inverts Note. 

6. Click Apply. 

7. At the “Identify element” prompt click the long pipe and Accept it. 

MicroStation prompts “Identify Note Location” for the note, which is “attached” to the 
cursor with a leader starting at the point where the pipe was selected. 

8. Place the note with a datapoint. 

9. At the “Identify element” prompt click the upstream inlet and Accept it. 

10. MicroStation prompts “Identify Note Location” for the note.  Notice that since the 
inlet’s Invert In field is blank (it is the uppermost structure in the network) the 
note’s “INVERT EL IN =” is followed by “{InvertIn}”, indicating that that field is 
blank. 

11. Right-click to cancel the note placement and right-click again to return to the Place 
Plan Note dialog. 

12. Place a note at the inlet using the Structure ID and Outgoing Invert note.  
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Lesson Name:  Laying Out On-Grade Combination Inlets and Pipes 

LESSON OBJECTIVE: 
Lay Out Combination Inlets On Grade.   

EXERCISE:  LAY OUT TWO COMBO GRATE INLETS IN ON-GRADE LOCATIONS 

This exercise will guide you through the steps to Lay Out two Curb Grate inlets in On-
Grade locations. 

1. Adjust the CAD view so that the ComboInlet callouts are visible. 

2. Select InRoads > Drainage > Lay Out. 
3. Select the Inlet tab. 

4. Click the Options button. 

5. The Drainage Options dialog opens to the Inlet tab.  There are many settings the 
user may adjust here.  To streamline the processes of defining and retrieving 
(Saving and Loading) settings most InRoads dialogs have a Preferences button. 

6. Click the Preferences button. 

7. Select the IW-3 ComboInletOn-Grade6x3 preference, select Load and then 
Close the form. 

8. Review the settings under the Inlet tab.   

9. Click on the Pipe tab to review the settings that were also loaded as part of the IW-
3 ComboInletOn-Grade6x3 preference. 

10. Click on the Gutter tab to review the gutter settings that were also loaded as part 
of the preference. 

An important drainage design limit in gutter spread.  Storm & Sanitary calculates 
the spread at each inlet assuming that all surface flow runs through a gutter whose 
dimensions were defined from the Gutter dimensions active at Lay Out.  The gutter 
flow spread, depth, and velocity, as well as the size and geometry of the grate 
determine the amount of flow captured by the inlet. 

11. Click Apply and Close the Drainage Options form. 

12. In the Drainage Lay Out form click on the Graphic Locator button to the right of 
the Northing Easting and Elevation fields. 

13. Snap to the end of the ComboGrate #3 leader, which ends at the gutter flow line 
of the road 

14. Click Apply. 

Note that graphics for the inlet are placed and the form resets for the next inlet.  
The grate should be aligned with the curb.  One of the active Drainage Option 
settings aligns the inlet parallel to the active horizontal alignment.  If the North-
South road is not the active alignment, the Orientation may not align with the curb.  
The Edit/Review tool can be used to change the inlet Orientation if necessary. 
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15.  Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

16. Snap to the end of the ComboGrate #4 leader.  

17. Click Apply. 

Note that curb is rotated automatically so that the grate is in the road. 

18. Select the Pipe tab of the Drainage Lay Out dialog. 

19. Click on the Graphic Locator button to the right of the Upstream ID field. 

20. Click on the eastern combo inlet (IN3).  A “snap” is not necessary. 

21. Click on the Graphic Locator button to the right of theDownstream ID field. 

22. Click on the western combo inlet (IN4).  A “snap” is not necessary. 

23. The Upstream and Downstream ID fields should read IN3 and IN4, respectively. 

24. Click Apply. 

Note that graphics for the pipe are placed and the form anticipates that the 
Downstream Inlet will be the Upstream Inlet for the next pipe. 

 

EXERCISE:  LAY OUT TWO COMBO INLETS USING PRECISION INPUT 

This exercise will guide you through the steps to Lay Out two Curb Grate inlets in On-
Grade locations using Precision Input. 

1. Select InRoads > Drainage > Lay Out. 
2. Select the Inlet tab. 

3. Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

4. When the form disappears, key in “so=1800,-14” in the MicroStation key in field 
and hit return. 

The Drainage Lay Out dialog returns with the Northing Easting and Elevations 
values from that station offset location. 

5. Click Apply. 
The graphics for the combo inlet are placed. 

6. Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

7. When the form disappears, key in “so=1800,14” in the MicroStation key in field 
and hit return. 

The Drainage Lay Out dialog returns with the Northing Easting and Elevations 
values from that station offset location. 

8. Click Apply. 

The graphics for the combo inlet are placed. 

9. Select the Pipe tab of the Drainage Lay Out dialog. 

10. Click on the Graphic Locator button to the right of the Upstream ID field. 
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11. Click on the ComboInlet #4 (IN4).  A “snap” is not necessary. 

12. Click on the Graphic Locator button to the right of theDownstream ID field. 

13. Click on the right-side inlet to the south (IN6).  A “snap” is not necessary. 

14. The Upstream and Downstream ID fields should read IN4 and IN6, respectively. 

15. Click Apply. 

16. Click on the Graphic Locator button to the right of the Upstream ID field. 

17. Click on the left-side ComboInlet at station 18+00, -14 (IN5).  A “snap” is not 
necessary. 

18. Click on the Graphic Locator button to the right of theDownstream ID field. 

19. Click on the right-side inlet at station 18+00, 14 (IN6).  A “snap” is not necessary. 

20. The Upstream and Downstream ID fields should read IN5 and IN6, respectively. 

21. Click Apply. 

Note that graphics for the pipe are placed and the form anticipates that the 
Downstream Inlet will be the Upstream Inlet for the next pipe. 

 

Lesson Name:  Using some Hydrology and Hydraulics Tools 

LESSON OBJECTIVE: 
Use some of the Hydrology and Hydraulics tools to establish inlet locations. 

EXERCISE:  USE THE TRICKLE COMMAND TO LOCATE SUMP LOCATIONS 

This exercise will guide you through the steps to use the Trickle command to locate sump 
locations. 

1. Display the road features by displaying the Surface Features (InRoads > Surface > 
View > Features) or turn on the Display of the RoadFeatures reference file. 

2. Select InRoads > Evaluation > Hydrology and Hydraulics > Trickle. 

3. Ensure that the Surface is set to design, Direction is set to Down, and the 
Dynamics check box is enabled. 

Our area to be evaluated is the north-south road south of the east-west road.  The 
road is curbed and crowned with a low point.  We are looking for two sump 
locations for inlets. 

4. Click Apply and drag the cursor over the North-South road.   

There should be two sump locations south of the east-west road, one on either side 
of the centerline. 

5. Place a data point to create a flow line on either side of the centerline. 

We will use the downstream ends of these lines to place sump inlets in the next 
section.  These sump locations are at the gutter flowlines at station 12+00. 
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Lesson Name:  Laying Out Curb Grates in Sump Locations 

LESSON OBJECTIVE: 
Lay Out Curb Grate Inlets in the Sump Locations.   

EXERCISE:  LAY OUT TWO COMBO GRATE INLETS IN ON-GRADE LOCATIONS 

This exercise will guide you through the steps to Lay Out two Curb Grate inlets in On-
Grade locations. 

1. Select InRoads > Drainage > Lay Out. 
2. Click the Options button. 

3. Click the Preferences button. 

4. Select the IW-3 CurbGrateSump6x3. 

5. Click Apply and Close the Drainage Options dialog. 

6. Click on the Graphic Locator button to the left of the Northing Easting and 
Elevation fields. 

7. Snap to the end of the left side trickle line. 

8. Click Apply. 
The graphics for the combo inlet are placed as well as a pipe between it and the 
previous inlet. 

9. Clear the Add Connecting Pipe check box.  Click on the Graphic Locator button to 
the right of the Northing Easting and Elevation fields. 

10. Snap to the end of the right side trickle line. 

The Drainage Lay Out dialog returns with the Northing Easting and Elevations 
values from that station offset location. 

11. Click Apply. 

The graphics for the combo inlet are placed.  
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EXERCISE:  CONNECT THE INLETS 

This exercise will guide you through the steps to connect the disconnected inlets. 

1. In the Drainage Lay Out dialog select the Pipe tab. 

2. Click on the Graphic Locator button to the right of the Upstream ID field. 

3. Click on the right-side inlet at station 18+00, 14 (IN6).. 
4. Click on the Graphic Locator button to the right of the Downstream ID field. 

5. Click on the right-side sump inlet at (IN8). 
6. Click Apply. 

7. The graphics for the pipe are placed.  

8. Click on the Graphic Locator button to the right of the Upstream ID field. 

9. Select the left sump inlet (IN7). 
10. Click on the Graphic Locator button to the right of the Downstream ID field. 

11. Select the right sump inlet (IN8) 
12. Click Apply. 

13. The graphics for the pipe are placed.  

 

EXERCISE:  ADJUST THE RIGHT SIDE COMBO INLETS 

This exercise will guide you through the steps to changing the right side combo inlets so 
that the curb openings are on the upside of the grate. 
Each type and size of Inlet has a specific style defined in the Drainage Structures file.  
Often there are left and right versions of the same type and size inlet.  By changing 
from the default Style for the inlet to its “mirror” the curb opening graphic is corrected. 

1. Select InRoads > Drainage > Edit/Review. 

2. Select one of the Combo Inlets on the right side of the North-South road. 

3. In the Edit/Review dialog, select the Styles tab. 

4. In the Point listbox, select the Style P_DRAIN_ComboL_6.0x3.0. 
5. Click Apply. 
Note that the opening is now to the north of the grate. 

6. Select the other right-side combination inlet and change its Point Style to 
P_DRAIN_ComboL_6.0x3.0. 



2009 NORDIC CONFERENCE 

USING INROADS STORM & SANITARY V8I 
  
 

© 2009 Bentley Systems, Incorporated          Page 18 

 
Lesson Name:  Adding Flows 

LESSON OBJECTIVE: 
Attach flows to the network. 

EXERCISE:  COMPUTE THE RUNOFFS FROM TWO DRAINAGE SHAPES 

This exercise will guide you through the steps to calculate the runoff from two drainage shapes 
and attach them to the drainage network. 
Any CAD shape can be selected and its area calculated. The Hydrology and Hydraulics 
tools can be used to determine flowpaths, ridges and valleys and source areas.  Once the 
various limits of a drainage basin is found the individual components can be merged using 
the Create Complex Shape command or by using the Place Shape command, snapping to 
the relevant points.  If the area is already known, that value can be keyed in; a shape is not 
necessary (this can save time when inlets are uniformly spaced with identical drainage 
areas). 
 
The Compute Flow command calculates a 
Peak Flow value using the Modified 
Rational or SCS Unit Hydrograph methods.   
In the Modified Rational method, Runoff 
Coefficients can be keyed in or a weighted-
average can be computed using the active 
Runoff Coefficient table.  The Time of 
Concentration can be keyed in or calculated 
using built-in Kirpich, FAA, or Overland 
Flow calculators. 
A known or required intensity can be keyed 
in instead of being computed via Time of 
Concentration. 
Once enough of the data is defined so that a 
Peak Flow can be calculated, the Area can 
be attached to a drainage structure. 

 
 

There are two shapes in the locked Temp_Area level.  Let us unlock the level and use 
the shapes for the Compute Flow tool. 

1. Isolate the shapes in the Temp_Area level by turning off the Reference file Displays 
and/or Surface Features display. 

2. In the MicroStation Key-in field, key in “level set lock off Temp_Area” 

3. Select InRoads > Drainage >Compute Flow. 

4. Click on the Graphic Locator button to the right of the Drainage Area field. 

5. Click on the upper shape. 
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6. The Drainage Area is computed to be 8400 sq. ft.  The default Runoff Coefficient is 
0.9, which is acceptable for this all-pavement area.  The Time of Concentration of 5 
minutes is also acceptable. A peak flow of 1.038 cfs is calculated from this 
information  

7. Click on the Graphic Locator button to the right of the Attach To field. 

8. This area drains to the northernmost left-side inlet (IN3).  Click on it and Accept 
with a data point. 

9. Click Apply. 

An Area database record is created, the shape is displayed according to the 
Symbology defined for Drainage Areas, and the dialog resets for the next shape. 

The next shape is the left-side sump shape. 

10. Click on the Graphic Locator button to the right of the Drainage Area field. 

11. Click on the lower shape. 

12. The Drainage Area is computed to be 10500 sq. ft.  The default Runoff Coefficient 
is 0.9, which is acceptable for this all-pavement area.  The Time of Concentration of 
5 minutes is also acceptable. A peak flow of 1.297 cfs is calculated from this 
information  

13. Click on the Graphic Locator button to the right of the Attach To field. 

14. This area drains to the left-side sump inlet (IN7).  Click on it and Accept with a data 
point. 

15. Click Apply. 

An Area database record is created, the shape is displayed according to the 
Symbology defined for Drainage Areas, and the dialog resets for the next shape. 
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EXERCISE:  USE THE COMPUTED ACREAGES FOR INLETS WITH THE SAME LAYOUTS 

The left-side and right-side drainage basins are symmetric.  Additionally the combo inlets all 

have identically-sized drainage areas.  Rather than define shapes for each, we will save time by 

simply keying in the acreage for each. 

1. Select InRoads > Drainage >Compute Flow. 

The three combo inlets without attached areas drain 8400 sq. ft.  They each have a 
Runoff Coefficient of 0.9 and a Time of Concentration of 5 minutes. 

2. In the Drainage Area field key in 8400. 

3. Verify a Runoff Coefficient of 0.9 and a Time of Concentration of 5 minutes. 

 A peak flow of 1.038 cfs is calculated from this information  

4. Click on the Graphic Locator button to the right of the Attach To field. 

5. This area drains to the northernmost right-side inlet (IN4).  Click on it and Accept 
with a data point. 

6. Click Apply. 

7. An Area database record is created and the dialog resets for the next shape. 

8. Repeat the above steps to create Drainage Areas for the other two ComboInlets. 

9. The right-side sump Curb Grate drains the same amount as the left-side sump Curb 
Grate, 10500.  Create a Drainage Area for this inlet. 

10. Verify that there are drainage areas for each curb grate and combo inlet, by double-
clicking the Areas Structure Type in the InRoads Explorer (the workspace tab must 
be set to Drainage).  The headers in the list are sortable. 

11. Save the Drainage File (InRoads > File > Save > Drainage Data). 
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Lesson Name:  Designing the Network 

LESSON OBJECTIVE: 
Use the Network Design command to perform a Hydraulic Design on the Network. 
Overview 
Given a physical network model and a hydrologic model linked to the physical model, network 
hydraulic modeling can now take place.   
 
Methodology 
A detailed breakdown of the S&S design calculation procedures can be found at InRoads > 
Help > Supplemental Information > Storm & Sanitary > Storm & Sanitary Design 
Procedures.  Most of S&S methodology, including Inlet capture methodology and Hydraulic 
and Energy Grade Line analysis, use as a foundation the Urban Drainage Design Manual, 
Hydraulic Engineering Circular No. 22. 
Fixed/Resize 
Every Network Structure (as opposed to a Storm Area, Sanitary Zone, or a Utility) in its 
database record has a field called “Status”.  The value is either Fixed or Resize.  It is this toggle 
that tells S&S whether to upsize structures to meet design criteria.  Our structure defaults were 
set to Fixed.  We can change the status using the InRoads > Drainage > Structure > Modify 
Status command; a fence can be used for bulk changes. 
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EXERCISE:  USE THE NETWORK DESIGN COMMAND TO PERFORM A HYDRAULIC DESIGN 

ON THE NETWORK 

We are going to perform a design of the North-South road network. 

1. Select InRoads > Drainage > Network > Design. 

2. Click on the Graphic 
Locator button to the right 
of the Tree Network 
Containing field. 

3. Select any structure in the 
North-South network. 

4. Accept the structure with a 
data point. 

For information on the 
individual controls click the 
Help button. 

5. Ensure that the following 
check boxes are enabled:  

• Generate Design Log 

• Assign Inlet Bypass 
Flows 

• Generate HGL and EGL 

6. Click Apply. 

 

 

 

The Design Log provides design values and messages on each structure in the sequence 
it was designed.  Violations of design constraints are noted here.  If the HGL and EGL 
check box is enabled the end of the log should be two HGL tables.  If the network 
processing halts at a structure due to some error the log typically explains why.  It is 
good technique to always scroll to the bottom of the log to verify successful 
completion. 

7. Now that the database is updated with design values the Drainage Annotation 
Design Results preference provides useful feedback. 

8. Save the Drainage File (InRoads > File > Save > Drainage Data). 
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Lesson Name:  Generating Drainage Profiles 

LESSON OBJECTIVE: 
Generate Drainage Profiles. 
The Create Profile dialog has many controls to provide completely customizable results.  The 
Help button provides full details on all the options; we will explore two “leafs” important to 
drainage: the Source leaf and the Network leaf. 
The Source leaf is used to define the horizontal path of the profile “slice.”   
 
  

 
 
For Drainage Structures to show, the Network Alignment radio button must be selected.   
To cut the profile along the structures select the Network radio button in the Drainage 
Network Reference frame.   

 
To cut along the active alignment and project the structures onto it, select the Alignment radio 
button.  The Existing Profile button projects drainage structures onto profiles that have already 
been created. 
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The  
 
Network leaf is where the symbology is set for the drainage structures and HGL, EGL 
and Branch Lines.  When the InRoads Style Lock is ON the Symbology of Structures is 
derived from the individual structure record’s Style attribute. 

 

EXERCISE:  GENERATE DRAINAGE PROFILES 

This exercise will guide you through the steps to create drainage profiles. 

1. Select InRoads > Evaluation > View > Profile > Create Profile. 

2. Turn the Style Lock OFF (InRoads > Tools > Locks > Style). 

3. In the General leaf ensure that the design surface check box is selected. 

4. Select the Source leaf. 

5. Ensure that the Create listbox reads Window and Data. 

6. Select the Network radio button. 

7. A drainage profile can be created between any two structures in the same network. 

8. Click on the Graphic Locator button to the right of the From field.  Select the 
northernmost left-side Combo Inlet (IN3). 

9. Click on the Graphic Locator button to the right of the To field.  Select the right-
side Curb Grate sump (IN8). 

10. Ensure that the radio button in the Drainage Network Reference frame is set to 
Network. 

11. Click Apply. 
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12. At the “Identify Location” prompt place a data point for the location of the lower 
left corner for the profile.  Place it to the right of the graphics. 

 

EXERCISE:  ANNOTATE DRAINAGE PROFILE 

This exercise will guide you through the steps to annotate drainage profiles. 

1. Select InRoads > Evaluation > Profile > Annotate Drainage Profile. 

The Annotate Drainage Profile dialog 
looks and behaves similarly to the 
Annotate Structure dialog with a specific 
difference: the Set List control.  Drainage 
profiles are annotated one at a time.  Use 
the Set List or the Graphic Locator button 
to its right to select the Profile to 
Annotate. 

 

2. Click Apply.  Verify that the Profile Structures were Annotated. 

3. Close the dialog. 

Structure Notes can be placed in profile using the InRoads > Drafting > Place Profile 
Note tool in a manner similar to the Place Plan Note tool. 
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Lesson Name:  Rapid Layout 

LESSON OBJECTIVE: 
This exercise has two objectives: (1) show how fast a network can be placed and (2) add 
additional structures for future interference checking. 

EXERCISE:  LAY OUT SANITARY MANHOLES AND PIPES 

This exercise will guide you through the steps to lay out sanitary manholes simultaneously 
with pipes.  Our goal here is to place a manholes and pipes within the limits of the 
NorthSouth road as an interference opportunity – not necessarily as good design. 

1. Select InRoads > Drainage > Lay Out. 
2. Click on the Manhole tab. 

3. Click on the Options button. 

4. Click on the Preferences button. 

5. Select the IW-3 Sanitary Preference. 

6. Click Load and Close the Preferences dialog. 

7. Review the Settings under the Manhole, Pipe and Structure IDs tab.   

Note that the Prefixes for the Manholes and Pipes include “san”.  This is for our 
tracking purposes only.  Storm & Sanitary does not distinguish between “sanitary” 
structures and “drainage” structures: it had fields for both flows in each database 
record. 

8. Close the Preferences dialog. 

9. In the Drainage Lay Out dialog, Manhole tab, enable the “Add Connecting 
Pipes” check box.   

10. Select the By Elevation radio button.  This places the invert at the active minimum 
pipe depth. 

11. Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

12. Place a data point within the NorthSouth road, somewhere near the north end. 

13. Click Apply.  The manhole is placed. 

14. Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

15. Place a data point within the NorthSouth road, somewhere near the middle. 

16. Click Apply.  The manhole and the pipe between it and the previous manhole is 
placed. 

17. Click on the Graphic Locator button to the right of the Northing Easting and 
Elevation fields. 

18. Place a data point within the NorthSouth road, somewhere near the south end. 
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19. Click Apply.  The manhole and the pipe between it and the previous manhole is 
placed. 

20. Close the dialog. 

21. Save the Drainage File (InRoads > File > Save > Drainage Data). 
 
Lesson Name:  Generating Cross Sections 

LESSON OBJECTIVE: 
Generate Cross Sections with Drainage Structures 

Like Profiles, Create Cross Sections involves many settings.  See the on-line Help for full 
details.   

The 
General 
leaf sets the 
interval 
and width 
for regular 
sections 
along the 
horizontal 
path, which 
is set in the 
Source 
leaf.  The 
Set Name 
reflects the 
name of the 
active 
source. 

 

 



2009 NORDIC CONFERENCE 

USING INROADS STORM & SANITARY V8I 
  
 

© 2009 Bentley Systems, Incorporated          Page 28 

Structures 
are 
included in 
Cross 
Sections 
via controls 
in the 
Storm and 
Sanitary 
frame of 
the Include 
leaf. 

 

Setting 
Ahead and 
Back 
Bands will 
limit the 
range 
within 
which 
Drainage 
Structures 
are 
projected. 

 

EXERCISE:  CREATE CROSS SECTIONS WITH DRAINAGE 

This exercise will guide you through the steps to Create Cross Sections with Drainage 
Structures. 

1. Select InRoads > Evaluation > Cross Section > Create Cross Section. 

2. In the General leaf ensure that the design surface check box is selected. 

3. Select the Source leaf and ensure that the NorthSouth Alignment is the active 
Source. 

4. Select the Include leaf enable the Crossing Structures and Projected Structures 
check boxes. 

5. Key in 10 for the Ahead Band and for the Back Band. 

6. Click Apply. 

7. At the “Identify location” prompt, place a data point to the upper right of the other 
graphics in the CAD file (so that the cross sections do not overlap anything). 

8. Close the dialog. 
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EXERCISE:  CREATE CROSS SECTIONS WITH DRAINAGE 

This exercise will guide you through the steps to View Cross Sections using the Cross 
Section Viewer.  The Cross Sections are normal MicroStation graphics.  The Viewer 
simply facilitates scrolling from one section to the next. 

1. Select InRoads > Evaluation > Cross Section > Cross Section Viewer. 

2. Select the first station in the Cross Sections list.   

3. Select the down arrow (↓) to move to the next section.  Repeat as interested. 

4. The screenshot shows the section at Station 18+00.   
 

 
5. Close the dialog. 

Note the apparent conflict at the crossing pipe.  Depending on where you placed the 
Sanitary Manholes your Sanitary pipe location may differ. 

Cross Section structures can be annotated using the InRoads > Drafting > Place 
Cross Section Note tool. 
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Lesson Name:  Visual Class Detection 

LESSON OBJECTIVE: 
Detect Structure Interference Visually. 

EXERCISE:  DISPLAY DRAINAGE AS SOLIDS 

This exercise will guide you through the steps to Display Drainage As Solids 
1. Place a fence around the structures. 
2. Select the MicroStation Delete Fence Contents command. 
3. Delete the network. 
4. Turn off the display of any Reference files. 
5. Select InRoads > Drainage > View > Drainage as Solids.  
6. In the View Drainage As Solids dialog click Apply. 
7. In the MicroStation Key-in field, key in “view clash_hiddenfill”. 
8. At “Saved View > Select view” prompt, place a data point in the view. 

This is a saved view with a close perspective on the interferences and the 
Display Style set to Filled Hidden Line. 

9. Use view controls (Fit View, Window Area, Rotate View, etc.) to check other 
interferences. 

10. When done key in “view drain_top” and place a data point in the view to return 
to the normal top view. 

 
Lesson Name:  Importing Storm & Sanitary data into StormCAD 

LESSON OBJECTIVE: 
Learn how to Import Storm & Sanitary into StormCAD. 
Note: we will not be performing these steps in class. 

No “export” or translation in InRoads/Storm & Sanitary is necessary.  From within 
StormCAD, the Drainage Data file, the *.sdb file, can be imported into StormCAD. 
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From within Bentley StormCAD V8i, select Project > Import > InRoads.  The Drainage 
Database must, of course, be specified.   
 
There are three other files 
StormCAD needs to 
successfully import the 
Drainage data: 

• The InRoads 
Preference file 

• The S&S Drainage 
Structures file 

• The rainfall 
Intensity-Duration-
Frequency file 

These three files can be 
specified automatically if 
the Project Configuration 
files are available (they are 
machine- and Windows 
user-specific.) 
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Lesson Name:  Manipulating Structures and Areas 

LESSON OBJECTIVE: 
Learn how to adjust placed structures and areas. 
As you have seen it is easy to Lay Out drainage structures and areas.  There are many tools in 
Storm & Sanitary to modify structures and networks already in the database.  Individual 
structures can be moved horizontally using the Structure > Move tool and vertically using the 
Structure > Move in Profile tool.  Inlets and Manholes can be inserted onto pipes (breaking the 
pipe in two) using the Structure > Insert and the Structure > Insert in Profile tools. 
Entire networks can be moved horizontally or have its elevations adjusted to a new surface 
using the Network > Move tool.  The Network > Adjust tool is used to move pipes to meet 
minimum cover requirements and to perform crown matching. 
 
If you noticed the results in the Design Log the 
spread at the inlets exceeded the Allowable spread, 
indicating the inlet spacing was too large.  An 
engineering solution would be to decrease the 
spacing between inlets.  The Drainage > Structure 
> Move Structures tool has a number of different 
options to meet the designer’s specific needs when 
moving a structure. 

 
 
When moving Drainage Inlets, Drainage Areas also change.  The Drainage Area graphics can 
be edited using standard CAD tools, such as Modify Element.  Once the graphic shape is edited 
selecting the area with the Compute Flow will update the area value (acreage) while 
maintaining its other previously-defined values. 
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EXERCISE:  MOVE THE COMBO INLETS NORTH 

This exercise will guide you through the steps to decrease the inlet spacing. 
1. Select InRoads > Drainage > Structure > Move. 
2. Ensure that the following checkboxes are set: 

• Track Surface for Elevation 
• Track Alignment for Angle 
• Track Alignment for Offset 
• Hold Slope 

3. Click Apply. 
4. Select the upper left combo inlet (IN3). 
5. You will get a warning that the junction is fixed.  Click OK to continue. 
6. Move the cursor. Note that the inlet retains its offset. 
7. Place the inlet further north than its current position. 
8. Use the MicroStation Modify Element tool to move the shape vertex north to the 

new location of the inlet. 
9. Select InRoads > Drainage > Flows > Compute Flows. 
10. Select the Graphic Locator button to the right of the Drainage Area field. 
11. Select the drainage area shape. 
12. The Compute Flow dialog returns with a square footage that should be less than 

the original 8400 sq. ft. 
13. Click Apply and Close the dialog. 
14. Re-Design the network to check the spread value (InRoads > Drainage > 

Network > Design). 
 
If the spread value for IN3 is still excessive the steps should be repeated until the 
spread value is allowable.   
Alternatively, we could assume that we will have to add an additional inlet.  We 
could recalculate the interval based on an additional inlet and move all the inlets to 
an even interval. The left additional inlet could be placed normally.  The new right 
inlet can be placed using the Structure > Insert tool.  Don’t forget to adjust all the 
drainage acreages. 
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EXERCISE:  MOVE THE SANITARY PIPES IN PROFILE 

There may have been some interference between different structures.  The interfering pipes 

can be moved in profile, maintaining slope or holding an invert using the Drainage > Structure 

> Move in Profile. 

 

This exercise will guide you through the steps to move the Sanitary Pipes to avoid conflict 
with the crossing storm pipes. 
Note: it is a very good idea to save and archive the Drainage file prior to doing major changes 

to a network. 
1. Create a Drainage Profile along the Sanitary network. 
2. Select InRoads > Drainage > Structure > Move in Profile. 
3. At the “Identify structure” prompt select a pipe.  Note: selecting a pipe in the 

middle third will hold the pipe’s slope constant; selecting an upper or lower 
third will lock the other invert, the “free” invert can be set with a data point or 
an elevation key-in. 

4. In order for the hydraulics to be re-designed and the HGL and EGL lines to be 
updated, a Network Design must be performed as well as a Drainage Profile 
Update (InRoads > Evaluation > Profile > Update Drainage Profile). 

 


