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Finishing the Model 

Module Overview 

The focus of this workshop is to concentrate on design issues that occur during the final 
design process which need to be addressed in order to complete proposed grading for the 
project. The workshop will explore doing this with a variety of tools including the Roadway 
Designer, the Apply Template tool, and site tools. 

 

Module Prerequisites 

� Familiarity with the overall InRoads Product. 

� A firm understanding of the Roadway Designer and template creation in InRoads 8.7 and 
higher. 

� Knowledge of the InRoads’ site tools. 

Modules Objectives 

After completing this module, you will be able to: 

� Incorporate Partial Pavement Widening in an existing Corridor. 

� Target features Styles to increase productivity in the Designer. 

� Learn to use the Apply Template Tool. 

� Use Site tools to complete your design. 
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Introductory Knowledge 

Before you begin this module, let’s define what you already know. 

1. End Conditions can target the style of particular features in your DTM? 

� True 
� False 

2. Site tools only found in InRoads Site? 

� True 
� False 

3. Point Controls and Parametric Constraints are the only external influence on Template 
points. 

� True 
� False 

4. Site tools are only productive for site development? 

� True 
� False 

5. Feature Lock allows for only one feature to be designed at a time? 

� True 
� False 
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Answers 

1. Can End Conditions target the style of particular features in your DTM? 

True 

InRoads’ End conditions can target a style that is defined for multiple features in a 
surface. This prevents you from targeting each feature individually. 

2. Site tools are only found in InRoads Site? 

False 

The Site tools are found also in InRoads & InRail. 

3. Point Controls and Parametric Constraints are the only external influence on Template 
points. 

False 

Style & Project to Surface constraints can act as external control for points within a 
template. These constraints obtain values from surfaces and geometries as Point Controls 
do. 

4. Site tools are only productive for site development? 

False 

 Site tools are valuable assets in complementing your corridor design. This workshop will 
display this. 

5.   Feature Lock allows for only one feature to be designed at a time? 

False 

The Feature Lock allows InRoads to scan for Features in the active DTM, and ignore any 
MicroStation Graphics.  
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Before You Begin 

Before beginning the exercises outlined in this workshop, you need to start InRoads and load 
the workshop files.  To do so, follow these steps: 

1. Start InRoads, then navigate to the workshop directory and select the proposed.dgn 

file from the MicroStation Manager.  This design file has several reference files 

attached showing some of the existing topological features which are stored in the 

DTM and also displays proposed pavement markings.  You may turn off the display 
of the reference files at any time, if you wish, by selecting File > Reference from the 
MicroStation menu and toggling off the checkmark in the Display column.  We only 

use this data for visual references during the workshop. 

2. From the InRoads Explorer, select File > Project Defaults and set the Configuration 
Name to W25.  Close the Project Defaults dialog. 

    

 

Hint If W25 does not show up in your list, select the Import button from the Project 
Defaults dialog, navigate to the workshop directory, and open W25.reg. 

3. Select File > Open and load the workshop files by selecting the project file named 

finishing.rwk.  This project file contains a geometry project, an existing surface, a 

template library and a roadway design file for use in the remainder of this workshop. 

4. Select Tools > Locks > Toolbar to turn on the Locks toolbar, if it is not already on. 

You are now ready to begin the exercises in this workshop.  If, for any reason, you must exit 
the software before the end of the workshop, simply repeat the steps in this section. 

If you are unable to complete an exercise as you proceed through this workshop, the 
completed files for that lesson are stored in \Finished subdirectory labeled with the exercise’s 
topic.  For example, if you cannot complete Driveways, you can open the completed files 
from the \Finished\Driveways subdirectory and continue with the exercise. 
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Partial Pavement Widening  

This section of the workshop will give an overview on adding partial full depth pavement 
widening to an already existing corridor defined in the Roadway Designer. The partial width 
full depth pavement is being placed to address the tapers associated with adding a left turning 
lane and for wider travel lanes. The design has called for full width reconstruction in the areas 
where the travel lanes are fully established and has already been defined in the corridor. The 
purpose of this lab is to add the partial width reconstruction to the corridor and use the 
Designer to complete the model. A typical section below is showing the design criteria for the 
pavement widening: 

 
 

Notice that the saw cut location in the typical. It is 8 feet from the centerline of the road. The 
original road is roughly 10 feet wide. It has been determined that the pavement near the end 
of the travel line has failed, thus around 2’ of existing pavement will be removed. The 
existing elevations at the centerline and at the saw cut will be used to determine the existing 
cross slope. This cross slope will be projected through the partial full depth pavement travel 
lanes and widening in the proposed design. 

This workshop will modify a template in an existing corridor to accommodate the above 
scenario. This will be done in the Designer, thus it allow one surface to be produced for both 
the full width and partial width sections of this design. 

Note: This workshop displays a specific design scenario, however the techniques used 
in this workflow will accommodate a wide variety of Designs. 
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� Exercise: This exercise will assume that you are familiar with Template Creation 
and the Roadway Designer. 

1. If you have not opened proposed.dgn, please do such. Examine the Proposed design, 
particularly at Sta. 200+63.63 until the end of the alignment for Main St.. Remember the 
topography, existing contours, and pavement markings are referenced. 

Note:  The instructor will provide a general review of the DGN files and InRoads’ file 
supplied at this time. 

2. Go to Modeler>Roadway Designer and observe the Main Street corridor that already 
exists, noting that the corridor stops at Sta. 200+63, which is at the beginning of the 
partial full depth pavement widening.  

3. Close the Designer and go to Modeler>Create Template. 

Note: We are making the new template for the widening in the ITL file. Remember this 
can be done in the IRD file also. 

4. Navigate to the Main Street folder in the Create Template dialog. Copy the Mainline 
template and paste it in the same folder. Rename the template to Widening. 
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5. Making sure the active template is Widening, delete the components that represent the 
right shoulder pavement courses, the right curb, and the right end conditions. This can be 
done by right clicking in the main dialog, and selecting Delete Components and then 
drawing a line through any unwanted components. 

Warning: Do not delete the right travel lane component, named Pavement, it also includes the 
left travel lane which is still needed. Remember, to use the Undo button, to delete any 
unwanted changes. 

6. Next the right travel lane need to be removed. However since it is in the same component 
as the left we can not use the same method as in Step 5. We will accomplish this by 
deleting the points: EP_R, EP1_R, EP2_R, & EP3_R. Right click on these respective 
points and select Delete Points. Your template should appear as below once completed. 

 
7. Turn on your Dynamic Settings. Then right click on point CL and choose Move Point. 

Choose xy= in the Dynamic Settings dialog and key-in -8, -.16, then press enter. 
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Note:  The Template was moved to reflect the location of the saw cut, 8 feet from the 
center line. 

 

8. Next a new point needs to be created at the profile grade line. Right click in the display 
and then choose Add New Component>Null Point. In your Dynamic Settings key in 
PGL for the point name, P_COGO_MainCL for the style, and XY=0,0 and then click 
Enter.  

 

 

 

 

 

 

 

 

 

9. The point CL now needs to be constrained to the point PGL and vertically projected to 
the elevation of the existing surface. Add a Horizontal & Project to Surface Constraints. 
Right click on the point CL and choose Edit Point. Apply the constraints below: 
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10. Next the template needs to be modified to allow the slope between point CL and EP_L to 
match existing cross slope. In order to accomplish this, the constraints for EP_L need to 
be modified. Double click on EP_L and then add the constraints as below:  

 
 

Note: The Style Constraint will be used to control the varying width of EP_L from a 
horizontal geometry with the style P_Road_LEP. The Range is left at zero since 
we only have one P_Road_LEP defined in our project. 

11. Test the behavior of the template by moving point PGL with Move Point tool. Notice the 
behavior of the cross slope. Also use the Test button to verify the End Condition 
solutions. 

Hint: Notice the additional Available Target, Existing-Surface, where did this target come from? 
How does this target affect the template? 

12. Save the template by going to File>Save in the Create Template Tool.  

13. Close the Create Template tool and return to the Roadway Designer. 

14. Copy the Main Street corridor. This is done by going to Corridor>Manage Corridor, 
highlight Main Street and the hit Copy. Key-in a new Corridor Name: Main Street with 
Widening. Then hit <OK> 

15. Highlight the Main Street with Widening Corridor and then key–in a new Stop Station: 
203+17.88 and then hit Change. Close the Manage Corridor dialog. 

Note: Navigate through the Stations in the Designer, notice that EP_L is only 12 feet 
wide from station 200+63.63 forward. 
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16. Add a new template drop for the partial pavement widening by going to 
Corridor>Template Drops. Choose the Widening template and key in Station 
200+63.64. Then press <Add > and then close the Template Drops Dialog. 

 
 

17. Run through the Designer and observe the region where the widening occurs. Verify that 
the EP_L is correctly placed and then verify the cross slope in this area. 

 



Partial Pavement Widening  
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Note: The EP_L did not need a point control to control its varying width. The 

Horizontal Alignment named, Main LEP, has the style P_ROAD_LEP, thus the 
Style Constraint in the Widening template automatically adjusts to the horizontal 
value defined through this alignment.  

Hint: Observe the cross slope between 200+63.63 and 200+63.64. The slope is the same. The 
superelevation was modified to match the existing roadway cross slope to provide a 
smooth transitions.  

A surface is not created at this time since we are not done with the improvements to Main 
Street.  

 

 

 

 

 

 

 

 



Driveways 

 

 

 

Finishing the Model 12 Nov-08 

Copyright © 2008 Bentley Systems Incorporated 

 

 

 

Driveways 

This exercise will demonstrate a procedure that will allow End Conditions to determine 
where to place depressed curbing instead of full 6”curbing to accommodate for driveway 
entrances. After the depressed curbing is placed at a driveway location then the End 
Conditions can continue to test for different tie in situations that are relevant for only when a 
driveway is present. This method can be quite useful on large corridors, where many 
driveways exist. This is because this workflow’s End Conditions target a Style of a feature 
and not just an individual feature. This eliminates the mapping of each individual driveway 
feature as a type of external control within the Roadway Designer.  

Note: The main goal of this lab is to display the functionality of End Condition using a 
Style as a target. This Style can exist in an ALG or a DTM, but it must be active 
for it to operate correctly. 

� Exercise: In this section we will modify the first template drop in our corridor to 
allow it to adjust the end condition solution if a driveway is found. 

1. Window your view to the beginning of the Main Street alignment around Sta. 192+00. 
There are two driveways in the location, one on the left and the other to the right of the 
baseline, each labeled appropriately. The drive openings are marked with a purple line 
that resides in the Proposed.dgn. 

 
2. Go to Reference Display in MicroStation and shut off the references. This will make the 

following steps easier by isolating the graphics. 

3. In InRoads go to File>Import>Import Surface>From Graphics.  

 



Driveways  
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4. Import the right driveway into the Existing Surface while draping the driveway onto 
Existing surface. Enter a Seed Name of Drive Rt with a feature style of 
P_Road_RT_Depressedcurb as a Breakline. Check the Exclude from Triangulation 
toggle. 

 

 
5. Repeat this process for the left driveway. Import it also into the Existing Surface while 

draping the driveway onto Existing surface. Enter a Seed Name of Drive Lt with a 
feature style of P_Road_LT_Depressedcurb as a Breakline. Check the Exclude from 
Triangulation toggle. 



Driveways 
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6. Next go to the Modeler>Roadway Designer. Make a copy of Main St with Widening 
corridor and rename it Main St with Driveways.  

7. Go to the Template Drop dialog, highlight the first template at Sta.191+20.00, and then 
press <Edit>. 

8. At this time we need to modify the template to include new End Conditions to determine 
when to use Depressed Curbing. Right click in the template dialog and <Delete 
Components>, draw a line through the existing End Conditions. 

9. The End Condition will determine when to place the curbing so the current curbing 
components will need to be in the End Condition. Delete the right and left curb 
components from the template.  



Driveways  
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10. Bring in the new End conditions from the End Condition Folder on the left. You will 
notice two end conditions named driveway end condition rt and driveway end 
condition lt. Drag and drop the end conditions from the preview window into the 
template stored in the Roadway Designer. Both end conditions should be placed at the 
left and right shoulder points, shldr_r & shldr_l. Your template should appear as below. 

 
11. Press the Template <Test> button. Observe the behavior of the template when there 

depressed curb styles are defined and when they are not. 

Hint: This workflow can easily modified to test to see if your proposed end condition is within 
the legal right of way. 

12. After observing the behavior of the template, press <OK>. 

13. Next add the driveways to the Roadway Designer as a reference. Go to 
Corridor>Display References. 

14. Typically, there is more than two driveways on a project, thus a filter would be a good 
idea to automate this process. A filter, named Driveways, has been created that seeks the 
styles, P_Road_RT_Depressedcurb & P_Road_LT_Depressedcurb . Select Surface 
Existing, the filter Driveways, and then click <Add> then dismiss the Display Reference 
dialog. 



Driveways 
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15.  The Driveways now appear in Designer, this will aid in seeing if the Design is 

appropriate. Cycle through the stations by the driveways. 

16. The template drop interval is set to 10 feet for this particular template drop, this may or 
may not satisfy the precision that is required to determine where our driveways are 
located. The design may call out that a template drop must occur at the beginning and end 
of each driveway location, increasing the accuracy of the model. First, go to File>Save in 
the Roadway Designer. 

17. Proceed to File>Import Geometry>From Graphics. Change the type Event Points and 
verify that the geometry project is W25 and the horizontal geometry is Main St. 



Driveways  
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18. Press <Apply> and select the two driveways graphically in the proposed.dgn. Remember 

to Accept your selection by clicking an additional data click. Right click to exit the 
operation and then Close the Import Geometry tool. 

19. Return to the Roadway Designer. Verify the additional template drops at the beginning 
and end of each driveway location. 

20. Next create the proposed Main St. surface by going to Corridor>Create Surface. Key in 
Main St for the surface name and select the corridor named Main St with Driveways, 
then <Apply>.  Dismiss the Create Surface dialog and then save the Roadway Designer 
by going to File>Save. Then Close the Designer. 



Driveways 
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21. The features have been displayed in the proposed.dgn. Next display the proposed Main 

St. contours. First turn on your Style Locks, it is the icon that resembles the painter 
palette, next change your active surface to Main St. Then go to Surface>View 
Surface>Contours.  
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Apply Template Tool 

In this section, the Apply template tool will be used to widen the Side Road. Again, the 
improvements do not call out for the total reconstruction of the roadway. However, there is 
no Roadway Designer corridor defined as there was for Pavement Widening Exercise. The 
widening includes a single face concrete barrier to accommodate the existing steep cut slope. 

 

Single Face Barrier Template 

Note: This exercise will display the use the Apply Template Tool, it will use a 
MicroStation graphic that does not exist as a feature or as geometry. This 
provides the ability to perform grading task quickly and easily.  

 

1. Locate the Sawcut line on the Side Road in proposed.dgn. This line in MicroStation is 
currently at elevation of zero. However, this line needs to be at the elevation of existing 
ground surface. The Apply Template tool is going to accomplish this as it places the 
pavement coarses, the single face barrier, and solve for our end condition in one step. 

2. First, examine the template, Single Face Barrier by going to the Modeler>Create 
Template. Inside the End Condition folder, locate and make active the Single Face 
Barrier template. Again, <Test> the template and note the targets. 



Apply Template Tool 
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3. Close the Create template dialog. 

4. Since the proposed contours for the Main St were just displayed, it is still active. Change 
the active surface back to Existing. 

5. Next, navigate to Surface>Design Surface>Apply Template. 

6. Key in for the Design Surface: Side Rd 

7. Open the EndCondtions folder and select Single Face Barrier. 

8. Verify the template appears in the preview window. 

 
9. Press <Apply> 

Warning: After applying, make sure to follows the prompts. 

10. Select the Side Road saw cut for the Primary and Reference Elements. Making sure to 
Accept after each prompt. 

11. The operation will be done on the entire length of the saw cut so when prompt for start 
and stop stations, just simply right click to Reset for entire length to be processed. 

12. InRoads will ask if the location is correct. Give a Data button to accept. 

Hint: If the widening was performed on wrong side of saw cut, simply reject the location and 
toggle the Reflect on in the Apply Template tool.   



Apply Template Tool  

 

 

 

 

Nov-08 21 Finishing the Model 

Copyright © 2008 Bentley Systems Incorporated 

 

 

 

13. Close the Apply Template tool. 

14. Next go to Surface>Surface Properties. Change the Surface to Side Rd. Then enter a 
Maximum triangle length of 10 and choose the preference, Finish Surface, and then 
<Apply> and Close.  

Note: The Apply Template tool does not add an exterior boundary; the maximum 
triangle length provides an adequate accuracy for this example. However, an 
exterior boundary could be used instead of setting a Maximum Length. 

15. Display the Side Rd. contours, Surface>View Surface>Contours. 
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Mountable Curb Island 

This exercise will perform the grading of a mountable curb section that is required at the 
intersection of Main Street and Side Road. The site tools will be used to accomplish this.  

 
 

 

1. Locate the mountable curb island located at the intersection of the Main Street and Side 
Road. 

2. The exterior portion, bottom of the Mountable Curb needs to tie into Existing Ground. 
While the top of mountable curb is a 1’ offset from the bottom at a slope of 75%. The 
island is required to be graded to drain so no water ponds on the island. 

3. Go to Surface>Design>Generate Longitudinal Feature.  

4. Key in a Surface: Island 

5. Enter the feature name of BC and a style of P_Road_ConcreteCurb. 

6. Tag the advanced tab, verify the horizontal offsets are 0 and the vertical method is Drape 
and the surface is Existing. 



Mountable Curb Island  
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7. Press <Apply> 

8. Select the exterior line of the island for Primary and Reference Elements. Then Accept 
the location. 

Note: The location is not relevant since the Horizontal Offsets define are 0.  

9. A yellow line now appears at the location. This line is at the existing ground elevation 
and is feature named BC in the surface named Island. 

10. Go to the Main tab, and enter a new feature name of TC and then go to the Advance tab 
and change the Horizontal Start and Stop offsets to 1.00 and then change the method for 
vertical to Traverse Slope. Enter a Start and Stop slope of 75.0% 

 



Mountable Curb Island 
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11. Turn on your Feature locks located on the Locks toolbar. 

Note: Feature Locks will allow InRoads to scan for Features in the active surface  when 
the Generate Longitudinal Feature tool is applied. This will allow the tool to 
select the Feature BC, which is at elevation and ignore the original 2D line in 
MicroStation. This functionality applies throughout the Site Tools. 

12.  <Apply> the Generate Longitudinal Feature tool. Select the BC feature created 
previously for your Primary and Reference Elements, note that name of the feature, BC,  
is displayed when selected, this is because Feature Lock is toggled on. 

13. The entire feature needs to be processed so Right Click for entire element. 

14. The software now prompts you to Accept the location, notice if you move your cursor 
from inside to the outside the island the TC is dynamically moving 1 foot in either 
direction. Place your cursor to the inside of the Island and then Accept with a left mouse 
click. Your TC feature should be place directly on top of the purple MicroStation 
graphic. 

15. Close the Generate Longitudinal Feature tool. 

16. Go to Surface>Design Surface>Place Feature tool.  

17. Verify the Surface is Island, enter the feature Name of Drain, with a Style of 
P_Road_ConcreteCurb and point type of Breakline. <Apply>. 

 
18. A Set Elevation Dialog appears; toggle on the Elevation from Surface with an 

Adjustment Value of zero. 



Mountable Curb Island  
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19. Place 3 points, with this tool. The XY location or somewhat arbitrary but the Elevation 

Adjustment for 1st and 3rd points are 0.00 while the 2nd point has an elevation adjustment 
of 1.00. This is achieved by simply placing the 1st point with the above settings and then 
change the Elevation Adjustment to 1.00 and then place the second point. Lastly, change 
the Elevation Adjustment back to 0.0 and then place the last point. This will track the 
elevations for the Island Surface and then add the Adjustment Value to that elevation for 
the drain feature. This will increase the elevation of the middle of the island ensuring that 
no ponding will occur.  

 

 
20. Go to Surface>Triangulate Surface. Triangulate the Island surface, and then Close the 

dialog. 

21. Go to Surface Properties and change the surface type to Design and the preference to 
Finished Surface. Select the advanced tab and change the Cross Section and Profile 
symbology to P_Surf_DesignSurface. Press <Apply> 



Mountable Curb Island 
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22. View the contours for Island.dtm. Surface>View Surface Contours. 
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Module Summary 

You are now able to: 

� Use the power of constraints to accommodate partial pavement widening matching the 
existing cross slope in the same corridor with full pavement reconstruction. 

� Place Depressed Curbing at driveway locations by targeting Styles within your End 
Conditions. 

� Use of the Apply Template command can be used effectively to perform grading task, 
particularly when no geometry is needed. 

� Use Site tools to complete a variety of design functions to finish your model. 


