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1. LESSON NAME: REGRESSION ANALYSIS ON EXISTING TRACKS 

LESSON OBJECTIVE: 
This lesson will show how to use the regression analysis for existing tracks 

1.1 EXERCISE: REGRESSION ANALYSIS 
This exercise will guide you through the steps to get a new alignment on survey points. 
The regression analysis allows you to find the best fit alignment based on survey points. 

1. Load the file _work.dgn 

2. Load the file Regression.alg 

3. View the cogo points V1* Geometry > View Geometry > Horizontal Annotation … 

 
4. Customize BRT with the palette for Horizontal Regression 

Tools > Customize … 
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5. Load survey points V1*  into the regression buffer 

 

 
Under the Advanced tab you can define i.e. the regression band width or distance 
tolerances. 
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Go back to the Main tab and hit Apply. 

 

The result should be look like this:  

 
The blue line is the control line which gives you a graphical feedback that all points are now in 
the regression buffer. 

 

6. Create a curvature diagram 
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Hit Apply and place the diagram into the drawing. 

Note: Do not place the curvature diagram across the survey points in the plan 

 
The diagram can be interpreted as shown above. 
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1.2 EXERCISE: ALIGNMENT CREATION 

1.1.1 USE DIFFERENT REGRESSION METHODS FOR ALIGNMENT CREATION 
Use the Edit/Review regression points command 

 
This command calls a dialog box which gives you the regression points. 

 
If you select a point by using the right mouse click you can add the point to the regression 
analysis or change the point state. 

 
You can select multiple regression points in the list before you click Edit; your edits 
will apply to all selected points. 
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Close the dialog box. 

1.1.2 USE SELECT & REGRESS 
Select & Regress lets you select points from graphics (plan, curvature, slew), then 

automatically regress an element using the selected points. The element created is added to 

the end of the horizontal element list. 

Place a selection fence along the points. Watch for the command on left lower side of 

MicroStation 

 

 
Accept this solution and move on the next circular element. 
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Accept this solution and move on the next linear elements. 

 

 
Accept this solution 
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1.1.3 USE REGRESS ONLY 
The Edit/Review regression point box must be open and you must call the Single 
Element Regression dialog box. 

 

 
 

The box let you decide which type of element you want to regress. 

Select in the curvature diagram the next curve. 

 
The point are selected in the dialog box as well 
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Select in the dialog box Curve and hit Compute. 

 
Save the solution. If you click on Report te software gives you the slew values along the 
calculated element. 

Move on with the next linear and circular element. 
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Check the Integrity. 

 
The elements are not connected but in the right order. 

1.1.4 CLOSE THE TRACK WITH SPIRALS 
Call the Horizontal Element palette 

 
To make life easier turn the check box for Replace and Fill Gaps on. 

 
Hit apply and identify the 1st and then the last (2nd) element in the alignment. 

Check the Integrity again. 

 
 

All gaps are close with transitions. 

Save your work. 
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2. VIEW REGRESSION POINTS 

Geometry > View Geometry > Horizontal Regression > View Horizontal 
Regression … 

 

Used to display regression points for the active horizontal or vertical alignment. You can define 

different symbologies for different types of regression points: fixed, normal, and ignored. The 

status of a regression point is determined on the Edit Horizontal Regression Point dialog box. 

Other functions for this command: 

• Annotate point name and slew value on multiple rows 

• Display a directional indicator to indicate the slew direction 

• Display other points of interest (platform edges, overhead line poles and other track  

furniture) 

• Horizontal regression points are updated as the horizontal alignment is edited. 

 

 
Hit Apply. 
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The result should look like this: 
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3. LOAD THE FILE IDEAL WORLD.ALG 

3.1 DISPLAY THE REGRESSION POINTS  
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3.2 USE THE QUICK REGRESSION 
Go to Edit/Review Horizontal  Regression Points … 

 

 
 

Select Quick … 

 
Apply this tolerance. 

The software creates a best fit alignment based on the regression points. Check the 
integrity. 
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Select all elements and delete them. 

 
 

Repeat the Quick regression by changing the tolerance. Tolerance defines the tolerance 
within all points shall fit. 

 
 

View the result. 

Attempt to replace circular arcs (that should be transition spirals) with transition spirals. 
In this context the software looks for three adjacent circular arcs with the middle arc’s 
radius less than the adjacent circular arcs’ radii. 
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4. LESSON NAME: CANT ALIGNMENT  CREATION 

LESSON OBJECTIVE: 
This lesson will show how use the Cant Alignment Creation 

4.1 EXERCISE: CANT ALIGNMENT CREATION 
This exercise will guide you through the Cant Alignment Creation 

5.1.2 SETUP RAIL & GEOMETRY DEFAULTS 
Go to Tools > Options > Rail … 

 
The Rail Tab specifies cant parameters for the Cant Editor and the Maglev 
Superelevation Editor commands located on the Geometry > Superelevation menu. Use 
this tab to set default cant values used by the Cant Editor and Maglev Superelevation 
Editor commands 

The Equilibrium Constant specifies the equilibrium constant used to calculate the equilibrium 

cant. This value can differ in various countries. 

The cant equation: D= 11.8 * v**/ R 
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1. Load the geometry file called Cant.alg 

2. Use the empty alignment A1 

3. Create a simple horizontal alignment by using the PI-method. Insert into the 
horizontal alignment some spirals. 

 
Create 3 PI’s  

Insert curves and spirals 
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Use the Design Calculator to calculate the cant based on radius & speed 

 
In this dialog box the user can create various scenarios to get the best geometric values 
for improving speed on a new or existing alignment. This Design Calculator can also 
use for existing alignment to improve speed on tracks.  
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Based on given values the software can compute the applied cant based on speed: 

 
 

Toggle back to cant and click OK. 



2009 NORDIC CONFERENCE 
  
 WORKING WITH RAIL GEOMETRY BENTLEY RAIL TRACK V81 
  
 

© 2009 Bentley Systems, Incorporated    Page 21 
 

 
 

The dialog box takes the defined values based on the design calculator. Hit apply and 
move on to the next PI. 
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Hit OK. 
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Hit Apply. 
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5.1.3 EDIT CANT 

 
 

Click on Define All … 

The following dialog box appears: 

 
We have already created cant on elements since we used the Design Calculator. Use 
Cant from Horizontal Alignment. 

Hit OK. 
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Apply ads the cant values to the alignment. 

Note: Cant is defined by coordinate at the circular elements. Any changes in the 
horizontal alignment changes the cant! The changed values are shown in RED. 

 

You also can setup the Design Check for cant related values. Click on Design Checks 
… 
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The Design Checks can be saved as Preferences … 

Hit OK. 

 
Hit Apply. 
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5.1.4 CREATE A NEW CANT ALIGNMENT USING THE EQUILIBRIUM EQUATION 

 

 
 

Hit Apply. 
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5.1.5 EDIT CANT 
 

 

 
 

Click on Define All … 
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The following dialog box appears: 

 
 

Turn OFF Use Cant from Horizontal Alignment. Hit OK. 

 
Hit Apply.  
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Select a cant 

 
 

If you want to edit cant go to Edit … 

 

Change some values and take a look at the results. 

 
 

Hit Apply. 
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The user defined values are added to the alignment. 

 

5.1.6 CREATE A REPORT (ASCII) 
Click on Report … 
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File > Save As … 

Save the report as *.txt file. 

 
 

The user can change the cant values by editing the ASCII-file. 
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5.1.7 CANT FROM ASCII 
Create a new cant alignment 

 
 

Click on Edit …. 

Define all … 
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Use Cant from Table 

 

 
 

Select the file Changed ASCII-Cant.txt and hit OK. 

 
 

The user defined ASCII-values are applied. Hit Apply. 
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5.1.8 ADD CANT 
Another way to change cant values is the ADD …  command 

 
 

Click on ADD … 
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This dialog allows the user to add cant values at any station. The user can select the station 
using the radio button.  

Apply ads the cant value at the selected station. 

 
Apply stores the values at the alignment. 

5.1.9 ACTIVATE CANT A1 

 

5.1.10 CREATE A PROFILE ALONG ALIGNMENT 
Evaluation > Profile > Profile > Create Profile … 
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Hit Apply and place the profile in the drawing. 

Annotate profile (Select Curvature, Cant Only & Rail Elevation) 

 
 

Hit Apply. 

You can activate the different cant alignment and view the results. 
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4.2 EXERCISE: CHANGE HORIZONTAL GEOMETRY WITH MULTIPLE HORIZONTAL 

ELEMENT REGRESSION AND RECOMPUTING CANT 
 
This exercise will guide you through the cant recomputing if the horiz.  alignment has 
been changed 

4.2.1 USE THE HORIZONTAL  MULTIPLE ELEMENT REGRESSION ANALYSIS 
Geometry > Horizontal Regression > Horizontal  Multiple Element Regression 
Analysis … 
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4.2.2 CHANGE A RADIUS 
User the right mouse click to Edit … 

 
 

 
Free up the length from clothoids & radius 
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Hit Apply and save the solution. 

4.2.3 EDIT CANT 

 
The geometry has been changed and the cant values as well since they are coordinative 
applied to the circular elements. 

To optimize the cant based on the equilibrium equation you can click on Define All … 
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Apply. 

 

 
 

The cant is now optimized for a given speed of 100 km/h. 

During the design process the user can use various scenarios to Add, Change & Delete cant.  
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The Design Calculator helps to find the best solution. 

 

5. LESSON NAME: TURNOUT CREATION 

LESSON OBJECTIVE: 
This lesson will show how to use the turnout commands. 
You will find the turnout libraries in the Bentley Rail Track product under: 
…\Program Files\Bentley\Bentley Rail Track V8.11\data\imperial\... for imperial units 
…\Program Files\Bentley\Bentley Rail Track V8.11\data\metric\... for metric units 
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5.1 EXERCISE: TURNOUT CREATION [IMPERIAL] 
This exercise will guide you use the turnout commands  

5.1.1 SETUP THE TURNOUT LIBRARY 
To access the right turnout library you need to setup the library in the Project Defaults. 
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Under Tools > Options > Preference … load the Imperial preference. 

 
 

Close the dialog box. 

5.1.2 DESIGNING TURNOUTS 
a. Imperial (AREMA)  

Under Tools > Customize > Turnouts … 

 
 

 
For Imperial unit you should use the Alternate Turnout Library. 
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We want to create the following turnout AREMA #6 Straight with the following 
parameters: 

This is an example how to create a turnout. 

Switch Angle:  2^39’34.0” 

Actual Lead:  47.500 

Radius Of Centerline: 258.57 

Frog Angle:  9^31’38.0” 

Heel Length:  6.250  
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Click on New … 

 
Under Type you can select different turnout type such a s Single, Single Slips etc. 

Select the New turnout from the library. 

 
Fill in the values: 
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Hit Apply. The turnout is now stored in the library. 
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5.1.3 TURNOUT DESIGN 
To create a simple turnout connection between two tracks goes to Geometry > Utilities 
> Parallel Horizontal Alignment … 

 

 
 

Apply. 

You will now have an alignment 15 ft to the left from alignment A1. 
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5.2 CREATE TURNOUT 
Interactive 

 
 

If you use Interactive you must follow the steps: 

• Identify mainline alignment 

• Identify point (turnout .1 as placement point) 

• Identify orientation point ( the direction for the branch) 

• Accept. 
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5.3 CREATE QUICK CONNECTION 
An easy way to make a connection is the Quick Connection Command. 

 

 
 

The software is using the same turnout which was place on alignment A1. To fill in a 
length is not needed in case you have a straight turnout connection. 

Hit Apply. 

 
 

If you close the dialog box the turnout will store to the geometry. 
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Create a new horizontal alignment. Place a single fixed line close to the track A1. 

 

 
 

 

 

 

 

 

 

Place a new turnout in A1 
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5.4 CREATE CONNECTION TURNOUT TO ELEMENT 

 
Select the turnout an check on Element, Identify the alignment 

 
 

By using the right mouse click select Add After … 

 

 
 

Select as connecting type a Circular element. Hit Apply. 
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If you want to set the turnout to a given station then key in the station and do not free 
the turnout. 

 
 

Free up the length & radius of the connecting element and the ending element. 

Hit Apply and Save the solution with Save As … 

 
Save As .. saves the whole connection including the alignment C1. 

Other options for turnout connections: 
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• Free Exit 

connects a turnout to nothing. For example, adds elements of known length and radii to the 
end of a turnout 

• Station 

defines the ending turnout’s tip station. If on then the value is free to change during 
computations. If off then this value is fixed during computations. This freedom is persisted 
with the geometry 

 

6. CREATE SHUNT LIMITS 

The Create Shunt Limits command computes a shunt point. A shunt point is a physical 
point at which a train must stop to avoid colliding with another train if two trains occupy a 
turnout and mainline track. 

 

This picture explains how a shunt limit will be created. 
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Hit Apply. 

 
 

 

 

 

 

 

Shunt limits  
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6.1 REPORTING 
 

If you want to create reports on turnout connections the use the report command 

 

 
 

There several report templates available. 
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6.2 EXERCISE: TURNOUT CREATION [METRIC] 
If the user wants to create metric turnouts then metric units needs to be setup in Tools > 

Options … 

If metric unit applied then the Alternate Turnout Library cannot be used. 

 
 

 

 

 

The user must use the Turnout Library. 
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If the user wants to create turnouts he has to follow a similar workflow like in the 
previous exercise.  

 

Click on New … 
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The bending method is German 

A typical turnout schematic drawing with a straight frog 
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The Schematic shows the user the required values. 
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Fill out the turnout values: 

Length Along Mainline: 27.1281 

Triangle Length:  16.6149 

Ratio:   9.000  

 
 

Click on Verify.  
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Apply. The New turnout has been stored in the library and can now used for design. 
 

 

 


