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Workshop Description 

This workshop will cover the tools available in InRoads for the creation of cross sections that 
contain drainage structures created with the InRoads Storm & Sanitary product. Some of the 
topics covered in this workshop include: display of drainage structures on cross sections, and 
labeling of drainage structures on cross sections using Drafting Notes. 

Target Audience   

This workshop is intended for Drainage/Highway Engineers, Designers, and Drafters. 

Prerequisites 
� MicroStation knowledge is helpful. 

� Basic InRoads knowledge is recommended. 

Course Objectives 
� Create a custom set of cross sections showing drainage structures. 

� Display realistic inlets using a cell. 

� Label the drainage structures using Drafting Notes. 

� Create a Drafting Note and use that note to label an inlet. 

Modules Included 
� Creating Cross Sections and Drainage Structures. 

� Drafting Notes and Drainage Structures. 
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Introductory Knowledge 

The purpose of the following questions is to gauge the learner’s pre-requisite knowledge prior to 
completing this course. At the completion of the course the learner will be asked to complete a 
review to measure the skills learned.  

Introductory Questions 

1. How many surfaces can be displayed on a cross section? 

2. Can linear surface features be projected to profiles and cross sections? 

3. Can InRoads files be stored on a network drive? 

 

Hint Answers can be found at the end of the manual. 
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Cross Sections and Drainage Structures 

Module Overview  
InRoads can now open a Storm & Sanitary database without having a license for Storm & 
Sanitary. 

 

An InRoads user can open Storm & Sanitary data and display the data in plan 
view and on cross sections. To design and layout a storm and/or sanitary system, Storm & 
Sanitary needs to be licensed, but InRoads alone can display Storm & Sanitary data. 
 

Module Objectives 
� Create custom cross sections with drainage structures. 

� Display realistic inlets using a cell. 
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InRoads Storm & Sanitary  
The latest versions of InRoads can read Storm & Sanitary database files directly, without 
Storm&Sanitary running. Drainage structures are now fully integrated into InRoads cross section 
capabilities.   
 
Surface features and drainage structures selected by the user and within a user specified 
bandwidth show up in cross sections.  The Ahead Band defines how far up-station and the Back 
Band defines how far back-station. If both numbers are positive (for example: ahead 10, back 15), 
and a cross section is created at station 100+25, the band starts at 100+10 and ends at 100+35. 
The band will be perpendicular to the alignment used for the cross section. For cross sections 
generated on arcs, the band is not rectangular but wedge shaped. 

 

Creating a custom cross section set can be very helpful to visualize the drainage structures. 
Custom cross sections allow you to specify skewed cross sections at any location along an 
alignment. Cross section locations can also be specified at drainage structures and will 
automatically create a cross section perpendicular to that structure. Projected and crossing 
drainage structures can be projected to specific cross sections and varying bandwidths can be 
applied. Custom cross section set parameters can be saved to a text file and imported for future 
use. 
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Let’s Get Started 

 

 Exercise: Start InRoads and Open the Project Data. 

 
1. Select Start> Programs > Bentley > InRoads Group XM > InRoads. 

 

2. From the MicroStation Manager, select the file 
C:\2008 RBUC\W11 Cross Sections with Drainage 
Structures\Data\StormAndSanitaryCrossSections.dgn and click OK. 

 

3. From the InRoads Menu, select File > Open. 

 

4. Select the Project C:\2008 RBUC\W11 Cross Sections with Drainage 
Structures\Data\RBUC_training.rwk and click Open. 

 

This Project file opens the following files: 

 

Existing Ground Surface  Existing.dtm 

Proposed Surface   Design.dtm 

Geometry Project    Drainage Geometry.alg 

Drainage    Drainage Design.sdb 

Preferences   RBUC_training.xin 

 

5. Click the Cancel button. 
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Drainage Tools in InRoads 

InRoads now provides you several drainage tools that were previously only included in InRoads 
Storm & Sanitary.  In the last exercise, a Drainage Database was opened and can now be used by 
InRoads alone. The Drainage tab in the InRoads Workspace Bar can be used to review the 
drainage data.  There is a Drainage menu which provides access to the View Drainage and 
Edit/Review tools.  

The Style Lock     

Each drainage structure has a Style associated with the different parts of the structure.  During the 
placement of the structures, the Style is assigned to the structures. The Edit/Review dialog 
contains a Styles tab which can be used to change or review the structure’s Styles. With the Style 
Lock in the On position, the drainage structures will be displayed using the Styles associated with 
each structure.  This allows you to individually control the display of different structure types and 
sizes.   
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Viewing the Drainage Structures in Plan View 

 

 Exercise: View Drainage Structures in Plan View. 

 
1. Verify that the Style Lock is in the On position.  

  

 
 

Hint If the Locks toolbar is not displayed, select Tools > Locks > Toolbar to display 
the toolbar. 

 
2.  Select Drainage > View > Drainage. 

 

 

3. Review the graphics of the drainage structures in Plan View. 
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Create Cross Sections 

The InRoads’ Create Cross Section command has been updated to be able to view projected and 
crossing drainage structures in cross sections. The Include and the Custom leafs of the Create 
Cross Section dialog allow you to display crossing and/or projected Storm & Sanitary Structures.  
Like in the Plan View, the display of the structures is controlled by the Styles assigned to the 
structures.  The Style Lock must in the On position to assure the graphical display of the 
structures produces the desired results.  When displaying Projected structures, the bandwidth 
must be specified to display the desired structures within an area of interest.  
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Create Cross Sections 

 

 Exercise: Create Custom Cross Sections with Drainage Structures. 

 

1. Select Evaluation > Cross Section > Create Cross Section. 

 

2. Select the Create Cross Section > Custom > General leaf. 

 

 
 

3. Click the Import button. 

 

4. Select the C:\2008 RBUC\W11 Cross Sections with Drainage 
Structures\Data\Custom Drainage Sections.xsc and click Open. 

 

5. Click the Apply button and click in the MicroStation View to create the cross 
sections. 

 

The click location specifies the lower left hand corner of the cross section set. 
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6. Close the Create Cross Section dialog. 

 

Review the Cross Sections 
 

1. Select Evaluation > Cross Section > Cross Section Viewer. 

 

 
 
2. Step through several of the cross sections and review the drainage structures 

that are displayed. 

 

3. Select station 141+40 from the Cross Sections: list. 

 

4. Review the right and left inlets. 

 

5. Close the Cross Section Viewer dialog. 
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Displaying Drainage Structures Using Cells 

Several drainage structure types have the option to select a Style for points.  Manholes, inlets, 
pumps and utilities use Point Styles. The Style used by a drainage structure is specified in the 
Structures file.  The Structure file assigns the Styles used when the drainage structure is being 
added to the database using the InRoads Storm & Sanitary’s Layout command.  Individual 
structure Styles can also be reviewed and modified using the Drainage > Edit/Review command. 

The Styles used are configured using the Tools > Style Manager command.  The drainage 
structure Styles are linked to Named Symbology through the Edit Style > Surface Features > 
Symbology leaf when editing a Style using the Style Manager. The Named Symbology can 
specify a cell to use when a drainage structure is being displayed as a point.   

Cells used for inlets may be oriented differently depending on which side of road the inlet is 
located.  Different Styles can be used to specify left and right cells, which reflect the differences 
in the orientation. 
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Adding a Cell to the Style 

 

 Exercise: Add a Cell to the Left and Right Inlets at station 141+40. 

 

Add a Cell to the Left Inlet 
 
1. Select Drainage > Edit/Review. 

 

2. At the “Key in ID or identify structure” prompt select the inlet on the left side 
(CBI34) of the cross section. 

 

3. Accept your selection by clicking on the View. 

 

4. Select the Styles Tab on the Edit/Review Inlet dialog. 

 

Notice the Style of the Point: is CBI TypeA Back 3FT. 

 

5. Select the New Style button. 

 

This is a shortcut to the Tools > Style Manager command. 

 

6. Select the Style named CBI TypeA Back 3FT  and click the Edit button. 
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7. Select the Edit Style > Surface Feature > Symbology leaf. 

 

This Style uses the Named Symbology called CBI TypeA Back 3FT. 

 

 
 

8. Click the Edit button.  

 

9. This is a shortcut to the Tools > Named Symbology command. 

 
10.  Select the Cross Section Point symbology and click the Edit button. 
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11.  Enable the Cell Display option and select the cell named CBI  TypeA Back 
3FT  and click OK. 

 

 
 
12.  Click Apply and Close on the Edit Named Symbology dialog. 

 

13.  Click Apply and Close on the Edit Style dialog. 
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Add a Cell to the Right Inlet 
 
The right inlet uses a Style named CBI TypeA Ahead 3FT.  We can change that 
Style while the Style Manager dialog is open. 

 

1. Select the Style named CBI TypeA Ahead 3FT  and click the Edit button. 

 

2. Select the Edit Style > Surface Feature > Symbology leaf. 

 

This Style uses the Named Symbology called CBI TypeA Ahead 3FT. 

 

 
 

3. Click the Edit button.  

 

4. This is a shortcut to the Tools > Named Symbology command. 
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5.  Select the Cross Section Point symbology and click the Edit button. 
 

 
 

6.  Enable the Cell Display option and select the cell named CBI  TypeA  Ahead 
3FT  and click OK. 

 

 
 

7.  Click Apply and Close on the Edit Named Symbology dialog. 
 

8.  Click Apply and Close on the Edit Style dialog. 
 

9. Close the Style Manager dialog. 
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Updating Cross Section Drainage Structures 

The Update Cross Section command allows you to update the drainage structures graphics on 
cross sections.  One option is to Refresh or synchronize the graphics with changes made to the 
drainage database.  This refresh also includes any changes made to the Styles associated with the 
drainage structures.  Drainage structures can be added or removed using the Display On or 
Display Off options.  Select the Update Cross Section > Storm and Sanitary leaf from the Update 
Cross Section dialog and select the drainage structures to update.  The bandwidth may also be 
redefined during the update.  If you need to change the Styles, there is a Styles button on this leaf 
that opens the Style Manager dialog. 
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Update Cross Section 

 

 Exercise: Update Drainage Structures in the Cross Sections. 

 
1. Select Evaluation > Cross Section > Update Cross Section. 

 

2. Select the Update Cross Section > Storm and Sanitary leaf. 

 

 
 
3. Click the All button next to the Projected: structures. 

 

4. Click the Apply and Close button. 

 

5. Review the inlet graphics. 

 

Notice the original inlet graphics overlap the cell graphics. 
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Top Height Parameter 

In the last exercise, the inlet cell was displayed on top of the normal inlet structure graphics.  The 
normal graphic can include the Inside and Outside Vaults, which are shown as concentric 
rectangles.  Using a cell can better represent more complicated structures.  To create an opening 
in the top of the normal vault graphics, the Top Height parameter can be used.  The Top Height is 
the amount of the vault graphic that is clipped from the vault's top.  This is measured down from 
the structure's stored elevation.  If the inlet's center style has a cell specified in its cross section 
point symbology and the inlet or manhole has a top height greater than 0.0, the top of the vault is 
clipped the top height amount.  The specified cell's origin will be placed at a location that is 
horizontally centered on the vault and vertically located at the structure's stored elevation.  The 
Top Height parameter applies to both inlets and manholes. 
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Changing the Top Height 

 

 Exercise: Clip the Inlet Graphics Using the Top Height. 

 
1. Select Drainage > Edit/Review. 

 

2. Select the left inlet (CBI34). 

 

3. Change the Top Height: to 2.0. 

 

4. Click Apply and then Close. 

 

5. Select Drainage > Edit/Review again. 

 

6. Select the right inlet (CBI35). 

 

7. Change the Top Height: to 2.0. 

 

8. Click Apply and then Close. 
 

Warning The Top Height parameter is stored in the Drainage file (.sdb).  InRoads Storm & 
Sanitary must be used to save the Drainage file (.sdb).   

 
Update the Cross Sections Again 

 

1. Select Evaluation > Cross Section > Update Cross Section. 
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2. Select the Update Cross Section > Storm and Sanitary leaf. 

 

 
 
3. Click the All button next to the Projected: structures area. 

 

4. Click the Apply button and then Close. 

 

5. Review the inlet graphics. 

 

Notice the original inlet graphics are now clipped and no longer overlap the 
cell graphics. 

 

 

 



  
 

Nov-04 23 Drafting Notes and Drainage Structures  
                                                                                                                            

Copyright © 2008 Bentley Systems, Incorporated 
 

Drafting Notes and Drainage Structures 

Module Overview  

 

The InRoads Drafting Notes now include Storm & Sanitary variables.  This module will step you 
through placing existing notes on drainage structures in cross sections.  You will also create a 
new note and place that note on a drainage structure. 
 

Module Objectives 
� Place several existing notes on drainage structures in cross section. 

� Create a new cross section note and place that note. 
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Drafting Tools 
 

 

Drafting tools are used to place intelligent notes in plan, profile, and cross section views. 
Intelligence refers to the notes ability to extract computed values from InRoads elements 
and include the computed values in the note. For example, when labeling a surface 
feature, the note can include the feature’s name, description, style, length, etc. Computed 
values can be extracted from InRoads surfaces, geometry, and InRoads Storm & Sanitary 
drainage elements. Drafting notes can also be used on MicroStation elements which are 
not related to InRoads. 
 

Drafting tools are located in the Drafting drop-down menu. Drafting note tools are 
separated into which view the note is being placed. There are three views: plan, profile, 
and cross section. For example, to place or create a cross section note, you would use 
Drafting > Place Cross Section Note.  
 

Notes can be easily created and saved to be reused in different projects. 
 

Other drafting tool benefits include the ability to dynamically scale and rotate the note 
when placing the notes. After the notes are placed, there are tools to update and move 
notes. If the note applies to more than one item, you can place a note with multiple leader 
lines. Various terminator types are available for use, which include Filled, Hollow, Open, 
and Cell. Notes can be created using various text frame shapes, which include Circle, 
Ellipse, Polygon, Box , Capsule, and Bar. 
 

Place Cross Section Note 

 

Place Cross Section Note is used to place notes in the cross section views. Select 
Drafting > Place Cross Section Note. This will bring up the Place Cross Section Note 
dialog. 
 

The basic workflow for placing cross section notes is to first enable any dynamics options 
if needed. Then navigate and select the cross section note you want to place. Click Apply 
and follow the prompts located in the MicroStation status bar. 
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Place Cross Section Notes on Structures 

 

 Exercise: Use the Place Cross Section Note command to Label Drainage Structures. 

 
1. Select Drafting > Place Cross Section Note. 

 

2. Select File > Open from the Place Cross Section Note dialog menu. 

 

3. Select the Note file C:\2008 RBUC\W11 Cross Sections with Drainage 
Structures\Data\notes.dft and click Open. 

 

4. Navigate and select the Sections > Proposed > Inlets note. 

 

 
 

5. Click the Apply button and select one of the inlets on the cross section.  
Follow the prompts in the MicroStation status bar. 

 

6. Right-click to return to the Place Cross Section Note dialog. 

 

7. Navigate and select the Sections > Proposed > Inlet Throat Elevation note. 
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8. Click the Apply button and select one of the inlets on the cross section.  
Follow the prompts in the MicroStation status bar. 

 

9. Right-click to return to the Place Cross Section Note dialog 

 

10. Navigate and select the Sections > Proposed > Pipes note. 

 

11. Click the Apply button and select one of the pipes on the cross section.  
Follow the prompts in the MicroStation status bar. 

 

12. Select the other pipe on the cross section.  Follow the prompts in the 
MicroStation status bar. 

 
13.  Right-click to return to the Place Cross Section Note dialog. 
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Creating Notes 

 

To create a note, you must use the appropriate command. To create plan notes, use Place Plan 
Note. Likewise, to create profile notes, use Place Profile Note. Cross section and alignment 
intersection notes are also created using their respective placement commands. 
 
The note file folder structure is completely customizable and is defined by the user. You can 
build the folder structure and notes to fit your needs. It is recommended that plan, profile, and 
cross section notes be separated into different folders because the notes are created specifically 
for each view type. 

 

 

Creating Note Names 

 

To create a new note name, select an existing folder. Then, use File > New > Note from the Place 
Note pull-down menus. Note names can be created using any of the Place Note tools. Instead of 
using the File menu commands, you can right-click on any folder and access the File menu 
commands through pop-up menus. Finally, key-in the name of the newly created note. To rename 
a note, right-click on the folder and select the Rename command. 

 

Note Content 

 

The content of any note consists of text and computed values. To reveal the note creation and 
editing portion of the Place Note dialogs, click the Expand arrow located directly below the 
Dynamics portion of the dialog. 

 

Text 

 

Any text can be included in a note. Key-in any text that you want to appear in a note in the Note 
area of the dialog. The Note area works like Notepad. You can right-click in this area and select 
common commands like Copy, Paste, Cut and Delete. Windows hot-keys may also be used in this 
area. For example, using the CTRL-Z combo invokes the Undo command. There are numerous 
icons adjacent to the Note area to assist you in creating notes. 
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Computed Values 

 

Computed values are used to display extracted data from InRoads graphics or pure MicroStation 
graphic elements. Computed values can be selected from the Inserts area of the Place Notes 
dialogs. Computed values are organized into a folder structure. There are three main categories: 
General, Geometry, and Surface. Under each category there are related computed values to be 
used for creating notes. To include a computed value in a note, navigate to the appropriate 
computed value and double-click it. The computed value will then appear in the Note area. 

 
Computed values use a very specific naming convention and format. When used, they appear in 
the Note area as text inside curved brackets. For example, the “Offset” computed value has the 
format {OFFSET}. Computed values can be combined with regular text in the Note area. If the 
computed value is not found when creating the note, the computed value will appear in the note 
text as text inside curved brackets. For example, if you use a note that is looking for surface 
feature information and you identify an element that is not a surface feature, then the computed 
value will not be calculated. 

 

The Storm and Sanitary Structures computed values allows you create notes used to label 
drainage elements created using the InRoads Storm & Sanitary software. When a drainage 
database has been opened, the list of available computed values is displayed. 
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Create a Drainage Note 

 

 > Exercise: Create and Place a Cross Section Note. 

  

 
1. In the Place Cross Section Note command, navigate and select the Sections > 

Proposed folder. 

 

 
 
2. Right-click the Proposed folder and select New > Note. 

 

3. Key-in the Note name as Inlet Inverts. 
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4. Click the Expand button located at the bottom right of the dialog. 
 

 
 

5. Key-in Invert Elevation In =  in the Note: area of the dialog. 
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6. Click the + sign next to the Storm and Sanitary Structures in the Inserts: 
area of the dialog. 

 

7. Navigate to the Storm and Sanitary Structures > Inlets > InvertIn insert. 

 

8. Double-click the InvertIn insert. 

 

This will insert the {InvertIn} variable in the Note: area of the dialog. 

 

 
 

9. Put your cursor next to {InvertIn} variable in the Note: area and press the 
Space bar on your keyboard.  Key-in FT and press Enter on your keyboard. 
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10.  Key-in Invert Elevation Out =  in the Note: area of the dialog. 

 

11.  Navigate to the Storm and Sanitary Structures > Inlets > InvertOut insert. 

 

12.  Double-click the InvertOut insert. 

 

This will insert the {InvertOut} variable in the Note: area of the dialog. 

 

13. Put your cursor next to {InvertOut} variable in the Note: area and press the 
Space bar on your keyboard.  Key-in FT and press Enter on your keyboard. 

 

14. The Note: area should look like this now. 

 

 
 

15. Select File > Save from the Place Cross Section Note dialog menu. 
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Note Settings 

 

When creating a note, click Settings to configure the setting of that note. Each note can have its 
own settings defined. If you copy a note, the settings are also copied. Using the Copy command 
could save you time creating new notes if the settings are similar.  The Settings dialog is where 
the placement mode is specified. Select one of the three placement modes: Data Point, Two Data 
Points, or Element.  Drainage notes generally use the Element placement mode, since the 
information about the drainage database is contained in the drainage structure graphics. 

 
The symbology of the note is specified here using the Named Symbology portion of the dialog. 
You can use different symbology for each part of the note or use the Lock icon to select one 
named symbology for all the different parts of the note. 
 
The text frame is also specified in the Settings dialog. The shape can be a Box, Circle, Ellipse, 
Polygon, Bar, Capsule, or None. 
 
The leader type and terminator are specified here. The leader type can be 2 Point, 3 Point, or 
none. The terminator can be Filled, Hollow, Open, Cell, Named Symbology, or None. 
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Configure the Note Settings 

 > Exercise: Setup the Display Setting of the New Note. 

 
1. Select the Settings button from the Place Cross Section Note dialog. 

 

2. Change the Placement Mode: to Element. 
 

3. Change the Named Symbology Text: to Cross Section Notes. 

 

The Lock next to the Named Symbology: area will use the same Named 
Symbology for all the note graphics, if enabled. 

 

4. Change the Frame Shape: to Capsule. 

 

5. Change the Leader Terminator: to Filled. 

 

6. The Settings dialog should look like this now: 
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7. Click the OK button. 

 

8. Select File > Save from the Place Cross Section Note dialog menu. 

 

Place the Inlet Inverts Note 
 
1. Click the Apply button and select one of the inlets on the cross section.  

Follow the prompts in the MicroStation status bar. 

 

2. Right-click to return to the Place Cross Section Note dialog. 

 

3. Close the Place Cross Section Note dialog. 
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Workshop Review 

InRoads now includes Storm & Sanitary tools which allow InRoads users to display drainage 
structures in plan and cross section views.  The Drafting Notes can now be used to label drainage 
structures in plan, profile and cross section views.   

The drainage structure Styles are now defined in the Structures file and are assigned to the 
structures when the drainage is placed using the Storm & Sanitary Layout tool.  Enabling the 
Style Lock will use the drainage Styles to control the symbology of the drainage structures in 
plan, profile, and cross section.  Individual drainage structure Styles can be modified using the 
Drainage > Edit/Review tool.  The drainage Styles are linked to the Named Symbology and is 
associated with the Style’s Surface Feature Symbology. 

Cross Sections can include drainage structures and will show crossing and/or projected features 
on the cross sections. The projected drainage is based on a bandwidth, which is defined when 
creating the cross sections.  The Update Cross Section command allows you to refresh the 
drainage structures and modify the bandwidth. 

Custom cross sections are very useful for displaying drainage structures in cross section.  Custom 
cross sections allow you to automatically create cross sections which are perpendicular to 
drainage structures and vary the bandwidth from station to station.  Skewed and Linestring cross 
sections can be used to help visualize the drainage structures in custom cross sections.  A custom 
cross section set can be saved and then later imported if needed for future use. 

Several structure types allow for the use of Point Styles.  This allows you to use cells to represent 
more complex structures.  Inlets and manholes are displayed as concentric rectangles in cross 
sections.  The Top Height parameter can be used to clip the top of the vault graphics when a cell 
is being used.  
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Review Questions 

1. Can projected and crossing drainage structures be added to a cross section set after the 
cross section set is created? 

2. When using a cell to display a drainage structures, does the Top Height parameter change 
the display if it is set to zero? 

3. Can a single Drafting Note include information about drainage structures and also include 
surface and geometry data? 
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Answers to Questions 

 

Introductory Answers  

1. Unlimited. 

2. Yes.  Point features may also be projected to both cross sections and profiles. 

3. Yes.  A mapped drive or UNC path can be used. 

 

 

Review Answers 

1. Yes.  Use the Display On option in the Update Cross Section command. 

2. No.  Only Top Height values larger than zero will result in vault top clipping. 

3. Yes.  Also, any general text may be included in any note. 


