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Resurfacing Techniques 

Module Overview 

This module will investigate the techniques for resurfacing roads.  It includes optimization of 
vertical alignments, milling and widening of existing roads. 

Module Prerequisites 

� Advanced knowledge of geometry commands 

� Advanced knowledge of template creation and usage 

� Advanced knowledge of Roadway Designer 

Modules Objectives 

After completing this module, you will be able to: 

� Create an optimization template 

� Create optimized vertical alignments 

� Level and widen roadways 
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Introductory Knowledge 

Before you being this module, let’s define what you already know. 

Questions 

1. Repaving is the same as rehabilitation. 

� True 
� False 

2. Repaving of roads requires leveling. 

� True 
� False 
� Maybe 

3. Is superelevation needed for rehabilitating a road? 

� True 
� False 
� Maybe 
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Answers 

1. Repaving is the same as rehabilitation. 

False 

Rehabilitation usually involves correcting cross slope and or re-engineering 
superelevation. 

2. Repaving of roads requires leveling. 

False 

Generally, repaving is a simple overlay of asphalt directly on the existing pavement with 
no corrections. 

3. Is superelevation needed for repaving a road? 

Maybe 

Straight roads will not need superelevation; however, if rehabilitating a roadway and you 
have curves you will need superelevation applied to your corridor. 
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Loading Data 

We will use an RWK file to load the project data.  The RWK is located in the following parent 
directory: 

C:\2008 RBUC_West\Widening and Overlay with Roadway Designer 
(InRoads_GEOPAK)\Data 

The data that will be loaded is: 

 OG.dtm  (Existing surface file) 

Overlay.alg (Existing regressed geometry file) 

Overlay.itl (Template library file) 

Overlay.ird (Roadway Designer file) 

civil.xin (Preference file) 

� Exercise: Opening the data 

1. Start InRoads from the InRoads icon (Start>Programs>Bentley>InRoads Group V8i) 

2. When the MicroStation Manager appears, select the file Overlay.dgn and open it. 

Hint: All files for this module are located in the parent directory stated above. 

3. When MicroStation fully opens and InRoads appears select File>Open from the 
InRoads menu. 

4. Select the file Ovrelay.rwk and open it. 

Viewing the Data 

We will now view the data that exists in the project you just opened. 

� Exercise: Viewing the data 

1. To view the horizontal alignment select Geometry>View Geometry>Active Horizontal. 

2. Fit the MicroStation view. 

3. To view the surface data select Surface>View Surface>Features.  When the dialog 
opens highlight all the features and select Apply. 

4. Close the View Features dialog. 

5. Cut a profile along the alignment.  Go to Evaluation>Profile>Create Profile.  Select 
Apply and then identify a location to cut the profile. 
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Widening Template 

The process in this section will allow you to automatically find the controlling points along the 
road to minimize the leveling.  

� Exercise: Widening 

1. Go to Modeler>Create Template. 

2. Expand the tree in the left pane of the Create Template dialog until you see the 
templates called Widening. 

 
3. Double click on the template Widening to activate it. 

4. Right Click on the point named L_OEOP. 

5. Note that the point is controlled from the centerline point in the horizontal direction and 
the slope is a vector-offset from the centerline to the inside edge of pavement. 

6. Close the Create Template dialog. 

7. Go to Modeler>Roadway Designer. 

8. Create a new corridor.  Go to Corridor>Corridor Management. 

9. Type in the name Widening in the name field of the Manage Corridors dialog. 

10. Set the following values: 

 Station:   On 

 Start:    48+00 

 Stop:    250+00 

 Type:      Alignment 

 Horizontal Alignment:  Highway 

 Vertical Alignment:  Highway 

11. Click Add and close the dialog. 

12. From the Roadway Designer go to Corridor>Template Drops. 

13. Expand the template list. 
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14. Double click on the folder Overlay Templates. 

15. Highlight Widening and select Add. 

 
16. Close the Template Drops dialog. 

17. Got to Corridor>Point Controls. 

18. In the Point Controls dialog set the following values 

 Point:   L_EOP 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature  LEP 

 Start Station:  48+00 

 Stop Station:  250+00 

 Vertical Offset  0.25 (for both Start and Stop) 
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19. In the Point Controls dialog set the following values. 

 Point:   R_EOP 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature  REP 

 Start Station:  48+00 

 Stop Station:  250+00 

 Vertical Offset  0.25 (for both Start and Stop) 

20. In the Point Controls dialog set the following values. 

 Point:   CL 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature  CL 

 Start Station:  48+00 

 Stop Station:  250+00 

 Vertical Offset  0.25 (for both Start and Stop) 

21. Close the Point Control dialog. 

22. Step through the model. 

23. Close the Roadway Designer (Save the corridor if you would like). 
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Optimization Template 

The process in this section will allow you to automatically find the controlling points along the 
road to minimize the leveling.  

� Exercise: Reviewing the optimization template 

1. Go to Modeler>Create Template. 

2. Expand the tree in the left pane of the Create Template dialog until you see the 
templates called Visual Optimization. 

 
3. Double click the template Visual Optimization to activate it. 

4. Right click on the green point on the upper most layer of the template and select Move. 

 
5. Move the point around and examine how the other layers react. 

6. Right click to reset. 

7. Right click on the right most green point and move it around. 

8. Right click on the left most green point and move it around. 
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Hint: If you accidentally left click and place the layer somewhere else use Edit>Undo or Ctrl+Z 
to undo the left click. 

9. Double click on the red point at the center of the white layer. 

 
10. Examine the constraints that are attached to the point.  The point is constrained 

horizontally to the green point above it and by slope from the green point to the right. 

 

11. Double click the template Optimization to activate it. 

12. Right click on the upper most green point and select move. 

13. Move it down in the window and at some point you will see another layer turn on and the 
layer you were moving turn off. 

14. Right click to reset. 
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15. Turn on the toggle Display All Components. 

 
16. Notice now that you can see the other components (layers) but they are dashed. 

17. Move the point at the left most end of the brown one. Notice if you move it above the 
upper layer it will turn on. 

18. Repeat the process with the white one by moving the right most point.  

19. What is causing this is Display Rules. 

20. Double click on any component.  In the lower portion of the dialog select the Edit button 
to the right of the Display Rules field.  

 
21. In the lower half of the dialog you will see a list of rules.  The upper half of the dialog 

allows you to use the rules in combination. 

 
22. Cancel and Close the Display Rule dialog and Edit Component dialog. 
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23. Notice there are two more templates in the folder.  The L_Visual Optimization and 
R_Visual Optimization are subset templates from the Visual Optimization template.  
These will be used to create superelevation.  Take a minute to examine the templates. 

Optimization Corridor 

The process in this section will tie the optimization template into a corridor.  

� Exercise: Creating an Optimization Corridor 

24. Go to Modeler>Roadway Designer. 

25. Create a new corridor.  Go to Corridor>Corridor Management. 

26. Type in the name Visual Optimization in the name field of the Manage Corridors 
dialog. 

27. Set the following values: 

 Station:   On 

 Start:    48+00 

 Stop:    250+00 

 Type:      Alignment 

 Horizontal Alignment:  Highway 

 Vertical Alignment:  Highway 

 
28. Click Add and close the dialog. 
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29. From the Roadway Designer go to Corridor>Template Drops. 

30. Expand the template list. 

31. Double click on the folder Vertical Optimization. 

32. Highlight Visual Optimization and select Add. 

 

33. Close the Template Drops dialog. 

34. Select the Superelevation button on the bottom right of the Roadway Designer. 

35. Right click in the lower right view and select Create Superelevation Wizard>Table. 

36. Select the  button on the Table Wizard dialog. 

37. Browse to the workshop folder and select the file 08_50.sup. 
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38. Change the %Runoff on Tangent to 80%. 

39. Select the Load Value From Table button. 

40. Select Next. 

41. When the next step appears select the Add button close to the center of the dialog. 

42. When the Add Superelevation Section dialog appears set the following values in the 
dialog. 

 Name:    CL_Tie 

 Crown Point:   CL 

 Left Range Point:  L_EOP 

 Right Range Point:  R_EOP 

 Pivot Direction:  From Crown 

 Number of Lanes:  2 

 Station    Off 
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43. Select OK. 

44. Select Next and then Finish when the wizard dialog appears. 

45. Go to Corridor>Template Drops. 

46. In the Current Template Drops list highlight (single click) on the entry in the list. 

47. In the Library Templates list select the L_Visual Optimization template. 

 
48. Select Change. 

49. Select Close. 

50. Right click in the lower right view and select Create Superelevation Wizard>Table. 



 Optimization Corridor 

 

Nov-08 15 Resurfacing Techniques 

Copyright © 2008 Bentley Systems Incorporated 

 

 

51. Select Next. 

52. Select Add. 

53. When the Add Superelevation Section dialog appears set the following values in the 
dialog. 

 Name:   L_Tie 

 Crown Point:  CL_LEOPTie 

 Left Range Point: L_EOP_LEOPTie 

 Right Range Point: R_EOP_LEOPTie 

 Pivot Direction: From Left Edge 

 Number of Lanes: 2 

 Station   Off 

54. Select OK. 

55. Select Next and then Finish when the wizard dialog appears. 

56. Go to Corridor>Template Drops. 

57. In the Current Template Drops list highlight (single click) on the entry in the list. 

58. In the Library Templates list select the R_Visual Optimization template. 

 
59. Select Change. 
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60. Select Close. 

61. Right click in the lower right view and select Create Superelevation Wizard>Table. 

62. Select Next. 

63. Select Add. 

64. When the Add Superelevation Section dialog appears set the following values in the 
dialog. 

 Name:   R_Tie 

 Crown Point:  CL_REOPTie 

 Left Range Point: L_EOP_REOPTie 

 Right Range Point: R_EOP_REOPTie 

 Pivot Direction: From Right Edge 

 Number of Lanes: 2 

 Station   Off 

65. Select OK. 

66. Select Next and then Finish when the wizard dialog appears. 

67. Go to Corridor>Template Drops. 

68. In the Current Template Drops list highlight (single click) on the entry in the list. 

69. In the Library Templates list select the Visual Optimization template. 
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70. Select Change. 

71. Select Close. 

72. Select the Superelevation button to turn off the superelevation mode. 

73. Go to Corridor>Point Controls. 

74. In the Point Controls dialog set the following values. 

 Point:   CL 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature  CL 

 Start Station:  48+00 

 Stop Station:  250+00 
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75. Click Add. 

76. In the Point Controls dialog set the following values. 

 Point:   L_EOP_LEOPTie 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature  LEP 

 Start Station:  48+00 

 Stop Station:  250+00 

77. Click Add. 

78. In the Point Controls dialog set the following values. 

 Point:   R_EOP_REOPTie 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature  REP 

 Start Station:  48+00 

 Stop Station:  250+00 

79. Click Add and Close the Point Controls dialog. 

80. Examine the corridor. 

81. Go to Corridor>Corridor Management. 

82. Highlight the Visual Optimization corridor. 

83. Select Copy. 

84. When the Copy Corridor appears enter Optimization in the New Corridor Name field 
and select OK. 
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85. Close the Manage Corridor dialog. 

86. In the lower left corner of the Roadway Design set the Corridor to Optimization. 

87. Go to Corridor>Template Drops. 

88. Highlight the template drop listed in the Current Template Drops list. 

 
89. In the Library Templates highlight the template Optimization and select Change. 

90. Close the Template Drops dialog. 

91. Examine the corridor. 

92. Go to Corridor>Create Surface. 
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93. When the Create Surface dialog appears set the following values. 

 Name:    Optimized 

 Default Preference:  Proposed 

 Empty Design Surface: On 

 Add Exterior Boundary: On – Style:  P_TOPO_Exterior 

 Triangulate:   On 

 Create Surface(s) From: Optimization (highlight this one only) 

 Add Transverse Feature: On – Style:  P_TOPO_Transverse 

 All other toggles:  Off 

 

94. Select Apply.  When the processing is finished Close the dialog. 

95. From the Roadway Designer dialog select File>Save. 

96. Close the Roadway Designer. 
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Optimization Vertical Alignment 

The process in this section will create an optimized vertical alignment from the corridor we just 
created.  

� Exercise: Creating an Optimization Vertical Alignment 

1. To create an optimized vertical go to File>Import>Geometry. 

2. Select the tab Vertical From Surface. 

3. Select Optimized as the surface name. 

4. Type in the name Optimized for the Vertical Alignment Name. 

5. Set the station limits from 48+00 to 250+00. 

 
6. Select Apply and then Close the Import Geometry dialog. 

7. Cut a profile and display both the Highway vertical alignment and the Optimized 
vertical alignment. 

8. Examine the differences between the two alignments. 
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Applying the Optimized Vertical Alignment 

Now we will used the optimized vertical alignment to compute leveling.  

� Exercise: Creating an Optimized Corridor 

1. Go to Modeler>Roadway Designer. 

2. Set the Active Surface in the lower left of the dialog to Existing. 

3. Go to Corridor>Corridor Management. 

4. Highlight the Optimization corridor and select Copy. 

5. In the New Corridor Name type in Overlay. 

 
6. Select OK. 

7. Go to Corridor>Template Drops and highlight the template drop in the Current 
Template Drops list. 

8. In the Library Templates list expand the Overlay Templates folder and highlight the 
template Overlay with Widening.   

9. Select Change and Close the Template Drops dialog. 

10. Go to the Point Controls dialog and delete the point controls that have the mode of 
“Both”. 

11. Add four point controls for the following points. 

Point Control 1: 

 Point:   CL 

 Mode:   Vertical 

 Control Type:  Alignment 

 Horizontal:  Highway 

 Vertical:  Optimized 

 Start Station:  48+00 

 Stop Station:  250+00 
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 Start Vertical Offset: 0.25 

 Stop Vertical Offset: 0.25 

Point Control 2: 

 Point:   CL 

 Mode:   Horizontal 

 Control Type:  Feature 

 Surface:  Existing 

 Feature:  CL 

 Start Station:  48+00 

 Stop Station:  250+00 

Point Control 3: 

 Point:   L_EOP 

 Mode:   Horizontal 

 Control Type:  Feature 

 Surface:  Existing 

 Feature:  LEP 

 Start Station:  48+00 

 Stop Station:  250+00 

Point Control 4: 

 Point:   R_EOP 

 Mode:   Horizontal 

 Control Type:  Feature 

 Surface:  Existing 

 Feature:  REP 

 Start Station:  48+00 

 Stop Station:  250+00 
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12. Add three more point controls for the following points. 

Point Control 1: 

 Point:   L_EOP_Tie 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature:  LEP 

 Start Station:  48+00 

 Stop Station:  250+00 

Point Control 2: 

 Point:   R_EOP_Tie 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature:  REP 

 Start Station:  48+00 

 Stop Station:  250+00 

Point Control 3: 

 Point:   CL_Tie 

 Mode:   Both 

 Control Type:  Feature 

 Surface:  Existing 

 Feature:  CL 

 Start Station:  48+00 

 Stop Station:  250+00 
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Module Review 

Now that you completed this module, let’s measure what you learned. 

Questions 

1. Have we optimized the vertical alignment for leveling? 

2. Have we calculated the leveling? 

3. Do you see any issues with the model? Why? 
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Answers 

1 Have we optimized the vertical alignment for leveling? 

Yes 

2 Have we calculated the leveling? 

Yes, however, you will need to cut cross sections and run end area volumes 

3 Do you see any issues with the model? Why? 

If the regressed horizontal alignment is too far away from the original centerline it 
could cause overlaps in the leveling and the new overlay. 

Module Summary 

After concluding this module you investigated the techniques for resurfacing roads.  It included 
optimization of vertical alignments, milling and widening of existing roads. 
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